]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- updated to 0.40.1
[packages/bmpx.git] / bmpx.spec
1 # TODO: use browser-plugins if plugin works with something else than firefox (e.g. seamonkey)
2 #
3 # Conditional build:
4 %bcond_without  sid     # build without sid support
5 #
6 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
7 Summary(pl.UTF-8):      Odtwarzacz dźwięku z interfejsem WinAmpa dla GTK+
8 Name:           bmpx
9 Version:        0.40.1
10 Release:        0.1
11 License:        GPL v2
12 Group:          X11/Applications/Sound
13 Source0:        http://files.beep-media-player.org/releases/0.40/%{name}-%{version}.tar.bz2
14 # Source0-md5:  0bcc992610a9c700b2fef4337e194f7a
15 Source1:        mp3license
16 Patch0:         %{name}-desktop.patch
17 URL:            http://beep-media-player.org/
18 BuildRequires:  alsa-lib-devel >= 1.0.9
19 BuildRequires:  autoconf >= 2.60
20 BuildRequires:  automake >= 1:1.8
21 BuildRequires:  boost-bind-devel
22 BuildRequires:  boost-call_traits-devel
23 BuildRequires:  boost-devel >= 1.33.1
24 BuildRequires:  boost-filesystem-devel
25 BuildRequires:  boost-regex-devel
26 BuildRequires:  cairomm-devel >= 0.6.0
27 BuildRequires:  cdparanoia-III-devel
28 BuildRequires:  dbus-glib-devel >= 0.62
29 BuildRequires:  gcc-c++ >= 5:4.0.0
30 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.10
31 BuildRequires:  gtkmm-devel >= 2.10.0
32 BuildRequires:  hal-devel >= 0.5.7.1
33 BuildRequires:  intltool >= 0.35.0
34 BuildRequires:  libglademm-devel >= 2.6.0
35 BuildRequires:  libmodplug-devel >= 0.7
36 BuildRequires:  libofa-devel >= 0.9.3
37 BuildRequires:  librsvg-devel >= 1:2.14.0
38 BuildRequires:  libsexymm-devel >= 0.1.9
39 %{?with_sid:BuildRequires:      libsidplay-devel}
40 BuildRequires:  libsigc++-devel >= 2.0.0
41 BuildRequires:  libsoup-devel >= 2.2.100
42 BuildRequires:  libtool
43 BuildRequires:  libxml2-devel >= 1:2.6.26
44 BuildRequires:  libxslt-progs
45 BuildRequires:  pkgconfig
46 BuildRequires:  rpmbuild(macros) >= 1.311
47 BuildRequires:  sqlite3-devel >= 3.3.11
48 BuildRequires:  startup-notification-devel >= 0.8
49 BuildRequires:  taglib-devel >= 1.4-2
50 BuildRequires:  unzip
51 BuildRequires:  xorg-lib-libSM-devel
52 Requires(post,postun):  desktop-file-utils
53 Requires(post,postun):  gtk+2 >= 2:2.10.0
54 Requires(post,postun):  hicolor-icon-theme
55 Requires:       gstreamer-audio-effects-base >= 0.10.10
56 Requires:       gstreamer-audio-formats >= 0.10.3
57 Requires:       gstreamer-audiosink
58 Obsoletes:      bmpx-curses
59 Obsoletes:      bmpx-libs
60 Obsoletes:      bmpx-plugin-container
61 Obsoletes:      bmpx-plugin-flow
62 Obsoletes:      bmpx-plugin-transport
63 Obsoletes:      bmpx-plugins-base
64 Obsoletes:      bmpx-remote
65 Obsoletes:      bmpx-remote-gtk
66 Obsoletes:      bmpx-static
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %define         _firefoxdir     %{_datadir}/mozilla-firefox
70 %define         _chromedir      %{_firefoxdir}/chrome
71
72 %description
73 BMPx is the follow-up of the BMP project with a codebase rewritten
74 from scratch and aims to maintain a stable audio player foundation,
75 and to provide a player with a consistent and easy to understand usage
76 experience.
77
78 %description -l pl.UTF-8
79 BMPx jest następcą projektu BMP z przepisanym od zera kodem i skupia
80 się na utrzymaniu stabilnej podstawy odtwarzacza dźwięku, aby
81 udostępnić odtwarzacz ze spójną i łatwą do zrozumienia obsługą.
82
83 %package devel
84 Summary:        Header files for BMPx media player
85 Summary(pl.UTF-8):      Pliki nagłówkowe odtwarzacza multimedialnego BMPx
86 Group:          X11/Development/Libraries
87 Requires:       dbus-glib-devel >= 0.62
88 Obsoletes:      libchroma-devel
89 Obsoletes:      libhrel-devel
90
91 %description devel
92 Header files required for compiling BMPx media player plugins.
93
94 %description devel -l pl.UTF-8
95 Pliki nagłówkowe potrzebne do kompilowania wtyczek odtwarzacza
96 multimedialnego BMPx.
97
98 %package -n mozilla-firefox-plugin-bmpx
99 Summary:        BMPx plugin for Mozilla Firefox
100 Summary(pl.UTF-8):      Wtyczka BMPx dla Mozilli Firefox
101 Group:          X11/Applications
102 Requires:       %{name} = %{version}-%{release}
103 Requires:       mozilla-firefox >= 2.0.0.1-2
104
105 %description -n mozilla-firefox-plugin-bmpx
106 This plugin registers the lastfm:// protocol to BMPx.
107
108 %description -n mozilla-firefox-plugin-bmpx -l pl.UTF-8
109 Ta wtyczka rejestruje protokół lastfm:// do BMPx.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114
115 %build
116 %{__libtoolize}
117 %{__aclocal} -I m4
118 %{__autoconf}
119 %{__autoheader}
120 %{__automake}
121 %configure \
122         --enable-hal \
123         --enable-modplug \
124         %{?with_sid:--enable-sid} \
125         --with-dbus-services-dir=%{_datadir}/dbus-1/services
126 %{__make}
127
128 %install
129 rm -rf $RPM_BUILD_ROOT
130 install -d $RPM_BUILD_ROOT%{_chromedir}
131
132 %{__make} install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 unzip -q -o xpi/bmp.xpi -d $RPM_BUILD_ROOT%{_firefoxdir}
136 sed -e 's@chrome/bmp\.jar@bmp\.jar@' $RPM_BUILD_ROOT%{_firefoxdir}/chrome.manifest \
137         > $RPM_BUILD_ROOT%{_chromedir}/bmp.manifest
138
139 rm -f $RPM_BUILD_ROOT%{_firefoxdir}/{install.rdf,chrome.manifest}
140 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
141 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/{taglib,vfs/container,vfs/transport}/*.la
142 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{dk,da}
143 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{th_TH,th}
144
145 %find_lang %{name}
146
147 %clean
148 rm -rf $RPM_BUILD_ROOT
149
150 %post
151 /sbin/ldconfig
152 %update_desktop_database_post
153 %update_icon_cache hicolor
154
155 %banner %{name} -e << EOF
156 Remember to install appropriate GStreamer plugins for files
157 you want to play:
158 - gstreamer-cdparanoia (for Audio-CD)
159 - gstreamer-flac (for FLAC)
160 - gstreamer-mad (for MP3s)
161 - gstreamer-vorbis (for Ogg Vorbis)
162 EOF
163
164 %postun
165 /sbin/ldconfig
166 %update_desktop_database_postun
167 %update_icon_cache hicolor
168
169 %files -f %{name}.lang
170 %defattr(644,root,root,755)
171 %doc AUTHORS ChangeLog NEWS README
172 %attr(755,root,root) %{_bindir}/beep-media-player-2
173 %attr(755,root,root) %{_bindir}/bmp-enqueue-files-2.0
174 %attr(755,root,root) %{_bindir}/bmp-enqueue-uris-2.0
175 %attr(755,root,root) %{_bindir}/bmp-play-files-2.0
176 %attr(755,root,root) %{_bindir}/bmp-play-lastfm-2.0
177 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-bin
178 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-sentinel
179 %attr(755,root,root) %{_libdir}/libbmp_id3v2_reader.so.*.*.*
180
181 %dir %{_libdir}/bmpx
182 %dir %{_libdir}/bmpx/plugins
183 %dir %{_libdir}/bmpx/plugins/taglib
184 %dir %{_libdir}/bmpx/plugins/vfs
185 %dir %{_libdir}/bmpx/plugins/vfs/container
186 %dir %{_libdir}/bmpx/plugins/vfs/transport
187 %attr(755,root,root) %{_libdir}/bmpx/plugins/taglib/*.so*
188 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/container/*.so*
189 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/transport/*.so*
190 %{_docdir}/bmpx
191 %{_datadir}/bmpx
192 %{_datadir}/dbus-1/services/*.service
193 %{_mandir}/man*/*
194 %{_desktopdir}/*.desktop
195 %{_iconsdir}/hicolor/*/*/*.png
196
197 %files devel
198 %defattr(644,root,root,755)
199 %{_includedir}/bmp-2.0
200 %{_pkgconfigdir}/*.pc
201
202 %files -n mozilla-firefox-plugin-bmpx
203 %defattr(644,root,root,755)
204 %{_chromedir}/bmp.jar
205 %{_chromedir}/bmp.manifest
This page took 0.138911 seconds and 4 git commands to generate.