]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- added mozilla-firefox-plugin-bmpx subpackage
[packages/bmpx.git] / bmpx.spec
1 #
2 # Conditional build:
3 %bcond_without  gaim    # build without D-BUS gaim support
4 %bcond_without  sid     # build without sid support
5 %bcond_without  ofa     # build without MusicIP support
6 #
7 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
8 Summary(pl):    Odtwarzacz d¼wiêku z interfejsem WinAmpa dla GTK+
9 Name:           bmpx
10 Version:        0.32.0
11 Release:        1.2
12 License:        GPL v2
13 Group:          X11/Applications/Sound
14 Source0:        http://files.beep-media-player.org/releases/0.30/%{name}-%{version}.tar.bz2
15 # Source0-md5:  52c5694f2702c0fc1c9b6fdba603ba7c
16 Source1:        mp3license
17 Patch0:         %{name}-desktop.patch
18 URL:            http://beep-media-player.org/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  bison
22 BuildRequires:  boost-bind-devel
23 BuildRequires:  boost-call_traits-devel
24 BuildRequires:  boost-devel
25 BuildRequires:  boost-filesystem-devel
26 BuildRequires:  curl-devel
27 BuildRequires:  dbus-glib-devel >= 0.62
28 BuildRequires:  esound-devel >= 0.2.8
29 BuildRequires:  fam-devel
30 BuildRequires:  flex
31 %{?with_gaim:BuildRequires:     gaim-devel}
32 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.9
33 BuildRequires:  gtkmm-devel >= 2.9.8
34 BuildRequires:  hal-devel >= 0.5.7
35 BuildRequires:  libglademm-devel >= 2.6.2
36 BuildRequires:  libnotify-devel >= 0.4.2
37 BuildRequires:  libmusicbrainz-devel >= 2.1.1
38 %{?with_ofa:BuildRequires:      libofa-devel >= 0.9.3}
39 %{?with_sid:BuildRequires:      libsidplay-devel}
40 BuildRequires:  libtool
41 BuildRequires:  libvorbis-devel >= 1:1.0
42 BuildRequires:  libxml2-devel >= 1:2.6.26
43 BuildRequires:  mpeg4ip-devel
44 BuildRequires:  neon-devel >= 0.25.5
45 BuildRequires:  rpmbuild(macros) >= 1.311
46 BuildRequires:  rpm-pythonprov
47 BuildRequires:  startup-notification-devel >= 0.8
48 BuildRequires:  taglib-devel >= 1.4
49 BuildRequires:  unzip
50 Requires(post,postun):  desktop-file-utils
51 Requires(post,postun):  gtk+2 >= 2:2.10.0
52 Requires(post,postun):  hicolor-icon-theme
53 Requires(post,postun):  shared-mime-info
54 Requires:       gstreamer-audio-effects-base >= 0.10.9
55 Requires:       gstreamer-audio-formats >= 0.10.3
56 Requires:       gstreamer-audiosink
57 Obsoletes:      bmpx-curses
58 Obsoletes:      bmpx-libs
59 Obsoletes:      bmpx-plugin-container
60 Obsoletes:      bmpx-plugin-flow
61 Obsoletes:      bmpx-plugins-base
62 Obsoletes:      bmpx-plugin-transport
63 Obsoletes:      bmpx-remote
64 Obsoletes:      bmpx-remote-gtk
65 Obsoletes:      bmpx-static
66 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
68 %define         _firefoxdir     %{_libdir}/mozilla-firefox
69 %define         _chromedir      %{_firefoxdir}/chrome
70
71 %description
72 BMPx is the follow-up of the BMP project with a codebase rewritten
73 from scratch and aims to maintain a stable audio player foundation,
74 and to provide a player with a consistent and easy to understand usage
75 experience.
76
77 %description -l pl
78 BMPx jest nastêpc± projektu BMP z przepisanym od zera kodem i skupia
79 siê na utrzymaniu stabilnej podstawy odtwarzacza d¼wiêku, aby
80 udostêpniæ odtwarzacz ze spójn± i ³atw± do zrozumienia obs³ug±.
81
82 %package devel
83 Summary:        Header files for BMPx media player
84 Summary(pl):    Pliki nag³ówkowe odtwarzacza multimedialnego BMPx
85 Group:          X11/Development/Libraries
86 Requires:       dbus-glib-devel >= 0.62
87 Obsoletes:      libchroma-devel
88 Obsoletes:      libhrel-devel
89
90 %description devel
91 Header files required for compiling BMPx media player plugins.
92
93 %description devel -l pl
94 Pliki nag³ówkowe potrzebne do kompilowania wtyczek odtwarzacza
95 multimedialnego BMPx.
96
97 %package -n mozilla-firefox-plugin-bmpx
98 Summary:        BMPx plugin for Mozilla Firefox
99 Summary(pl):    Wtyczka BMPx dla Mozilli Firefox
100 Group:          X11/Applications
101 Requires:       bmpx
102 Requires:       mozilla-firefox
103
104 %description -n mozilla-firefox-plugin-bmpx
105 This plugin registers the lastfm:// protocol to BMPx.
106
107 %description -n mozilla-firefox-plugin-bmpx -l pl
108 Ta wtyczka rejestruje protokó³ lastfm:// do BMPx.
109
110 %prep
111 %setup -q
112 %patch0 -p1
113
114 %build
115 %{__libtoolize}
116 %{__aclocal} -I m4
117 %{__autoconf}
118 %{__autoheader}
119 %{__automake}
120 %configure \
121         --enable-hal \
122         --enable-gamin \
123         --enable-libnotify \
124         --enable-mp4v2 \
125         %{?with_ofa:--enable-ofa} \
126         %{?with_sid:--enable-sid} \
127         --enable-shared \
128         --enable-static \
129         %{?with_gaim:--enable-gaim} \
130         --with-dbus-services-dir=%{_datadir}/dbus-1/services
131 %{__make}
132
133 %install
134 rm -rf $RPM_BUILD_ROOT
135 install -d $RPM_BUILD_ROOT%{_chromedir}
136
137 %{__make} install \
138         DESTDIR=$RPM_BUILD_ROOT \
139         m4datadir=%{_aclocaldir}
140
141 unzip xpi/bmp.xpi -d $RPM_BUILD_ROOT%{_firefoxdir}
142 sed -e 's@chrome/bmp\.jar@bmp\.jar@' $RPM_BUILD_ROOT%{_firefoxdir}/chrome.manifest \
143         > $RPM_BUILD_ROOT%{_chromedir}/bmp.manifest
144
145 rm -f $RPM_BUILD_ROOT%{_firefoxdir}/{install.rdf,chrome.manifest}
146 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
147 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/{flow,vfs/container,vfs/transport}/*.{a,la}
148 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/th_TH
149
150 %find_lang %{name}
151
152 %clean
153 rm -rf $RPM_BUILD_ROOT
154
155 %post
156 %update_desktop_database_post
157 %update_mime_database
158 %update_icon_cache hicolor
159
160 %banner %{name} -e << EOF
161 Remember to install appropriate GStreamer plugins for files
162 you want to play:
163 - gstreamer-cdparanoia (for Audio-CD)
164 - gstreamer-flac (for FLAC)
165 - gstreamer-mad (for MP3s)
166 - gstreamer-vorbis (for Ogg Vorbis)
167 EOF
168
169 %postun
170 %update_desktop_database_postun
171 %update_mime_database
172 %update_icon_cache hicolor
173
174 %files -f %{name}.lang
175 %defattr(644,root,root,755)
176 %doc AUTHORS ChangeLog NEWS README
177 %attr(755,root,root) %{_bindir}/beep-media-player-2
178 %attr(755,root,root) %{_bindir}/bmp-enqueue-files-2.0 
179 %attr(755,root,root) %{_bindir}/bmp-enqueue-uris-2.0
180 %attr(755,root,root) %{_bindir}/bmp-play-files-2.0
181 %attr(755,root,root) %{_bindir}/bmp-play-lastfm-2.0
182 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-bin
183
184 %dir %{_libdir}/bmpx
185 %dir %{_libdir}/bmpx/plugins
186 #%dir %{_libdir}/bmpx/plugins/flow
187 %dir %{_libdir}/bmpx/plugins/vfs
188 %dir %{_libdir}/bmpx/plugins/vfs/container
189 %dir %{_libdir}/bmpx/plugins/vfs/transport
190 #%attr(755,root,root) %{_libdir}/bmpx/plugins/flow/*.so*
191 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/container/*.so*
192 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/transport/*.so*
193
194 %{_datadir}/bmpx
195 %{_datadir}/dbus-1/services/*.service
196 %{_datadir}/mime/packages/*.xml
197 %{_mandir}/man*/*
198 %{_desktopdir}/*
199 %{_iconsdir}/hicolor/*/*/*.png
200
201 %files devel
202 %defattr(644,root,root,755)
203 %{_includedir}/bmp-2.0
204 %{_pkgconfigdir}/*.pc
205
206 %files -n mozilla-firefox-plugin-bmpx
207 %defattr(644,root,root,755)
208 %{_chromedir}/bmp.jar
209 %{_chromedir}/bmp.manifest
This page took 0.069755 seconds and 4 git commands to generate.