]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- updated to 0.12 RC11
[packages/bmpx.git] / bmpx.spec
1 #
2 # Conditional build:
3 %bcond_with     gstreamer       # build with GStreamer support (instead of XINE)
4
5 %define         _rc     RC11
6
7 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+2
8 Summary(pl):    Odtwarzacz d¼wiêku z interfejsem WinAmpa dla GTK+2
9 Name:           bmpx
10 Version:        0.12
11 Release:        0.%{_rc}.1
12 License:        GPL v2
13 Group:          X11/Applications/Sound
14 Source0:        http://download.berlios.de/bmpx/%{name}-%{version}_%{_rc}.tar.gz
15 # Source0-md5:  0d41858036dad52b3a3a3d98c79ba872
16 Source1:        mp3license
17 Patch0:         %{name}-embedded-images.patch
18 URL:            http://bmpx.berlios.de/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  cairo-devel >= 1.0.0
22 BuildRequires:  curl-devel
23 BuildRequires:  dbus-glib-devel
24 BuildRequires:  esound-devel >= 0.2.8
25 BuildRequires:  fam-devel
26 BuildRequires:  gtk+2-devel >= 2:2.8.0
27 BuildRequires:  gss-devel
28 BuildRequires:  libglade2-devel >= 1:2.5.1
29 BuildRequires:  libvorbis-devel >= 1:1.0
30 BuildRequires:  taglib-devel
31 %if %{with gstreamer}
32 BuildRequires:  gstreamer-devel >= 0.9.1
33 %else
34 BuildRequires:  xine-lib-devel
35 %endif
36 Requires:       %{name}-plugin-container = %{epoch}:%{version}-%{release}
37 Requires:       %{name}-plugin-transport = %{epoch}:%{version}-%{release}
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 BMPx is the follow-up of the BMP project with a codebase rewritten
42 from scratch and aims to maintain a stable audio player foundation,
43 and to provide a player with a consistent and easy to understand usage
44 experience.
45
46 %description -l pl
47 BMPx jest nastêpc± projektu BMP z przepisanym od zera kodem i skupia
48 siê na utrzymaniu stabilnej podstawy odtwarzacza d¼wiêku, aby
49 udostêpniæ odtwarzacz ze spójn± i ³atw± do zrozumienia obs³ug±.
50
51 %package devel
52 Summary:        Header files for BMPx media player
53 Summary(pl):    Pliki nag³ówkowe odtwarzacza multimedialnego BMPx
54 Group:          X11/Development/Libraries
55 #Requires:      %{name} = %{epoch}:%{version}-%{release}
56
57 %description devel
58 Header files required for compiling BMPx media player plugins.
59
60 %description devel -l pl
61 Pliki nag³ówkowe potrzebne do kompilowania wtyczek odtwarzacza
62 multimedialnego BMPx.
63
64 %package plugin-container
65 Summary:        Container plugin for BMPx
66 Summary(pl):    Wtyczka Container dla BMPx
67 Group:          X11/Applications/Sound
68 #Requires:      %{name} = %{epoch}:%{version}-%{release}
69
70 %description plugin-container
71 Plugin providing support for folders, m3u & pls playlist files, etc.
72
73 %description plugin-container -l pl
74 Wtyczka dodaj±ca obs³ugê folderów, playlist w formacie m3u i pls, itp.
75
76 %package plugin-flow
77 Summary:        Flow plugin for BMPx
78 Summary(pl):    Wtyczka Flow dla BMPx
79 Group:          X11/Applications/Sound
80 Requires:       %{name} = %{epoch}:%{version}-%{release}
81
82 %description plugin-flow
83 -
84
85 %description plugin-flow -l pl
86 -
87
88 %package plugin-transport
89 Summary:        Transport plugin for BMPx
90 Summary(pl):    Wtyczka Transport dla BMPx
91 Group:          X11/Applications/Sound
92 #Requires:      %{name} = %{epoch}:%{version}-%{release}
93
94 %description plugin-transport
95 -
96
97 %description plugin-transport -l pl
98 -
99
100 %prep
101 %setup -q -n %{name}-%{version}_%{_rc}
102
103 %patch0 -p1
104
105 %build
106 rm -rf autom4te.cache
107 %{__aclocal} -I m4
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112 %if %{with gstreamer}
113         --enable-gst \
114         --disable-xine
115 %else
116         --enable-xine \
117 %endif
118         --enable-shared \
119         --disable-static
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT \
127         m4datadir=%{_aclocaldir}
128
129 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
130
131 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
132 mv -f $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/bmpx.png \
133         $RPM_BUILD_ROOT%{_pixmapsdir}
134
135 %find_lang %{name}
136
137 %clean
138 rm -rf $RPM_BUILD_ROOT
139
140 %post
141 umask 022
142 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
143
144 /sbin/ldconfig
145
146 %postun
147 umask 022
148 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
149
150 /sbin/ldconfig
151
152 %files -f %{name}.lang
153 %defattr(644,root,root,755)
154 %doc AUTHORS ChangeLog NEWS README
155 %attr(755,root,root) %{_bindir}/bmp*
156 %attr(755,root,root) %{_libdir}/libskinned.so.*
157 %dir %{_libdir}/bmpx
158 %dir %{_libdir}/bmpx/plugins
159 %{_mandir}/man*/*
160 %{_desktopdir}/*
161 %{_datadir}/bmpx
162 %{_datadir}/bmp-remote
163 %{_pixmapsdir}/*
164
165 %files devel
166 %defattr(644,root,root,755)
167 #%attr(755,root,root) %{_libdir}/libbeep.so
168 %{_libdir}/lib*.la
169 %{_includedir}/*
170
171 %files plugin-container
172 %defattr(644,root,root,755)
173 %dir %{_libdir}/bmpx/plugins/container
174 %attr(755,root,root) %{_libdir}/bmpx/plugins/container/*.so.*
175 %{_libdir}/bmpx/plugins/container/*.la
176
177 %files plugin-flow
178 %defattr(644,root,root,755)
179 %dir %{_libdir}/bmpx/plugins/flow
180 %attr(755,root,root) %{_libdir}/bmpx/plugins/flow/*.so.*
181 %{_libdir}/bmpx/plugins/flow/*.la
182
183 %files plugin-transport
184 %defattr(644,root,root,755)
185 %dir %{_libdir}/bmpx/plugins/transport
186 %attr(755,root,root) %{_libdir}/bmpx/plugins/transport/*.so.*
187 %{_libdir}/bmpx/plugins/transport/*.la
This page took 0.35006 seconds and 4 git commands to generate.