]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- obsolete desktop.patch
[packages/bmpx.git] / bmpx.spec
1 #
2 # Conditional build:
3 %bcond_without  sid     # build without sid support
4 #
5 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
6 Summary(pl.UTF-8):      Odtwarzacz dźwięku z interfejsem WinAmpa dla GTK+
7 Name:           bmpx
8 Version:        0.40.13
9 Release:        2
10 License:        GPL v2
11 Group:          X11/Applications/Sound
12 Source0:        http://files.beep-media-player.org/releases/0.40/%{name}-%{version}.tar.bz2
13 # Source0-md5:  11da3d4c63e77dc15a53d0c6c25ddadb
14 Source1:        mp3license
15 URL:            http://beep-media-player.org/
16 BuildRequires:  alsa-lib-devel >= 1.0.9
17 BuildRequires:  autoconf >= 2.60
18 BuildRequires:  automake >= 1:1.8
19 BuildRequires:  boost-bind-devel
20 BuildRequires:  boost-call_traits-devel
21 BuildRequires:  boost-devel >= 1.33.1
22 BuildRequires:  boost-filesystem-devel
23 BuildRequires:  boost-regex-devel
24 BuildRequires:  cairomm-devel >= 0.6.0
25 BuildRequires:  cdparanoia-III-devel
26 BuildRequires:  dbus-glib-devel >= 0.62
27 BuildRequires:  gcc-c++ >= 5:4.0.0
28 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.10
29 BuildRequires:  gtkmm-devel >= 2.10.0
30 BuildRequires:  hal-devel >= 0.5.7.1
31 BuildRequires:  intltool >= 0.35.0
32 BuildRequires:  libglademm-devel >= 2.6.0
33 BuildRequires:  libmodplug-devel >= 0.7
34 BuildRequires:  libofa-devel >= 0.9.3
35 BuildRequires:  librsvg-devel >= 1:2.14.0
36 BuildRequires:  libsexymm-devel >= 0.1.9
37 %{?with_sid:BuildRequires:      libsidplay-devel}
38 BuildRequires:  libsigc++-devel >= 2.0.0
39 BuildRequires:  libsoup-devel >= 2.2.100
40 BuildRequires:  libtool
41 BuildRequires:  libxml2-devel >= 1:2.6.26
42 BuildRequires:  libxslt-progs
43 BuildRequires:  pkgconfig
44 BuildRequires:  rpmbuild(macros) >= 1.311
45 BuildRequires:  sqlite3-devel >= 3.3.11
46 BuildRequires:  startup-notification-devel >= 0.8
47 BuildRequires:  taglib-devel >= 1.4-2
48 BuildRequires:  unzip
49 BuildRequires:  xorg-lib-libSM-devel
50 Requires(post,postun):  desktop-file-utils
51 Requires(post,postun):  gtk+2 >= 2:2.10.0
52 Requires(post,postun):  hicolor-icon-theme
53 Requires:       gstreamer-audiosink
54 Suggests:       gstreamer-aac
55 Suggests:       gstreamer-audio-formats >= 0.10.3
56 Suggests:       gstreamer-cdparanoia
57 Suggests:       gstreamer-ffmpeg
58 Suggests:       gstreamer-flac
59 Suggests:       gstreamer-mad
60 Suggests:       gstreamer-mms
61 Suggests:       gstreamer-musepack
62 Suggests:       gstreamer-plugins-bad
63 Suggests:       gstreamer-sid
64 Suggests:       gstreamer-vorbis
65 Obsoletes:      bmpx-curses
66 Obsoletes:      bmpx-libs
67 Obsoletes:      bmpx-plugin-container
68 Obsoletes:      bmpx-plugin-flow
69 Obsoletes:      bmpx-plugin-transport
70 Obsoletes:      bmpx-plugins-base
71 Obsoletes:      bmpx-remote
72 Obsoletes:      bmpx-remote-gtk
73 Obsoletes:      bmpx-static
74 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
75
76 %define         _firefoxdir     %{_datadir}/mozilla-firefox
77 %define         _chromedir      %{_firefoxdir}/chrome
78
79 %description
80 BMPx is the follow-up of the BMP project with a codebase rewritten
81 from scratch and aims to maintain a stable audio player foundation,
82 and to provide a player with a consistent and easy to understand usage
83 experience.
84
85 %description -l pl.UTF-8
86 BMPx jest następcą projektu BMP z przepisanym od zera kodem i skupia
87 się na utrzymaniu stabilnej podstawy odtwarzacza dźwięku, aby
88 udostępnić odtwarzacz ze spójną i łatwą do zrozumienia obsługą.
89
90 %package devel
91 Summary:        Header files for BMPx media player
92 Summary(pl.UTF-8):      Pliki nagłówkowe odtwarzacza multimedialnego BMPx
93 Group:          X11/Development/Libraries
94 Requires:       dbus-glib-devel >= 0.62
95 Obsoletes:      libchroma-devel
96 Obsoletes:      libhrel-devel
97
98 %description devel
99 Header files required for compiling BMPx media player plugins.
100
101 %description devel -l pl.UTF-8
102 Pliki nagłówkowe potrzebne do kompilowania wtyczek odtwarzacza
103 multimedialnego BMPx.
104
105 %package -n mozilla-firefox-plugin-bmpx
106 Summary:        BMPx plugin for Mozilla Firefox
107 Summary(pl.UTF-8):      Wtyczka BMPx dla Mozilli Firefox
108 Group:          X11/Applications
109 Requires:       %{name} = %{version}-%{release}
110 Requires:       mozilla-firefox >= 2.0.0.1-2
111
112 %description -n mozilla-firefox-plugin-bmpx
113 This plugin registers the lastfm:// protocol to BMPx.
114
115 %description -n mozilla-firefox-plugin-bmpx -l pl.UTF-8
116 Ta wtyczka rejestruje protokół lastfm:// do BMPx.
117
118 %prep
119 %setup -q
120
121 %build
122 %{__libtoolize}
123 %{__aclocal} -I m4
124 %{__autoconf}
125 %{__autoheader}
126 %{__automake}
127 %configure \
128         --enable-hal \
129         --enable-modplug \
130         %{?with_sid:--enable-sid} \
131         --with-dbus-services-dir=%{_datadir}/dbus-1/services
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT%{_chromedir}
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 unzip -q -o xpi/bmp.xpi -d $RPM_BUILD_ROOT%{_firefoxdir}
142 sed -e 's@chrome/bmp\.jar@bmp\.jar@' $RPM_BUILD_ROOT%{_firefoxdir}/chrome.manifest \
143         > $RPM_BUILD_ROOT%{_chromedir}/bmp.manifest
144
145 rm -f $RPM_BUILD_ROOT%{_firefoxdir}/{install.rdf,chrome.manifest}
146 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
147 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/{taglib,vfs/container,vfs/transport}/*.la
148 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{dk,da}
149 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{th_TH,th}
150
151 %find_lang %{name}
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post
157 /sbin/ldconfig
158 %update_desktop_database_post
159 %update_icon_cache hicolor
160
161 %postun
162 /sbin/ldconfig
163 %update_desktop_database_postun
164 %update_icon_cache hicolor
165
166 %files -f %{name}.lang
167 %defattr(644,root,root,755)
168 %doc AUTHORS ChangeLog NEWS README
169 %attr(755,root,root) %{_bindir}/beep-media-player-2
170 %attr(755,root,root) %{_bindir}/bmp-enqueue-files-2.0
171 %attr(755,root,root) %{_bindir}/bmp-enqueue-uris-2.0
172 %attr(755,root,root) %{_bindir}/bmp-play-files-2.0
173 %attr(755,root,root) %{_bindir}/bmp-play-lastfm-2.0
174 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-bin
175 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-sentinel
176 %attr(755,root,root) %{_libdir}/libbmp_id3v2_reader.so.*.*.*
177
178 %dir %{_libdir}/bmpx
179 %dir %{_libdir}/bmpx/plugins
180 %dir %{_libdir}/bmpx/plugins/taglib
181 %dir %{_libdir}/bmpx/plugins/vfs
182 %dir %{_libdir}/bmpx/plugins/vfs/container
183 %dir %{_libdir}/bmpx/plugins/vfs/transport
184 %attr(755,root,root) %{_libdir}/bmpx/plugins/taglib/*.so*
185 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/container/*.so*
186 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/transport/*.so*
187 %{_docdir}/bmpx
188 %{_datadir}/bmpx
189 %{_datadir}/dbus-1/services/*.service
190 %{_mandir}/man*/*
191 %{_desktopdir}/*.desktop
192 %{_iconsdir}/hicolor/*/*/*.png
193
194 %files devel
195 %defattr(644,root,root,755)
196 %{_includedir}/bmp-2.0
197 %{_pkgconfigdir}/*.pc
198
199 %files -n mozilla-firefox-plugin-bmpx
200 %defattr(644,root,root,755)
201 %{_chromedir}/bmp.jar
202 %{_chromedir}/bmp.manifest
This page took 0.052258 seconds and 4 git commands to generate.