]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- 0.36.1
[packages/bmpx.git] / bmpx.spec
1 # TODO: use browser-plugins if plugin works with something else than firefox (e.g. seamonkey)
2 #
3 # Conditional build:
4 %bcond_without  gaim    # build without D-BUS gaim support
5 %bcond_without  sid     # build without sid support
6 %bcond_without  ofa     # build without MusicIP support
7 #
8 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
9 Summary(pl):    Odtwarzacz d¼wiêku z interfejsem WinAmpa dla GTK+
10 Name:           bmpx
11 Version:        0.36.1
12 Release:        0.1
13 License:        GPL v2
14 Group:          X11/Applications/Sound
15 Source0:        http://files.beep-media-player.org/releases/0.36/%{name}-%{version}.tar.bz2
16 # Source0-md5:  03a55f8b5b3899f03d71ca9dd681545d
17 Source1:        mp3license
18 Patch0:         %{name}-desktop.patch
19 URL:            http://beep-media-player.org/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  bison
23 BuildRequires:  boost-bind-devel
24 BuildRequires:  boost-call_traits-devel
25 BuildRequires:  boost-devel
26 BuildRequires:  boost-filesystem-devel
27 BuildRequires:  boost-regex-devel
28 BuildRequires:  cdparanoia-III-devel
29 BuildRequires:  curl-devel
30 BuildRequires:  dbus-glib-devel >= 0.62
31 BuildRequires:  esound-devel >= 0.2.8
32 BuildRequires:  fam-devel
33 BuildRequires:  flex
34 %{?with_gaim:BuildRequires:     gaim-devel}
35 BuildRequires:  gcc-c++ >= 5:4.0.0
36 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.9
37 BuildRequires:  gtkmm-devel >= 2.9.8
38 BuildRequires:  hal-devel >= 0.5.7
39 BuildRequires:  libglademm-devel >= 2.6.2
40 BuildRequires:  libnotify-devel >= 0.4.2
41 BuildRequires:  libmusicbrainz-devel >= 2.1.1
42 %{?with_ofa:BuildRequires:      libofa-devel >= 0.9.3}
43 %{?with_sid:BuildRequires:      libsidplay-devel}
44 BuildRequires:  libtool
45 BuildRequires:  libvorbis-devel >= 1:1.0
46 BuildRequires:  libxml2-devel >= 1:2.6.26
47 BuildRequires:  mpeg4ip-devel
48 BuildRequires:  neon-devel >= 0.25.5
49 BuildRequires:  rpmbuild(macros) >= 1.311
50 BuildRequires:  rpm-pythonprov
51 BuildRequires:  startup-notification-devel >= 0.8
52 BuildRequires:  taglib-devel >= 1.4
53 BuildRequires:  unzip
54 Requires(post,postun):  desktop-file-utils
55 Requires(post,postun):  gtk+2 >= 2:2.10.0
56 Requires(post,postun):  hicolor-icon-theme
57 Requires(post,postun):  shared-mime-info
58 Requires:       gstreamer-audio-effects-base >= 0.10.9
59 Requires:       gstreamer-audio-formats >= 0.10.3
60 Requires:       gstreamer-audiosink
61 Obsoletes:      bmpx-curses
62 Obsoletes:      bmpx-libs
63 Obsoletes:      bmpx-plugin-container
64 Obsoletes:      bmpx-plugin-flow
65 Obsoletes:      bmpx-plugins-base
66 Obsoletes:      bmpx-plugin-transport
67 Obsoletes:      bmpx-remote
68 Obsoletes:      bmpx-remote-gtk
69 Obsoletes:      bmpx-static
70 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
71
72 %define         _firefoxdir     %{_libdir}/mozilla-firefox
73 %define         _chromedir      %{_firefoxdir}/chrome
74
75 %description
76 BMPx is the follow-up of the BMP project with a codebase rewritten
77 from scratch and aims to maintain a stable audio player foundation,
78 and to provide a player with a consistent and easy to understand usage
79 experience.
80
81 %description -l pl
82 BMPx jest nastêpc± projektu BMP z przepisanym od zera kodem i skupia
83 siê na utrzymaniu stabilnej podstawy odtwarzacza d¼wiêku, aby
84 udostêpniæ odtwarzacz ze spójn± i ³atw± do zrozumienia obs³ug±.
85
86 %package devel
87 Summary:        Header files for BMPx media player
88 Summary(pl):    Pliki nag³ówkowe odtwarzacza multimedialnego BMPx
89 Group:          X11/Development/Libraries
90 Requires:       dbus-glib-devel >= 0.62
91 Obsoletes:      libchroma-devel
92 Obsoletes:      libhrel-devel
93
94 %description devel
95 Header files required for compiling BMPx media player plugins.
96
97 %description devel -l pl
98 Pliki nag³ówkowe potrzebne do kompilowania wtyczek odtwarzacza
99 multimedialnego BMPx.
100
101 %package -n mozilla-firefox-plugin-bmpx
102 Summary:        BMPx plugin for Mozilla Firefox
103 Summary(pl):    Wtyczka BMPx dla Mozilli Firefox
104 Group:          X11/Applications
105 Requires:       %{name} = %{version}-%{release}
106 Requires:       mozilla-firefox
107
108 %description -n mozilla-firefox-plugin-bmpx
109 This plugin registers the lastfm:// protocol to BMPx.
110
111 %description -n mozilla-firefox-plugin-bmpx -l pl
112 Ta wtyczka rejestruje protokó³ lastfm:// do BMPx.
113
114 %prep
115 %setup -q
116 %patch0 -p1
117
118 %build
119 %{__libtoolize}
120 %{__aclocal} -I m4
121 %{__autoconf}
122 %{__autoheader}
123 %{__automake}
124 %configure \
125         --enable-hal \
126         --enable-gamin \
127         --enable-libnotify \
128         --enable-mp4v2 \
129         %{?with_ofa:--enable-ofa} \
130         %{?with_sid:--enable-sid} \
131         --enable-shared \
132         --enable-static \
133         %{?with_gaim:--enable-gaim} \
134         --with-dbus-services-dir=%{_datadir}/dbus-1/services
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 install -d $RPM_BUILD_ROOT%{_chromedir}
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT \
143         m4datadir=%{_aclocaldir}
144
145 unzip xpi/bmp.xpi -d $RPM_BUILD_ROOT%{_firefoxdir}
146 sed -e 's@chrome/bmp\.jar@bmp\.jar@' $RPM_BUILD_ROOT%{_firefoxdir}/chrome.manifest \
147         > $RPM_BUILD_ROOT%{_chromedir}/bmp.manifest
148
149 rm -f $RPM_BUILD_ROOT%{_firefoxdir}/{install.rdf,chrome.manifest}
150 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
151 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/{taglib,vfs/container,vfs/transport}/*.{a,la}
152 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/th_TH
153
154 %find_lang %{name}
155
156 %clean
157 rm -rf $RPM_BUILD_ROOT
158
159 %post
160 %update_desktop_database_post
161 %update_mime_database
162 %update_icon_cache hicolor
163
164 %banner %{name} -e << EOF
165 Remember to install appropriate GStreamer plugins for files
166 you want to play:
167 - gstreamer-cdparanoia (for Audio-CD)
168 - gstreamer-flac (for FLAC)
169 - gstreamer-mad (for MP3s)
170 - gstreamer-vorbis (for Ogg Vorbis)
171 EOF
172
173 %postun
174 %update_desktop_database_postun
175 %update_mime_database
176 %update_icon_cache hicolor
177
178 %files -f %{name}.lang
179 %defattr(644,root,root,755)
180 %doc AUTHORS ChangeLog NEWS README
181 %attr(755,root,root) %{_bindir}/beep-media-player-2
182 %attr(755,root,root) %{_bindir}/bmp-enqueue-files-2.0 
183 %attr(755,root,root) %{_bindir}/bmp-enqueue-uris-2.0
184 %attr(755,root,root) %{_bindir}/bmp-play-files-2.0
185 %attr(755,root,root) %{_bindir}/bmp-play-lastfm-2.0
186 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-bin
187 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-sentinel
188
189 %dir %{_libdir}/bmpx
190 %dir %{_libdir}/bmpx/plugins
191 %dir %{_libdir}/bmpx/plugins/taglib
192 %dir %{_libdir}/bmpx/plugins/vfs
193 %dir %{_libdir}/bmpx/plugins/vfs/container
194 %dir %{_libdir}/bmpx/plugins/vfs/transport
195 %attr(755,root,root) %{_libdir}/bmpx/plugins/taglib/*.so*
196 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/container/*.so*
197 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/transport/*.so*
198
199 %{_datadir}/bmpx
200 %{_datadir}/dbus-1/services/*.service
201 %{_mandir}/man*/*
202 %{_desktopdir}/*.desktop
203 %{_iconsdir}/hicolor/*/*/*.png
204
205 %files devel
206 %defattr(644,root,root,755)
207 %{_includedir}/bmp-2.0
208 %{_pkgconfigdir}/*.pc
209
210 %files -n mozilla-firefox-plugin-bmpx
211 %defattr(644,root,root,755)
212 %{_chromedir}/bmp.jar
213 %{_chromedir}/bmp.manifest
This page took 0.170443 seconds and 4 git commands to generate.