]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- static supackage, work in progress
[packages/bmpx.git] / bmpx.spec
1 #
2 # Conditional build:
3 %bcond_with     gstreamer       # build with GStreamer support (instead of XINE)
4 #
5 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
6 Summary(pl):    Odtwarzacz d¼wiêku z interfejsem WinAmpa dla GTK+
7 Name:           bmpx
8 Version:        0.12.1
9 Release:        1
10 License:        GPL v2
11 Group:          X11/Applications/Sound
12 Source0:        http://download.berlios.de/bmpx/%{name}-%{version}.tar.gz
13 # Source0-md5:  40965fe0e9707a49a773c91eff777fb2
14 Source1:        mp3license
15 Patch0:         %{name}-embedded-images.patch
16 Patch1:         %{name}-desktop.patch
17 URL:            http://bmpx.berlios.de/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  curl-devel
21 BuildRequires:  dbus-glib-devel
22 BuildRequires:  esound-devel >= 0.2.8
23 BuildRequires:  fam-devel
24 BuildRequires:  gtk+2-devel >= 2:2.8.0
25 BuildRequires:  libglade2-devel >= 1:2.5.1
26 BuildRequires:  libvorbis-devel >= 1:1.0
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  taglib-devel
29 %if %{with gstreamer}
30 # there is no gstreamer 0.9.x in PLD cvs yet!
31 BuildRequires:  gstreamer-devel >= 0.9.1
32 %else
33 BuildRequires:  xine-lib-devel
34 %endif
35 Requires:       %{name}-plugin-flow = %{epoch}:%{version}-%{release}
36 Requires:       %{name}-plugin-container = %{epoch}:%{version}-%{release}
37 Requires:       %{name}-plugin-transport = %{epoch}:%{version}-%{release}
38 %if %{with gstreamer}
39 Requires:       gstreamer-audio-effects
40 Requires:       gstreamer-audio-formats
41 Requires:       gstreamer-audiosink
42 %else
43 Requires:       xine-plugin-audio
44 %endif
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 BMPx is the follow-up of the BMP project with a codebase rewritten
49 from scratch and aims to maintain a stable audio player foundation,
50 and to provide a player with a consistent and easy to understand usage
51 experience.
52
53 %description -l pl
54 BMPx jest nastêpc± projektu BMP z przepisanym od zera kodem i skupia
55 siê na utrzymaniu stabilnej podstawy odtwarzacza d¼wiêku, aby
56 udostêpniæ odtwarzacz ze spójn± i ³atw± do zrozumienia obs³ug±.
57
58 %package devel
59 Summary:        Header files for BMPx media player
60 Summary(pl):    Pliki nag³ówkowe odtwarzacza multimedialnego BMPx
61 Group:          X11/Development/Libraries
62 # doesn't require base
63
64 %description devel
65 Header files required for compiling BMPx media player plugins.
66
67 %description devel -l pl
68 Pliki nag³ówkowe potrzebne do kompilowania wtyczek odtwarzacza
69 multimedialnego BMPx.
70
71 %package static
72 Summary:        Static BMPx library
73 Summary(pl):    Statyczna biblioteka BMPx
74 Group:          X11/Development/Libraries
75 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
76
77 %description static
78 Static BMPx library.
79
80 %description static -l pl
81 Statyczna biblioteka BMPx.
82
83 %package plugin-container
84 Summary:        Container plugin for BMPx
85 Summary(pl):    Wtyczka Container dla BMPx
86 Group:          X11/Applications/Sound
87 Requires:       %{name} = %{epoch}:%{version}-%{release}
88
89 %description plugin-container
90 Plugin providing support for folders, m3u & pls playlist files, etc.
91
92 %description plugin-container -l pl
93 Wtyczka dodaj±ca obs³ugê folderów, playlist w formacie m3u i pls, itp.
94
95 %package plugin-flow
96 Summary:        Flow plugin for BMPx
97 Summary(pl):    Wtyczka Flow dla BMPx
98 Group:          X11/Applications/Sound
99 Requires:       %{name} = %{epoch}:%{version}-%{release}
100
101 %description plugin-flow
102 Flow plugin for BMPx.
103
104 %description plugin-flow -l pl
105 Wtyczka Flow dla BMPx.
106
107 %package plugin-transport
108 Summary:        Transport plugin for BMPx
109 Summary(pl):    Wtyczka Transport dla BMPx
110 Group:          X11/Applications/Sound
111 Requires:       %{name} = %{epoch}:%{version}-%{release}
112
113 %description plugin-transport
114 Transport plugin for BMPx.
115
116 %description plugin-transport -l pl
117 Wtyczka Transport dla BMPx.
118
119 %prep
120 %setup -q
121 %patch0 -p1
122 %patch1 -p1
123
124 %build
125 rm -rf autom4te.cache
126 %{__aclocal} -I m4
127 %{__autoconf}
128 %{__autoheader}
129 %{__automake}
130 %configure \
131 %if %{with gstreamer}
132         --enable-gst \
133         --disable-xine
134 %else
135         --enable-xine \
136 %endif
137         --enable-shared \
138         --enable-static
139 %{__make}
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 %{__make} install \
145         DESTDIR=$RPM_BUILD_ROOT \
146         m4datadir=%{_aclocaldir}
147
148 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
149
150 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
151 mv -f $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/bmpx.png \
152         $RPM_BUILD_ROOT%{_pixmapsdir}
153
154 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/*/*.{a,la}
155
156 %find_lang %{name}
157
158 %clean
159 rm -rf $RPM_BUILD_ROOT
160
161 %post
162 /sbin/ldconfig
163 umask 022
164 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
165
166 %if %{with gstreamer}
167 %banner %{name} -e << EOF
168 Remember to install appropriate GStreamer plugins for files
169 you want to play:
170 - gstreamer-flac (for FLAC)
171 - gstreamer-mad (for MP3s)
172 - gstreamer-vorbis (for Ogg Vorbis)
173 EOF
174 %else
175 %banner %{name} -e << EOF
176 Remember to install appropriate xine-decode plugins for files
177 you want to play:
178 - xine-decode-flac (for FLAC)
179 - xine-decode-ogg (for Ogg Vorbis)
180 EOF
181 %endif
182
183 %postun
184 /sbin/ldconfig
185 if [ $1 = 0 ]; then
186     umask 022
187     [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
188 fi
189
190 %files -f %{name}.lang
191 %defattr(644,root,root,755)
192 %doc AUTHORS ChangeLog NEWS README
193 %attr(755,root,root) %{_bindir}/bmp*
194 %attr(755,root,root) %{_libdir}/libskinned.so.*.*.*
195 %dir %{_libdir}/bmpx
196 %dir %{_libdir}/bmpx/plugins
197 %{_mandir}/man*/*
198 %{_desktopdir}/*
199 %{_datadir}/bmpx
200 %{_datadir}/bmp-remote
201 %{_pixmapsdir}/*
202
203 %files devel
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_libdir}/libskinned.so
206 %{_libdir}/libskinned.la
207 %{_includedir}/bmpx
208
209 %files static
210 %defattr(644,root,root,755)
211 %{_libdir}/*.a
212
213 %files plugin-container
214 %defattr(644,root,root,755)
215 %dir %{_libdir}/bmpx/plugins/container
216 %attr(755,root,root) %{_libdir}/bmpx/plugins/container/*.so*
217
218 %files plugin-flow
219 %defattr(644,root,root,755)
220 %dir %{_libdir}/bmpx/plugins/flow
221 %attr(755,root,root) %{_libdir}/bmpx/plugins/flow/*.so*
222
223 %files plugin-transport
224 %defattr(644,root,root,755)
225 %dir %{_libdir}/bmpx/plugins/transport
226 %attr(755,root,root) %{_libdir}/bmpx/plugins/transport/*.so*
This page took 0.046945 seconds and 4 git commands to generate.