]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- use Suggests instead of %banner
[packages/bmpx.git] / bmpx.spec
1 #
2 # Conditional build:
3 %bcond_without  sid     # build without sid support
4 #
5 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
6 Summary(pl.UTF-8):      Odtwarzacz dźwięku z interfejsem WinAmpa dla GTK+
7 Name:           bmpx
8 Version:        0.40.1
9 Release:        1
10 License:        GPL v2
11 Group:          X11/Applications/Sound
12 Source0:        http://files.beep-media-player.org/releases/0.40/%{name}-%{version}.tar.bz2
13 # Source0-md5:  0bcc992610a9c700b2fef4337e194f7a
14 Source1:        mp3license
15 Patch0:         %{name}-desktop.patch
16 URL:            http://beep-media-player.org/
17 BuildRequires:  alsa-lib-devel >= 1.0.9
18 BuildRequires:  autoconf >= 2.60
19 BuildRequires:  automake >= 1:1.8
20 BuildRequires:  boost-bind-devel
21 BuildRequires:  boost-call_traits-devel
22 BuildRequires:  boost-devel >= 1.33.1
23 BuildRequires:  boost-filesystem-devel
24 BuildRequires:  boost-regex-devel
25 BuildRequires:  cairomm-devel >= 0.6.0
26 BuildRequires:  cdparanoia-III-devel
27 BuildRequires:  dbus-glib-devel >= 0.62
28 BuildRequires:  gcc-c++ >= 5:4.0.0
29 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.10
30 BuildRequires:  gtkmm-devel >= 2.10.0
31 BuildRequires:  hal-devel >= 0.5.7.1
32 BuildRequires:  intltool >= 0.35.0
33 BuildRequires:  libglademm-devel >= 2.6.0
34 BuildRequires:  libmodplug-devel >= 0.7
35 BuildRequires:  libofa-devel >= 0.9.3
36 BuildRequires:  librsvg-devel >= 1:2.14.0
37 BuildRequires:  libsexymm-devel >= 0.1.9
38 %{?with_sid:BuildRequires:      libsidplay-devel}
39 BuildRequires:  libsigc++-devel >= 2.0.0
40 BuildRequires:  libsoup-devel >= 2.2.100
41 BuildRequires:  libtool
42 BuildRequires:  libxml2-devel >= 1:2.6.26
43 BuildRequires:  libxslt-progs
44 BuildRequires:  pkgconfig
45 BuildRequires:  rpmbuild(macros) >= 1.311
46 BuildRequires:  sqlite3-devel >= 3.3.11
47 BuildRequires:  startup-notification-devel >= 0.8
48 BuildRequires:  taglib-devel >= 1.4-2
49 BuildRequires:  unzip
50 BuildRequires:  xorg-lib-libSM-devel
51 Requires(post,postun):  desktop-file-utils
52 Requires(post,postun):  gtk+2 >= 2:2.10.0
53 Requires(post,postun):  hicolor-icon-theme
54 Requires:       gstreamer-audiosink
55 Suggests:       gstreamer-aac
56 Suggests:       gstreamer-audio-formats >= 0.10.3
57 Suggests:       gstreamer-cdparanoia
58 Suggests:       gstreamer-ffmpeg
59 Suggests:       gstreamer-flac
60 Suggests:       gstreamer-mad
61 Suggests:       gstreamer-mms
62 Suggests:       gstreamer-musepack
63 Suggests:       gstreamer-plugins-bad
64 Suggests:       gstreamer-sid
65 Suggests:       gstreamer-vorbis
66 Obsoletes:      bmpx-curses
67 Obsoletes:      bmpx-libs
68 Obsoletes:      bmpx-plugin-container
69 Obsoletes:      bmpx-plugin-flow
70 Obsoletes:      bmpx-plugin-transport
71 Obsoletes:      bmpx-plugins-base
72 Obsoletes:      bmpx-remote
73 Obsoletes:      bmpx-remote-gtk
74 Obsoletes:      bmpx-static
75 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
76
77 %define         _firefoxdir     %{_datadir}/mozilla-firefox
78 %define         _chromedir      %{_firefoxdir}/chrome
79
80 %description
81 BMPx is the follow-up of the BMP project with a codebase rewritten
82 from scratch and aims to maintain a stable audio player foundation,
83 and to provide a player with a consistent and easy to understand usage
84 experience.
85
86 %description -l pl.UTF-8
87 BMPx jest następcą projektu BMP z przepisanym od zera kodem i skupia
88 się na utrzymaniu stabilnej podstawy odtwarzacza dźwięku, aby
89 udostępnić odtwarzacz ze spójną i łatwą do zrozumienia obsługą.
90
91 %package devel
92 Summary:        Header files for BMPx media player
93 Summary(pl.UTF-8):      Pliki nagłówkowe odtwarzacza multimedialnego BMPx
94 Group:          X11/Development/Libraries
95 Requires:       dbus-glib-devel >= 0.62
96 Obsoletes:      libchroma-devel
97 Obsoletes:      libhrel-devel
98
99 %description devel
100 Header files required for compiling BMPx media player plugins.
101
102 %description devel -l pl.UTF-8
103 Pliki nagłówkowe potrzebne do kompilowania wtyczek odtwarzacza
104 multimedialnego BMPx.
105
106 %package -n mozilla-firefox-plugin-bmpx
107 Summary:        BMPx plugin for Mozilla Firefox
108 Summary(pl.UTF-8):      Wtyczka BMPx dla Mozilli Firefox
109 Group:          X11/Applications
110 Requires:       %{name} = %{version}-%{release}
111 Requires:       mozilla-firefox >= 2.0.0.1-2
112
113 %description -n mozilla-firefox-plugin-bmpx
114 This plugin registers the lastfm:// protocol to BMPx.
115
116 %description -n mozilla-firefox-plugin-bmpx -l pl.UTF-8
117 Ta wtyczka rejestruje protokół lastfm:// do BMPx.
118
119 %prep
120 %setup -q
121 %patch0 -p1
122
123 %build
124 %{__libtoolize}
125 %{__aclocal} -I m4
126 %{__autoconf}
127 %{__autoheader}
128 %{__automake}
129 %configure \
130         --enable-hal \
131         --enable-modplug \
132         %{?with_sid:--enable-sid} \
133         --with-dbus-services-dir=%{_datadir}/dbus-1/services
134 %{__make}
135
136 %install
137 rm -rf $RPM_BUILD_ROOT
138 install -d $RPM_BUILD_ROOT%{_chromedir}
139
140 %{__make} install \
141         DESTDIR=$RPM_BUILD_ROOT
142
143 unzip -q -o xpi/bmp.xpi -d $RPM_BUILD_ROOT%{_firefoxdir}
144 sed -e 's@chrome/bmp\.jar@bmp\.jar@' $RPM_BUILD_ROOT%{_firefoxdir}/chrome.manifest \
145         > $RPM_BUILD_ROOT%{_chromedir}/bmp.manifest
146
147 rm -f $RPM_BUILD_ROOT%{_firefoxdir}/{install.rdf,chrome.manifest}
148 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
149 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/{taglib,vfs/container,vfs/transport}/*.la
150 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{dk,da}
151 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{th_TH,th}
152
153 %find_lang %{name}
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post
159 /sbin/ldconfig
160 %update_desktop_database_post
161 %update_icon_cache hicolor
162
163 %postun
164 /sbin/ldconfig
165 %update_desktop_database_postun
166 %update_icon_cache hicolor
167
168 %files -f %{name}.lang
169 %defattr(644,root,root,755)
170 %doc AUTHORS ChangeLog NEWS README
171 %attr(755,root,root) %{_bindir}/beep-media-player-2
172 %attr(755,root,root) %{_bindir}/bmp-enqueue-files-2.0
173 %attr(755,root,root) %{_bindir}/bmp-enqueue-uris-2.0
174 %attr(755,root,root) %{_bindir}/bmp-play-files-2.0
175 %attr(755,root,root) %{_bindir}/bmp-play-lastfm-2.0
176 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-bin
177 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-sentinel
178 %attr(755,root,root) %{_libdir}/libbmp_id3v2_reader.so.*.*.*
179
180 %dir %{_libdir}/bmpx
181 %dir %{_libdir}/bmpx/plugins
182 %dir %{_libdir}/bmpx/plugins/taglib
183 %dir %{_libdir}/bmpx/plugins/vfs
184 %dir %{_libdir}/bmpx/plugins/vfs/container
185 %dir %{_libdir}/bmpx/plugins/vfs/transport
186 %attr(755,root,root) %{_libdir}/bmpx/plugins/taglib/*.so*
187 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/container/*.so*
188 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/transport/*.so*
189 %{_docdir}/bmpx
190 %{_datadir}/bmpx
191 %{_datadir}/dbus-1/services/*.service
192 %{_mandir}/man*/*
193 %{_desktopdir}/*.desktop
194 %{_iconsdir}/hicolor/*/*/*.png
195
196 %files devel
197 %defattr(644,root,root,755)
198 %{_includedir}/bmp-2.0
199 %{_pkgconfigdir}/*.pc
200
201 %files -n mozilla-firefox-plugin-bmpx
202 %defattr(644,root,root,755)
203 %{_chromedir}/bmp.jar
204 %{_chromedir}/bmp.manifest
This page took 0.135552 seconds and 4 git commands to generate.