]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- libs subpackage
[packages/bmpx.git] / bmpx.spec
1 #
2 # Conditional build:
3 %bcond_with     gstreamer       # build with GStreamer support (instead of XINE)
4 #
5 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
6 Summary(pl):    Odtwarzacz d¼wiêku z interfejsem WinAmpa dla GTK+
7 Name:           bmpx
8 Version:        0.12.1
9 Release:        1
10 License:        GPL v2
11 Group:          X11/Applications/Sound
12 Source0:        http://download.berlios.de/bmpx/%{name}-%{version}.tar.gz
13 # Source0-md5:  40965fe0e9707a49a773c91eff777fb2
14 Source1:        mp3license
15 Patch0:         %{name}-embedded-images.patch
16 Patch1:         %{name}-desktop.patch
17 URL:            http://bmpx.berlios.de/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  curl-devel
21 BuildRequires:  dbus-glib-devel
22 BuildRequires:  esound-devel >= 0.2.8
23 BuildRequires:  fam-devel
24 BuildRequires:  gtk+2-devel >= 2:2.8.0
25 BuildRequires:  libglade2-devel >= 1:2.5.1
26 BuildRequires:  libvorbis-devel >= 1:1.0
27 BuildRequires:  rpm-pythonprov
28 BuildRequires:  taglib-devel
29 %if %{with gstreamer}
30 # there is no gstreamer 0.9.x in PLD cvs yet!
31 BuildRequires:  gstreamer-devel >= 0.9.1
32 %else
33 BuildRequires:  xine-lib-devel
34 %endif
35 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
36 Requires:       %{name}-plugin-flow = %{epoch}:%{version}-%{release}
37 Requires:       %{name}-plugin-container = %{epoch}:%{version}-%{release}
38 Requires:       %{name}-plugin-transport = %{epoch}:%{version}-%{release}
39 %if %{with gstreamer}
40 Requires:       gstreamer-audio-effects
41 Requires:       gstreamer-audio-formats
42 Requires:       gstreamer-audiosink
43 %else
44 Requires:       xine-plugin-audio
45 %endif
46 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
47
48 %description
49 BMPx is the follow-up of the BMP project with a codebase rewritten
50 from scratch and aims to maintain a stable audio player foundation,
51 and to provide a player with a consistent and easy to understand usage
52 experience.
53
54 %description -l pl
55 BMPx jest nastêpc± projektu BMP z przepisanym od zera kodem i skupia
56 siê na utrzymaniu stabilnej podstawy odtwarzacza d¼wiêku, aby
57 udostêpniæ odtwarzacz ze spójn± i ³atw± do zrozumienia obs³ug±.
58
59 %package libs
60 Summary:        BMPx player library
61 Summary(pl):    Biblioteka odtwarzacza BMPx
62 Group:          X11/Development/Libraries
63
64 %description libs
65 BMPx player library.
66
67 %description libs -l pl
68 Biblioteka odtwarzacza BMPx.
69
70 %package devel
71 Summary:        Header files for BMPx media player
72 Summary(pl):    Pliki nag³ówkowe odtwarzacza multimedialnego BMPx
73 Group:          X11/Development/Libraries
74 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
75
76 %description devel
77 Header files required for compiling BMPx media player plugins.
78
79 %description devel -l pl
80 Pliki nag³ówkowe potrzebne do kompilowania wtyczek odtwarzacza
81 multimedialnego BMPx.
82
83 %package static
84 Summary:        Static BMPx library
85 Summary(pl):    Statyczna biblioteka BMPx
86 Group:          X11/Development/Libraries
87 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
88
89 %description static
90 Static BMPx library.
91
92 %description static -l pl
93 Statyczna biblioteka BMPx.
94
95 %package plugin-container
96 Summary:        Container plugin for BMPx
97 Summary(pl):    Wtyczka Container dla BMPx
98 Group:          X11/Applications/Sound
99 Requires:       %{name} = %{epoch}:%{version}-%{release}
100
101 %description plugin-container
102 Plugin providing support for folders, m3u & pls playlist files, etc.
103
104 %description plugin-container -l pl
105 Wtyczka dodaj±ca obs³ugê folderów, playlist w formacie m3u i pls, itp.
106
107 %package plugin-flow
108 Summary:        Flow plugin for BMPx
109 Summary(pl):    Wtyczka Flow dla BMPx
110 Group:          X11/Applications/Sound
111 Requires:       %{name} = %{epoch}:%{version}-%{release}
112
113 %description plugin-flow
114 Flow plugin for BMPx.
115
116 %description plugin-flow -l pl
117 Wtyczka Flow dla BMPx.
118
119 %package plugin-transport
120 Summary:        Transport plugin for BMPx
121 Summary(pl):    Wtyczka Transport dla BMPx
122 Group:          X11/Applications/Sound
123 Requires:       %{name} = %{epoch}:%{version}-%{release}
124
125 %description plugin-transport
126 Transport plugin for BMPx.
127
128 %description plugin-transport -l pl
129 Wtyczka Transport dla BMPx.
130
131 %prep
132 %setup -q
133 %patch0 -p1
134 %patch1 -p1
135
136 %build
137 rm -rf autom4te.cache
138 %{__aclocal} -I m4
139 %{__autoconf}
140 %{__autoheader}
141 %{__automake}
142 %configure \
143 %if %{with gstreamer}
144         --enable-gst \
145         --disable-xine
146 %else
147         --enable-xine \
148 %endif
149         --enable-shared \
150         --enable-static
151 %{__make}
152
153 %install
154 rm -rf $RPM_BUILD_ROOT
155
156 %{__make} install \
157         DESTDIR=$RPM_BUILD_ROOT \
158         m4datadir=%{_aclocaldir}
159
160 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
161
162 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
163 mv -f $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/bmpx.png \
164         $RPM_BUILD_ROOT%{_pixmapsdir}
165
166 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/*/*.{a,la}
167
168 %find_lang %{name}
169
170 %clean
171 rm -rf $RPM_BUILD_ROOT
172
173 %post
174 umask 022
175 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
176
177 %if %{with gstreamer}
178 %banner %{name} -e << EOF
179 Remember to install appropriate GStreamer plugins for files
180 you want to play:
181 - gstreamer-flac (for FLAC)
182 - gstreamer-mad (for MP3s)
183 - gstreamer-vorbis (for Ogg Vorbis)
184 EOF
185 %else
186 %banner %{name} -e << EOF
187 Remember to install appropriate xine-decode plugins for files
188 you want to play:
189 - xine-decode-flac (for FLAC)
190 - xine-decode-ogg (for Ogg Vorbis)
191 EOF
192 %endif
193
194 %postun
195 if [ $1 = 0 ]; then
196     umask 022
197     [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
198 fi
199
200 %post   libs -p /sbin/ldconfig
201 %postun libs -p /sbin/ldconfig
202
203 %files -f %{name}.lang
204 %defattr(644,root,root,755)
205 %doc AUTHORS ChangeLog NEWS README
206 %attr(755,root,root) %{_bindir}/bmp*
207 %dir %{_libdir}/bmpx
208 %dir %{_libdir}/bmpx/plugins
209 %{_mandir}/man*/*
210 %{_desktopdir}/*
211 %{_datadir}/bmpx
212 %{_datadir}/bmp-remote
213 %{_pixmapsdir}/*
214
215 %files libs
216 %defattr(644,root,root,755)
217 %attr(755,root,root) %{_libdir}/libskinned.so.*.*.*
218
219 %files devel
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_libdir}/libskinned.so
222 %{_libdir}/libskinned.la
223 %{_includedir}/bmpx
224
225 %files static
226 %defattr(644,root,root,755)
227 %{_libdir}/*.a
228
229 %files plugin-container
230 %defattr(644,root,root,755)
231 %dir %{_libdir}/bmpx/plugins/container
232 %attr(755,root,root) %{_libdir}/bmpx/plugins/container/*.so*
233
234 %files plugin-flow
235 %defattr(644,root,root,755)
236 %dir %{_libdir}/bmpx/plugins/flow
237 %attr(755,root,root) %{_libdir}/bmpx/plugins/flow/*.so*
238
239 %files plugin-transport
240 %defattr(644,root,root,755)
241 %dir %{_libdir}/bmpx/plugins/transport
242 %attr(755,root,root) %{_libdir}/bmpx/plugins/transport/*.so*
This page took 0.257977 seconds and 4 git commands to generate.