]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- updated to 0.12 RC 12
[packages/bmpx.git] / bmpx.spec
1 #
2 # Conditional build:
3 %bcond_with     gstreamer       # build with GStreamer support (instead of XINE)
4
5 %define         _rc     RC12
6
7 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+2
8 Summary(pl):    Odtwarzacz d¼wiêku z interfejsem WinAmpa dla GTK+2
9 Name:           bmpx
10 Version:        0.12
11 Release:        0.%{_rc}.1
12 License:        GPL v2
13 Group:          X11/Applications/Sound
14 Source0:        http://download.berlios.de/bmpx/%{name}-%{version}_%{_rc}.tar.gz
15 # Source0-md5:  0699c155ee81067cac2f306668cacf82
16 Source1:        mp3license
17 Patch0:         %{name}-embedded-images.patch
18 URL:            http://bmpx.berlios.de/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  cairo-devel >= 1.0.0
22 BuildRequires:  curl-devel
23 BuildRequires:  dbus-glib-devel
24 BuildRequires:  esound-devel >= 0.2.8
25 BuildRequires:  fam-devel
26 BuildRequires:  gtk+2-devel >= 2:2.8.0
27 BuildRequires:  libglade2-devel >= 1:2.5.1
28 BuildRequires:  libvorbis-devel >= 1:1.0
29 BuildRequires:  rpm-pythonprov
30 BuildRequires:  taglib-devel
31 %if %{with gstreamer}
32 BuildRequires:  gstreamer-devel >= 0.9.1
33 %else
34 BuildRequires:  xine-lib-devel
35 %endif
36 Requires:       %{name}-plugin-flow = %{epoch}:%{version}-%{release}
37 Requires:       %{name}-plugin-container = %{epoch}:%{version}-%{release}
38 Requires:       %{name}-plugin-transport = %{epoch}:%{version}-%{release}
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %description
42 BMPx is the follow-up of the BMP project with a codebase rewritten
43 from scratch and aims to maintain a stable audio player foundation,
44 and to provide a player with a consistent and easy to understand usage
45 experience.
46
47 %description -l pl
48 BMPx jest nastêpc± projektu BMP z przepisanym od zera kodem i skupia
49 siê na utrzymaniu stabilnej podstawy odtwarzacza d¼wiêku, aby
50 udostêpniæ odtwarzacz ze spójn± i ³atw± do zrozumienia obs³ug±.
51
52 %package devel
53 Summary:        Header files for BMPx media player
54 Summary(pl):    Pliki nag³ówkowe odtwarzacza multimedialnego BMPx
55 Group:          X11/Development/Libraries
56 #Requires:      %{name} = %{epoch}:%{version}-%{release}
57
58 %description devel
59 Header files required for compiling BMPx media player plugins.
60
61 %description devel -l pl
62 Pliki nag³ówkowe potrzebne do kompilowania wtyczek odtwarzacza
63 multimedialnego BMPx.
64
65 %package plugin-container
66 Summary:        Container plugin for BMPx
67 Summary(pl):    Wtyczka Container dla BMPx
68 Group:          X11/Applications/Sound
69 Requires:       %{name} = %{epoch}:%{version}-%{release}
70
71 %description plugin-container
72 Plugin providing support for folders, m3u & pls playlist files, etc.
73
74 %description plugin-container -l pl
75 Wtyczka dodaj±ca obs³ugê folderów, playlist w formacie m3u i pls, itp.
76
77 %package plugin-flow
78 Summary:        Flow plugin for BMPx
79 Summary(pl):    Wtyczka Flow dla BMPx
80 Group:          X11/Applications/Sound
81 Requires:       %{name} = %{epoch}:%{version}-%{release}
82
83 %description plugin-flow
84 Flow plugin for BMPx.
85
86 %description plugin-flow -l pl
87 Wtyczka Flow dla BMPx.
88
89 %package plugin-transport
90 Summary:        Transport plugin for BMPx
91 Summary(pl):    Wtyczka Transport dla BMPx
92 Group:          X11/Applications/Sound
93 Requires:       %{name} = %{epoch}:%{version}-%{release}
94
95 %description plugin-transport
96 Transport plugin for BMPx.
97
98 %description plugin-transport -l pl
99 Wtyczka Transport dla BMPx.
100
101 %prep
102 %setup -q -n %{name}-%{version}_%{_rc}
103 %patch0 -p1
104
105 %build
106 rm -rf autom4te.cache
107 %{__aclocal} -I m4
108 %{__autoconf}
109 %{__autoheader}
110 %{__automake}
111 %configure \
112 %if %{with gstreamer}
113         --enable-gst \
114         --disable-xine
115 %else
116         --enable-xine \
117 %endif
118         --enable-shared \
119         --disable-static
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124
125 %{__make} install \
126         DESTDIR=$RPM_BUILD_ROOT \
127         m4datadir=%{_aclocaldir}
128
129 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
130
131 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
132 mv -f $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/bmpx.png \
133         $RPM_BUILD_ROOT%{_pixmapsdir}
134
135 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/*/*.la
136
137 %find_lang %{name}
138
139 %clean
140 rm -rf $RPM_BUILD_ROOT
141
142 %post
143 umask 022
144 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
145
146 /sbin/ldconfig
147
148 %postun
149 umask 022
150 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
151
152 /sbin/ldconfig
153
154 %files -f %{name}.lang
155 %defattr(644,root,root,755)
156 %doc AUTHORS ChangeLog NEWS README
157 %attr(755,root,root) %{_bindir}/bmp*
158 %attr(755,root,root) %{_libdir}/libskinned.so.*.*.*
159 %dir %{_libdir}/bmpx
160 %dir %{_libdir}/bmpx/plugins
161 %{_mandir}/man*/*
162 %{_desktopdir}/*
163 %{_datadir}/bmpx
164 %{_datadir}/bmp-remote
165 %{_pixmapsdir}/*
166
167 %files devel
168 %defattr(644,root,root,755)
169 %{_includedir}/bmpx
170
171 %files plugin-container
172 %defattr(644,root,root,755)
173 %dir %{_libdir}/bmpx/plugins/container
174 %attr(755,root,root) %{_libdir}/bmpx/plugins/container/*.so*
175
176 %files plugin-flow
177 %defattr(644,root,root,755)
178 %dir %{_libdir}/bmpx/plugins/flow
179 %attr(755,root,root) %{_libdir}/bmpx/plugins/flow/*.so*
180
181 %files plugin-transport
182 %defattr(644,root,root,755)
183 %dir %{_libdir}/bmpx/plugins/transport
184 %attr(755,root,root) %{_libdir}/bmpx/plugins/transport/*.so*
This page took 0.154639 seconds and 4 git commands to generate.