]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- up to 0.34.9
[packages/bmpx.git] / bmpx.spec
1 # TODO: use browser-plugins if plugin works with something else than firefox (e.g. seamonkey)
2 #
3 # Conditional build:
4 %bcond_without  gaim    # build without D-BUS gaim support
5 %bcond_without  sid     # build without sid support
6 %bcond_without  ofa     # build without MusicIP support
7 #
8 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
9 Summary(pl):    Odtwarzacz d¼wiêku z interfejsem WinAmpa dla GTK+
10 Name:           bmpx
11 Version:        0.34.9
12 Release:        0.1
13 License:        GPL v2
14 Group:          X11/Applications/Sound
15 Source0:        http://files.beep-media-player.org/releases/0.34/%{name}-%{version}.tar.bz2
16 # Source0-md5:  6c124e9bb3cb80e9e16d2e050886093a
17 Source1:        mp3license
18 Patch0:         %{name}-desktop.patch
19 URL:            http://beep-media-player.org/
20 BuildRequires:  autoconf
21 BuildRequires:  automake
22 BuildRequires:  bison
23 BuildRequires:  boost-bind-devel
24 BuildRequires:  boost-call_traits-devel
25 BuildRequires:  boost-devel
26 BuildRequires:  boost-filesystem-devel
27 BuildRequires:  curl-devel
28 BuildRequires:  dbus-glib-devel >= 0.62
29 BuildRequires:  esound-devel >= 0.2.8
30 BuildRequires:  fam-devel
31 BuildRequires:  flex
32 %{?with_gaim:BuildRequires:     gaim-devel}
33 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.9
34 BuildRequires:  gtkmm-devel >= 2.9.8
35 BuildRequires:  hal-devel >= 0.5.7
36 BuildRequires:  libglademm-devel >= 2.6.2
37 BuildRequires:  libnotify-devel >= 0.4.2
38 BuildRequires:  libmusicbrainz-devel >= 2.1.1
39 %{?with_ofa:BuildRequires:      libofa-devel >= 0.9.3}
40 %{?with_sid:BuildRequires:      libsidplay-devel}
41 BuildRequires:  libtool
42 BuildRequires:  libvorbis-devel >= 1:1.0
43 BuildRequires:  libxml2-devel >= 1:2.6.26
44 BuildRequires:  mpeg4ip-devel
45 BuildRequires:  neon-devel >= 0.25.5
46 BuildRequires:  rpmbuild(macros) >= 1.311
47 BuildRequires:  rpm-pythonprov
48 BuildRequires:  startup-notification-devel >= 0.8
49 BuildRequires:  taglib-devel >= 1.4
50 BuildRequires:  unzip
51 Requires(post,postun):  desktop-file-utils
52 Requires(post,postun):  gtk+2 >= 2:2.10.0
53 Requires(post,postun):  hicolor-icon-theme
54 Requires(post,postun):  shared-mime-info
55 Requires:       gstreamer-audio-effects-base >= 0.10.9
56 Requires:       gstreamer-audio-formats >= 0.10.3
57 Requires:       gstreamer-audiosink
58 Obsoletes:      bmpx-curses
59 Obsoletes:      bmpx-libs
60 Obsoletes:      bmpx-plugin-container
61 Obsoletes:      bmpx-plugin-flow
62 Obsoletes:      bmpx-plugins-base
63 Obsoletes:      bmpx-plugin-transport
64 Obsoletes:      bmpx-remote
65 Obsoletes:      bmpx-remote-gtk
66 Obsoletes:      bmpx-static
67 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
68
69 %define         _firefoxdir     %{_libdir}/mozilla-firefox
70 %define         _chromedir      %{_firefoxdir}/chrome
71
72 %description
73 BMPx is the follow-up of the BMP project with a codebase rewritten
74 from scratch and aims to maintain a stable audio player foundation,
75 and to provide a player with a consistent and easy to understand usage
76 experience.
77
78 %description -l pl
79 BMPx jest nastêpc± projektu BMP z przepisanym od zera kodem i skupia
80 siê na utrzymaniu stabilnej podstawy odtwarzacza d¼wiêku, aby
81 udostêpniæ odtwarzacz ze spójn± i ³atw± do zrozumienia obs³ug±.
82
83 %package devel
84 Summary:        Header files for BMPx media player
85 Summary(pl):    Pliki nag³ówkowe odtwarzacza multimedialnego BMPx
86 Group:          X11/Development/Libraries
87 Requires:       dbus-glib-devel >= 0.62
88 Obsoletes:      libchroma-devel
89 Obsoletes:      libhrel-devel
90
91 %description devel
92 Header files required for compiling BMPx media player plugins.
93
94 %description devel -l pl
95 Pliki nag³ówkowe potrzebne do kompilowania wtyczek odtwarzacza
96 multimedialnego BMPx.
97
98 %package -n mozilla-firefox-plugin-bmpx
99 Summary:        BMPx plugin for Mozilla Firefox
100 Summary(pl):    Wtyczka BMPx dla Mozilli Firefox
101 Group:          X11/Applications
102 Requires:       %{name} = %{version}-%{release}
103 Requires:       mozilla-firefox
104
105 %description -n mozilla-firefox-plugin-bmpx
106 This plugin registers the lastfm:// protocol to BMPx.
107
108 %description -n mozilla-firefox-plugin-bmpx -l pl
109 Ta wtyczka rejestruje protokó³ lastfm:// do BMPx.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114
115 %build
116 %{__libtoolize}
117 %{__aclocal} -I m4
118 %{__autoconf}
119 %{__autoheader}
120 %{__automake}
121 %configure \
122         --enable-hal \
123         --enable-gamin \
124         --enable-libnotify \
125         --enable-mp4v2 \
126         %{?with_ofa:--enable-ofa} \
127         %{?with_sid:--enable-sid} \
128         --enable-shared \
129         --enable-static \
130         %{?with_gaim:--enable-gaim} \
131         --with-dbus-services-dir=%{_datadir}/dbus-1/services
132 %{__make}
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT%{_chromedir}
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT \
140         m4datadir=%{_aclocaldir}
141
142 unzip xpi/bmp.xpi -d $RPM_BUILD_ROOT%{_firefoxdir}
143 sed -e 's@chrome/bmp\.jar@bmp\.jar@' $RPM_BUILD_ROOT%{_firefoxdir}/chrome.manifest \
144         > $RPM_BUILD_ROOT%{_chromedir}/bmp.manifest
145
146 rm -f $RPM_BUILD_ROOT%{_firefoxdir}/{install.rdf,chrome.manifest}
147 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
148 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/{flow,vfs/container,vfs/transport}/*.{a,la}
149 rm -rf $RPM_BUILD_ROOT%{_datadir}/locale/th_TH
150
151 %find_lang %{name}
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %post
157 %update_desktop_database_post
158 %update_mime_database
159 %update_icon_cache hicolor
160
161 %banner %{name} -e << EOF
162 Remember to install appropriate GStreamer plugins for files
163 you want to play:
164 - gstreamer-cdparanoia (for Audio-CD)
165 - gstreamer-flac (for FLAC)
166 - gstreamer-mad (for MP3s)
167 - gstreamer-vorbis (for Ogg Vorbis)
168 EOF
169
170 %postun
171 %update_desktop_database_postun
172 %update_mime_database
173 %update_icon_cache hicolor
174
175 %files -f %{name}.lang
176 %defattr(644,root,root,755)
177 %doc AUTHORS ChangeLog NEWS README
178 %attr(755,root,root) %{_bindir}/beep-media-player-2
179 %attr(755,root,root) %{_bindir}/bmp-enqueue-files-2.0 
180 %attr(755,root,root) %{_bindir}/bmp-enqueue-uris-2.0
181 %attr(755,root,root) %{_bindir}/bmp-play-files-2.0
182 %attr(755,root,root) %{_bindir}/bmp-play-lastfm-2.0
183 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-bin
184 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-sentinel
185
186 %dir %{_libdir}/bmpx
187 %dir %{_libdir}/bmpx/plugins
188 #%dir %{_libdir}/bmpx/plugins/flow
189 %dir %{_libdir}/bmpx/plugins/vfs
190 %dir %{_libdir}/bmpx/plugins/vfs/container
191 %dir %{_libdir}/bmpx/plugins/vfs/transport
192 #%attr(755,root,root) %{_libdir}/bmpx/plugins/flow/*.so*
193 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/container/*.so*
194 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/transport/*.so*
195
196 %{_datadir}/bmpx
197 %{_datadir}/dbus-1/services/*.service
198 #%{_datadir}/mime/packages/*.xml
199 %{_mandir}/man*/*
200 %{_desktopdir}/*.desktop
201 %{_iconsdir}/hicolor/*/*/*.png
202
203 %files devel
204 %defattr(644,root,root,755)
205 %{_includedir}/bmp-2.0
206 %{_pkgconfigdir}/*.pc
207
208 %files -n mozilla-firefox-plugin-bmpx
209 %defattr(644,root,root,755)
210 %{_chromedir}/bmp.jar
211 %{_chromedir}/bmp.manifest
This page took 0.16855 seconds and 4 git commands to generate.