]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- fixed the gstreamer build
[packages/bmpx.git] / bmpx.spec
1 #
2 # Conditional build:
3 %bcond_with     gstreamer       # build with GStreamer support (instead of XINE)
4
5 %define         _rc     RC3
6
7 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+2
8 Summary(pl):    Odtwarzacz d¼wiêku z interfejsem WinAmpa dla GTK+2
9 Name:           bmpx
10 Version:        0.12
11 Release:        0.%{_rc}.1
12 License:        GPL
13 Group:          X11/Applications/Sound
14 Source0:        http://download.berlios.de/bmpx/%{name}-%{version}-%{_rc}.tar.gz
15 # Source0-md5:  ad3eb15dc0ba2f3ad2be9724e19d35ee
16 Source1:        mp3license
17 URL:            http://bmpx.berlios.de/
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRequires:  cairo-devel >= 1.0.0
21 BuildRequires:  curl-devel
22 BuildRequires:  dbus-glib-devel
23 BuildRequires:  esound-devel >= 0.2.8
24 BuildRequires:  fam-devel
25 BuildRequires:  gtk+2-devel >= 2:2.8.0
26 BuildRequires:  libglade2-devel >= 1:2.5.1
27 BuildRequires:  libvorbis-devel >= 1:1.0
28 BuildRequires:  taglib-devel
29 %if %{with gstreamer}
30 BuildRequires:  gstreamer-devel >= 0.9.1
31 %else
32 BuildRequires:  xine-lib-devel
33 %endif
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 BMPx is the follow-up of the BMP project with a codebase rewritten
38 from scratch and aims to maintain a stable audio player foundation,
39 and to provide a player with a consistent and easy to understand usage
40 experience.
41
42 %description -l pl
43 BMPx jest nastêpc± projektu BMP z przepisanym od zera kodem i skupia
44 siê na utrzymaniu stabilnej podstawy odtwarzacza d¼wiêku, aby
45 udostêpniæ odtwarzacz ze spójn± i ³atw± do zrozumienia obs³ug±.
46
47 %prep
48 %setup -q -n %{name}-%{version}-%{_rc}
49
50 %build
51 rm -rf autom4te.cache
52 %{__aclocal} -I m4
53 %{__autoconf}
54 %{__autoheader}
55 %{__automake}
56 %configure \
57 %if %{with gstreamer}
58         --enable-gst \
59         --disable-xine
60 %else
61         --enable-xine \
62 %endif
63         --enable-shared \
64         --enable-static
65 %{__make}
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %{__make} install \
71         DESTDIR=$RPM_BUILD_ROOT \
72         m4datadir=%{_aclocaldir}
73
74 rm -f $RPM_BUILD_ROOT%{_datadir}/bmpx/data/GPL.txt
75
76 install -d $RPM_BUILD_ROOT%{_pixmapsdir}
77 mv -f $RPM_BUILD_ROOT%{_iconsdir}/hicolor/48x48/apps/bmpx.png \
78         $RPM_BUILD_ROOT%{_pixmapsdir}
79
80 %find_lang %{name}
81
82 %clean
83 rm -rf $RPM_BUILD_ROOT
84
85 %post
86 umask 022
87 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1 ||:
88
89 /sbin/ldconfig
90
91 %postun
92 umask 022
93 [ ! -x /usr/bin/update-desktop-database ] || /usr/bin/update-desktop-database >/dev/null 2>&1
94
95 /sbin/ldconfig
96
97 %files -f %{name}.lang
98 %defattr(644,root,root,755)
99 %attr(755,root,root) %{_bindir}/bmp*
100 %attr(755,root,root) %{_libdir}/libskinned.so.*
101 %{_mandir}/man*/*
102 %{_desktopdir}/*
103 %{_datadir}/bmpx
104 %{_datadir}/bmp-remote
105 %{_pixmapsdir}/*
This page took 0.032485 seconds and 4 git commands to generate.