]> git.pld-linux.org Git - packages/bmpx.git/blob - bmpx.spec
- reorganize boost BRs (boost-devel >= 1.35.0).
[packages/bmpx.git] / bmpx.spec
1 #
2 # Conditional build:
3 %bcond_without  sid     # build without sid support
4 #
5 Summary:        Sound player with the WinAmp GUI, for Unix-based systems for GTK+
6 Summary(pl.UTF-8):      Odtwarzacz dźwięku z interfejsem WinAmpa dla GTK+
7 Name:           bmpx
8 Version:        0.40.13
9 Release:        6
10 License:        GPL v2
11 Group:          X11/Applications/Sound
12 Source0:        http://files.backtrace.info/releases/0.40/%{name}-%{version}.tar.bz2
13 # Source0-md5:  11da3d4c63e77dc15a53d0c6c25ddadb
14 Patch0:         %{name}-sql_check.patch
15 Patch1:         %{name}-lib64.patch
16 Patch2:         %{name}-libsoup24.patch
17 Patch3:         %{name}-invalid-conversion.patch
18 URL:            http://bmpx.backtrace.info/
19 BuildRequires:  alsa-lib-devel >= 1.0.9
20 BuildRequires:  autoconf >= 2.60
21 BuildRequires:  automake >= 1:1.8
22 BuildRequires:  boost-devel >= 1.35.0
23 BuildRequires:  cairomm-devel >= 0.6.0
24 BuildRequires:  cdparanoia-III-devel
25 BuildRequires:  dbus-glib-devel >= 0.62
26 BuildRequires:  gcc-c++ >= 5:4.0.0
27 BuildRequires:  gstreamer-plugins-base-devel >= 0.10.10
28 BuildRequires:  gtkmm-devel >= 2.10.0
29 BuildRequires:  hal-devel >= 0.5.7.1
30 BuildRequires:  intltool >= 0.35.0
31 BuildRequires:  libglademm-devel >= 2.6.0
32 BuildRequires:  libmodplug-devel >= 0.7
33 BuildRequires:  libofa-devel >= 0.9.3
34 BuildRequires:  librsvg-devel >= 1:2.14.0
35 BuildRequires:  libsexymm-devel >= 0.1.9
36 %{?with_sid:BuildRequires:      libsidplay-devel}
37 BuildRequires:  libsigc++-devel >= 2.0.0
38 BuildRequires:  libsoup-devel >= 2.4.0
39 BuildRequires:  libtool
40 BuildRequires:  libxml2-devel >= 1:2.6.26
41 BuildRequires:  libxslt-progs
42 BuildRequires:  pkgconfig
43 BuildRequires:  rpmbuild(macros) >= 1.311
44 BuildRequires:  sqlite3-devel >= 3.3.11
45 BuildRequires:  startup-notification-devel >= 0.8
46 BuildRequires:  taglib-devel >= 1.4-2
47 BuildRequires:  unzip
48 BuildRequires:  xorg-lib-libSM-devel
49 Requires(post,postun):  desktop-file-utils
50 Requires(post,postun):  gtk+2 >= 2:2.10.0
51 Requires(post,postun):  hicolor-icon-theme
52 Requires:       gstreamer-audiosink
53 Suggests:       gstreamer-aac
54 Suggests:       gstreamer-audio-formats >= 0.10.3
55 Suggests:       gstreamer-cdparanoia
56 Suggests:       gstreamer-ffmpeg
57 Suggests:       gstreamer-flac
58 Suggests:       gstreamer-mad
59 Suggests:       gstreamer-mms
60 Suggests:       gstreamer-musepack
61 Suggests:       gstreamer-plugins-bad
62 Suggests:       gstreamer-sid
63 Suggests:       gstreamer-vorbis
64 Obsoletes:      bmpx-curses
65 Obsoletes:      bmpx-libs
66 Obsoletes:      bmpx-plugin-container
67 Obsoletes:      bmpx-plugin-flow
68 Obsoletes:      bmpx-plugin-transport
69 Obsoletes:      bmpx-plugins-base
70 Obsoletes:      bmpx-remote
71 Obsoletes:      bmpx-remote-gtk
72 Obsoletes:      bmpx-static
73 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
74
75 %define         _firefoxdir     %{_datadir}/mozilla-firefox
76 %define         _chromedir      %{_firefoxdir}/chrome
77
78 %description
79 BMPx is the follow-up of the BMP project with a codebase rewritten
80 from scratch and aims to maintain a stable audio player foundation,
81 and to provide a player with a consistent and easy to understand usage
82 experience.
83
84 %description -l pl.UTF-8
85 BMPx jest następcą projektu BMP z przepisanym od zera kodem i skupia
86 się na utrzymaniu stabilnej podstawy odtwarzacza dźwięku, aby
87 udostępnić odtwarzacz ze spójną i łatwą do zrozumienia obsługą.
88
89 %package devel
90 Summary:        Header files for BMPx media player
91 Summary(pl.UTF-8):      Pliki nagłówkowe odtwarzacza multimedialnego BMPx
92 Group:          X11/Development/Libraries
93 Requires:       dbus-glib-devel >= 0.62
94 Obsoletes:      libchroma-devel
95 Obsoletes:      libhrel-devel
96
97 %description devel
98 Header files required for compiling BMPx media player plugins.
99
100 %description devel -l pl.UTF-8
101 Pliki nagłówkowe potrzebne do kompilowania wtyczek odtwarzacza
102 multimedialnego BMPx.
103
104 %package -n mozilla-firefox-plugin-bmpx
105 Summary:        BMPx plugin for Mozilla Firefox
106 Summary(pl.UTF-8):      Wtyczka BMPx dla Mozilli Firefox
107 Group:          X11/Applications
108 Requires:       %{name} = %{version}-%{release}
109 Requires:       mozilla-firefox >= 2.0.0.1-2
110
111 %description -n mozilla-firefox-plugin-bmpx
112 This plugin registers the lastfm:// protocol to BMPx.
113
114 %description -n mozilla-firefox-plugin-bmpx -l pl.UTF-8
115 Ta wtyczka rejestruje protokół lastfm:// do BMPx.
116
117 %prep
118 %setup -q
119 %patch0 -p1
120 %patch1 -p1
121 %patch2 -p1
122 %patch3 -p1
123
124 %build
125 %{__libtoolize}
126 %{__aclocal} -I m4
127 %{__autoconf}
128 %{__autoheader}
129 %{__automake}
130 %configure \
131         --enable-hal \
132         --enable-modplug \
133         %{?with_sid:--enable-sid} \
134         --with-dbus-services-dir=%{_datadir}/dbus-1/services
135 %{__make}
136
137 %install
138 rm -rf $RPM_BUILD_ROOT
139 install -d $RPM_BUILD_ROOT%{_chromedir}
140
141 %{__make} install \
142         DESTDIR=$RPM_BUILD_ROOT
143
144 unzip -q -o xpi/bmp.xpi -d $RPM_BUILD_ROOT%{_firefoxdir}
145 sed -e 's@chrome/bmp\.jar@bmp\.jar@' $RPM_BUILD_ROOT%{_firefoxdir}/chrome.manifest \
146         > $RPM_BUILD_ROOT%{_chromedir}/bmp.manifest
147
148 rm -f $RPM_BUILD_ROOT%{_firefoxdir}/{install.rdf,chrome.manifest}
149 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
150 rm -f $RPM_BUILD_ROOT%{_libdir}/bmpx/plugins/{taglib,vfs/container,vfs/transport}/*.la
151 mv -f $RPM_BUILD_ROOT%{_datadir}/locale/{th_TH,th}
152
153 %find_lang %{name}
154
155 %clean
156 rm -rf $RPM_BUILD_ROOT
157
158 %post
159 /sbin/ldconfig
160 %update_desktop_database_post
161 %update_icon_cache hicolor
162
163 %postun
164 /sbin/ldconfig
165 %update_desktop_database_postun
166 %update_icon_cache hicolor
167
168 %files -f %{name}.lang
169 %defattr(644,root,root,755)
170 %doc AUTHORS ChangeLog NEWS README
171 %attr(755,root,root) %{_bindir}/beep-media-player-2
172 %attr(755,root,root) %{_bindir}/bmp-play-files-2.0
173 %attr(755,root,root) %{_bindir}/bmp-play-uris-2.0
174 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-bin
175 %attr(755,root,root) %{_libexecdir}/beep-media-player-2-sentinel
176
177 %dir %{_libdir}/bmpx
178 %dir %{_libdir}/bmpx/plugins
179 %dir %{_libdir}/bmpx/plugins/taglib
180 %dir %{_libdir}/bmpx/plugins/vfs
181 %dir %{_libdir}/bmpx/plugins/vfs/container
182 %dir %{_libdir}/bmpx/plugins/vfs/transport
183 %attr(755,root,root) %{_libdir}/bmpx/plugins/taglib/*.so*
184 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/container/*.so*
185 %attr(755,root,root) %{_libdir}/bmpx/plugins/vfs/transport/*.so*
186 %{_docdir}/bmpx
187 %{_datadir}/bmpx
188 %{_datadir}/dbus-1/services/*.service
189 %{_mandir}/man*/*
190 %{_desktopdir}/*.desktop
191 %{_iconsdir}/hicolor/*/*/*.png
192
193 %files devel
194 %defattr(644,root,root,755)
195 %{_includedir}/bmp-2.0
196 %{_pkgconfigdir}/*.pc
197
198 %files -n mozilla-firefox-plugin-bmpx
199 %defattr(644,root,root,755)
200 %{_chromedir}/bmp.jar
201 %{_chromedir}/bmp.manifest
This page took 0.357955 seconds and 4 git commands to generate.