]> git.pld-linux.org Git - packages/bluez.git/commitdiff
- 4.14 auto/th/bluez-4_14-1
authorPatryk Zawadzki <patrys@room-303.com>
Sat, 18 Oct 2008 15:43:20 +0000 (15:43 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- actually works

Changed files:
    bluez.init -> 1.2
    bluez.spec -> 1.9
    bluez.sysconfig -> 1.2

bluez.init
bluez.spec
bluez.sysconfig

index 00cacb8da9a01f30048339fd57fe59983045a063..a45ca2d2fbeb71c16a0b578437484abec32f1105 100644 (file)
@@ -22,7 +22,12 @@ fi
 start() {
        # Check if the service is already running?
        if [ ! -f /var/lock/subsys/bluetooth ]; then
-               msg_starting bluetooth; started
+               if is_yes "${DAEMON_ENABLE}" && [ -x /usr/sbin/bluetoothd ]; then
+                       msg_starting bluetooth
+                       daemon /usr/sbin/bluetoothd
+                       RETVAL=$?
+               fi
+
                if is_yes "${HID2HCI_ENABLE}" && [ -x /usr/sbin/hid2hci ]; then
                        msg_starting hid2hci
                        daemon /usr/sbin/hid2hci -0 -q    #be quiet
@@ -103,6 +108,11 @@ stop() {
                        killproc /usr/sbin/hcid
                fi
 
+               if is_yes "${DAEMON_ENABLE}" && [ -x /usr/sbin/bluetoothd ]; then
+                       msg_stopping bluetooth
+                       killproc /usr/sbin/bluetoothd
+               fi
+
                if [ "$UART_CONF" != "no" ]; then
                        killproc hciattach >/dev/null 2>&1
                fi
index 8a24d1eeb1f47d20cb9651dee21bd1d468c79582..6fcdf334e279c043deb6da9acd53bee6483b99d9 100644 (file)
@@ -1,14 +1,14 @@
 Summary:       Bluetooth utilities
 Summary(pl.UTF-8):     NarzÄ™dzia Bluetooth
 Name:          bluez
-Version:       4.13
+Version:       4.14
 Release:       1
 Epoch:         0
 License:       GPL v2+
 Group:         Applications/System
 #Source0Download: http://www.bluez.org/download.html
 Source0:       http://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.gz
-# Source0-md5: 7ce8ed3a586782aa48251f9a547e287f
+# Source0-md5: 1f33ebac05d056879ceb4063e7b1def4
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 Source3:       %{name}-udev.rules
@@ -176,11 +176,9 @@ aplikacji Bluetooth.
        --enable-shared \
        --enable-static \
        --enable-alsa \
-       --enable-bccmd \
-       --enable-configfiles \
-       --enable-netlink \
        --enable-audio \
        --enable-bccmd \
+       --enable-configfiles \
        --enable-cups \
        --enable-dfutool \
        --enable-dund \
@@ -189,12 +187,12 @@ aplikacji Bluetooth.
        --enable-hidd \
        --enable-input \
        --enable-manpages \
+       --enable-netlink \
        --enable-network \
        --enable-pand \
        --enable-pcmciarules \
        --enable-serial \
        --enable-tools \
-       --enable-test \
        --enable-usb
 
 %{__make} \
index e73e223026d30da186fc15118807791f80e22160..7830c3a701de8af245b779a833769c2143c9091b 100644 (file)
@@ -7,6 +7,7 @@ SERVICE_RUN_NICE_LEVEL="+0"
 # (alternatively you can pass uart configuration file path here)
 UART_CONF="no"
 
+DAEMON_ENABLE=yes
 #HID2HCI_ENABLE=yes
 HCID_ENABLE=yes
 SDPD_ENABLE=yes
This page took 0.050427 seconds and 4 git commands to generate.