]> git.pld-linux.org Git - packages/bluez.git/commitdiff
- rel 3; oui/utf8 patches from fc, init fixes auto/th/bluez-4_47-3 auto/ti/bluez-4_47-3
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 8 Aug 2009 11:52:52 +0000 (11:52 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    bluez-oui.patch -> 1.1
    bluez-try-utf8-harder.patch -> 1.1
    bluez.spec -> 1.32

bluez-oui.patch [new file with mode: 0644]
bluez-try-utf8-harder.patch [new file with mode: 0644]
bluez.spec

diff --git a/bluez-oui.patch b/bluez-oui.patch
new file mode 100644 (file)
index 0000000..fec7d16
--- /dev/null
@@ -0,0 +1,25 @@
+--- bluez-4.47/common/oui.c~   2009-01-08 17:00:12.000000000 +0100
++++ bluez-4.47/common/oui.c    2009-08-08 13:51:09.519278151 +0200
+@@ -38,7 +38,7 @@
+ /* http://standards.ieee.org/regauth/oui/oui.txt */
+-#define OUIFILE "/var/lib/misc/oui.txt"
++#define OUIFILE "/usr/share/hwdata/oui.txt"
+ char *ouitocomp(const char *oui)
+ {
+@@ -48,12 +48,7 @@
+       fd = open("oui.txt", O_RDONLY);
+       if (fd < 0) {
+-              fd = open(OUIFILE, O_RDONLY);
+-              if (fd < 0) {
+-                      fd = open("/usr/share/misc/oui.txt", O_RDONLY);
+-                      if (fd < 0)
+-                              return NULL;
+-              }
++              return NULL;
+       }
+       if (fstat(fd, &st) < 0) {
diff --git a/bluez-try-utf8-harder.patch b/bluez-try-utf8-harder.patch
new file mode 100644 (file)
index 0000000..6a95fb7
--- /dev/null
@@ -0,0 +1,23 @@
+diff --git a/src/security.c b/src/security.c
+index 905cf61..67fd266 100644
+--- a/src/security.c
++++ b/src/security.c
+@@ -705,8 +705,16 @@ static inline void remote_name_information(int dev, bdaddr_t *sba, void *ptr)
+               memcpy(name, evt->name, MAX_NAME_LENGTH);
+               /* It's ok to cast end between const and non-const since
+                * we know it points to inside of name which is non-const */
+-              if (!g_utf8_validate(name, -1, (const char **) &end))
+-                      *end = '\0';
++              if (!g_utf8_validate(name, -1, (const char **) &end)) {
++                      char *utf8_name;
++
++                      utf8_name = g_convert(name, -1, "UTF-8", "ISO-8859-1", NULL, NULL, NULL);
++                      if (utf8_name) {
++                              memcpy(name, utf8_name, 248);
++                              g_free(utf8_name);
++                      } else
++                              *end = '\0';
++              }
+               write_device_name(sba, &dba, name);
+       }
index a5496ee0754f6724d343fc617a02668da4dde9cd..3429a84474cc5db5bca6658940863f370c3b428d 100644 (file)
@@ -2,7 +2,7 @@ Summary:        Bluetooth utilities
 Summary(pl.UTF-8):     Narzędzia Bluetooth
 Name:          bluez
 Version:       4.47
-Release:       2
+Release:       3
 License:       GPL v2+
 Group:         Applications/System
 #Source0Download: http://www.bluez.org/download.html
@@ -14,7 +14,9 @@ Source3:      dund.init
 Source4:       pand.init
 Source5:       rfcomm.init
 Patch0:                %{name}-etc_dir.patch
+Patch1:                %{name}-oui.patch
 Patch2:                %{name}-wacom-mode-2.patch
+Patch3:                %{name}-try-utf8-harder.patch
 URL:           http://www.bluez.org/
 BuildRequires: alsa-lib-devel >= 1.0.10-1
 BuildRequires: autoconf >= 2.50
@@ -33,6 +35,7 @@ BuildRequires:        udev-devel
 BuildRequires: rpmbuild(macros) >= 1.268
 Requires:      %{name}-libs = %{epoch}:%{version}-%{release}
 Requires:      rc-scripts
+Requires:      hwdata >= 0.225
 Obsoletes:     bluez-hciemu
 Obsoletes:     bluez-pan
 Obsoletes:     bluez-sdp
@@ -169,7 +172,9 @@ aplikacji Bluetooth.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 %patch2 -p1
+%patch3 -p1
 
 %build
 %{__libtoolize}
This page took 0.041451 seconds and 4 git commands to generate.