]> git.pld-linux.org Git - packages/bluez.git/blobdiff - bluez.spec
- release 2 (by relup.sh)
[packages/bluez.git] / bluez.spec
index a3fa4f504725b651bb6eb76d531f7f8be6ce40a0..c6efb9fb3e38d7d36fec7e09ca359c77000df663 100644 (file)
@@ -1,23 +1,30 @@
 # TODO:
 # - verify/update bluetooth init script
 # - separate obex?
+#
+# Conditional build:
+%bcond_without deprecated      # deprecated tools (ciptool,hciattach,hciconfig,hcidump,hcitool,rfcomm,sdptool)
+#
 Summary:       Bluetooth utilities
 Summary(pl.UTF-8):     Narzędzia Bluetooth
 Name:          bluez
-Version:       5.36
-Release:       1
+Version:       5.51
+Release:       2
 License:       GPL v2+
 Group:         Applications/System
 Source0:       https://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.xz
-# Source0-md5: 9a0ee479cacc44fac68f6a65b1cd3eba
+# Source0-md5: a2f269c9f9a943394043ac1de69eb5b0
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
 URL:           http://www.bluez.org/
+BuildRequires: alsa-lib-devel >= 1.0
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
 BuildRequires: check-devel >= 0.9.6
 BuildRequires: dbus-devel >= 1.6
+BuildRequires: ell-devel >= 0.14
 BuildRequires: glib2-devel >= 1:2.28
+BuildRequires: json-c-devel
 BuildRequires: libical-devel
 BuildRequires: libtool
 BuildRequires: pkgconfig >= 1:0.9.0
@@ -29,6 +36,7 @@ BuildRequires:        xz
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      %{name}-libs = %{version}-%{release}
 Requires:      dbus-libs >= 1.6
+Requires:      ell >= 0.14
 Requires:      glib2 >= 1:2.28
 Requires:      hwdata >= 0.225
 Requires:      rc-scripts
@@ -89,7 +97,7 @@ Znaki towarowe BLUETOOTH są własnością Bluetooth SIG, Inc. z USA.
 Summary:       Bluetooth backend for CUPS
 Summary(pl.UTF-8):     Backend Bluetooth dla CUPS-a
 Group:         Applications/Printing
-Requires:      bluez-libs >= %{version}-%{release}
+Requires:      %{name}-libs = %{version}-%{release}
 Requires:      cups
 
 %description -n cups-backend-bluetooth
@@ -98,6 +106,20 @@ Bluetooth backend for CUPS.
 %description -n cups-backend-bluetooth -l pl.UTF-8
 Backend Bluetooth dla CUPS-a.
 
+%package -n zsh-completion-bluez
+Summary:       Zsh completion for bluez commands
+Summary(pl.UTF-8):     Dopełnianie parametrów w zsh dla poleceń z pakietu bluez
+Group:         Applications/Shells
+Requires:      %{name} = %{version}-%{release}
+Requires:      zsh
+
+%description -n zsh-completion-bluez
+Zsh completion for bluez commands (bluezctl utility).
+
+%description -n zsh-completion-bluez -l pl.UTF-8
+Dopełnianie parametrów w zsh dla poleceń z pakietu bluez (narzędzia
+bluezctl).
+
 %package libs
 Summary:       Bluetooth libraries
 Summary(pl.UTF-8):     Biblioteki Bluetooth
@@ -155,8 +177,16 @@ aplikacji Bluetooth.
 %{__automake}
 %configure \
        --disable-silent-rules \
+       --enable-btpclient \
+       %{?with_deprecated:--enable-deprecated} \
        --enable-experimental \
+       --enable-external-ell \
+       --enable-health \
        --enable-library \
+       --enable-mesh \
+       --enable-midi \
+       --enable-nfc \
+       --enable-sap \
        --enable-sixaxis \
        --enable-static \
        --with-systemdsystemunitdir=%{systemdunitdir} \
@@ -185,7 +215,6 @@ install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/bluetooth
 
 install profiles/input/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth
 install profiles/network/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth
-install profiles/proximity/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth
 
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbluetooth.la
 
@@ -223,22 +252,30 @@ fi
 %attr(755,root,root) %{_bindir}/bccmd
 %attr(755,root,root) %{_bindir}/bluemoon
 %attr(755,root,root) %{_bindir}/bluetoothctl
+%attr(755,root,root) %{_bindir}/btattach
 %attr(755,root,root) %{_bindir}/btmon
-%attr(755,root,root) %{_bindir}/ciptool
-%attr(755,root,root) %{_bindir}/hciattach
-%attr(755,root,root) %{_bindir}/hciconfig
-%attr(755,root,root) %{_bindir}/hcidump
-%attr(755,root,root) %{_bindir}/hcitool
 %attr(755,root,root) %{_bindir}/hex2hcd
 %attr(755,root,root) %{_bindir}/l2ping
 %attr(755,root,root) %{_bindir}/l2test
+%attr(755,root,root) %{_bindir}/meshctl
 %attr(755,root,root) %{_bindir}/mpris-proxy
 %attr(755,root,root) %{_bindir}/rctest
+%if %{with deprecated}
+%attr(755,root,root) %{_bindir}/ciptool
+%attr(755,root,root) %{_bindir}/hciattach
+%attr(755,root,root) %{_bindir}/hciconfig
+%attr(755,root,root) %{_bindir}/hcidump
+%attr(755,root,root) %{_bindir}/hcitool
 %attr(755,root,root) %{_bindir}/rfcomm
 %attr(755,root,root) %{_bindir}/sdptool
+%endif
+%if "%{_libexecdir}" != "%{_libdir}"
+%dir %{_libexecdir}/bluetooth
+%endif
+%attr(755,root,root) %{_libexecdir}/bluetooth/bluetooth-meshd
+%attr(755,root,root) %{_libexecdir}/bluetooth/bluetoothd
+%attr(755,root,root) %{_libexecdir}/bluetooth/obexd
 %dir %{_libdir}/bluetooth
-%attr(755,root,root) %{_libdir}/bluetooth/bluetoothd
-%attr(755,root,root) %{_libdir}/bluetooth/obexd
 %dir %{_libdir}/bluetooth/plugins
 %attr(755,root,root) %{_libdir}/bluetooth/plugins/sixaxis.so
 %dir %{_libdir}/obex
@@ -246,33 +283,42 @@ fi
 %dir %{_sysconfdir}/bluetooth
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/input.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/network.conf
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/proximity.conf
 %attr(754,root,root) /etc/rc.d/init.d/bluetooth
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bluetooth
 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/bluetooth.conf
+%config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/bluetooth-mesh.conf
 %{systemdunitdir}/bluetooth.service
+%{systemdunitdir}/bluetooth-mesh.service
 %{systemduserunitdir}/obex.service
 %{_datadir}/dbus-1/services/org.bluez.obex.service
 %{_datadir}/dbus-1/system-services/org.bluez.service
+%{_datadir}/dbus-1/system-services/org.bluez.mesh.service
 %attr(755,root,root) %{udevdir}/hid2hci
 %{udevdir}/rules.d/97-hid2hci.rules
 %{_mandir}/man1/bccmd.1*
+%{_mandir}/man1/btattach.1*
+%{_mandir}/man1/hid2hci.1*
+%{_mandir}/man1/l2ping.1*
+%{_mandir}/man1/rctest.1*
+%if %{with deprecated}
 %{_mandir}/man1/ciptool.1*
 %{_mandir}/man1/hciattach.1*
 %{_mandir}/man1/hciconfig.1*
 %{_mandir}/man1/hcidump.1*
 %{_mandir}/man1/hcitool.1*
-%{_mandir}/man1/hid2hci.1*
-%{_mandir}/man1/l2ping.1*
-%{_mandir}/man1/rctest.1*
 %{_mandir}/man1/rfcomm.1*
 %{_mandir}/man1/sdptool.1*
+%endif
 %{_mandir}/man8/bluetoothd.8*
 
 %files -n cups-backend-bluetooth
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_prefix}/lib/cups/backend/bluetooth
 
+%files -n zsh-completion-bluez
+%defattr(644,root,root,755)
+%{zsh_compdir}/_bluetoothctl
+
 %files libs
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libbluetooth.so.*.*.*
This page took 0.119124 seconds and 4 git commands to generate.