]> git.pld-linux.org Git - packages/bluez.git/blobdiff - bluez.spec
- up to 5.47
[packages/bluez.git] / bluez.spec
index 083a64a00726b0b4ef62fe2ed3e89021e61920b6..9d38efd7bc4dadcd357290ecb8a2764070255123 100644 (file)
@@ -1,23 +1,27 @@
 # TODO:
 # - verify/update bluetooth init script
 # - separate obex?
+#
+# Conditional build:
+%bcond_without deprecated      # deprecated tools (ciptool,hciattach,hciconfig,hcidump,hcitool,rfcomm,sdptool)
+#
 Summary:       Bluetooth utilities
 Summary(pl.UTF-8):     NarzÄ™dzia Bluetooth
 Name:          bluez
-Version:       5.13
-Release:       2
+Version:       5.47
+Release:       1
 License:       GPL v2+
 Group:         Applications/System
 Source0:       https://www.kernel.org/pub/linux/bluetooth/%{name}-%{version}.tar.xz
-# Source0-md5: c68f8cb270110256a684403ee43b5f79
+# Source0-md5: 783e15f65e70cdb8f721c659e140dd56
 Source1:       %{name}.init
 Source2:       %{name}.sysconfig
-Patch0:                %{name}-wacom-mode-2.patch
 URL:           http://www.bluez.org/
+BuildRequires: alsa-lib-devel >= 1.0
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake
 BuildRequires: check-devel >= 0.9.6
-BuildRequires: dbus-devel >= 1.4
+BuildRequires: dbus-devel >= 1.6
 BuildRequires: glib2-devel >= 1:2.28
 BuildRequires: libical-devel
 BuildRequires: libtool
@@ -25,16 +29,16 @@ BuildRequires:      pkgconfig >= 1:0.9.0
 BuildRequires: readline-devel
 BuildRequires: rpmbuild(macros) >= 1.682
 BuildRequires: tar >= 1:1.22
-BuildRequires: udev-devel >= 1:143
+BuildRequires: udev-devel >= 1:172
 BuildRequires: xz
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      %{name}-libs = %{version}-%{release}
-Requires:      dbus-libs >= 1.4
+Requires:      dbus-libs >= 1.6
 Requires:      glib2 >= 1:2.28
 Requires:      hwdata >= 0.225
 Requires:      rc-scripts
 Requires:      systemd-units >= 38
-Requires:      udev >= 1:143
+Requires:      udev >= 1:172
 Provides:      bluez-hcidump = %{version}
 Provides:      bluez-utils = %{version}-%{release}
 Provides:      obexd = %{version}
@@ -147,7 +151,6 @@ aplikacji Bluetooth.
 
 %prep
 %setup -q
-%patch0 -p1
 
 %build
 %{__libtoolize}
@@ -157,8 +160,13 @@ aplikacji Bluetooth.
 %{__automake}
 %configure \
        --disable-silent-rules \
+       %{?with_deprecated:--enable-deprecated} \
        --enable-experimental \
+       --enable-health \
        --enable-library \
+       --enable-midi \
+       --enable-nfc \
+       --enable-sap \
        --enable-sixaxis \
        --enable-static \
        --with-systemdsystemunitdir=%{systemdunitdir} \
@@ -187,7 +195,6 @@ install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/bluetooth
 
 install profiles/input/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth
 install profiles/network/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth
-install profiles/proximity/*.conf $RPM_BUILD_ROOT%{_sysconfdir}/bluetooth
 
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libbluetooth.la
 
@@ -223,18 +230,24 @@ fi
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog README
 %attr(755,root,root) %{_bindir}/bccmd
+%attr(755,root,root) %{_bindir}/bluemoon
 %attr(755,root,root) %{_bindir}/bluetoothctl
+%attr(755,root,root) %{_bindir}/btattach
 %attr(755,root,root) %{_bindir}/btmon
+%attr(755,root,root) %{_bindir}/hex2hcd
+%attr(755,root,root) %{_bindir}/l2ping
+%attr(755,root,root) %{_bindir}/l2test
+%attr(755,root,root) %{_bindir}/mpris-proxy
+%attr(755,root,root) %{_bindir}/rctest
+%if %{with deprecated}
 %attr(755,root,root) %{_bindir}/ciptool
 %attr(755,root,root) %{_bindir}/hciattach
 %attr(755,root,root) %{_bindir}/hciconfig
 %attr(755,root,root) %{_bindir}/hcidump
 %attr(755,root,root) %{_bindir}/hcitool
-%attr(755,root,root) %{_bindir}/l2ping
-%attr(755,root,root) %{_bindir}/l2test
-%attr(755,root,root) %{_bindir}/rctest
 %attr(755,root,root) %{_bindir}/rfcomm
 %attr(755,root,root) %{_bindir}/sdptool
+%endif
 %dir %{_libdir}/bluetooth
 %attr(755,root,root) %{_libdir}/bluetooth/bluetoothd
 %attr(755,root,root) %{_libdir}/bluetooth/obexd
@@ -245,7 +258,6 @@ fi
 %dir %{_sysconfdir}/bluetooth
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/input.conf
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/network.conf
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/proximity.conf
 %attr(754,root,root) /etc/rc.d/init.d/bluetooth
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bluetooth
 %config(noreplace) %verify(not md5 mtime size) /etc/dbus-1/system.d/bluetooth.conf
@@ -256,16 +268,19 @@ fi
 %attr(755,root,root) %{udevdir}/hid2hci
 %{udevdir}/rules.d/97-hid2hci.rules
 %{_mandir}/man1/bccmd.1*
+%{_mandir}/man1/btattach.1*
+%{_mandir}/man1/hid2hci.1*
+%{_mandir}/man1/l2ping.1*
+%{_mandir}/man1/rctest.1*
+%if %{with deprecated}
 %{_mandir}/man1/ciptool.1*
 %{_mandir}/man1/hciattach.1*
 %{_mandir}/man1/hciconfig.1*
 %{_mandir}/man1/hcidump.1*
 %{_mandir}/man1/hcitool.1*
-%{_mandir}/man1/hid2hci.1*
-%{_mandir}/man1/l2ping.1*
-%{_mandir}/man1/rctest.1*
 %{_mandir}/man1/rfcomm.1*
 %{_mandir}/man1/sdptool.1*
+%endif
 %{_mandir}/man8/bluetoothd.8*
 
 %files -n cups-backend-bluetooth
This page took 0.028175 seconds and 4 git commands to generate.