]> git.pld-linux.org Git - packages/bluez-utils.git/commitdiff
This commit was manufactured by cvs2git to create branch 'unlabeled-1.1.2'.
authorcvs2git <feedback@pld-linux.org>
Fri, 28 Apr 2006 18:45:04 +0000 (18:45 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Sprout from master 2006-04-28 18:45:04 UTC Arkadiusz Miśkiewicz <arekm@maven.pl> '- new'
Cherrypick from master 2003-04-16 15:02:14 UTC Jakub Bogusz <qboosh@pld-linux.org> '- started init script, based on one for RH systems':
    bluez-utils.sysconfig -> 1.1
Delete:
    bluez-utils-etc_dir.patch
    bluez-utils.init
    bluez-utils.spec

bluez-utils-etc_dir.patch [deleted file]
bluez-utils.init [deleted file]
bluez-utils.spec [deleted file]
bluez-utils.sysconfig

diff --git a/bluez-utils-etc_dir.patch b/bluez-utils-etc_dir.patch
deleted file mode 100644 (file)
index e7234a5..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-diff -Nru bluez-utils-2.2/rfcomm/parser.y bluez-utils-2.2.new/rfcomm/parser.y
---- bluez-utils-2.2/rfcomm/parser.y    Thu Oct 31 10:09:48 2002
-+++ bluez-utils-2.2.new/rfcomm/parser.y        Sun Mar 23 18:18:14 2003
-@@ -147,7 +147,11 @@
-       if (filename) {
-               snprintf(file, MAXPATHLEN,  "%s", filename);
-       } else {
--              snprintf(file, MAXPATHLEN, "%s/.bluetooth/rfcomm.conf", getenv("HOME"));
-+              char *etc_dir = getenv("HOME_ETC");
-+              if (etc_dir)
-+                      snprintf(file, MAXPATHLEN, "%s/.bluetooth/rfcomm.conf", etc_dir);
-+              else
-+                      snprintf(file, MAXPATHLEN, "%s/.bluetooth/rfcomm.conf", getenv("HOME"));
-               if ((getuid() == 0) || (access(file, R_OK) < 0))
-                       snprintf(file, MAXPATHLEN, "/etc/bluetooth/rfcomm.conf");
diff --git a/bluez-utils.init b/bluez-utils.init
deleted file mode 100644 (file)
index ec15b0f..0000000
+++ /dev/null
@@ -1,153 +0,0 @@
-#!/bin/sh
-#
-# bluetooth    Bluetooth subsystem starting and stopping
-#
-# chkconfig:   345 25 90
-#
-# description: Bluetooth subsystem
-#
-# $Id$
-
-
-# Source function library
-. /etc/rc.d/init.d/functions
-
-UART_CONF="/etc/bluetooth/uart"
-[ -f /etc/sysconfig/bluetooth ] && . /etc/sysconfig/bluetooth
-
-if [ "$UART_CONF" != "no" -a ! -f "$UART_CONF" ]; then
-       UART_CONF="no"
-fi
-
-RETVAL=0
-# See how we were called.
-case "$1" in
-  start)
-       # Check if the service is already running?
-       if [ ! -f /var/lock/subsys/bluetooth ]; then
-               msg_starting bluetooth; started
-               if is_yes "${HID2HCI_ENABLE}" && [ -x /usr/sbin/hid2hci ]; then
-                       msg_starting hid2hci
-                       daemon /usr/sbin/hid2hci -0 -q    #be quiet
-                       RETVAL=$?
-                       /bin/sleep 1 # delay for hid's to be detected by hotplug
-               fi
-               
-               if is_yes "${HCID_ENABLE}" && [ -x /usr/sbin/hcid ]; then
-                       msg_starting hcid
-                       daemon /usr/sbin/hcid -f /etc/bluetooth/hcid.conf
-                       RETVAL=$?
-               fi
-       
-               if is_yes "${SDPD_ENABLE}" && [ -x /usr/sbin/sdpd ]; then
-                       msg_starting sdpd
-                       daemon /usr/sbin/sdpd
-                       RETVAL=$?
-               fi
-               
-               if is_yes "${HIDD_ENABLE}" && [ -x /usr/bin/hidd ]; then
-                       msg_starting hidd
-                       daemon /usr/bin/hidd ${HIDD_OPTIONS} --server
-                       RETVAL=$?
-               fi
-
-               if is_yes "${RFCOMM_ENABLE}" && [ -x /usr/bin/rfcomm ]; then
-                       msg_starting rfcomm
-                       daemon /usr/bin/rfcomm -f /etc/bluetooth/rfcomm.conf bind all
-                       RETVAL=$?
-               fi
-       
-               if is_yes "${DUND_ENABLE}" && [ -x /usr/bin/dund ]; then
-                       msg_starting dund
-                       daemon /usr/bin/dund ${DUND_OPTIONS}
-                       RETVAL=$?
-               fi
-       
-               if is_yes "${PAND_ENABLE}" && [ -x /usr/bin/pand ]; then
-                       msg_starting pand
-                       daemon /usr/bin/pand ${PAND_OPTIONS}
-                       RETVAL=$?
-               fi
-
-               if [ -f /usr/sbin/hciattach -a "$UART_CONF" != "no" ]; then
-                       grep -v '^#' $UART_CONF | while read i; do
-                               /usr/sbin/hciattach $i
-                       done
-               fi
-               [ $RETVAL -eq 0 ] && touch /var/lock/subsys/bluetooth
-       else
-               msg_already_running bluetooth
-       fi
-       ;;
-  stop)
-       if [ -f /var/lock/subsys/bluetooth ]; then
-               if is_yes "${PAND_ENABLE}" && [ -x /usr/bin/pand ]; then
-                       msg_stopping pand
-                       killproc /usr/bin/pand
-               fi
-
-               if is_yes "${DUND_ENABLE}" && [ -x /usr/bin/dund ]; then
-                       msg_stopping dund
-                       killproc /usr/bin/dund
-               fi
-
-               if is_yes "${RFCOMM_ENABLE}" && [ -x /usr/bin/rfcomm ]; then
-                       msg_stopping rfcomm
-                       daemon /usr/bin/rfcomm release all
-               fi
-
-               if is_yes "${HIDD_ENABLE}" && [ -x  /usr/bin/hidd ]; then
-                       msg_stopping hidd
-                       killproc /usr/bin/hidd
-               fi
-       
-               if is_yes "${SDPD_ENABLE}" && [ -x /usr/sbin/sdpd ]; then
-                       msg_stopping sdpd
-                       killproc /usr/sbin/sdpd
-               fi
-       
-               if is_yes "${HCID_ENABLE}" && [ -x /usr/sbin/hcid ]; then
-                       msg_stopping hcid
-                       daemon /usr/sbin/hcid
-               fi
-
-               if [ "$UART_CONF" != "no" ]; then
-                       killproc hciattach >/dev/null 2>&1
-               fi
-               rm -f /var/lock/subsys/bluetooth
-       else
-               msg_not_running bluetooth
-       fi
-       ;;
-  restart)
-       $0 stop
-       $0 start
-       exit $?
-       ;;
-  reload|force-reload)
-       if [ -f /var/lock/subsys/bluetooth ]; then
-               msg_reloading hcid
-               killproc hcid -HUP
-               RETVAL=$?
-       else
-               msg_not_running bluetooth >&2
-               exit 7
-       fi
-       ;;
-  status)
-       is_yes "${HID2HCI_ENABLE}" && status hid2hci
-       is_yes "${HCID_ENABLE}" && status hcid
-       is_yes "${SDPD_ENABLE}" && status sdpd
-       is_yes "${HIDD_ENABLE}" && status hidd
-       is_yes "${DUND_ENABLE}" && status dund
-       exit $?
-       ;;
-  *)
-       msg_usage "$0 {start|stop|restart|reload|force-reload|status}"
-       exit 3
-esac
-
-exit $RETVAL
-
-# This must be last line !
-# vi:syntax=sh:tw=78:ts=8:sw=4
diff --git a/bluez-utils.spec b/bluez-utils.spec
deleted file mode 100644 (file)
index 862e191..0000000
+++ /dev/null
@@ -1,146 +0,0 @@
-# TODO:
-# - check init script, add support for rfcomm bind on startup
-Summary:       Bluetooth utilities
-Summary(pl):   Narzêdzia Bluetooth
-Name:          bluez-utils
-Version:       2.25
-Release:       2
-Epoch:         0
-License:       GPL v2
-Group:         Applications/System
-Source0:       http://bluez.sourceforge.net/download/%{name}-%{version}.tar.gz
-# Source0-md5: ae3729ab5592be06ed01b973d4b3e9fe
-Source1:       %{name}.init
-Source2:       %{name}.sysconfig
-Patch0:                %{name}-etc_dir.patch
-URL:           http://bluez.sourceforge.net/
-BuildRequires: autoconf
-BuildRequires: automake
-BuildRequires: bison
-BuildRequires: bluez-libs-devel >= 2.25
-BuildRequires: dbus-devel >= 0.33
-BuildRequires: libtool
-BuildRequires: libusb-devel
-BuildRequires: rpmbuild(macros) >= 1.268
-# alsa-lib-devel, openobex-devel - currently only checked for, not used
-Requires:      bluez-libs >= 2.21
-Requires:      rc-scripts
-Obsoletes:     bluez-pan
-Obsoletes:     bluez-sdp
-Conflicts:     bluez-bluefw
-ExcludeArch:   s390 s390x
-BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-
-# currently lib, not %{_lib} (see cups.spec)
-%define                cupsdir         /usr/lib/cups/backend
-
-%description
-Bluetooth utilities:
- - hcitool
- - hciattach
- - hciconfig
- - hcid
- - l2ping
- - start scripts (PLD)
- - PCMCIA configuration files
-
-The BLUETOOTH trademarks are owned by Bluetooth SIG, Inc., U.S.A.
-
-%description -l pl
-Narzêdzia Bluetooth:
- - hcitool
- - hciattach
- - hciconfig
- - hcid
- - l2ping
- - skrypty startowe (PLD)
- - pliki konfiguracji PCMCIA
-
-%package -n cups-backend-bluetooth
-Summary:       Bluetooth backend for CUPS
-Summary(pl):   Backend Bluetooth dla CUPS-a
-Group:         Applications/Printing
-Requires:      bluez-libs >= 2.21
-Requires:      cups
-
-%description -n cups-backend-bluetooth
-Bluetooth backend for CUPS.
-
-%description -n cups-backend-bluetooth -l pl
-Backend Bluetooth dla CUPS-a.
-
-%package init
-Summary:       Init script for Bluetooth subsystem
-Summary(pl):   Skrypt init dla podsystemu Bluetooth
-Group:         Applications/System
-Requires(post,preun):  /sbin/chkconfig
-Requires:      %{name} = %{epoch}:%{version}-%{release}
-
-%description init
-Init script for Bluetooth subsystem.
-
-%description init -l pl
-Skrypt init dla podsystemu Bluetooth.
-
-%prep
-%setup -q
-%patch0 -p1
-
-%build
-%{__libtoolize}
-%{__aclocal}
-%{__autoconf}
-%{__automake}
-%configure \
-       --enable-bcm203x \
-       --enable-cups \
-       --enable-pcmcia \
-       --with-cups=/usr
-%{__make} \
-       cupsdir=%{cupsdir}
-
-%install
-rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
-
-%{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       cupsdir=%{cupsdir}
-
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/bluetooth
-install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/bluetooth
-
-%clean
-rm -rf $RPM_BUILD_ROOT
-
-%post init
-/sbin/chkconfig --add bluetooth
-%service bluetooth restart
-
-%preun init
-if [ "$1" = "0" ]; then
-       %service bluetooth stop
-       /sbin/chkconfig --del bluetooth
-fi
-
-%files
-%defattr(644,root,root,755)
-%doc AUTHORS ChangeLog README
-%attr(755,root,root) %{_bindir}/*
-%attr(755,root,root) %{_sbindir}/*
-%{_mandir}/man*/*
-%attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/bluetooth
-%dir %{_sysconfdir}/bluetooth
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bluetooth/*
-%attr(755,root,root) %{_sysconfdir}/hotplug/usb/bcm203x
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/hotplug/usb/bcm203x.usermap
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pcmcia/bluetooth.conf
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pcmcia/bluetooth
-
-%files -n cups-backend-bluetooth
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_prefix}/lib/cups/backend/bluetooth
-
-%files init
-%defattr(644,root,root,755)
-%attr(754,root,root) /etc/rc.d/init.d/bluetooth
index e73e223026d30da186fc15118807791f80e22160..7a8c423c97696bf482e72970b1b285b1c002afbb 100644 (file)
@@ -6,14 +6,3 @@ SERVICE_RUN_NICE_LEVEL="+0"
 # remove if you have serial Bluetooth dongles configured in /etc/bluetooth/uart
 # (alternatively you can pass uart configuration file path here)
 UART_CONF="no"
-
-#HID2HCI_ENABLE=yes
-HCID_ENABLE=yes
-SDPD_ENABLE=yes
-HIDD_ENABLE=yes
-#HIDD_OPTIONS=""
-RFCOMM_ENABLE=yes
-#DUND_ENABLE=yes
-#DUND_OPTIONS=""
-#PAND_ENABLE=yes
-#PAND_OPTIONS=""
This page took 0.062909 seconds and 4 git commands to generate.