]> git.pld-linux.org Git - packages/bluefish.git/blob - bluefish.spec
- one more broken dir deps fix
[packages/bluefish.git] / bluefish.spec
1 #
2 # Conditional build:
3 %bcond_with     python  # enable python integration (HIGHLY EXPERIMENTAL)
4 #
5 Summary:        Bluefish - HTML editor for the experienced web designer
6 Summary(pl.UTF-8):      Bluefish - Edytor HTML-a dla zaawansowanych
7 Name:           bluefish
8 Version:        2.0.0
9 Release:        3
10 License:        GPL
11 Group:          X11/Applications/Editors
12 # The master server is here
13 Source0:        http://www.bennewitz.com/bluefish/stable/source/%{name}-%{version}.tar.bz2
14 # Source0-md5:  ac9b1e8ef6d5691718a0daa6c78d5618
15 # but if you want ftp: try this one
16 # Source0:      ftp://bluefish.advancecreations.com/bluefish/downloads/%{name}-%{version}.tar.bz2
17 Patch0:         %{name}-desktop.patch
18 Patch1:         %{name}-locales.patch
19 URL:            http://bluefish.openoffice.nl/
20 BuildRequires:  aspell-devel
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 BuildRequires:  gettext-devel
24 BuildRequires:  giflib-devel
25 BuildRequires:  gnome-vfs2-devel >= 2.2
26 BuildRequires:  gtk+2-devel     >= 2.14
27 BuildRequires: intltool
28 BuildRequires:  libbonobo-devel >= 2.2
29 BuildRequires:  libjpeg-devel
30 BuildRequires:  libpng >= 1.2.5
31 BuildRequires:  libtiff-devel
32 BuildRequires: libtool
33 BuildRequires:  pcre-devel      >=      3.0
34 BuildRequires:  pkgconfig
35 BuildRequires:  rpmbuild(macros) >= 1.311
36 Requires(post,postun):  desktop-file-utils
37 Requires(post,postun):  gtk+2
38 Requires(post,postun):  hicolor-icon-theme
39 Requires(post,postun):  shared-mime-info
40 Requires:       gnome-vfs2 >= 2.2
41 # sr@Latn vs. sr@latin
42 Conflicts:      glibc-misc < 6:2.7
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Bluefish is a GTK+ based HTML editor designed for the experienced web
47 designer.
48
49 %description -l pl.UTF-8
50 Bluefish jest opartym na GTK+ edytorem HTML-a, przeznaczonym dla
51 doświadczonych projektantów stron WWW.
52
53 %description -l pt_BR.UTF-8
54 O bluefish é um editor HTML feito com GTK+ para web designers
55 experientes. Atualmente ele está em estágio alfa, mas já está bastante
56 usável. Algumas opções ainda não estão completamente finalizadas.
57 Bluefish é liberado sob a licença GPL.
58
59 %prep
60 %setup -q
61 %patch0 -p0
62 %patch1 -p1
63
64 mv -f po/ko{_KR,}.po
65 mv -f po/sr{,@Latn}.po
66 mv -f src/plugin_about/po/sr{,@Latn}.po  
67 mv -f src/plugin_charmap/po/sr{,@Latn}.po  
68 mv -f src/plugin_entities/po/sr{,@Latn}.po  
69 mv -f src/plugin_htmlbar/po/sr{,@Latn}.po  
70 mv -f src/plugin_infbrowser/po/sr{,@Latn}.po  
71 mv -f src/plugin_snippets/po/sr{,@Latn}.po
72
73 %{__intltoolize}
74 %{__libtoolize}
75 %{__aclocal}
76 %{__autoconf}
77 %configure \
78         --disable-update-databases \
79         %{?with_python:--enable-python}
80
81 %{__make}
82
83 %install
84 rm -rf $RPM_BUILD_ROOT
85
86 %{__make} install \
87         DESTDIR=$RPM_BUILD_ROOT
88
89 mkdir -p doc/bflang/
90 mv data/bflang/sample.bflang2 doc/bflang/
91 rm -r %{buildroot}%{_docdir}/bluefish/
92
93 %find_lang %{name} --all-name
94
95 %clean
96 rm -rf $RPM_BUILD_ROOT
97
98 %post
99 %update_mime_database
100 %update_desktop_database_post
101 %update_icon_cache hicolor
102
103 %postun
104 %update_desktop_database_postun
105 %update_mime_database
106 %update_icon_cache hicolor
107
108 %files -f %{name}.lang
109 %defattr(644,root,root,755)
110 %doc AUTHORS README TODO doc/
111 %attr(755,root,root) %{_bindir}/bluefish
112 %dir %{_datadir}/%{name}
113 %{_datadir}/mime/packages/bluefish.xml
114 %{_datadir}/xml/bluefish
115 %{_datadir}/bluefish/bflang
116 %{_datadir}/bluefish/bflib
117 %{_datadir}/bluefish/bluefish_splash.png
118 %{_datadir}/bluefish/encodings
119 %{_mandir}/man1/bluefish.1*
120 %{_iconsdir}/hicolor/128x128/apps/bluefish.png
121 %{_iconsdir}/hicolor/128x128/mimetypes/application-x-bluefish-project.png
122 %{_iconsdir}/hicolor/16x16/apps/bluefish.png
123 %{_iconsdir}/hicolor/16x16/mimetypes/application-x-bluefish-project.png
124 %{_iconsdir}/hicolor/192x192/apps/bluefish.png
125 %{_iconsdir}/hicolor/192x192/mimetypes/application-x-bluefish-project.png
126 %{_iconsdir}/hicolor/22x22/apps/bluefish.png
127 %{_iconsdir}/hicolor/22x22/mimetypes/application-x-bluefish-project.png
128 %{_iconsdir}/hicolor/32x32/apps/bluefish.png
129 %{_iconsdir}/hicolor/32x32/mimetypes/application-x-bluefish-project.png
130 %{_iconsdir}/hicolor/36x36/apps/bluefish.png
131 %{_iconsdir}/hicolor/36x36/mimetypes/application-x-bluefish-project.png
132 %{_iconsdir}/hicolor/48x48/apps/bluefish.png
133 %{_iconsdir}/hicolor/48x48/mimetypes/application-x-bluefish-project.png
134 %{_iconsdir}/hicolor/64x64/apps/bluefish.png
135 %{_iconsdir}/hicolor/64x64/mimetypes/application-x-bluefish-project.png
136 %{_iconsdir}/hicolor/72x72/apps/bluefish.png
137 %{_iconsdir}/hicolor/72x72/mimetypes/application-x-bluefish-project.png
138 %{_iconsdir}/hicolor/96x96/apps/bluefish.png
139 %{_iconsdir}/hicolor/96x96/mimetypes/application-x-bluefish-project.png
140 %{_iconsdir}/hicolor/scalable/apps/bluefish-icon.svg
141 %{_iconsdir}/hicolor/scalable/mimetypes/bluefish-project.svg
142 %{_desktopdir}/bluefish.desktop
143 %{_pixmapsdir}/application-x-bluefish-project.png
144 %{_pixmapsdir}/bluefish.png
145 %dir %{_libdir}/bluefish
146 %attr(755,root,root) %{_libdir}/bluefish/*.so
This page took 0.034413 seconds and 3 git commands to generate.