]> git.pld-linux.org Git - packages/bless.git/commitdiff
- updated to 0.4.1
authormaciek2w <maciek2w@pld-linux.org>
Thu, 21 Sep 2006 15:43:36 +0000 (15:43 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- fixed glyphs overlapping (patch based on https://gna.org/bugs/?6158)
- removed already applied bless-buildfixes.patch

Changed files:
    bless-buildfixes.patch -> 1.2
    bless-glyphs_overlap.patch -> 1.1
    bless.spec -> 1.8

bless-buildfixes.patch [deleted file]
bless-glyphs_overlap.patch [new file with mode: 0644]
bless.spec

diff --git a/bless-buildfixes.patch b/bless-buildfixes.patch
deleted file mode 100644 (file)
index 5dd31d7..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -uNr bless-0.4.0.orig/src/ByteBuffer/SaveAsOperation.cs bless-0.4.0/src/ByteBuffer/SaveAsOperation.cs
---- bless-0.4.0.orig/src/ByteBuffer/SaveAsOperation.cs 2005-09-11 18:22:16.000000000 +0200
-+++ bless-0.4.0/src/ByteBuffer/SaveAsOperation.cs      2006-04-03 08:03:21.000000000 +0200
-@@ -63,8 +63,8 @@
-       {
- #if ENABLE_UNIX_SPECIFIC
-               // get info about the device the file will be saved on
--              Mono.Unix.Statvfs stat=new Mono.Unix.Statvfs();
--              Mono.Unix.Syscall.statvfs(Path.GetDirectoryName(fn), out stat);
-+              Mono.Unix.Native.Statvfs stat=new Mono.Unix.Native.Statvfs();
-+              Mono.Unix.Native.Syscall.statvfs(Path.GetDirectoryName(fn), out stat);
-                       
-               long freeSpace=(long)(stat.f_bavail*stat.f_bsize);
-                       
-diff -uNr bless-0.4.0.orig/src/ByteBuffer/SaveOperation.cs bless-0.4.0/src/ByteBuffer/SaveOperation.cs
---- bless-0.4.0.orig/src/ByteBuffer/SaveOperation.cs   2005-05-11 22:10:19.000000000 +0200
-+++ bless-0.4.0/src/ByteBuffer/SaveOperation.cs        2006-04-03 08:03:09.000000000 +0200
-@@ -53,8 +53,8 @@
-               // get info about the device the file will be saved on
-               FileInfo fi=new FileInfo(bb.Filename);
-                       
--              Mono.Unix.Statvfs stat=new Mono.Unix.Statvfs();
--              Mono.Unix.Syscall.statvfs(bb.Filename, out stat);
-+              Mono.Unix.Native.Statvfs stat=new Mono.Unix.Native.Statvfs();
-+              Mono.Unix.Native.Syscall.statvfs(bb.Filename, out stat);
-                       
-               long freeSpace=(long)(stat.f_bavail*stat.f_bsize) + fi.Length;
-                       
-diff -uNr bless-0.4.0.orig/src/gui/dialogs/SaveConfirmationMultiAlert.cs bless-0.4.0/src/gui/dialogs/SaveConfirmationMultiAlert.cs
---- bless-0.4.0.orig/src/gui/dialogs/SaveConfirmationMultiAlert.cs     2005-02-07 12:46:46.000000000 +0100
-+++ bless-0.4.0/src/gui/dialogs/SaveConfirmationMultiAlert.cs  2006-04-05 03:42:24.000000000 +0200
-@@ -78,12 +78,11 @@
-                       
-                       tv.AppendColumn ("Save", crt, "active", 0);
-                       tv.AppendColumn ("Name", new CellRendererText(), "text", 1);
--                      
--                      foreach (SaveFileItem item in list) {
--                              item.Save=true;
--                              store.AppendValues(item.Save, item.Name);       
-+
-+                      for (int i=0; i<list.Length; ++i) {
-+                          list[i].Save=true;
-+                          store.AppendValues(list[i].Save, list[i].Name);
-                       }
--                       
-                       return tv;
-               }
-               
diff --git a/bless-glyphs_overlap.patch b/bless-glyphs_overlap.patch
new file mode 100644 (file)
index 0000000..20a9fa4
--- /dev/null
@@ -0,0 +1,30 @@
+--- bless-0.4.1/src/gui/drawers/Drawer.cs.orig 2006-09-21 17:31:58.000000000 +0200
++++ bless-0.4.1/src/gui/drawers/Drawer.cs      2006-09-21 17:33:33.000000000 +0200
+@@ -179,20 +179,13 @@
+               Pango.Context pangoCtx=widget.PangoContext;
+               Pango.FontMetrics fm=pangoCtx.GetMetrics(fontDescription, lang);
+               
+-              // set the font height and width
+-              height =(int)( (fm.Ascent+fm.Descent)/Pango.Scale.PangoScale);
+-              width =(int) ((fm.ApproximateCharWidth)/Pango.Scale.PangoScale);
+-              
+-              // temporary workaround for font width problem
+-              int fontWidthFix;
+-              try {
+-                       fontWidthFix = Convert.ToInt32(Preferences.Instance["FontWidthFix"]);
+-              }
+-              catch (Exception e) {
+-                      fontWidthFix = 0;
+-              }
+-              
+-              width += fontWidthFix;
++              // set the font height and width                
++              // BUGFIX:
++              Pango.Layout layout = new Pango.Layout(pangoCtx);
++              layout.FontDescription = fontDescription;
++              layout.SetText("A"); // check for a single character
++              layout.GetPixelSize(out width, out height);
++              // END OF FIX
+               
+               // create the font pixmaps
+               InitializePixmaps();
index 1d0ac9f7d26f61c7fd7eb29e0ceb7fb264fdd607..ebf33413eab5219c7549482bd80aac5b33147346 100644 (file)
@@ -1,16 +1,16 @@
 Summary:       Hex Editor written in GTK#
 Summary(pl):   Edytor szesnastkowy napisany w GTK#
 Name:          bless
-Version:       0.4.0
+Version:       0.4.1
 Release:       1
 License:       GPL
 Group:         Applications/Editors
 Source0:       http://download.gna.org/bless/%{name}-%{version}.tar.gz
-# Source0-md5: e161996a67155303d9e6a04fa28662ca
+# Source0-md5: a3551ebecda11b115e98608894f5c0ec
 Source1:       %{name}.desktop
 Patch0:                %{name}-DESTDIR.patch
 Patch1:                %{name}-help.patch
-Patch2:                %{name}-buildfixes.patch
+Patch2:                %{name}-glyphs_overlap.patch
 URL:           http://home.gna.org/bless/
 BuildRequires: autoconf
 BuildRequires: automake
This page took 0.055303 seconds and 4 git commands to generate.