]> git.pld-linux.org Git - packages/blender.git/commitdiff
- up to 2.82a auto/th/blender-2.82a-1
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 25 Mar 2020 22:43:28 +0000 (23:43 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Wed, 25 Mar 2020 22:43:28 +0000 (23:43 +0100)
blender.spec
python-3.8.patch [deleted file]

index 04d5e9028cef250f38c60ff2d17acbab4caed706..c6a872b7fce2a56599230bbc36a62faea04fc87e 100644 (file)
@@ -4,15 +4,14 @@
 Summary:       3D modeling, rendering, animation and game creation package
 Summary(pl.UTF-8):     Pakiet do tworzenia animacji 3D oraz gier
 Name:          blender
 Summary:       3D modeling, rendering, animation and game creation package
 Summary(pl.UTF-8):     Pakiet do tworzenia animacji 3D oraz gier
 Name:          blender
-Version:       2.81a
-Release:       2
+Version:       2.82a
+Release:       1
 License:       GPL
 Group:         X11/Applications/Graphics
 Source0:       http://download.blender.org/source/%{name}-%{version}.tar.xz
 License:       GPL
 Group:         X11/Applications/Graphics
 Source0:       http://download.blender.org/source/%{name}-%{version}.tar.xz
-# Source0-md5: fd106a2c3debfd215617d31197883173
+# Source0-md5: 3e9d669185b83d5d2cb1b38dcf64d5ec
 Patch0:                %{name}-2.76-droid.patch
 Patch1:                format-security.patch
 Patch0:                %{name}-2.76-droid.patch
 Patch1:                format-security.patch
-Patch2:                python-3.8.patch
 Patch3:                struct-alignment.patch
 URL:           http://www.blender.org/
 BuildRequires: OpenAL-devel
 Patch3:                struct-alignment.patch
 URL:           http://www.blender.org/
 BuildRequires: OpenAL-devel
@@ -56,7 +55,7 @@ BuildRequires:        zlib-devel
 Requires(post,postun): desktop-file-utils
 Requires:      OpenGL
 Requires:      freetype
 Requires(post,postun): desktop-file-utils
 Requires:      OpenGL
 Requires:      freetype
-Requires:      python-modules
+Requires:      python3-modules
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqdep   libGL.so.1 libGLU.so.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _noautoreqdep   libGL.so.1 libGLU.so.1
@@ -74,11 +73,20 @@ Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
 %ifarch x32
 %patch3 -p1
 %endif
 
 %ifarch x32
 %patch3 -p1
 %endif
 
+%{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python3}\1,' -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
+      release/bin/blender-thumbnailer.py \
+      release/scripts/addons/io_curve_svg/svg_util_test.py \
+      release/scripts/addons/io_scene_fbx/fbx2json.py \
+      release/scripts/addons/io_scene_fbx/json2fbx.py \
+      release/scripts/addons/sun_position/geo.py \
+      release/scripts/modules/bl_i18n_utils/merge_po.py \
+      release/scripts/modules/bl_i18n_utils/utils_rtl.py \
+      release/scripts/modules/blend_render_info.py
+
 %build
 install -d build
 cd build
 %build
 install -d build
 cd build
diff --git a/python-3.8.patch b/python-3.8.patch
deleted file mode 100644 (file)
index c26934e..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-Index: blender-2.80_patched/source/blender/python/generic/py_capi_utils.c
-===================================================================
---- blender-2.80_patched/source/blender/python/generic/py_capi_utils.c
-+++ blender-2.80_patched/source/blender/python/generic/py_capi_utils.c
-@@ -717,9 +717,11 @@
-  ****************************************************************************/
- PyObject *PyC_DefaultNameSpace(const char *filename)
- {
--  PyInterpreterState *interp = PyThreadState_GET()->interp;
-+  PyObject *modules = PyImport_GetModuleDict();
-+  PyObject *builtins = PyDict_GetItemString(modules, "builtins");
-+
-   PyObject *mod_main = PyModule_New("__main__");
--  PyDict_SetItemString(interp->modules, "__main__", mod_main);
-+  PyDict_SetItemString(modules, "__main__", mod_main);
-   Py_DECREF(mod_main); /* sys.modules owns now */
-   PyModule_AddStringConstant(mod_main, "__name__", "__main__");
-   if (filename) {
-@@ -727,8 +729,8 @@
-      * note: this wont map to a real file when executing text-blocks and buttons. */
-     PyModule_AddObject(mod_main, "__file__", PyC_UnicodeFromByte(filename));
-   }
--  PyModule_AddObject(mod_main, "__builtins__", interp->builtins);
--  Py_INCREF(interp->builtins); /* AddObject steals a reference */
-+  PyModule_AddObject(mod_main, "__builtins__", builtins);
-+  Py_INCREF(builtins); /* AddObject steals a reference */
-   return PyModule_GetDict(mod_main);
- }
-@@ -755,15 +757,15 @@
- /* restore MUST be called after this */
- void PyC_MainModule_Backup(PyObject **main_mod)
- {
--  PyInterpreterState *interp = PyThreadState_GET()->interp;
--  *main_mod = PyDict_GetItemString(interp->modules, "__main__");
-+  PyObject *modules = PyImport_GetModuleDict();
-+  *main_mod = PyDict_GetItemString(modules, "__main__");
-   Py_XINCREF(*main_mod); /* don't free */
- }
- void PyC_MainModule_Restore(PyObject *main_mod)
- {
--  PyInterpreterState *interp = PyThreadState_GET()->interp;
--  PyDict_SetItemString(interp->modules, "__main__", main_mod);
-+  PyObject *modules = PyImport_GetModuleDict();
-+  PyDict_SetItemString(modules, "__main__", main_mod);
-   Py_XDECREF(main_mod);
- }
This page took 0.255511 seconds and 4 git commands to generate.