]> git.pld-linux.org Git - packages/blender.git/blob - blender.spec
d4938e7bc4698d859d7905fce364c171fcc5e683
[packages/blender.git] / blender.spec
1 # TODO:
2 # - enable internalization support (BR libftgl)
3 # - libsolid/libqhull/libode BR ?
4 Summary:        3D modeling, rendering, animation and game creation package
5 Summary(pl.UTF-8):      Pakiet do tworzenia animacji 3D oraz gier
6 Name:           blender
7 Version:        3.1.0
8 Release:        4
9 License:        GPL
10 Group:          X11/Applications/Graphics
11 Source0:        https://download.blender.org/source/%{name}-%{version}.tar.xz
12 # Source0-md5:  483e16f010cc8c2363ba05b716fde3d0
13 Patch0:         %{name}-2.76-droid.patch
14 Patch1:         format-security.patch
15 Patch2:         boost1.81.patch
16 URL:            https://www.blender.org/
17 BuildRequires:  OpenAL-devel
18 BuildRequires:  OpenColorIO-devel
19 BuildRequires:  OpenEXR-devel
20 BuildRequires:  OpenGL-devel
21 BuildRequires:  OpenGL-GLU-devel
22 BuildRequires:  OpenImageIO-devel
23 BuildRequires:  SDL2-devel
24 BuildRequires:  boost-devel
25 BuildRequires:  cmake
26 BuildRequires:  embree-devel
27 BuildRequires:  ffmpeg-devel >= 0.4.9-4.20080930.1
28 BuildRequires:  fftw3-devel
29 BuildRequires:  freealut-devel
30 BuildRequires:  freetype-devel
31 BuildRequires:  ftgl-devel
32 BuildRequires:  gcc >= 5:3.4.0
33 BuildRequires:  gettext-tools
34 BuildRequires:  glew-devel
35 BuildRequires:  jack-audio-connection-kit-devel
36 BuildRequires:  jemalloc-devel
37 BuildRequires:  libjpeg-devel
38 BuildRequires:  libpng-devel
39 BuildRequires:  libsndfile-devel
40 BuildRequires:  libspnav-devel
41 BuildRequires:  libstdc++-devel
42 BuildRequires:  libtiff-devel
43 BuildRequires:  libtool
44 BuildRequires:  libvorbis-devel
45 BuildRequires:  openjpeg2-devel
46 BuildRequires:  openssl-devel >= 0.9.7d
47 BuildRequires:  pugixml-devel
48 BuildRequires:  python3 >= 1:3.10
49 BuildRequires:  python3-devel >= 1:3.10
50 BuildRequires:  python3-numpy-devel
51 BuildRequires:  rpm-pythonprov
52 BuildRequires:  rpmbuild(macros) >= 1.605
53 BuildRequires:  sed >= 4.0
54 BuildRequires:  tar >= 1:1.22
55 BuildRequires:  xorg-lib-libXi-devel
56 BuildRequires:  xz
57 BuildRequires:  zlib-devel
58 Requires(post,postun):  desktop-file-utils
59 Requires:       OpenGL
60 Requires:       freetype
61 Requires:       python3-modules >= 1:3.10
62 ExclusiveArch:  %{x8664}
63 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
64
65 %define         _noautoreqdep   libGL.so.1 libGLU.so.1
66
67 %description
68 Blender is a free and fully functional 3D modeling, rendering,
69 animation and game creation package for Unix, Windows and BeOS
70 systems.
71
72 %description -l pl.UTF-8
73 Blender to darmowy i w pełni funkcjonalny pakiet do tworzenia animacji
74 3D oraz gier, dostępny dla systemów Unix, Windows i BeOS.
75
76 %prep
77 %setup -q
78 %patch0 -p1
79 %patch1 -p1
80 %patch2 -p1
81
82 %{__sed} -E -i -e '1s,#!\s*/usr/bin/env\s+python(\s|$),#!%{__python3}\1,' -e '1s,#!\s*/usr/bin/env\s+python3(\s|$),#!%{__python3}\1,' \
83       release/scripts/addons/io_curve_svg/svg_util_test.py \
84       release/scripts/addons/io_scene_fbx/fbx2json.py \
85       release/scripts/addons/io_scene_fbx/json2fbx.py \
86       release/scripts/addons/sun_position/geo.py \
87       release/scripts/modules/bl_i18n_utils/merge_po.py \
88       release/scripts/modules/bl_i18n_utils/utils_rtl.py \
89       release/scripts/modules/blend_render_info.py
90
91 %build
92 install -d build
93 cd build
94 %cmake \
95         -DCMAKE_SKIP_RPATH:BOOL=ON \
96         -DBUILD_SHARED_LIBS:BOOL=OFF \
97         -DWITH_FFTW3:BOOL=ON \
98         -DWITH_JACK:BOOL=ON \
99         -DWITH_JACK_DYNLOAD:BOOL=ON \
100         -DWITH_CODEC_SNDFILE:BOOL=ON \
101         -DWITH_IMAGE_OPENJPEG:BOOL=ON \
102         -DWITH_OPENCOLLADA:BOOL=ON \
103         -DWITH_OPENCOLORIO:BOOL=ON \
104         -DWITH_CYCLES:BOOL=ON \
105         -DWITH_FFTW3:BOOL=ON \
106         -DWITH_MOD_OCEANSIM:BOOL=ON \
107         -DOPENCOLLADA=%{_includedir} \
108         -DWITH_PYTHON:BOOL=ON \
109         -DPYTHON_VERSION:STRING=%{py3_ver} \
110         -DWITH_PYTHON_INSTALL:BOOL=OFF \
111         -DWITH_CODEC_FFMPEG:BOOL=ON \
112         -DWITH_GAMEENGINE:BOOL=ON \
113         -DWITH_CXX_GUARDEDALLOC:BOOL=OFF \
114         -DWITH_INSTALL_PORTABLE:BOOL=OFF \
115         -DWITH_PYTHON_SAFETY:BOOL=ON \
116         -DWITH_PLAYER:BOOL=ON \
117         -DWITH_MEM_JEMALLOC:BOOL=ON \
118         -DWITH_SYSTEM_GLEW:BOOL=ON \
119         -DBOOST_ROOT=%{_prefix} \
120         -DWITH_INPUT_NDOF:BOOL=ON \
121         -DWITH_SDL:BOOL=ON \
122         -DWITH_SDL_DYNLOAD:BOOL=ON \
123         ..
124
125 %{__make} V=1
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129
130 install -d $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir},%{_mandir}/man1}
131
132 %{__make} -C build install \
133         DESTDIR=$RPM_BUILD_ROOT
134
135 ./doc/manpage/blender.1.py \
136         --blender $RPM_BUILD_ROOT%{_bindir}/blender \
137         --output $RPM_BUILD_ROOT%{_mandir}/man1/blender.1
138
139 #%find_lang %{name}
140
141 %clean
142 rm -rf $RPM_BUILD_ROOT
143
144 %post
145 %update_desktop_database_post
146
147 %postun
148 %update_desktop_database_postun
149
150 %files
151 %defattr(644,root,root,755)
152 # -f %{name}.lang
153 %doc doc/license/bf-members.txt doc/guides/*.txt
154 %attr(755,root,root) %{_bindir}/blender
155 %attr(755,root,root) %{_bindir}/blender-thumbnailer
156 %attr(755,root,root) %{_datadir}/%{name}
157 %{_desktopdir}/*.desktop
158 %{_iconsdir}/hicolor/scalable/apps/blender.svg
159 %{_iconsdir}/hicolor/symbolic/apps/blender-symbolic.svg
160 %{_mandir}/man1/*
This page took 0.063497 seconds and 3 git commands to generate.