]> git.pld-linux.org Git - packages/blcr.git/blame - blcr.spec
- try forcing SMP kernel
[packages/blcr.git] / blcr.spec
CommitLineData
b0f85f1d
JB
1# TODO: multi-kernels build?
2# NOTE: probably doesn't work with kernel address space randomization(?)
3#
4# Conditional build:
5%bcond_without static_libs # static library
6%bcond_without kernel # kernel modules
7%bcond_without userspace # userspace library and utilities
8%bcond_with verbose # verbose build (V=1) of kernel modules
9#
10Summary: Berkeley Lab Checkpoint/Restart for Linux
11Summary(pl.UTF-8): Berkeley Lab Checkpoint/Restart dla Linuksa
12%define pname blcr
13Name: %{pname}
14Version: 0.8.5
15%define rel 1
16Release: %{rel}
17License: LGPL v2+ (library), GPL v2+ (utilities and modules)
18Group: Libraries
19#Source0Download: http://crd.lbl.gov/departments/computer-science/CLaSS/research/BLCR/berkeley-lab-checkpoint-restart-for-linux-blcr-downloads/
20Source0: http://crd.lbl.gov/assets/Uploads/FTG/Projects/CheckpointRestart/downloads/%{pname}-%{version}.tar.gz
21# Source0-md5: e0e6d3f6c117d820eaafabf2599ad37b
22URL: http://crd.lbl.gov/departments/computer-science/CLaSS/research/BLCR/
23%if %{with userspace}
24BuildRequires: ftb-devel
25BuildRequires: glibc-devel >= 5:2.4
26%endif
27BuildRequires: perl-base
28%if %{with kernel}
29# for System.map and vmlinux symbol lookups
30BuildRequires: kernel%{_alt_kernel} = 3:%{_kernel_ver}
31BuildRequires: kernel%{_alt_kernel}-module-build = 3:%{_kernel_ver}
32BuildRequires: kernel%{_alt_kernel}-module-build >= 3:2.6
33%endif
34ExclusiveArch: %{ix86} %{x8664} arm ppc ppc64 sparc sparcv9 sparc64
35ExcludeArch: i386
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39Berkeley Lab Checkpoint/Restart (BLCR) for Linux is a project of
40Future Technologies Group researchers to develop a hybrid kernel/user
41implementation of checkpoint/restart. Their goal is to provide a
42robust, production quality implementation that checkpoints a wide
43range of applications, without requiring changes to be made to
44application code. This work focuses on checkpointing parallel
45applications that communicate through MPI, and on compatibility with
46the software suite produced by the SciDAC Scalable Systems Software
47ISIC.
48
49%description -l pl.UTF-8
50Berkeley Lab Checkpoint/Restart (BLCR) dla Linuksa to projekt badaczy
51Future Technologies Group polegający na stworzeniu hybrydowej
52(działającej w jądrze i przestrzeni użytkownika) implementacji
53mechanizmu checkpoint/restart (punktów kontrolnych i restartów
54programów). Celem jest dostarczenie bogatej, mającej produkcyjną
55jakość implementacji potrafiącej wykonać migawki stanu szerokiej gamy
56aplikacji bez potrzeby wykonywania zmian w ich kodzie. Praca skupia
57się na aplikacjach równoległych komunikujących się poprzez MPI oraz
58zgodności z oprogramowaniem tworzonym przez SciDAC Scalable Systems
59Software ISIC.
60
61%package devel
62Summary: Header files for BLCR library
63Summary(pl.UTF-8): Pliki nagłówkowe biblioteki BLCR
64License: LGPL v2+
65Group: Development/Libraries
66Requires: %{pname} = %{version}-%{release}
67
68%description devel
69Header files for BLCR library.
70
71%description devel -l pl.UTF-8
72Pliki nagłówkowe biblioteki BLCR.
73
74%package static
75Summary: Static BLCR library
76Summary(pl.UTF-8): Statyczna biblioteka BLCR
77License: LGPL v2+
78Group: Development/Libraries
79Requires: %{pname}-devel = %{version}-%{release}
80
81%description static
82Static BLCR library.
83
84%description static -l pl.UTF-8
85Statyczna biblioteka BLCR.
86
87%package -n kernel%{_alt_kernel}-extra-blcr
88Summary: BLCR modules for Linux kernel
89Summary(pl.UTF-8): Moduły BLCR dla jądra Linuksa
90Release: %{rel}@%{_kernel_ver_str}
91License: GPL v2+
92Group: Base/Kernel
93Requires(post,postun): /sbin/depmod
94%requires_releq_kernel
95Requires(postun): %releq_kernel
96
97%description -n kernel%{_alt_kernel}-extra-blcr
98BLCR modules for Linux kernel.
99
100%description -n kernel%{_alt_kernel}-extra-blcr -l pl.UTF-8
101Moduły BLCR dla jądra Linuksa.
102
103%prep
104%setup -q
105
106%build
107%configure \
108 %{?with_static_libs:--enable-static} \
109%if %{with kernel}
110 %{?with_verbose:--enable-kbuild-verbose} \
ae9628b8 111 --with-kernel-type=SMP \
b0f85f1d
JB
112 --with-linux=%{_kernel_ver} \
113 --with-linux-src=%{_kernelsrcdir} \
114 --with-system-map=/boot/System.map-%{_kernel_ver} \
115 --with-vmlinux=/boot/vmlinuz-%{_kernel_ver} \
116%endif
117 --with-components="%{?with_kernel:modules} %{?with_userspace:util libcr include tests examples contrib}"
118
119%{__make}
120
121%install
122rm -rf $RPM_BUILD_ROOT
123
124%{__make} install \
125 DESTDIR=$RPM_BUILD_ROOT
126
127%clean
128rm -rf $RPM_BUILD_ROOT
129
130%post -p /sbin/ldconfig
131%postun -p /sbin/ldconfig
132
133%post -n kernel%{_alt_kernel}-extra-blcr
134%depmod %{_kernel_ver}
135
136%postun -n kernel%{_alt_kernel}-extra-blcr
137%depmod %{_kernel_ver}
138
139%if %{with userspace}
140%files
141%defattr(644,root,root,755)
142%doc LICENSE.txt NEWS README.FTB doc/{README,html}
143%attr(755,root,root) %{_bindir}/cr_checkpoint
144%attr(755,root,root) %{_bindir}/cr_restart
145%attr(755,root,root) %{_bindir}/cr_run
146%attr(755,root,root) %{_libdir}/libcr.so.*.*.*
147%attr(755,root,root) %ghost %{_libdir}/libcr.so.0
148%attr(755,root,root) %{_libdir}/libcr_omit.so.*.*.*
149%attr(755,root,root) %ghost %{_libdir}/libcr_omit.so.0
150%attr(755,root,root) %{_libdir}/libcr_run.so.*.*.*
151%attr(755,root,root) %ghost %{_libdir}/libcr_run.so.0
152%{_mandir}/man1/cr_checkpoint.1*
153%{_mandir}/man1/cr_restart.1*
154%{_mandir}/man1/cr_run.1*
155
156%files devel
157%defattr(644,root,root,755)
158%doc README.devel
159%attr(755,root,root) %{_libdir}/libcr.so
160%attr(755,root,root) %{_libdir}/libcr_omit.so
161%attr(755,root,root) %{_libdir}/libcr_run.so
162%{_libdir}/libcr.la
163%{_libdir}/libcr_omit.la
164%{_libdir}/libcr_run.la
165%{_includedir}/blcr_*.h
166%{_includedir}/libcr.h
167
168%if %{with static_libs}
169%files static
170%defattr(644,root,root,755)
171%{_libdir}/libcr.a
172%{_libdir}/libcr_omit.a
173%{_libdir}/libcr_run.a
174%endif
175%endif
176
177%if %{with kernel}
178%files -n kernel%{_alt_kernel}-extra-blcr
179%defattr(644,root,root,755)
180/lib/modules/%{_kernel_ver}/extra/blcr.ko*
181/lib/modules/%{_kernel_ver}/extra/blcr_imports.ko*
182%endif
This page took 0.083718 seconds and 4 git commands to generate.