]> git.pld-linux.org Git - packages/blam.git/commitdiff
This commit was manufactured by cvs2git to create branch 'AC-branch'.
authorcvs2git <feedback@pld-linux.org>
Thu, 25 Jan 2007 13:50:18 +0000 (13:50 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Sprout from master 2007-01-25 13:50:18 UTC hawk <hawk@pld-linux.org> '- added xulrunner support'
Cherrypick from master 2005-12-01 20:03:34 UTC freetz <freetz@pld-linux.org> '- one more %%files fix':
    blam.spec -> 1.22
Delete:
    blam-dotnet2.patch

blam-dotnet2.patch [deleted file]
blam.spec

diff --git a/blam-dotnet2.patch b/blam-dotnet2.patch
deleted file mode 100644 (file)
index 74d697c..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-diff -urN aaa/blam-1.8.2/configure.in blam-1.8.2/configure.in
---- aaa/blam-1.8.2/configure.in        2005-06-20 17:12:07.000000000 +0200
-+++ blam-1.8.2/configure.in    2006-08-14 20:30:29.777546250 +0200
-@@ -51,14 +51,14 @@
- PKG_CHECK_MODULES(BASE_DEPENDENCIES, 
-                 mono >= $MONO_REQUIRED_VERSION
--                gtk-sharp >= $GTKSHARP_REQUIRED_VERSION
-+                gtk-sharp-2.0 >= $GTKSHARP_REQUIRED_VERSION
-                   gconf-2.0 >= $GCONF_REQUIRED_VERSION)
- PKG_CHECK_MODULES(BLAM,
--                gtk-sharp >= $GTKSHARP_REQUIRED_VERSION
--                  gecko-sharp >= $GECKOSHARP_REQUIRED_VERSION
--                gconf-sharp >= $GTKSHARP_REQUIRED_VERSION
--                glade-sharp >= $GTKSHARP_REQUIRED_VERSION)
-+                gtk-sharp-2.0 >= $GTKSHARP_REQUIRED_VERSION
-+                  gecko-sharp-2.0 >= $GECKOSHARP_REQUIRED_VERSION
-+                gconf-sharp-2.0 >= $GTKSHARP_REQUIRED_VERSION
-+                glade-sharp-2.0 >= $GTKSHARP_REQUIRED_VERSION)
- AC_SUBST(BLAM_LIBS)
-diff -urN aaa/blam-1.8.2/src/Printing.cs blam-1.8.2/src/Printing.cs
---- aaa/blam-1.8.2/src/Printing.cs     2005-06-18 19:00:42.000000000 +0200
-+++ blam-1.8.2/src/Printing.cs 2006-08-14 22:20:45.915029000 +0200
-@@ -14,7 +14,7 @@
- namespace Imendio.Blam {
-     public class PrintDialog {
-       private ItemView itemView;
--      private PrintJob printJob;
-+      private Gnome.PrintJob printJob;
-       private static string printConfigFile = Application.BaseDir + "/print-config";
-@@ -31,7 +31,7 @@
-               return;
-           }
-           
--          printJob = new PrintJob(LoadPrintConfig());
-+          printJob = new Gnome.PrintJob(LoadPrintConfig());
-           Gnome.PrintDialog dialog = new Gnome.PrintDialog(printJob,
-                                                            "Print - " + itemView.Widget.Title);
-           dialog.Icon = Gdk.Pixbuf.LoadFromResource("blam.png");
index 2757e1dc031e4cebe395ff38a990d83f0280a5da..188ff7e93ca41c6a8f9343208bf310466d5a2102 100644 (file)
--- a/blam.spec
+++ b/blam.spec
@@ -1,10 +1,9 @@
-#
 %include        /usr/lib/rpm/macros.mono
 Summary:       .NET RSS Reader
 Summary(pl):   Program do pobierania informacji w formacie RSS
 Name:          blam
 Version:       1.8.2
-Release:       3
+Release:       2
 License:       GPL v2
 Group:         X11/Applications
 Source0:       http://ftp.imendio.com/pub/imendio/blam/src/%{name}-%{version}.tar.gz
@@ -13,25 +12,22 @@ Patch0:             %{name}-mozilla.patch
 Patch1:                %{name}-mozilla_includes.patch
 Patch2:                %{name}-desktop.patch
 Patch3:                %{name}-install.patch
-Patch4:                %{name}-dotnet2.patch
-Patch5:                %{name}-include.patch
 URL:           http://micke.hallendal.net/
-BuildRequires: GConf2-devel >= 2.14.0
+BuildRequires: GConf2-devel >= 2.4.0
 BuildRequires: autoconf
 BuildRequires: automake >= 1:1.7
-BuildRequires: dotnet-gecko-sharp2-devel >= 0.11
-BuildRequires: dotnet-gnome-sharp-devel >= 2.15.0
-BuildRequires: dotnet-gtk-sharp2-devel >= 2.9.0
+BuildRequires: dotnet-gecko-sharp-devel >= 0.6
+BuildRequires: dotnet-gtk-sharp-devel >= 1.0
+BuildRequires: dotnet-gtk-sharp-gnome-devel >= 1.0
 BuildRequires: intltool >= 0.25
-BuildRequires: libgnomeui-devel >= 2.15.91
+BuildRequires: libgnomeui-devel >= 2.2.0
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
 BuildRequires: mono-csharp >= 1.1.4
-BuildRequires: xulrunner-devel
 BuildRequires: pkgconfig
 BuildRequires: rpmbuild(macros) >= 1.213
 Requires(post,preun):  GConf2 >= 2.4.0
-%requires_eq   xulrunner
+Requires:      mozilla-embedded
 ExcludeArch:   alpha i386 sparc sparc64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -48,8 +44,6 @@ Program do pobierania informacji w formacie RSS wykonany w technologii
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch4 -p1
-%patch5 -p1
 
 %build
 rm -rf autom4te.cache
@@ -69,8 +63,6 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
-
 %find_lang %{name}
 
 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
@@ -97,6 +89,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_prefix}/lib/%{name}/blam.exe.config
 %{_prefix}/lib/%{name}/*.dll
 %{_datadir}/%{name}
-%{_desktopdir}/*.desktop
+%{_desktopdir}/*
 %{_pixmapsdir}/*
 %{_sysconfdir}/gconf/schemas/blam.schemas
This page took 0.112587 seconds and 4 git commands to generate.