]> git.pld-linux.org Git - packages/blackbox.git/blob - blackbox.spec
- fixed x86-centric thinko
[packages/blackbox.git] / blackbox.spec
1 #
2 # TODO: review/update patches
3 #
4 # Conditional build:
5 %bcond_with     epistrophy      # enables using epistorophy key grabber
6 #
7 Summary:        Very small and fast window manger for the X Window
8 Summary(pl.UTF-8):      Mały i szybki zarządca okien dla X Window
9 Summary(de.UTF-8):      Blackbox ist ein Windowmanager
10 Name:           blackbox
11 Version:        0.70.1
12 Release:        3.1
13 License:        BSD-like
14 Group:          X11/Window Managers
15 Source0:        http://dl.sourceforge.net/blackboxwm/%{name}-%{version}.tar.gz
16 # Source0-md5:  2d173b95ca5e64ef478c6a5d2deee9df
17 Source1:        %{name}.desktop
18 Source3:        %{name}.1
19 Source4:        bsetroot.1
20 Source5:        %{name}-README.PLD
21 Source6:        %{name}-xsession.desktop
22 Patch0:         %{name}-am_fixes.patch
23 Patch1:         %{name}-pipe.patch
24 Patch3:         %{name}-epistrophy.patch
25 Patch4:         %{name}-etc_dir.patch
26 Patch5:         %{name}-nls-codesets.patch
27 Patch6:         %{name}-assert.patch
28 Patch7:         %{name}-lib64.patch
29 URL:            http://blackboxwm.sourceforge.net/
30 BuildRequires:  autoconf
31 BuildRequires:  automake
32 %{?with_epistrophy:Requires:    epistrophy}
33 BuildRequires:  rpm >= 4.0.2-48
34 BuildRequires:  xorg-lib-libX11-devel
35 BuildRequires:  xorg-lib-libXft-devel
36 Obsoletes:      fluxbox
37 Conflicts:      filesystem < 3.0-20
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _sysconfdir     /etc/X11/%{name}
41 %define         _wmpropsdir     /usr/share/gnome/wm-properties
42
43 %define         _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
44 %if %{_gcc_ver} == 2
45 %define         __cxx           "%{__cc}"
46 %endif
47
48 %description
49 Blackbox is a window manager for the X Window environment, which is
50 almost completely compliant with ICCCM specified operation policies.
51 It features nice and fast interface with multiple workspaces and
52 simple menus. Fast built-in graphics code that can render solids,
53 gradients and bevels is used to draw window decorations. Remaining
54 small in size, blackbox preserves memory and CPU.
55
56 %description -l pl.UTF-8
57 Blackbox jest zarządcą okien dla X Window spełniającym prawie
58 wszystkie zalecenia ICCM. Jego zaletą jest estetyczny i szybki
59 interfejs z wieloma pulpitami i prostym menu. Wbudowano weń także
60 algorytm rysowania dekoracji okien, które mogą być jednokolorowe,
61 gradientowe lub trójwymiarowe. Blackbox oszczędza pamięć i czas CPU.
62
63 %description -l de.UTF-8
64 Blackbox ist ein Windowmanager für offene Betriebssystem wie z.B.
65 Linux oder freie BSD-Varianten. Er erfreut sich einer großen
66 Fangemeinde, da er sehr ressourcenschonend und voll konfigurierbar
67 ist.
68
69 %prep
70 %setup -q
71 #%patch0 -p1
72 #%patch1 -p1
73 %{?with_epistrophy:%patch3 -p1}
74 #%patch4 -p1
75 #%patch5 -p1
76 #%patch6 -p1
77 %if "%{_lib}" == "lib64"
78 %patch7 -p0
79 %endif
80
81 %build
82 rm -f missing
83 %{__libtoolize}
84 %{__aclocal}
85 %{__autoconf}
86 %{__automake}
87 %configure
88 %{__make}
89
90 %install
91 rm -rf $RPM_BUILD_ROOT
92 install -d \
93         $RPM_BUILD_ROOT{%{_wmpropsdir},%{_mandir}/pl/man1,%{_sysconfdir}} \
94         $RPM_BUILD_ROOT%{_datadir}/xsessions
95
96 %{__make} install \
97         DESTDIR=$RPM_BUILD_ROOT
98
99 install %{SOURCE1} $RPM_BUILD_ROOT%{_wmpropsdir}
100 install %{SOURCE3} $RPM_BUILD_ROOT%{_mandir}/pl/man1
101 install %{SOURCE4} $RPM_BUILD_ROOT%{_mandir}/pl/man1
102 cp %{SOURCE5} README.PLD
103 install %{SOURCE6} $RPM_BUILD_ROOT%{_datadir}/xsessions/%{name}.desktop
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %files
109 %defattr(644,root,root,755)
110 %doc AUTHORS README* ChangeLog LICENSE TODO
111 %attr(755,root,root) %{_bindir}/*
112 %dir %{_sysconfdir}
113 %dir %{_datadir}/blackbox
114 %{_datadir}/blackbox/styles
115 %{_datadir}/xsessions/%{name}.desktop
116 %{_wmpropsdir}/blackbox.desktop
117 %{_mandir}/man1/*
118 %lang(pl) %{_mandir}/pl/man1/*
119 %{_datadir}/blackbox/menu
This page took 0.083016 seconds and 3 git commands to generate.