]> git.pld-linux.org Git - packages/blackbox.git/blob - blackbox.spec
- final gcc stuff
[packages/blackbox.git] / blackbox.spec
1 Summary:        Very small and fast window manger for the X Window
2 Summary(pl):    Ma³y i szybki menad¿er okien dla X Window
3 Name:           blackbox
4 Version:        0.62.1
5 Release:        3
6 License:        GPL
7 Group:          X11/Window Managers
8 Group(de):      X11/Fenstermanager
9 Group(es):      X11/Administraadores De Ventanas
10 Group(fr):      X11/Gestionnaires De Fenêtres
11 Group(pl):      X11/Zarz±dcy Okien
12 Vendor:         Brad Hughes <blackbox@alug.org>
13 Source0:        http://prdownloads.sourceforge.net/blackboxwm/%{name}-%{version}.tar.gz
14 Source1:        %{name}.desktop
15 Patch0:         %{name}-am_fixes.patch
16 URL:            http://blackboxwm.sourceforge.net/
17 BuildRequires:  XFree86-devel
18 BuildRequires:  autoconf
19 BuildRequires:  automake
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _prefix         /usr/X11R6
23 %define         _mandir         %{_prefix}/man
24 %define         _sysconfdir     /etc/X11/%{name}
25
26 %define         _gcc_ver        %(%{__cc} --version | cut -b 1)
27 %if %{_gcc_ver} == 3
28 %define         __cxx           "%{__cc} -lstdc++"
29 %else
30 %define         __cxx           "%{__cc}"
31 %endif
32
33 %description
34 Blackbox is a window manager for the X Window environment, which is
35 almost completely compliant with ICCCM specified operation policies.
36 It features nice and fast interface with multiple workspaces and
37 simple menus. Fast built-in graphics code that can render solids,
38 gradients and bevels is used to draw window decorations. Remaining
39 small in size, blackbox preserves memory and CPU.
40
41 %description -l pl
42 Blackbox jest mened¿erem okien dla X Window spe³niaj±cym prawie
43 wszystkie zalecenia ICCM. Jego zalet± jest estetyczny i szybki
44 interfejs z wieloma pulpitami i prostym menu. Wbudowano weñ tak¿e
45 algorytm rysowania dekoracji okien, które mog± byæ jednokolorowe,
46 gradientowe lub trójwymiarowe. Blackbox oszczêdza pamiêæ i czas CPU.
47
48 %prep
49 %setup -q
50 %patch0 -p1
51
52 %build
53 aclocal
54 autoconf
55 automake -a -c
56 %configure
57 %{__make}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT%{_datadir}/wm-properties
62
63 %{__make} install DESTDIR=$RPM_BUILD_ROOT
64
65 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/wm-properties/
66
67 gzip -9nf README* ChangeLog
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc *.gz
75 %attr(755,root,root) %{_bindir}/*
76 %dir %{_sysconfdir}
77 %dir %{_datadir}/blackbox
78 %{_datadir}/blackbox/styles/*
79 %{_datadir}/blackbox/nls/*
80 %{_datadir}/wm-properties/blackbox.desktop
81 %{_mandir}/man1/*
82 %{_sysconfdir}/menu
This page took 0.035815 seconds and 3 git commands to generate.