]> git.pld-linux.org Git - packages/bitlbee.git/blame_incremental - bitlbee.spec
- do not leak skyped listening socket to spawned skype process
[packages/bitlbee.git] / bitlbee.spec
... / ...
CommitLineData
1# TODO
2# - sync pl
3#
4# Conditional build:
5%bcond_without otr # build without OTR
6%bcond_with purple # build with libpurple (not recommended for public servers). http://wiki.bitlbee.org/HowtoPurple
7
8Summary: An IRC to other chat networks gateway
9Summary(pl.UTF-8): Bramka pomiędzy IRC-em i innymi sieciami komunikacyjnymi
10Name: bitlbee
11Version: 3.0.5
12Release: 0.16
13License: GPL v2+ and MIT
14Group: Daemons
15Source0: http://get.bitlbee.org/src/%{name}-%{version}.tar.gz
16# Source0-md5: 9ff97260a2a7f3a7d102db158a8d9887
17URL: http://www.bitlbee.org/
18Patch0: config.patch
19Patch1: systemd.patch
20Patch2: skyped-FD_CLOEXEC.patch
21BuildRequires: asciidoc
22BuildRequires: gnutls-devel
23%{?with_otr:BuildRequires: libotr-devel >= 3.2.0}
24%{?with_purple:BuildRequires: libpurple-devel}
25BuildRequires: rpmbuild(macros) >= 1.461
26BuildRequires: systemd-units
27Requires(postun): /usr/sbin/groupdel
28Requires(postun): /usr/sbin/userdel
29Requires(pre): /bin/id
30Requires(pre): /usr/bin/getgid
31Requires(pre): /usr/sbin/groupadd
32Requires(pre): /usr/sbin/useradd
33Requires: systemd-units >= 37-0.10
34Provides: group(bitlbee)
35Provides: user(bitlbee)
36BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38%description
39Bitlbee is an IRC to other chat networks gateway. Bitlbee can be used
40as an IRC server which forwards everything you say to people on other
41chat networks like ICQ/AIM, MSN, XMPP/Jabber (including Google Talk),
42Yahoo or Twitter!
43
44%description -l pl.UTF-8
45Bramka pomiędzy IRC-em i innymi sieciami komunikacyjnymi. Ten program
46może być używany jako serwer IRC przekazujący wszystko co się mówi do
47ludzi korzystających z innych sieci komunikacyjnych, takich jak
48MSN/ICQ/Jabber.
49
50%package devel
51Summary: Development files for bitlbee
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
54
55%description devel
56The bitlbee-devel package includes header files necessary for building
57and developing programs and plugins which use bitlbee.
58
59%package otr
60Summary: OTR plugin for bitlbee
61Group: Daemons
62Requires: %{name} = %{version}-%{release}
63
64%description otr
65The bitlbee-otr package includes OTR plugin for bitlbee. Not
66completely stable and not 100% foolproof so use at your own risk.
67
68%package protocol-skype
69Summary: Skype protocol support for bitlbee
70Group: Daemons
71Requires: %{name} = %{version}-%{release}
72Requires: python-skype
73
74%description protocol-skype
75Skype protocol support for bitlbee.
76
77%prep
78%setup -q
79%patch0 -p1
80%patch1 -p1
81%patch2 -p1
82
83# fix wrong assumption with $DESTDIR
84%{__sed} -i -e 's,$(shell id -u),0,' Makefile
85
86# fix #!%{_bindir}/env python -> #!%{__python}:
87%{__sed} -i -e '1s,^#!.*python.*,#!%{__python},' protocols/skype/*.py
88
89# fix config path
90%{__sed} -i -e 's,/usr/local/etc/skyped,%{_sysconfdir}/skyped,' protocols/skype/*.py
91
92%build
93CFLAGS="%{rpmcflags}" \
94./configure \
95 --prefix=%{_prefix} \
96 --bindir=%{_sbindir} \
97 --etcdir=%{_sysconfdir}/%{name} \
98 --mandir=%{_mandir} \
99 --datadir=%{_datadir}/%{name} \
100 --config=%{_localstatedir}/lib/%{name} \
101 --pcdir=%{_pkgconfigdir} \
102 --plugindir=%{_libdir}/%{name} \
103 --strip=0 \
104 --plugins=1 \
105 --ssl=gnutls \
106%if %{with purple}
107 --purple=1 \
108%endif
109%if %{with otr}
110 --otr=plugin \
111%endif
112 --skype=plugin \
113
114%{__make}
115
116%install
117rm -rf $RPM_BUILD_ROOT
118install -d $RPM_BUILD_ROOT%{_localstatedir}/lib/%{name}
119%{__make} install install-dev install-etc install-systemd \
120 DESTDIR=$RPM_BUILD_ROOT
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%pre
126%groupadd -g 280 bitlbee
127%useradd -u 280 -d /var/lib/bitlbee -g bitlbee -c "Bitlbee User" bitlbee
128%systemd_post bitlbee.service
129
130%preun
131%systemd_preun bitlbee.service
132
133%postun
134if [ "$1" = "0" ]; then
135 %userremove bitlbee
136 %groupremove bitlbee
137fi
138%systemd_reload
139
140%files
141%defattr(644,root,root,755)
142%doc doc/{AUTHORS,CHANGES,CREDITS,FAQ,README} utils
143%dir %attr(750,root,bitlbee) %{_sysconfdir}/%{name}
144%attr(640,root,bitlbee) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/bitlbee.conf
145%attr(640,root,bitlbee) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/motd.txt
146%attr(755,root,root) %{_sbindir}/bitlbee
147%{_mandir}/man5/bitlbee.conf.5*
148%{_mandir}/man8/bitlbee.8*
149%{_datadir}/bitlbee
150%dir %{_libdir}/%{name}
151%attr(770,root,bitlbee) %{_localstatedir}/lib/bitlbee
152%{systemdunitdir}/bitlbee.service
153%{systemdunitdir}/bitlbee.socket
154%{systemdunitdir}/bitlbee@.service
155
156%files devel
157%defattr(644,root,root,755)
158%doc doc/example_plugin.c
159%{_includedir}/%{name}
160%{_pkgconfigdir}/%{name}.pc
161
162%if %{with otr}
163%files otr
164%defattr(644,root,root,755)
165%attr(755,root,root) %{_libdir}/%{name}/otr.so
166%endif
167
168%files protocol-skype
169%defattr(644,root,root,755)
170%doc protocols/skype/{HACKING,NEWS,README,skyped.txt}
171%dir %attr(750,root,bitlbee) %{_sysconfdir}/skyped
172%attr(640,root,bitlbee) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/skyped/skyped.cnf
173%attr(640,root,bitlbee) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/skyped/skyped.conf
174%attr(755,root,root) %{_libdir}/%{name}/skype.so
175%attr(755,root,root) %{_sbindir}/skyped
176%{_mandir}/man1/skyped.1*
This page took 0.086571 seconds and 4 git commands to generate.