]> git.pld-linux.org Git - packages/bitcoin.git/commitdiff
fix build with current libunivalue (from debian)
authorJan Palus <atler@pld-linux.org>
Sun, 15 Aug 2021 21:26:38 +0000 (23:26 +0200)
committerJan Palus <atler@pld-linux.org>
Sun, 15 Aug 2021 21:26:38 +0000 (23:26 +0200)
bitcoin.spec
univalue.patch [new file with mode: 0644]

index c53ec598827dd3e2956cf7c72890d49a214ec03b..53cebd7adc1fb699f7fc8ee6b9f340bdc4852aef 100644 (file)
@@ -11,6 +11,7 @@ Group:                X11/Applications
 Source0:       https://bitcoin.org/bin/bitcoin-core-%{version}/bitcoin-%{version}.tar.gz
 # Source0-md5: 46e632b4f42a5162e6f100a01cf4ee00
 Patch0:                qt-5.15.patch
+Patch1:                univalue.patch
 URL:           http://www.bitcoin.org/
 BuildRequires: Qt5Core-devel >= 5.0
 BuildRequires: Qt5DBus-devel >= 5.0
@@ -88,6 +89,7 @@ Portfel na bitcoiny oparty na Qt.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 %{__libtoolize}
diff --git a/univalue.patch b/univalue.patch
new file mode 100644 (file)
index 0000000..d0928c0
--- /dev/null
@@ -0,0 +1,19 @@
+Description: fix convert atomic to non-atomic integer for UniValue
+ Fixes Bitcoin 0.20.1 build failure when linked with mainline UniValue:
+ rpc/blockchain.cpp:2077:35: error: cannot convert 'std::atomic<int>' to 'const UniValue&'
+Author: Jonas Smedegaard <dr@jones.dk>
+License: Expat
+Last-Update: 2020-11-26
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/src/rpc/blockchain.cpp
++++ b/src/rpc/blockchain.cpp
+@@ -2187,7 +2187,7 @@
+             // no scan in progress
+             return NullUniValue;
+         }
+-        result.pushKV("progress", g_scan_progress);
++        result.pushKV("progress", (int)g_scan_progress);
+         return result;
+     } else if (request.params[0].get_str() == "abort") {
+         CoinsViewScanReserver reserver;
This page took 0.126898 seconds and 4 git commands to generate.