]> git.pld-linux.org Git - packages/bison.git/blob - bison.spec
- added code_start-segv patch (fix for possible SEGV in EPILOGUE), release 7
[packages/bison.git] / bison.spec
1 Summary:        A GNU general-purpose parser generator
2 Summary(de):    GNU-Parser-Generator
3 Summary(es):    Generador de parser de la GNU
4 Summary(fr):    Générateur d'analyseur lexical de GNU
5 Summary(pl):    GNU generator sk³adni
6 Summary(pt_BR): Gerador de parser da GNU
7 Summary(ru):    Bison - ÇÅÎÅÒÁÔÏÒ ÐÁÒÓÅÒÏ× GNU
8 Summary(tr):    GNU ayrýþtýrýcý üreticisi
9 Summary(uk):    Bison - ÇÅÎÅÒÁÔÏÒ ÐÁÒÓÅҦנGNU
10 Name:           bison
11 Version:        1.875
12 Release:        7
13 License:        GPL
14 Group:          Development/Tools
15 Source0:        ftp://ftp.gnu.org/pub/gnu/%{name}/%{name}-%{version}.tar.bz2
16 # Source0-md5: b7f8027b249ebd4dd0cc948943a71af0
17 Source1:        %{name}.1.pl
18 Patch0:         %{name}-info.patch
19 Patch1:         %{name}-unused.patch
20 Patch2:         %{name}-code_start-segv.patch
21 BuildRequires:  automake
22 BuildRequires:  m4 >= 1.4
23 BuildRequires:  texinfo
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         pkgdatadir      %{_datadir}/bison
27
28 %description
29 Bison is a general purpose parser generator which converts a grammar
30 description for an LALR context-free grammar into a C program to parse
31 that grammar. Bison can be used to develop a wide range of language
32 parsers, from ones used in simple desk calculators to complex
33 programming languages. Bison is upwardly compatible with Yacc, so any
34 correctly written Yacc grammar should work with Bison without any
35 changes. If you know Yacc, you shouldn't have any trouble using Bison
36 (but you do need to be very proficient in C programming to be able to
37 use Bison). Many programs use Bison as part of their build process.
38 Bison is only needed on systems that are used for development.
39
40 %description -l de
41 Dies ist der GNU-Parser-Generator, der größtenteils mit yacc
42 kompatibel ist. Viele Programme benutzen ihn als Teil des
43 Aufbauvorgangs. Bison wird nur auf Systemen benötigt, die zur
44 Entwicklung verwendet werden.
45
46 %description -l es
47 Este es el creador de análisis gramatical GNU más compatible con yacc.
48 Varios programas lo utilizan como parte del su proceso de
49 construcción. Bison solamente hace falta en sistemas que se usan para
50 desarrollo.
51
52 %description -l fr
53 Générateur d'analyseur lexical de GNU compatible avec yacc. De
54 nombreux programmes l'utilisent dans leur phase de construction. Bison
55 ne sert que sur les systèmes utilisés pour le développement.
56
57 %description -l pl
58 W pakiecie znajduje siê implementacja GNU generatora analizatora
59 sk³adni, który jest odpowiednikiem programu yacc. Wiele programów
60 podczas kompilacji potrzebuje tego programu aby proces budowy plików
61 binarnych przebiega³ prawid³owo. Bison jest potrzebny tylko w
62 systemach, w których prowadzone s± ró¿nego rodzaju kompilacje.
63
64 %description -l pt_BR
65 Este é o gerador de análise gramatical GNU que é mais compatível com
66 yacc. Vários programas o utilizam como parte do seu processo de
67 construção. Bison é somente necessário em sistemas que são usados para
68 desenvolvimento.
69
70 %description -l ru
71 Bison - ÜÔÏ ÐÁÒÓÅÒ, × ÏÓÎÏ×ÎÏÍ ÓÏ×ÍÅÓÔÉÍÙÊ Ó yacc. íÎÏÇÉÅ ÐÒÏÇÒÁÍÍÙ
72 ÉÓÐÏÌØÚÕÀÔ ÅÇÏ × ÐÒÏÃÅÓÓÅ ËÏÍÐÉÌÌÑÃÉÉ. Bison ÎÕÖÅΠÔÏÌØËÏ × ÓÉÓÔÅÍÁÈ,
73 ËÏÔÏÒÙÅ ÉÓÐÏÌØÚÕÀÔÓÑ ÄÌÑ ÒÁÚÒÁÂÏÔËÉ ÐÒÏÇÒÁÍÍ.
74
75 %description -l tr
76 byacc bir yacc ayrýþtýrýcýsýdýr. Pek çok program tarafýndan, kurulum
77 süreci sýrasýnda kullanýlýr. Geliþtirme yapanlara gerekli olabilir.
78
79 %description -l uk
80 Bison - ÃÅ ÐÁÒÓÅÒ, ÚÄŦÌØÛÏÇÏ ÓÕͦÓÎÉÊ Ú yacc. âÁÇÁÔÏ ÐÒÏÇÒÁÍ
81 ×ÉËÏÒÉÓÔÏ×ÕÀÔØ ÊÏÇÏ × ÐÒÏÃÅÓ¦ ËÏÍЦÌÑæ§. Bison ÐÏÔÒ¦ÂÅΠԦÌØËÉ ×
82 ÓÉÓÔÅÍÁÈ, Ñ˦ ×ÉËÏÒÉÓÔÏ×ÕÀÔØÓÑ ÄÌÑ ÒÏÚÒÏÂËÉ ÐÒÏÇÒÁÍ.
83
84 %prep
85 %setup -q
86 %patch0 -p1
87 %patch1 -p1
88 %patch2 -p1
89
90 %build
91 rm -f config/config.sub
92 cp /usr/share/automake/config.sub config/
93 %configure
94 %{__make} \
95         pkgdatadir=%{pkgdatadir}
96
97 %install
98 rm -rf $RPM_BUILD_ROOT
99 install -d $RPM_BUILD_ROOT%{_mandir}/pl/man1
100
101 %{__make} install \
102         DESTDIR=$RPM_BUILD_ROOT \
103         pkgdatadir=%{pkgdatadir}
104
105 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/pl/man1/bison.1
106
107 %find_lang %{name}
108
109 %clean
110 rm -rf $RPM_BUILD_ROOT
111
112 %post
113 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
114
115 %postun
116 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
117
118 %files -f %{name}.lang
119 %defattr(644,root,root,755)
120 %attr(755,root,root) %{_bindir}/bison
121 %{pkgdatadir}
122 %{_libdir}/lib*.a
123 %{_mandir}/man1/*
124 %lang(pl) %{_mandir}/pl/man1/*
125 %{_infodir}/*.info*
This page took 0.091054 seconds and 3 git commands to generate.