]> git.pld-linux.org Git - packages/bison.git/blob - bison.spec
63686cd43442d3cc5f18533839507a3c10940536
[packages/bison.git] / bison.spec
1 #
2 # Conditional build:
3 %bcond_without  libtextstyle    # libtextstyle support
4
5 Summary:        A GNU general-purpose parser generator
6 Summary(de.UTF-8):      GNU-Parser-Generator
7 Summary(es.UTF-8):      Generador de parser de la GNU
8 Summary(fr.UTF-8):      Générateur d'analyseur lexical de GNU
9 Summary(pl.UTF-8):      GNU generator składni
10 Summary(pt_BR.UTF-8):   Gerador de parser da GNU
11 Summary(ru.UTF-8):      Bison - генератор парсеров GNU
12 Summary(tr.UTF-8):      GNU ayrıştırıcı üreticisi
13 Summary(uk.UTF-8):      Bison - генератор парсерів GNU
14 Name:           bison
15 Version:        3.8.2
16 Release:        1
17 License:        GPL v3+
18 Group:          Development/Tools
19 Source0:        https://ftp.gnu.org/gnu/bison/%{name}-%{version}.tar.lz
20 # Source0-md5:  26e76218c2a50a0dd307286d42eb0af9
21 Source1:        %{name}.1.pl
22 Patch0:         %{name}-info.patch
23 Patch1:         no_libtextstyle.patch
24 URL:            http://www.gnu.org/software/bison/
25 BuildRequires:  flex
26 BuildRequires:  gcc >= 5:3.2
27 BuildRequires:  gettext-tools >= 0.19
28 BuildRequires:  help2man
29 %{?with_libtextstyle:BuildRequires:     libtextstyle-devel >= 0.20.5}
30 BuildRequires:  libxslt-progs
31 BuildRequires:  lzip
32 BuildRequires:  m4 >= 1.4.6
33 # find_lang -a
34 BuildRequires:  rpmbuild(find_lang) >= 1.31
35 BuildRequires:  tar >= 1:1.22
36 BuildRequires:  texinfo >= 4.0
37 Requires:       %{name}-runtime = %{version}-%{release}
38 %{?with_libtextstyle:Requires:  libtextstyle >= 0.20.5}
39 Requires:       m4 >= 1.4.6
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %description
43 Bison is a general purpose parser generator which converts a grammar
44 description for an LALR context-free grammar into a C program to parse
45 that grammar. Bison can be used to develop a wide range of language
46 parsers, from ones used in simple desk calculators to complex
47 programming languages. Bison is upwardly compatible with Yacc, so any
48 correctly written Yacc grammar should work with Bison without any
49 changes. If you know Yacc, you shouldn't have any trouble using Bison
50 (but you do need to be very proficient in C programming to be able to
51 use Bison). Many programs use Bison as part of their build process.
52 Bison is only needed on systems that are used for development.
53
54 %description -l de.UTF-8
55 Dies ist der GNU-Parser-Generator, der größtenteils mit yacc
56 kompatibel ist. Viele Programme benutzen ihn als Teil des
57 Aufbauvorgangs. Bison wird nur auf Systemen benötigt, die zur
58 Entwicklung verwendet werden.
59
60 %description -l es.UTF-8
61 Este es el creador de análisis gramatical GNU más compatible con yacc.
62 Varios programas lo utilizan como parte del su proceso de
63 construcción. Bison solamente hace falta en sistemas que se usan para
64 desarrollo.
65
66 %description -l fr.UTF-8
67 Générateur d'analyseur lexical de GNU compatible avec yacc. De
68 nombreux programmes l'utilisent dans leur phase de construction. Bison
69 ne sert que sur les systèmes utilisés pour le développement.
70
71 %description -l pl.UTF-8
72 W pakiecie znajduje się implementacja GNU generatora analizatora
73 składni, który jest odpowiednikiem programu yacc. Wiele programów
74 podczas kompilacji potrzebuje tego programu aby proces budowy plików
75 binarnych przebiegał prawidłowo. Bison jest potrzebny tylko w
76 systemach, w których prowadzone są różnego rodzaju kompilacje.
77
78 %description -l pt_BR.UTF-8
79 Este é o gerador de análise gramatical GNU que é mais compatível com
80 yacc. Vários programas o utilizam como parte do seu processo de
81 construção. Bison é somente necessário em sistemas que são usados para
82 desenvolvimento.
83
84 %description -l ru.UTF-8
85 Bison - это парсер, в основном совместимый с yacc. Многие программы
86 используют его в процессе компилляции. Bison нужен только в системах,
87 которые используются для разработки программ.
88
89 %description -l tr.UTF-8
90 byacc bir yacc ayrıştırıcısıdır. Pek çok program tarafından, kurulum
91 süreci sırasında kullanılır. Geliştirme yapanlara gerekli olabilir.
92
93 %description -l uk.UTF-8
94 Bison - це парсер, здебільшого сумісний з yacc. Багато програм
95 використовують його в процесі компіляції. Bison потрібен тільки в
96 системах, які використовуються для розробки програм.
97
98 %package runtime
99 Summary:        Runtime library for programs containing bison-generated parsers
100 Summary(pl.UTF-8):      Biblioteka uruchomieniowa dla programów zawierajacych parsery bisonowe
101 Group:          Libraries
102
103 %description runtime
104 Runtime library for internationalized programs containing
105 bison-generated parsers.
106
107 %description runtime -l pl.UTF-8
108 Biblioteka uruchomieniowa dla umiędzynarodowionych programów
109 zawierajacych parsery wygenerowane przez bisona.
110
111 %prep
112 %setup -q
113 %patch0 -p1
114 %{!?with_libtextstyle:%patch1 -p1}
115
116 %{__rm} po/stamp-po
117
118 %build
119 %{__aclocal} -I m4
120 %{__autoconf}
121 %{__autoheader}
122 %{__automake}
123 %configure \
124         --disable-silent-rules
125 %{__make}
126
127 %install
128 rm -rf $RPM_BUILD_ROOT
129 install -d $RPM_BUILD_ROOT%{_mandir}/pl/man1
130
131 %{__make} install \
132         DESTDIR=$RPM_BUILD_ROOT
133
134 install %{SOURCE1} $RPM_BUILD_ROOT%{_mandir}/pl/man1/bison.1
135
136 # provided by byacc (bison is not 100% compatible)
137 %{__rm} $RPM_BUILD_ROOT{%{_bindir}/yacc,%{_mandir}/man1/yacc.1}
138
139 install -d $RPM_BUILD_ROOT%{_examplesdir}
140 %{__mv} $RPM_BUILD_ROOT%{_docdir}/bison/examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
141 # the rest is packaged as %doc
142 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/bison
143
144 %find_lang %{name}
145 %find_lang %{name}-gnulib -a %{name}.lang
146 %find_lang %{name}-runtime
147
148 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %post   -p /sbin/postshell
154 -/usr/sbin/fix-info-dir -c %{_infodir}
155
156 %postun -p /sbin/postshell
157 -/usr/sbin/fix-info-dir -c %{_infodir}
158
159 %files -f %{name}.lang
160 %defattr(644,root,root,755)
161 %doc AUTHORS ChangeLog NEWS README THANKS TODO
162 %attr(755,root,root) %{_bindir}/bison
163 %{_libdir}/liby.a
164 %{_datadir}/bison
165 %{_aclocaldir}/bison-i18n.m4
166 %{_mandir}/man1/bison.1*
167 %lang(pl) %{_mandir}/pl/man1/bison.1*
168 %{_infodir}/bison.info*
169 %{_examplesdir}/%{name}-%{version}
170
171 %files runtime -f %{name}-runtime.lang
172 %defattr(644,root,root,755)
This page took 0.039626 seconds and 3 git commands to generate.