]> git.pld-linux.org Git - packages/binutils.git/commitdiff
- up to 2.33.1; gasp no longer builds auto/th/binutils-2.33.1-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 9 Nov 2019 01:46:17 +0000 (02:46 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 9 Nov 2019 01:46:17 +0000 (02:46 +0100)
binutils-CVE-2019-1010204.patch [new file with mode: 0644]
binutils-CVE-2019-9071.patch [deleted file]
binutils-CVE-2019-9073.patch [deleted file]
binutils-CVE-2019-9074.patch [deleted file]
binutils-CVE-2019-9075.patch [deleted file]
binutils-CVE-2019-9077.patch [deleted file]
binutils-elf_remove_property.patch [deleted file]
binutils-libdir.patch [deleted file]
binutils.spec

diff --git a/binutils-CVE-2019-1010204.patch b/binutils-CVE-2019-1010204.patch
new file mode 100644 (file)
index 0000000..56434b1
--- /dev/null
@@ -0,0 +1,15 @@
+--- binutils.orig/gold/fileread.cc     2019-08-06 14:22:08.669313110 +0100
++++ binutils-2.32/gold/fileread.cc     2019-08-06 14:22:28.799177543 +0100
+@@ -381,6 +381,12 @@ File_read::do_read(off_t start, section_
+   ssize_t bytes;
+   if (this->whole_file_view_ != NULL)
+     {
++      // See PR 23765 for an example of a testcase that triggers this error.
++      if (((ssize_t) start) < 0)
++      gold_fatal(_("%s: read failed, starting offset (%#llx) less than zero"),
++                 this->filename().c_str(),
++                 static_cast<long long>(start));
++      
+       bytes = this->size_ - start;
+       if (static_cast<section_size_type>(bytes) >= size)
+       {
diff --git a/binutils-CVE-2019-9071.patch b/binutils-CVE-2019-9071.patch
deleted file mode 100644 (file)
index f4ef3bc..0000000
+++ /dev/null
@@ -1,110 +0,0 @@
---- binutils.orig/libiberty/cp-demangle.c      2019-04-10 10:31:27.854997707 +0100
-+++ binutils-2.31.1/libiberty/cp-demangle.c    2019-04-10 16:00:35.820350978 +0100
-@@ -858,7 +858,7 @@ CP_STATIC_IF_GLIBCPP_V3
- int
- cplus_demangle_fill_name (struct demangle_component *p, const char *s, int len)
- {
--  if (p == NULL || s == NULL || len == 0)
-+  if (p == NULL || s == NULL || len <= 0)
-     return 0;
-   p->d_printing = 0;
-   p->type = DEMANGLE_COMPONENT_NAME;
-@@ -4032,7 +4032,7 @@ d_growable_string_callback_adapter (cons
-    are larger than the actual numbers encountered.  */
- static void
--d_count_templates_scopes (int *num_templates, int *num_scopes,
-+d_count_templates_scopes (struct d_print_info *dpi,
-                         const struct demangle_component *dc)
- {
-   if (dc == NULL)
-@@ -4052,13 +4052,13 @@ d_count_templates_scopes (int *num_templ
-       break;
-     case DEMANGLE_COMPONENT_TEMPLATE:
--      (*num_templates)++;
-+      dpi->num_copy_templates++;
-       goto recurse_left_right;
-     case DEMANGLE_COMPONENT_REFERENCE:
-     case DEMANGLE_COMPONENT_RVALUE_REFERENCE:
-       if (d_left (dc)->type == DEMANGLE_COMPONENT_TEMPLATE_PARAM)
--      (*num_scopes)++;
-+      dpi->num_saved_scopes++;
-       goto recurse_left_right;
-     case DEMANGLE_COMPONENT_QUAL_NAME:
-@@ -4122,42 +4122,42 @@ d_count_templates_scopes (int *num_templ
-     case DEMANGLE_COMPONENT_TAGGED_NAME:
-     case DEMANGLE_COMPONENT_CLONE:
-     recurse_left_right:
--      d_count_templates_scopes (num_templates, num_scopes,
--                              d_left (dc));
--      d_count_templates_scopes (num_templates, num_scopes,
--                              d_right (dc));
-+      /* PR 89394 - Check for too much recursion.  */
-+      if (dpi->recursion > DEMANGLE_RECURSION_LIMIT)
-+      /* FIXME: There ought to be a way to report to the
-+         user that the recursion limit has been reached.  */
-+      return;
-+
-+      ++ dpi->recursion;
-+      d_count_templates_scopes (dpi, d_left (dc));
-+      d_count_templates_scopes (dpi, d_right (dc));
-+      -- dpi->recursion;
-       break;
-     case DEMANGLE_COMPONENT_CTOR:
--      d_count_templates_scopes (num_templates, num_scopes,
--                              dc->u.s_ctor.name);
-+      d_count_templates_scopes (dpi, dc->u.s_ctor.name);
-       break;
-     case DEMANGLE_COMPONENT_DTOR:
--      d_count_templates_scopes (num_templates, num_scopes,
--                              dc->u.s_dtor.name);
-+      d_count_templates_scopes (dpi, dc->u.s_dtor.name);
-       break;
-     case DEMANGLE_COMPONENT_EXTENDED_OPERATOR:
--      d_count_templates_scopes (num_templates, num_scopes,
--                              dc->u.s_extended_operator.name);
-+      d_count_templates_scopes (dpi, dc->u.s_extended_operator.name);
-       break;
-     case DEMANGLE_COMPONENT_FIXED_TYPE:
--      d_count_templates_scopes (num_templates, num_scopes,
--                                dc->u.s_fixed.length);
-+      d_count_templates_scopes (dpi, dc->u.s_fixed.length);
-       break;
-     case DEMANGLE_COMPONENT_GLOBAL_CONSTRUCTORS:
-     case DEMANGLE_COMPONENT_GLOBAL_DESTRUCTORS:
--      d_count_templates_scopes (num_templates, num_scopes,
--                              d_left (dc));
-+      d_count_templates_scopes (dpi, d_left (dc));
-       break;
-     case DEMANGLE_COMPONENT_LAMBDA:
-     case DEMANGLE_COMPONENT_DEFAULT_ARG:
--      d_count_templates_scopes (num_templates, num_scopes,
--                              dc->u.s_unary_num.sub);
-+      d_count_templates_scopes (dpi, dc->u.s_unary_num.sub);
-       break;
-     }
- }
-@@ -4192,8 +4192,12 @@ d_print_init (struct d_print_info *dpi,
-   dpi->next_copy_template = 0;
-   dpi->num_copy_templates = 0;
--  d_count_templates_scopes (&dpi->num_copy_templates,
--                          &dpi->num_saved_scopes, dc);
-+  d_count_templates_scopes (dpi, dc);
-+  /* If we did not reach the recursion limit, then reset the
-+     current recursion value back to 0, so that we can print
-+     the templates.  */
-+  if (dpi->recursion < DEMANGLE_RECURSION_LIMIT)
-+    dpi->recursion = 0;
-   dpi->num_copy_templates *= dpi->num_saved_scopes;
-   dpi->current_template = NULL;
diff --git a/binutils-CVE-2019-9073.patch b/binutils-CVE-2019-9073.patch
deleted file mode 100644 (file)
index 37256f4..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
---- binutils.orig/binutils/objdump.c   2019-02-25 16:12:30.394056901 +0000
-+++ binutils-2.31.1/binutils/objdump.c 2019-02-25 16:13:07.224778005 +0000
-@@ -2993,7 +2993,9 @@ dump_bfd_header (bfd *abfd)
- static void
- dump_bfd_private_header (bfd *abfd)
- {
--  bfd_print_private_bfd_data (abfd, stdout);
-+  if (!bfd_print_private_bfd_data (abfd, stdout))
-+    non_fatal (_("warning: private headers incomplete: %s"),
-+              bfd_errmsg (bfd_get_error ()));
- }
- static void
diff --git a/binutils-CVE-2019-9074.patch b/binutils-CVE-2019-9074.patch
deleted file mode 100644 (file)
index 84f0fd5..0000000
+++ /dev/null
@@ -1,32 +0,0 @@
---- binutils.orig/bfd/pei-x86_64.c     2019-02-25 16:12:29.798061414 +0000
-+++ binutils-2.31.1/bfd/pei-x86_64.c   2019-02-25 17:09:02.783425236 +0000
-@@ -541,7 +541,7 @@ pex64_bfd_print_pdata_section (bfd *abfd
-   /* virt_size might be zero for objects.  */
-   if (stop == 0 && strcmp (abfd->xvec->name, "pe-x86-64") == 0)
-     {
--      stop = (datasize / onaline) * onaline;
-+      stop = datasize;
-       virt_size_is_zero = TRUE;
-     }
-   else if (datasize < stop)
-@@ -551,8 +551,8 @@ pex64_bfd_print_pdata_section (bfd *abfd
-                _("Warning: %s section size (%ld) is smaller than virtual size (%ld)\n"),
-                pdata_section->name, (unsigned long) datasize,
-                (unsigned long) stop);
--      /* Be sure not to read passed datasize.  */
--      stop = datasize / onaline;
-+      /* Be sure not to read past datasize.  */
-+      stop = datasize;
-       }
-   /* Display functions table.  */
-@@ -724,8 +724,7 @@ pex64_bfd_print_pdata_section (bfd *abfd
-             altent += imagebase;
-             if (altent >= pdata_vma
--                && (altent + PDATA_ROW_SIZE <= pdata_vma
--                    + pei_section_data (abfd, pdata_section)->virt_size))
-+                && altent - pdata_vma + PDATA_ROW_SIZE <= stop)
-               {
-                 pex64_get_runtime_function
-                   (abfd, &arf, &pdata[altent - pdata_vma]);
diff --git a/binutils-CVE-2019-9075.patch b/binutils-CVE-2019-9075.patch
deleted file mode 100644 (file)
index ec3e8ca..0000000
+++ /dev/null
@@ -1,73 +0,0 @@
-diff -rup binutils.orig/bfd/archive64.c binutils-2.31.1/bfd/archive64.c
---- binutils.orig/bfd/archive64.c      2019-02-26 11:17:11.882530151 +0000
-+++ binutils-2.31.1/bfd/archive64.c    2019-02-26 11:19:18.422488805 +0000
-@@ -100,8 +100,6 @@ _bfd_archive_64_bit_slurp_armap (bfd *ab
-     return FALSE;
-   carsyms = ardata->symdefs;
-   stringbase = ((char *) ardata->symdefs) + carsym_size;
--  stringbase[stringsize] = 0;
--  stringend = stringbase + stringsize;
-   raw_armap = (bfd_byte *) bfd_alloc (abfd, ptrsize);
-   if (raw_armap == NULL)
-@@ -115,15 +113,17 @@ _bfd_archive_64_bit_slurp_armap (bfd *ab
-       goto release_raw_armap;
-     }
-+  stringend = stringbase + stringsize;
-+  *stringend = 0;
-   for (i = 0; i < nsymz; i++)
-     {
-       carsyms->file_offset = bfd_getb64 (raw_armap + i * 8);
-       carsyms->name = stringbase;
--      if (stringbase < stringend)
--      stringbase += strlen (stringbase) + 1;
-+      stringbase += strlen (stringbase);
-+      if (stringbase != stringend)
-+      ++stringbase;
-       ++carsyms;
-     }
--  *stringbase = '\0';
-   ardata->symdef_count = nsymz;
-   ardata->first_file_filepos = bfd_tell (abfd);
-diff -rup binutils.orig/bfd/archive.c binutils-2.31.1/bfd/archive.c
---- binutils.orig/bfd/archive.c        2019-02-26 11:17:11.884530134 +0000
-+++ binutils-2.31.1/bfd/archive.c      2019-02-26 11:18:33.354859687 +0000
-@@ -1014,6 +1014,7 @@ do_slurp_coff_armap (bfd *abfd)
-   int *raw_armap, *rawptr;
-   struct artdata *ardata = bfd_ardata (abfd);
-   char *stringbase;
-+  char *stringend;
-   bfd_size_type stringsize;
-   bfd_size_type parsed_size;
-   carsym *carsyms;
-@@ -1073,22 +1074,20 @@ do_slurp_coff_armap (bfd *abfd)
-     }
-   /* OK, build the carsyms.  */
--  for (i = 0; i < nsymz && stringsize > 0; i++)
-+  stringend = stringbase + stringsize;
-+  *stringend = 0;
-+  for (i = 0; i < nsymz; i++)
-     {
-       bfd_size_type len;
-       rawptr = raw_armap + i;
-       carsyms->file_offset = swap ((bfd_byte *) rawptr);
-       carsyms->name = stringbase;
--      /* PR 17512: file: 4a1d50c1.  */
--      len = strnlen (stringbase, stringsize);
--      if (len < stringsize)
--      len ++;
--      stringbase += len;
--      stringsize -= len;
-+      stringbase += strlen (stringbase);
-+      if (stringbase != stringend)
-+      ++stringbase;
-       carsyms++;
-     }
--  *stringbase = 0;
-   ardata->symdef_count = nsymz;
-   ardata->first_file_filepos = bfd_tell (abfd);
diff --git a/binutils-CVE-2019-9077.patch b/binutils-CVE-2019-9077.patch
deleted file mode 100644 (file)
index 1790bfa..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
---- binutils.orig/binutils/readelf.c   2019-02-26 11:17:12.414525772 +0000
-+++ binutils-2.31.1/binutils/readelf.c 2019-02-26 12:11:40.642876742 +0000
-@@ -16009,6 +16009,13 @@ process_mips_specific (Filedata * fileda
-         return FALSE;
-       }
-+      /* PR 24243  */
-+      if (sect->sh_size < sizeof (* eopt))
-+      {
-+        error (_("The MIPS options section is too small.\n"));
-+        return FALSE;
-+      }
-+
-       eopt = (Elf_External_Options *) get_data (NULL, filedata, options_offset, 1,
-                                                 sect->sh_size, _("options"));
-       if (eopt)
diff --git a/binutils-elf_remove_property.patch b/binutils-elf_remove_property.patch
deleted file mode 100644 (file)
index 927e5ee..0000000
+++ /dev/null
@@ -1,170 +0,0 @@
-From df010caac3b33b1d38b6d67024091854c3f77c77 Mon Sep 17 00:00:00 2001
-From: "H.J. Lu" <hjl.tools@gmail.com>
-Date: Mon, 24 Jun 2019 11:08:40 -0700
-Subject: [PATCH] elf: Remove the property after reporting its removal
-
-commit d2ef37ebd9f771d06edf1fdea37970f60b242b2d
-Author: H.J. Lu <hjl.tools@gmail.com>
-Date:   Fri Dec 7 08:30:30 2018 -0800
-
-    elf: Report property change when merging properties
-
-failed to remove the property after reporting it has been removed.  This
-patch corrects it.
-
-bfd/
-
-       PR ld/24721
-       * elf-properties.c (elf_merge_gnu_property_list): Remove the
-       property after reporting property removal.
-
-ld/
-
-       PR ld/24721
-       * testsuite/ld-x86-64/x86-64.exp: Run PR ld/24721 tests.
-       * testsuite/ld-x86-64/pr24721-x32.d: New file.
-       * testsuite/ld-x86-64/pr24721.d: Likewise.
-       * testsuite/ld-x86-64/pr24721.map: Likewise.
-       * testsuite/ld-x86-64/pr24721a.s: Likewise.
-       * testsuite/ld-x86-64/pr24721b.s: Likewise.
-
-(cherry picked from commit f93ab3a0b8039a1667a666f013cca50b03d67f9b)
----
- bfd/ChangeLog                        |  6 ++++++
- bfd/elf-properties.c                 | 10 ++++------
- ld/ChangeLog                         | 10 ++++++++++
- ld/testsuite/ld-x86-64/pr24721-x32.d |  6 ++++++
- ld/testsuite/ld-x86-64/pr24721.d     |  6 ++++++
- ld/testsuite/ld-x86-64/pr24721.map   |  3 +++
- ld/testsuite/ld-x86-64/pr24721a.s    | 34 ++++++++++++++++++++++++++++++++++
- ld/testsuite/ld-x86-64/pr24721b.s    |  6 ++++++
- ld/testsuite/ld-x86-64/x86-64.exp    |  2 ++
- 9 files changed, 77 insertions(+), 6 deletions(-)
- create mode 100644 ld/testsuite/ld-x86-64/pr24721-x32.d
- create mode 100644 ld/testsuite/ld-x86-64/pr24721.d
- create mode 100644 ld/testsuite/ld-x86-64/pr24721.map
- create mode 100644 ld/testsuite/ld-x86-64/pr24721a.s
- create mode 100644 ld/testsuite/ld-x86-64/pr24721b.s
-
-diff --git a/bfd/elf-properties.c b/bfd/elf-properties.c
-index 5e48d75..4a9907f 100644
---- a/bfd/elf-properties.c
-+++ b/bfd/elf-properties.c
-@@ -322,12 +322,10 @@ elf_merge_gnu_property_list (struct bfd_link_info *info, bfd *first_pbfd,
-                        (bfd_vma) p->property.pr_type, first_pbfd, abfd);
-                 }
-             }
--          else
--            {
--              /* Remove this property.  */
--              *lastp = p->next;
--              continue;
--            }
-+
-+          /* Remove this property.  */
-+          *lastp = p->next;
-+          continue;
-         }
-       else if (number_p)
-         {
-diff --git a/ld/testsuite/ld-x86-64/pr24721-x32.d b/ld/testsuite/ld-x86-64/pr24721-x32.d
-new file mode 100644
-index 0000000..9b067ef
---- /dev/null
-+++ b/ld/testsuite/ld-x86-64/pr24721-x32.d
-@@ -0,0 +1,6 @@
-+#source: pr24721a.s
-+#source: pr24721b.s
-+#as: --x32 -mx86-used-note=no
-+#ld: -r -m elf32_x86_64 -Map tmpdir/pr24721.map
-+#readelf: -n
-+#map: pr24721.map
-diff --git a/ld/testsuite/ld-x86-64/pr24721.d b/ld/testsuite/ld-x86-64/pr24721.d
-new file mode 100644
-index 0000000..efa88db
---- /dev/null
-+++ b/ld/testsuite/ld-x86-64/pr24721.d
-@@ -0,0 +1,6 @@
-+#source: pr24721a.s
-+#source: pr24721b.s
-+#as: --64 -defsym __64_bit__=1 -mx86-used-note=no
-+#ld: -r -melf_x86_64 -Map tmpdir/pr24721.map
-+#readelf: -n
-+#map: pr24721.map
-diff --git a/ld/testsuite/ld-x86-64/pr24721.map b/ld/testsuite/ld-x86-64/pr24721.map
-new file mode 100644
-index 0000000..9e63fff
---- /dev/null
-+++ b/ld/testsuite/ld-x86-64/pr24721.map
-@@ -0,0 +1,3 @@
-+#...
-+Removed property 0xc0000002 to merge tmpdir/pr24721a.o \(0x1\) and tmpdir/pr24721b.o \(not found\)
-+#pass
-diff --git a/ld/testsuite/ld-x86-64/pr24721a.s b/ld/testsuite/ld-x86-64/pr24721a.s
-new file mode 100644
-index 0000000..b229d19
---- /dev/null
-+++ b/ld/testsuite/ld-x86-64/pr24721a.s
-@@ -0,0 +1,34 @@
-+      .text
-+      .globl foo
-+      .type foo,@function
-+      .p2align 4
-+foo:
-+      ret
-+
-+      .section ".note.gnu.property", "a"
-+.ifdef __64_bit__
-+      .p2align 3
-+.else
-+      .p2align 2
-+.endif
-+      .long 1f - 0f           /* name length */
-+      .long 5f - 2f           /* data length */
-+      .long 5                 /* note type */
-+0:    .asciz "GNU"            /* vendor name */
-+1:
-+.ifdef __64_bit__
-+      .p2align 3
-+.else
-+      .p2align 2
-+.endif
-+2:    .long 0xc0000002        /* pr_type.  */
-+      .long 4f - 3f           /* pr_datasz.  */
-+3:
-+      .long 0x1
-+4:
-+.ifdef __64_bit__
-+      .p2align 3
-+.else
-+      .p2align 2
-+.endif
-+5:
-diff --git a/ld/testsuite/ld-x86-64/pr24721b.s b/ld/testsuite/ld-x86-64/pr24721b.s
-new file mode 100644
-index 0000000..3d11691
---- /dev/null
-+++ b/ld/testsuite/ld-x86-64/pr24721b.s
-@@ -0,0 +1,6 @@
-+      .text
-+      .globl bar
-+      .type bar,@function
-+      .p2align 4
-+bar:
-+      ret
-diff --git a/ld/testsuite/ld-x86-64/x86-64.exp b/ld/testsuite/ld-x86-64/x86-64.exp
-index 9a76486..707ab89 100644
---- a/ld/testsuite/ld-x86-64/x86-64.exp
-+++ b/ld/testsuite/ld-x86-64/x86-64.exp
-@@ -432,6 +432,8 @@ run_dump_test "pr24458b"
- run_dump_test "pr23854"
- run_dump_test "pr23930"
- run_dump_test "pr23930-x32"
-+run_dump_test "pr24721"
-+run_dump_test "pr24721-x32"
- if { ![istarget "x86_64-*-linux*"] && ![istarget "x86_64-*-nacl*"]} {
-     return
--- 
-2.9.3
-
diff --git a/binutils-libdir.patch b/binutils-libdir.patch
deleted file mode 100644 (file)
index d8ec2c0..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
---- binutils-2.26/bfd/Makefile.am.orig 2016-01-26 21:10:01.893801762 +0100
-+++ binutils-2.26/bfd/Makefile.am      2016-01-26 21:10:42.507133384 +0100
-@@ -52,7 +52,7 @@
- WARN_CFLAGS = @WARN_CFLAGS@
- NO_WERROR = @NO_WERROR@
- AM_CFLAGS = $(WARN_CFLAGS) $(ZLIBINC)
--AM_CPPFLAGS = -DBINDIR='"$(bindir)"'
-+AM_CPPFLAGS = -DBINDIR='"$(bindir)"' -DLIBDIR='"$(libdir)"'
- if PLUGINS
- bfdinclude_HEADERS += $(INCDIR)/plugin-api.h
- LIBDL = @lt_cv_dlopen_libs@
---- binutils-2.25.51.0.1/bfd/plugin.c.orig     2015-03-15 11:04:52.000000000 +0100
-+++ binutils-2.25.51.0.1/bfd/plugin.c  2015-03-17 21:03:28.116034504 +0100
-@@ -404,8 +404,7 @@
- static int
- load_plugin (bfd *abfd)
- {
--  char *plugin_dir;
--  char *p;
-+  const char *p = LIBDIR "/bfd-plugins";
-   DIR *d;
-   struct dirent *ent;
-   int found = 0;
-@@ -416,13 +415,6 @@
-   if (plugin_program_name == NULL)
-     return 0;
--  plugin_dir = concat (BINDIR, "/../lib/bfd-plugins", NULL);
--  p = make_relative_prefix (plugin_program_name,
--                          BINDIR,
--                          plugin_dir);
--  free (plugin_dir);
--  plugin_dir = NULL;
--
-   d = opendir (p);
-   if (!d)
-     goto out;
-@@ -441,7 +433,6 @@
-     }
-  out:
--  free (p);
-   if (d)
-     closedir (d);
index 406036076b0556a20bc9a23d2d42d3ebcc30b150..fe60cfdece0369861d2d79155cd21a6ca7453d30 100644 (file)
@@ -6,7 +6,7 @@
 %bcond_with    pax             # without PaX flags (for upstream bugreports)
 %bcond_without gold            # don't build gold (no C++ dependencies)
 %bcond_without default_bfd     # default ld.bfd instead of gold
-%bcond_without gasp            # gasp
+%bcond_with    gasp            # gasp
 %bcond_with    tests           # check target
 
 %ifnarch %{ix86} %{x8664} x32
@@ -23,32 +23,27 @@ Summary(ru.UTF-8):  Набор инструментов GNU для построе
 Summary(tr.UTF-8):     GNU geliştirme araçları
 Summary(uk.UTF-8):     Набір інструментів GNU для побудови виконуваних програм
 Name:          binutils
-Version:       2.32
-Release:       2
+Version:       2.33.1
+Release:       1
 Epoch:         4
 License:       GPL v3+
 Group:         Development/Tools
 Source0:       http://ftp.gnu.org/gnu/binutils/%{name}-%{version}.tar.lz
-# Source0-md5: 3f1013fc8c5b18e1c28ba5c018a4110c
+# Source0-md5: f4e7e023664f087b3017fc42955ebb46
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
 # Source1-md5: a717d9707ec77d82acb6ec9078c472d6
 Patch0:                %{name}-gasp.patch
 Patch1:                %{name}-info.patch
 Patch2:                %{name}-libtool-relink.patch
 Patch3:                %{name}-pt_pax_flags.patch
-Patch4:                %{name}-libdir.patch
 
 Patch6:                %{name}-absolute-gnu_debuglink-path.patch
 Patch7:                %{name}-libtool-m.patch
 Patch8:                %{name}-build-id.patch
 Patch9:                %{name}-tooldir.patch
 Patch10:       %{name}-sanity-check.patch
-Patch11:       binutils-CVE-2019-9071.patch
-Patch12:       binutils-CVE-2019-9073.patch
-Patch13:       binutils-CVE-2019-9074.patch
-Patch14:       binutils-CVE-2019-9075.patch
-Patch15:       binutils-CVE-2019-9077.patch
-Patch16:       %{name}-elf_remove_property.patch
+Patch11:       binutils-CVE-2019-1010204.patch
+
 URL:           http://sources.redhat.com/binutils/
 BuildRequires: autoconf >= 2.64
 BuildRequires: automake >= 1:1.11
@@ -170,7 +165,6 @@ niektórych pakietów.
 %patch1 -p1
 %patch2 -p1
 %{?with_pax:%patch3 -p1}
-%patch4 -p1
 
 %patch6 -p1
 %patch7 -p1
@@ -178,11 +172,6 @@ niektórych pakietów.
 %patch9 -p1
 %patch10 -p1
 %patch11 -p1
-%patch12 -p1
-%patch13 -p1
-%patch14 -p1
-%patch15 -p1
-%patch16 -p1
 
 # file contains hacks for ac 2.59 only
 %{__rm} config/override.m4
This page took 0.05578 seconds and 4 git commands to generate.