]> git.pld-linux.org Git - packages/binutils.git/commitdiff
- looks like gcc 4.7 "fix" breaks kernel builds on i686
authorJan Rękorajski <baggins@pld-linux.org>
Wed, 2 May 2012 18:18:17 +0000 (18:18 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    binutils-fix-i686-kernel.patch -> 1.1
    binutils.spec -> 1.360

binutils-fix-i686-kernel.patch [new file with mode: 0644]
binutils.spec

diff --git a/binutils-fix-i686-kernel.patch b/binutils-fix-i686-kernel.patch
new file mode 100644 (file)
index 0000000..d23f21f
--- /dev/null
@@ -0,0 +1,32 @@
+It seems that this:
+http://sourceware.org/bugzilla/show_bug.cgi?id=13621
+breaks i686 3.3.x kernel build
+
+--- binutils-2.22.52.0.2/bfd/linker.c~ 2012-04-25 19:42:51.000000000 +0200
++++ binutils-2.22.52.0.2/bfd/linker.c  2012-05-02 18:37:51.247665432 +0200
+@@ -3198,10 +3198,12 @@
+       best = prev;
+     }
+-  /* Refuse to choose a section for which we are out of bounds.  */
+-  /* ??? This may make most of the above moot.  */
+-  if (addr < best->vma || addr > best->vma + best->size)
+-    best = bfd_abs_section_ptr;
++// This code causes kernel issues in i686
++// http://lists.pld-linux.org/mailman/pipermail/pld-devel-pl/2012-April/155404.html
++//  /* Refuse to choose a section for which we are out of bounds.  */
++//  /* ??? This may make most of the above moot.  */
++//  if (addr < best->vma || addr > best->vma + best->size)
++//    best = bfd_abs_section_ptr;
+   return best;
+ }
+--- binutils-2.22.52.0.2/ld/testsuite/ld-elf/warn2.d~  2012-04-25 19:42:51.000000000 +0200
++++ binutils-2.22.52.0.2/ld/testsuite/ld-elf/warn2.d   2012-05-02 19:43:00.852579191 +0200
+@@ -13,5 +13,5 @@
+ # construct and that the symbol still appears as expected.
+ #...
+- +[0-9]+: +[0-9a-f]+ +20 +OBJECT +GLOBAL +DEFAULT +ABS Foo
++ +[0-9]+: +[0-9a-f]+ +20 +OBJECT +GLOBAL +DEFAULT +[1-9] Foo
+ #pass
index f748887ed6e2fc8f99720bc39a469ea984cd0e06..1296bd9fc7f1b839bdf76e7addf3fce85618c41e 100644 (file)
@@ -37,6 +37,7 @@ Patch6:               %{name}-absolute-gnu_debuglink-path.patch
 Patch7:                %{name}-libtool-m.patch
 Patch8:                %{name}-build-id.patch
 Patch9:                %{name}-tooldir.patch
+Patch10:       %{name}-fix-i686-kernel.patch
 URL:           http://sources.redhat.com/binutils/
 BuildRequires: autoconf >= 2.64
 BuildRequires: automake >= 1:1.11
@@ -159,6 +160,7 @@ niektórych pakietów.
 %patch7 -p1
 %patch8 -p0
 %patch9 -p1
+%patch10 -p1
 
 # file contains hacks for ac 2.59 only
 %{__rm} config/override.m4
This page took 0.107389 seconds and 4 git commands to generate.