]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
fixed Group
[packages/binutils.git] / binutils.spec
1 Summary:        GNU Binary Utility Development Utilities
2 Summary(pl):    Narzêdzia GNU dla programistów
3 Name:           binutils
4 Version:        2.9.1.0.23
5 Release:        2
6 Copyright:      GPL
7 Group:          Development/Tools
8 Group(pl):      Programowanie/Narzêdzia
9 Source:         ftp://ftp.varesearch.com/pub/support/hjl/binutils/%{name}-%{version}.tar.gz
10 Patch0:         binutils-info.patch
11 BuildRoot:      /tmp/%{name}-%{version}-root
12
13 %description
14 binutils is a collection of utilities necessary for compiling programs. It
15 includes the assembler and linker, as well as a number of other
16 miscellaneous programs for dealing with executable formats.
17
18 %description -l pl
19 Pakiet binutils zawiera zestaw narzêdzi umo¿liwiaj±cych kompilacjê programów. 
20 Znajduj± siê tutaj miêdzy innymi assembler, konsolidator (linker), a tak¿e 
21 inne narzêdzia do manipulowania binarnymi plikami programów i bibliotek.
22
23 %package static
24 Summary:        GNU Binutils static libraries
25 Summary(pl):    Biblioteki statyczne do GNU Binutils
26 Group:          Development/Libraries
27 Group(pl):      Programowanie/Biblioteki
28 Requires:       %{name} = %{version}
29
30 %description static
31 Static libraries for GNU Binutils.
32
33 %description -l pl static
34 Biblioteki statyczne GNU Binutils.
35
36 %prep
37 %setup -q 
38 %patch0 -p1
39
40 %build
41 CFLAGS="$RPM_OPT_FLAGS" LDFLAGS="-s" \
42 %ifarch sparc sparc64
43 sparc32 ./configure \
44 %else
45 ./configure \
46         --prefix=/usr \
47         --enable-shared \
48         --disable-debug \
49         $RPM_ARCH-pld-linux
50 %endif
51
52 make tooldir=/usr all info
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 install -d $RPM_BUILD_ROOT/usr
58
59 make install install-info \
60         prefix=$RPM_BUILD_ROOT/usr \
61         tooldir=$RPM_BUILD_ROOT/usr
62
63 gzip -9nf $RPM_BUILD_ROOT/usr/info/*.inf*
64
65 strip $RPM_BUILD_ROOT/usr/bin/*
66
67 install include/libiberty.h $RPM_BUILD_ROOT/usr/include
68
69 gzip -9nf $RPM_BUILD_ROOT/usr/man/man1/* \
70         README
71
72 %clean
73 rm -rf $RPM_BUILD_ROOT
74
75 %post
76 /sbin/install-info /usr/info/as.info.gz /etc/info-dir
77 /sbin/install-info /usr/info/bfd.info.gz /etc/info-dir
78 /sbin/install-info /usr/info/binutils.info.gz /etc/info-dir 
79 /sbin/install-info /usr/info/ld.info.gz /etc/info-dir
80 /sbin/install-info /usr/info/gasp.info.gz /etc/info-dir 
81 /sbin/install-info /usr/info/gprof.info.gz /etc/info-dir 
82 /sbin/ldconfig
83
84 %preun
85 if [ "$1" = "0" ]; then
86         /sbin/install-info --delete /usr/info/as.info.gz /etc/info-dir
87         /sbin/install-info --delete /usr/info/bfd.info.gz /etc/info-dir
88         /sbin/install-info --delete /usr/info/binutils.info.gz /etc/info-dir
89         /sbin/install-info --delete /usr/info/ld.info.gz /etc/info-dir
90         /sbin/install-info --delete /usr/info/gasp.info.gz /etc/info-dir
91         /sbin/install-info --delete /usr/info/gprof.info.gz /etc/info-dir
92 fi
93
94 %postun -p /sbin/ldconfig
95
96 %files
97 %defattr(644,root,root,755)
98 %doc *.gz
99 %attr(755,root,root) /usr/bin/*
100 %attr(755,root,root) /usr/lib/*.so
101
102 /usr/lib/ldscripts
103 /usr/include/*.h
104
105 /usr/info/*.gz
106
107 /usr/lib/libiberty.a
108 /usr/man/man1/*
109
110 %files static
111 %defattr(644,root,root)
112 /usr/lib/libbfd.a
113 /usr/lib/libopcodes.a
114
115 %changelog
116 * Thu Apr 22 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
117   [2.9.1.0.23-2]
118 - recompiles on new rpm.
119
120 * Wed Apr  7 1999 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
121   [2.9.1.0.23-1]
122 - standarized {un}registering info pages (added binutils-info.patch).
123
124 * Thu Feb 18 1999 Micha³ Kuratczyk <kura@wroclaw.art.pl>
125   [2.9.1.0.19-5d]
126 - gzipping instead bzipping
127 - added LDFLAGS=-s
128 - minor changes
129
130 * Mon Jan 18 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
131   [2.9.1.0.19-4d]
132 - fixed %preun && %post,
133 - commpresed %doc,
134 - added Group(pl),
135 - added Prereq: /sbin/ldconfig,
136 - added URL,
137
138   by Maciek W. Ró¿ycki <macro@ds2.pg.gda.pl>    
139
140 - fixed the binary BFD to correctly output sections,
141 - modified gas so it recognizes single-argument aad and aam,
142 - modified gas so iret generates a non-prefixed opcode
143   regardless of the current argument size.
144 - added support for new Pentium II instructions (see "Addendum
145   -- Intel Architecture Software Developer's Manual, Volume 2:
146   Instruction Set Reference", order number 243689-001),
147 - fixed a problem with relative branch distance overflow checking,
148 - added a fix for 16-bit PC-relative relocations on i386.
149
150 * Sun Dec 20 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
151   [2.9.1.0.19-2d]
152 - removed static subpackages,
153 - cosmetic changes,
154 - final build for Tornado.
155
156 * Wed Dec  8 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
157   [2.9.1.0.17-2] 
158 - added using sparc32 for run ./configure script on sparc
159   architecture (thanks DaveM).
160
161 * Fri Oct  9 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
162   [2.9.1.0.15-2]
163 - /usr/lib/libiberty.a moved to main.
164
165 * Sat Oct 03 1998 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
166   [2.9.1.0.15-1d]
167 - fixed pl translation,
168 - updated to 2.9.1.0.15.
169
170 * Sun Sep 13 1998 Wojtek ¦lusarczyk <wojtek@SHADOW.EU.ORG>
171   [2.9.1.0.12-1d]
172 - updated to 2.9.1.0.12.
173 - install -d instead mkdir -p,
174 - restricted ELF binaries permissions.
175
176 * Tue Sep 07 1998 Wojtek ¦lusarczyk <wojtek@SHADOW.EU.ORG>
177   [2.9.1.0.11-1d]
178 - updated to 2.9.1.0.11,
179 - build without $RPM_OPT_FLAGS - some problems with egcs & -O6 ...
180 - added a static package,
181 - build from non root's account.
182
183 * Sat Aug 22 1998 Tomasz K³oczko <kloczek@rudy.mif.pg.gda.pl>
184   [2.9.1.0.10-3]
185 - changed Buildroot to /tmp/%%{name}-%%{version}-root,
186 - added using %%{name} and %%{version} in Source,
187 - added static subpackage,
188 - removed /usr/lib/lib*.la files,
189 - added using $RPM_OPT_FLAGS during building package.
190
191 * Fri Jun 12 1998 Wojtek ¦lusarczyk <wojtek@SHADOW.EU.ORG>
192   [2.9.1.0.6-2]
193 - build against GNU libc-2.1.
194
195 * Fri May 29 1998 Wojtek ¦lusarczyk <wojtek@SHADOW.EU.ORG>
196 - Replaced binutils to binutils-2.9.1.0.6,
197 - start at RH spec file.
This page took 1.139021 seconds and 4 git commands to generate.