]> git.pld-linux.org Git - packages/binutils.git/blob - binutils.spec
- md5sums, cleanups
[packages/binutils.git] / binutils.spec
1 Summary:        GNU Binary Utility Development Utilities
2 Summary(de):    GNU Binary Utility Development Utilities
3 Summary(es):    Utilitarios para desarrollo de binarios de la GNU
4 Summary(fr):    Utilitaires de développement binaire de GNU
5 Summary(pl):    Narzêdzia GNU dla programistów
6 Summary(pt_BR): Utilitários para desenvolvimento de binários da GNU
7 Summary(tr):    GNU geliþtirme araçlarý
8 Name:           binutils
9 Version:        2.11.90.0.19
10 Release:        4
11 Epoch:          2
12 License:        GPL
13 Group:          Development/Tools
14 Source0:        ftp://ftp.kernel.org/pub/linux/devel/binutils/%{name}-%{version}.tar.bz2
15 # Source0-md5:  59cb6db4b7642562b5abb3298a25b063
16 Source1:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
17 # Source1-md5:  48e506c0a8b87e0a762f990111aed707
18 Patch0:         %{name}-info.patch
19 Patch1:         %{name}-sparc_unaligned_reloc.patch
20 Patch2:         %{name}-preserve_e_flags.patch
21 Patch3:         %{name}-getopt.patch
22 URL:            http://sourceware.cygnus.com/binutils/
23 Prereq:         /sbin/ldconfig
24 BuildRequires:  bison
25 BuildRequires:  flex
26 BuildRequires:  perl-devel
27 %ifarch sparc sparc32
28 BuildRequires:  sparc32
29 %endif
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Binutils is a collection of binary utilities, including:
34 - ar - create, modify and extract from archives,
35 - nm - lists symbols from object files,
36 - objcopy - copy and translate object files,
37 - objdump - display information from object files,
38 - ranlib - generate an index for the contents of an archive,
39 - size - list the section sizes of an object or archive file,
40 - strings - list printable strings from files,
41 - strip - discard symbols,
42 - addr2line - convert addresses to file and line,
43 - nlmconv - convert object code into an NLM.
44
45 %description -l pl
46 Pakiet binutils zawiera zestaw narzêdzi umo¿liwiaj±cych kompilacjê
47 programów. Znajduj± siê tutaj miêdzy innymi assembler, konsolidator
48 (linker), a tak¿e inne narzêdzia do manipulowania binarnymi plikami
49 programów i bibliotek.
50
51 %description -l es
52 binutils es una colectánea de utilitarios necesarios para compilar
53 programas. Incluye assembler y linker, así como varios otros programas
54 para trabajar con formatos que se puedan ejecutar.
55
56 %description -l pt_BR
57 binutils é uma coletânea de utilitários necessários para compilar
58 programas. Inclui assembler e linker, assim como vários outros
59 programas para trabalhar com formatos executáveis.
60
61 %package static
62 Summary:        GNU Binutils static libraries
63 Summary(pl):    Biblioteki statyczne do GNU Binutils
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}
66
67 %description static
68 Static libraries for GNU Binutils.
69
70 %description -l pl static
71 Biblioteki statyczne GNU Binutils.
72
73 %prep
74 %setup -q 
75 %patch0 -p1
76 %patch1 -p1
77 %patch2 -p0
78 %patch3 -p1
79
80 %build
81 CFLAGS="%{rpmcflags}"
82 export CFLAGS
83 %ifarch sparc 
84 sparc32 \
85 %endif
86 ./configure %{_target_platform} \
87         --enable-shared \
88         --disable-debug \
89         --prefix=%{_prefix} \
90         --infodir=%{_infodir} \
91         --mandir=%{_mandir} \
92 %ifarch sparc
93         --enable-targets=sparc64-linux
94 %endif
95
96 %{__make} tooldir=%{_prefix} all info
97
98 %install
99 rm -rf $RPM_BUILD_ROOT
100 install -d $RPM_BUILD_ROOT%{_prefix}
101
102 %{__make} install install-info \
103         prefix=$RPM_BUILD_ROOT%{_prefix} \
104         tooldir=$RPM_BUILD_ROOT%{_prefix} \
105         mandir=$RPM_BUILD_ROOT%{_mandir} \
106         infodir=$RPM_BUILD_ROOT%{_infodir} \
107         includedir=$RPM_BUILD_ROOT%{_includedir} \
108         libdir=$RPM_BUILD_ROOT%{_libdir}
109
110 # these are already in gcc-g++
111 rm -f $RPM_BUILD_ROOT%{_bindir}/c++filt $RPM_BUILD_ROOT%{_mandir}/man1/c++filt*
112
113 rm -f $RPM_BUILD_ROOT%{_infodir}/standards.info*
114
115 # remove these man pages unless we cross-build for win*/netware platforms.
116 # however, this should be done in Makefiles.
117 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{dlltool,nlmconv,windres}.1
118
119 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}/
120
121 install include/libiberty.h $RPM_BUILD_ROOT%{_includedir}
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post
127 /sbin/ldconfig
128 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
129
130 %postun
131 /sbin/ldconfig
132 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir -c %{_infodir} >/dev/null 2>&1
133
134 %files
135 %defattr(644,root,root,755)
136 %doc README
137 %attr(755,root,root) %{_bindir}/*
138 %attr(755,root,root) %{_libdir}/*.so
139
140 %{_libdir}/ldscripts
141 %{_includedir}/*.h
142
143 %{_infodir}/*info*
144 %{_mandir}/man1/*
145 %lang(cs) %{_mandir}/cs/man1/*
146 %lang(de) %{_mandir}/de/man1/*
147 %lang(es) %{_mandir}/es/man1/*
148 %lang(fi) %{_mandir}/fi/man1/*
149 %lang(fr) %{_mandir}/fr/man1/*
150 %lang(hu) %{_mandir}/hu/man1/*
151 %lang(ja) %{_mandir}/ja/man1/*
152 %lang(pl) %{_mandir}/pl/man1/*
153
154 %files static
155 %defattr(644,root,root,755)
156 %{_libdir}/lib*.a
This page took 0.048296 seconds and 3 git commands to generate.