]> git.pld-linux.org Git - packages/binfmt-detector.git/blob - binfmt-detector.spec
- R: rc-scripts
[packages/binfmt-detector.git] / binfmt-detector.spec
1 Summary:        Microsoft PE executable type detector
2 Summary(pl):    Detector typu plików wykonywalnych PE Microsoftu
3 Name:           binfmt-detector
4 Version:        0.1
5 Release:        2
6 License:        GPL
7 Group:          Base
8 Source0:        http://team.pld-linux.org/~wolf/%{name}.tar.gz
9 # Source0-md5:  11623bddbeb536e88c47c8a1aedc9189
10 Source1:        %{name}.init
11 BuildRequires:  rpmbuild(macros) >= 1.268
12 Requires:       rc-scripts
13 Conflicts:      wine <= 1:0.9.12-1
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 This utility determines the Microsoft PE executable file's type
18 (Native, .NET CLR) and runs it using the appropriate runtime (Wine,
19 Mono).
20
21 It is inteded to be used in a Linux binfmt configuration, since binfmt
22 itself is incapable of reliably distinguishing between various PE file
23 types (since they have no different "magic string") and runtimes
24 refuse to run files which they don't support (CLR runtimes refuse to
25 run Native images and vice versa).
26
27 %description -l pl
28 To narzêdzie okre¶la typ pliku wykonywalnego PE Microsoftu (natywny,
29 .NET CLR) i uruchamia odpowiednie ¶rodowisko wykonawcze (Wine, Mono).
30
31 Jest u¿ywane w po³±czeniu z linuksowym binfmt, poniewa¿ samo binfmt
32 nie jest w stanie odró¿niæ ró¿nych typów plików PE (nie zawieraj± one
33 ró¿nych "magicznych ci±gów"), a ¶rodowiska uruchomieniowe nie
34 pozwalaj± uruchomiæ nieobs³ugiwanych przez siebie plików (CLR nie
35 uruchamia natywnych obrazów i vice versa).
36
37 %prep
38 %setup -q -n %{name}
39
40 %build
41 %{__cc} %{rpmcflags} binfmt-detector-cli.c -o binfmt-detector-cli
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT{%{_bindir},/etc/rc.d/init.d}
46
47 install binfmt-detector-cli $RPM_BUILD_ROOT%{_bindir}
48 install binfmt-detector.sh $RPM_BUILD_ROOT%{_bindir}
49
50 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/binfmt-detector
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 /sbin/chkconfig --add binfmt-detector
57 %service binfmt-detector restart
58
59 %preun
60 if [ "$1" = "0" ]; then
61         %service binfmt-detector stop
62         /sbin/chkconfig --del binfmt-detector
63 fi
64
65 %files
66 %defattr(644,root,root,755)
67 %doc README
68 %attr(755,root,root) %{_bindir}/*
69 %attr(754,root,root) /etc/rc.d/init.d/binfmt-detector
This page took 0.075503 seconds and 3 git commands to generate.