]> git.pld-linux.org Git - packages/bind.git/commitdiff
fix for "Segmentation fault" in nsupdate
authorSzymon Siwek <Szymon.Siwek@gmail.com>
Tue, 21 Aug 2012 14:30:06 +0000 (16:30 +0200)
committerSzymon Siwek <Szymon.Siwek@gmail.com>
Tue, 21 Aug 2012 14:30:06 +0000 (16:30 +0200)
 $ nsupdate
 > update
 Segmentation fault

from https://bugs.archlinux.org/task/30139?getfile=8868
(they say: "The upstream bug reference number is 29550")

bind.spec
nsupdate_segfault.patch [new file with mode: 0644]

index 91ba838a9949acd6a18b5b74064b6187d8a9b2cd..0a19a15ff42a977a427e143960d177ff1bb72c3d 100644 (file)
--- a/bind.spec
+++ b/bind.spec
@@ -68,6 +68,7 @@ Patch2:               %{name}-pmake.patch
 Patch3:                %{name}-sdb-ldap.patch
 Patch4:                %{name}-ac-libs.patch
 Patch5:                %{name}-edns-client-subnet.patch
+Patch6:         nsupdate_segfault.patch
 URL:           https://www.isc.org/software/bind
 BuildRequires: autoconf >= 2.59
 BuildRequires: automake
@@ -363,6 +364,7 @@ Schemat BIND dla openldap.
 %{?with_ldap:%patch3 -p1}
 %patch4 -p1
 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
+%patch6 -p0
 
 %{?with_edns_cli:%patch5 -p0}
 
diff --git a/nsupdate_segfault.patch b/nsupdate_segfault.patch
new file mode 100644 (file)
index 0000000..eff9c2c
--- /dev/null
@@ -0,0 +1,19 @@
+fix for "Segmentation fault" in nsupdate
+
+ $ nsupdate
+ > update
+ Segmentation fault
+
+from https://bugs.archlinux.org/task/30139?getfile=8868
+(they say: "The upstream bug reference number is 29550")
+--- /home/bisson/Desktop/bind-9.9.1-P1/bin/nsupdate/nsupdate.c  2012-06-02 01:29:52.000000000 +1000
++++ bin/nsupdate/nsupdate.c     2012-06-06 02:50:37.894357220 +1000
+@@ -376,7 +376,7 @@
+       char sc, dc;
+       if (string == NULL)
+-              return (NULL);
++              return &string;
+       for (; *string != '\0'; string++) {
+               sc = *string;
This page took 0.361356 seconds and 4 git commands to generate.