]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- rel 3; disable seccomp as bind built with it hangs/stops at boot; newstats option...
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with     edns_cli        # build with the ability to use edns-client-subnet in dig
13 %bcond_with     hip             # build with HIP RR support
14 %bcond_without  geoip           # build with GeoIP support
15 %bcond_with     seccomp         # seccomp
16
17 %if "%{pld_release}" == "ac"
18 %bcond_with     epoll           # enable epoll support
19 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
20 %ifarch %{x8664}
21 %define         with_epoll      1
22 %endif
23 %else
24 %bcond_without  epoll           # disable epoll support
25 %endif
26
27 %define         ver     9.10.1
28 %if 0
29 %define         pverdot .P2
30 %define         pverdir -P2
31 %else
32 %define         pverdot %{nil}
33 %define         pverdir %{nil}
34 %endif
35 Summary:        BIND - DNS name server
36 Summary(de.UTF-8):      BIND - DNS-Namenserver
37 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
38 Summary(fr.UTF-8):      BIND - serveur de noms DNS
39 Summary(pl.UTF-8):      BIND - serwer nazw DNS
40 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
41 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
42 Summary(tr.UTF-8):      DNS alan adı sunucusu
43 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
44 Summary(zh_CN.UTF-8):   Internet 域名服务器
45 Name:           bind
46 Version:        %{ver}%{pverdot}
47 Release:        3
48 Epoch:          7
49 License:        BSD-like
50 Group:          Networking/Daemons
51 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
52 # Source0-md5:  82a69faf01b569568d9233f2666e744d
53 Source1:        named.init
54 Source2:        named.sysconfig
55 Source3:        named.logrotate
56 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
57 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
58 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
59 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
60 Source6:        %{name}-hip.tar.gz
61 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
62 Source7:        ftp://rs.internic.net/domain/root.zone
63 # Source7-md5:  f6e19255972d0d584c629df560cd5f75
64 Source8:        %{name}-127.0.0.zone
65 Source9:        %{name}-localhost.zone
66 Source10:       %{name}-named.conf
67 Source11:       %{name}.tmpfiles
68 Source12:       named.service
69 Patch0:         %{name}-time.patch
70 Patch1:         %{name}-link.patch
71 Patch2:         %{name}-pmake.patch
72 Patch3:         %{name}-sdb-ldap.patch
73 Patch4:         %{name}-ac-libs.patch
74 Patch5:         %{name}-edns-client-subnet.patch
75 Patch6:         nsupdate_segfault.patch
76 URL:            https://www.isc.org/software/bind
77 BuildRequires:  autoconf >= 2.59
78 BuildRequires:  automake
79 BuildRequires:  bison
80 BuildRequires:  flex
81 %{?with_kerberos5:BuildRequires:        heimdal-devel}
82 BuildRequires:  idnkit-devel
83 %{?with_seccomp:BuildRequires:  libseccomp-devel}
84 BuildRequires:  libtool
85 %{?with_hip:BuildRequires:      libxml2-devel}
86 %{?with_sql:BuildRequires:      mysql-devel}
87 %{?with_ldap:BuildRequires:     openldap-devel}
88 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
89 %{?with_sql:BuildRequires:      postgresql-devel}
90 BuildRequires:  readline-devel
91 BuildRequires:  rpm >= 4.4.9-56
92 BuildRequires:  rpmbuild(macros) >= 1.647
93 %{?with_sql:BuildRequires:      unixODBC-devel}
94 Requires(post,preun):   /sbin/chkconfig
95 Requires(postun):       /usr/sbin/groupdel
96 Requires(postun):       /usr/sbin/userdel
97 Requires(pre):  /bin/id
98 Requires(pre):  /usr/bin/getgid
99 Requires(pre):  /usr/sbin/groupadd
100 Requires(pre):  /usr/sbin/useradd
101 Requires(pre):  fileutils
102 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
103 Requires:       psmisc >= 20.1
104 Requires:       rc-scripts >= 0.2.0
105 Requires:       systemd-units >= 38
106 Requires:       uname(release) >= 2.2.18
107 Provides:       group(named)
108 Provides:       nameserver
109 Provides:       user(named)
110 Obsoletes:      caching-nameserver
111 Conflicts:      %{name}-chroot
112 Conflicts:      logrotate < 3.8.0
113 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
114
115 %define         schemadir       /usr/share/openldap/schema
116
117 %description
118 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
119 (Domain Name System) protocols. BIND includes a DNS server (named),
120 which resolves host names to IP addresses, and a resolver library
121 (routines for applications to use when interfacing with DNS). A DNS
122 server allows clients to name resources or objects and share the
123 information with other network machines. The named DNS server can be
124 used on workstations as a caching name server, but is generally only
125 needed on one machine for an entire network. Note that the
126 configuration files for making BIND act as a simple caching nameserver
127 are included in the caching-nameserver package.
128
129 Install the bind package if you need a DNS server for your network. If
130 you want bind to act a caching name server, you will also need to
131 install the caching-nameserver package.
132
133 %description -l de.UTF-8
134 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
135 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
136 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
137 Recher des Netzwerks erforderlich.
138
139 %description -l es.UTF-8
140 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
141 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
142 un servidor de nombres caché, pero generalmente sólo hace falta en una
143 máquina para toda la red.
144
145 %description -l fr.UTF-8
146 Contient le serveur de noms named, utilisé pour définir les
147 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
148 utilisé sur les stations de travail comme serveur de nom en cache mais
149 n'est souvent nécessaire que sur une machine pour un réseau entier.
150
151 %description -l pl.UTF-8
152 Pakiet ten zawiera demona named, który służy do zmieniania nazw
153 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
154 roboczych jako bufor odwołań do serwisu nazw (caching name server),
155 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
156 program na fragment sieci.
157
158 %description -l pt_BR.UTF-8
159 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
160 IP (e vice-versa). Pode ser usado em estações de trabalho como um
161 servidor de nomes cache, mas geralmente só é necessário em uma máquina
162 para toda a rede.
163
164 %description -l ru.UTF-8
165 BIND (Berkeley Internet Name Domain) является реализацией протоколов
166 DNS (Domain Name System). BIND включает DNS сервер (named) и
167 библиотеку "резолвера" (подпрограммы для приложений, через которые
168 происходят обращения к DNS). DNS сервер named может быть использован
169 на рабочих станциях как кеширующий сервер, но обычно запускается на
170 одной машине в локальной сети и используется остальными машинами (этим
171 достигается намного более эффективное кеширование).
172
173 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
174 кеширующего сервера, включены в пакет caching-nameserver.
175
176 %description -l tr.UTF-8
177 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
178 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
179 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
180 için sadece bir makina üzerinde kurulur.
181
182 %description -l uk.UTF-8
183 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
184 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
185 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
186 сервер named може бути використаний на робочих станціях як кешируючий
187 сервер, але звичайно запускається на одній машині в локальній мережі і
188 використовується іншими (цим досягається більша ефективність
189 використання кешу).
190
191 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
192 кешируючого серверу, включені в пакет caching-nameserver.
193
194 %package utils
195 Summary:        DNS utils - host, dig, dnsquery, nslookup
196 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
197 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
198 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
199 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
200 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
201 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
202 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
203 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
204 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
205 Group:          Networking/Utilities
206 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
207 Requires:       iconv
208
209 %description utils
210 Bind-utils contains a collection of utilities for querying DNS (Domain
211 Name Service) name servers to find out information about Internet
212 hosts. These tools will provide you with the IP addresses for given
213 host names, as well as other information about registered domains and
214 network addresses.
215
216 You should install bind-utils if you need to get information from DNS
217 name servers.
218
219 %description utils -l de.UTF-8
220 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
221 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
222 Informationen über registrierte Domains und Netzwerk-Adressen.
223
224 %description utils -l es.UTF-8
225 Conjunto de utilitarios para consulta a servidores de nombres. Estas
226 herramientas permiten la determinación de direcciones IP para nombres
227 de máquinas informados y busca información sobre dominios registrados
228 y direcciones de red.
229
230 %description utils -l fr.UTF-8
231 Ensemble d'utilitaires pour interroger les serveurs de noms et
232 rechercher des hôtes. Ces outils vous permettent de déterminer les
233 adresses IP pour des noms d'hôtes donnés, et trouver des informations
234 sur les noms de domaine déclarés et les adresses réseau.
235
236 %description utils -l pl.UTF-8
237 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
238 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
239 i ich adresach IP.
240
241 %description utils -l pt_BR.UTF-8
242 Conjunto de utilitários para consulta a servidores DNS. Estas
243 ferramentas permitem a determinação de endereços IP para nomes de
244 máquinas informados e busca informações sobre domínios registrados e
245 endereços de rede. Você deveria instalar este pacote se necessitar
246 obter informações de servidores DNS.
247
248 %description utils -l ru.UTF-8
249 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
250 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
251 доменному имени (и наоборот) и другую информацию о зарегистрированных
252 доменах и сетевых адресах.
253
254 %description utils -l tr.UTF-8
255 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
256 için kullanılan araçlar bulunmaktadır.
257
258 %description utils -l uk.UTF-8
259 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
260 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
261 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
262 домени та адреси.
263
264 %package libs
265 Summary:        DNS libraries
266 Summary(pl.UTF-8):      Biblioteki DNS
267 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
268 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
269 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
270 Group:          Libraries
271
272 %description libs
273 The bind-libs package contains all libraries required for running BIND
274 and bind utils.
275
276 %description libs -l pl.UTF-8
277 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
278 lub programów z pakietu bind-utils.
279
280 %description libs -l ru.UTF-8
281 Библиотеки, необходимые для работы bind.
282
283 %description libs -l uk.UTF-8
284 Бібліотеки, необхідні для роботи bind.
285
286 %package devel
287 Summary:        DNS development includes
288 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
289 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
290 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
291 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
292 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
293 Group:          Development/Libraries
294 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
295
296 %description devel
297 The bind-devel package contains all the include files and symlinks
298 required for DNS (Domain Name Service) development for BIND.
299
300 You should install bind-devel if you want to develop bind DNS
301 applications. If you install bind-devel, you'll also need to install
302 bind-libs.
303
304 %description devel -l es.UTF-8
305 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
306 para el bind.
307
308 %description devel -l pl.UTF-8
309 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
310 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
311 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
312 pakiet.
313
314 %description devel -l pt_BR.UTF-8
315 Todos os arquivos de cabeçalho e bibliotecas necessários para o
316 desenvolvimento com o bind.
317
318 %description devel -l ru.UTF-8
319 Все хедеры и библиотеки, необходимые для написания программ с
320 использованием BIND 9.x.x.
321
322 %description devel -l uk.UTF-8
323 Всі хедери та бібліотеки, необхідні для розробки програм з
324 використанням BIND 9.x.x.
325
326 %package static
327 Summary:        DNS static libs
328 Summary(pl.UTF-8):      Biblioteki statyczne DNS
329 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
330 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
331 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
332 Group:          Development/Libraries
333 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
334
335 %description static
336 Static bind libraries.
337
338 %description static -l pl.UTF-8
339 Statyczne biblioteki binda.
340
341 %description static -l pt_BR.UTF-8
342 Bibliotecas estáticas para desenvolvimento DNS.
343
344 %description static -l ru.UTF-8
345 Статические библиотеки, необходимые для написания программ с
346 использованием BIND.
347
348 %description static -l uk.UTF-8
349 Статичні бібліотеки, необхідні для розробки програм з використанням
350 BIND.
351
352 %package -n openldap-schema-bind
353 Summary:        BIND schema for openldap
354 Summary(pl.UTF-8):      Schemat BIND dla openldap
355 Group:          Development/Libraries
356 Requires(post,postun):  sed >= 4.0
357 Requires:       openldap-servers
358 Requires:       sed >= 4.0
359 %if "%{_rpmversion}" >= "5"
360 BuildArch:      noarch
361 %endif
362
363 %description -n openldap-schema-bind
364 BIND schema for openldap.
365
366 %description -n openldap-schema-bind -l pl.UTF-8
367 Schemat BIND dla openldap.
368
369 %prep
370 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
371 %patch0 -p1
372 %patch1 -p1
373 %patch2 -p1
374 %{?with_ldap:%patch3 -p1}
375 %patch4 -p1
376 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
377 %{?with_edns_cli:%patch5 -p0}
378 %patch6 -p0
379
380 %build
381 %{__libtoolize}
382 %{__aclocal}
383 %{__autoconf}
384 cp -f /usr/share/automake/config.* .
385 %configure \
386         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
387         --with-idn \
388         --with-libtool \
389         %{?with_ssl:--with-openssl} \
390         %{?with_ipv6:--enable-ipv6} \
391         %{?with_kerberos5:--with-gssapi} \
392         %{?with_sql:--with-dlz-postgres=yes} \
393         %{?with_sql:--with-dlz-mysql=yes} \
394         --with-dlz-bdb=no \
395         --with-dlz-filesystem=yes \
396         %{?with_ldap:--with-dlz-ldap=yes} \
397         %{?with_geoip:--with-geoip=yes} \
398         --with-dlz-odbc=no \
399         --with-dlz-stub=yes \
400         --enable-largefile \
401         %{!?with_epoll:--disable-epoll --disable-devpoll} \
402         %{!?with_static_libs:--enable-static=no} \
403         --enable-sit \
404         --enable-threads \
405         --enable-getifaddrs \
406         --enable-full-report \
407         %{__enable_disable seccomp}
408
409 %{__make}
410 %{?with_hip:cd bind-hip/; %{__make}}
411
412 %{?with_tests:%{__make} test-force}
413
414 %install
415 rm -rf $RPM_BUILD_ROOT
416 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
417         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
418         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}} \
419         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
420
421 %{__make} install \
422         DESTDIR=$RPM_BUILD_ROOT
423
424 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
425 rm $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
426 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
427 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
428
429 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
430 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
431 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
432 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
433 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
434 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
435 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
436 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
437 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
438 mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
439
440 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
441 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
442 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
443 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
444
445 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
446
447 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
448 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
449
450 %if %{with ldap}
451 install -d $RPM_BUILD_ROOT%{schemadir}
452 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
453 %endif
454
455 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
456
457 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
458 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
459
460 # let rpm generate deps (workaround -m644 used for libs installation)
461 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
462
463 # we don't want Makefiles in documentation...
464 rm -rf _doc
465 cp -a doc _doc
466 %{__rm} _doc/misc/Makefile*
467
468 %clean
469 rm -rf $RPM_BUILD_ROOT
470
471 %pre
472 if [ -f %{_sysconfdir}/named.boot ]; then
473         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
474         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
475         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
476 fi
477 %groupadd -g 58 named
478 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
479
480 %post
481 /sbin/chkconfig --add named
482 %service named restart
483 %systemd_post named.service
484
485 %preun
486 if [ "$1" = "0" ]; then
487         %service named stop
488         /sbin/chkconfig --del named
489 fi
490 %systemd_preun named.service
491
492 %postun
493 if [ "$1" = "0" ]; then
494         %userremove named
495         %groupremove named
496 fi
497 %systemd_reload
498
499 %post   libs -p /sbin/ldconfig
500 %postun libs -p /sbin/ldconfig
501
502 %post -n openldap-schema-bind
503 %openldap_schema_register %{schemadir}/dnszone.schema
504 %service -q ldap restart
505
506 %postun -n openldap-schema-bind
507 if [ "$1" = "0" ]; then
508         %openldap_schema_unregister %{schemadir}/dnszone.schema
509         %service -q ldap restart
510 fi
511
512 %triggerpostun -- %{name} < 7:9.4.2-2
513 /sbin/chkconfig named reset
514 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
515 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
516 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
517
518 %triggerpostun -- %{name} < 7:9.9.2.P2-2
519 %systemd_trigger named.service
520
521 %files
522 %defattr(644,root,root,755)
523 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
524 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
525
526 %{systemdunitdir}/named.service
527 %attr(754,root,root) /etc/rc.d/init.d/named
528 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
529 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
530 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
531 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
532
533 %attr(755,root,root) %{_sbindir}/arpaname
534 %attr(755,root,root) %{_sbindir}/ddns-confgen
535 %attr(755,root,root) %{_sbindir}/dnssec-*
536 %attr(755,root,root) %{_sbindir}/genrandom
537 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
538 %attr(755,root,root) %{_sbindir}/lwresd
539 %attr(755,root,root) %{_sbindir}/named
540 %attr(755,root,root) %{_sbindir}/named-*
541 %attr(755,root,root) %{_sbindir}/nsec3hash
542 %attr(755,root,root) %{_sbindir}/rndc
543 %attr(755,root,root) %{_sbindir}/rndc-confgen
544 %attr(755,root,root) %{_sbindir}/tsig-keygen
545
546 %{_mandir}/man1/arpaname.1*
547 %{_mandir}/man1/named-rrchecker.1*
548 %{_mandir}/man5/named.conf.5*
549 %{_mandir}/man5/rndc.conf.5*
550 %{_mandir}/man8/ddns-confgen.8*
551 %{_mandir}/man8/dnssec-*.8*
552 %{_mandir}/man8/genrandom.8*
553 %{_mandir}/man8/isc-hmac-fixup.8*
554 %{_mandir}/man8/lwresd.8*
555 %{_mandir}/man8/named.8*
556 %{_mandir}/man8/named-*.8*
557 %{_mandir}/man8/nsec3hash.8*
558 %{_mandir}/man8/rndc.8*
559 %{_mandir}/man8/rndc-confgen.8*
560 %{_mandir}/man8/tsig-keygen.8*
561 %lang(ja) %{_mandir}/ja/man8/named*
562
563 %{systemdtmpfilesdir}/%{name}.conf
564
565 %attr(770,root,named) %dir %{_var}/lib/named
566 %attr(770,root,named) %dir %{_var}/lib/named/D
567 %attr(770,root,named) %dir %{_var}/lib/named/M
568 %attr(770,root,named) %dir %{_var}/lib/named/S
569 %attr(750,root,named) %dir %{_var}/lib/named/etc
570 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
571 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
572 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
573 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
574 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
575 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
576
577 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
578 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
579
580 %attr(770,root,named) %dir %{_var}/run/named
581 %attr(770,root,named) %dir %{_var}/run/lwresd
582
583 %files utils
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{_bindir}/delv
586 %attr(755,root,root) %{_bindir}/dig
587 %attr(755,root,root) %{_bindir}/host
588 %attr(755,root,root) %{_bindir}/nslookup
589 %attr(755,root,root) %{_bindir}/nsupdate
590 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
591 %{_mandir}/man1/delv.1*
592 %{_mandir}/man1/dig.1*
593 %{_mandir}/man1/host.1*
594 %{_mandir}/man1/nslookup.1*
595 %{_mandir}/man1/nsupdate.1*
596
597 %lang(fi) %{_mandir}/fi/man1/host.1*
598
599 %lang(fr) %{_mandir}/fr/man1/host.1*
600
601 %lang(hu) %{_mandir}/hu/man1/host.1*
602
603 %lang(ja) %{_mandir}/ja/man1/dig.1*
604 %lang(ja) %{_mandir}/ja/man1/host.1*
605 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
606 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
607
608 %lang(pl) %{_mandir}/pl/man1/host.1*
609
610 %files libs
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
613 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.140
614 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
615 %attr(755,root,root) %ghost %{_libdir}/libdns.so.146
616 %attr(755,root,root) %{_libdir}/libirs.so.*.*.*
617 %attr(755,root,root) %ghost %{_libdir}/libirs.so.141
618 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
619 %attr(755,root,root) %ghost %{_libdir}/libisc.so.142
620 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
621 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.140
622 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
623 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.140
624 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
625 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.141
626
627 %files devel
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_bindir}/bind9-config
630 %attr(755,root,root) %{_bindir}/isc-config.sh
631 %attr(755,root,root) %{_libdir}/libbind9.so
632 %attr(755,root,root) %{_libdir}/libdns.so
633 %attr(755,root,root) %{_libdir}/libirs.so
634 %attr(755,root,root) %{_libdir}/libisc.so
635 %attr(755,root,root) %{_libdir}/libisccc.so
636 %attr(755,root,root) %{_libdir}/libisccfg.so
637 %attr(755,root,root) %{_libdir}/liblwres.so
638 %{_libdir}/libbind9.la
639 %{_libdir}/libdns.la
640 %{_libdir}/libirs.la
641 %{_libdir}/libisc.la
642 %{_libdir}/libisccc.la
643 %{_libdir}/libisccfg.la
644 %{_libdir}/liblwres.la
645 %{_includedir}/bind9
646 %{_includedir}/dns
647 %{_includedir}/dst
648 %{_includedir}/irs
649 %{_includedir}/isc
650 %{_includedir}/isccc
651 %{_includedir}/isccfg
652 %{_includedir}/lwres
653 %{_includedir}/pk11
654 %{_includedir}/pkcs11
655 %{_mandir}/man1/bind9-config.1*
656 %{_mandir}/man1/isc-config.sh.1*
657 %{_mandir}/man3/lwres*.3*
658
659 %if %{with static_libs}
660 %files static
661 %defattr(644,root,root,755)
662 %{_libdir}/libbind9.a
663 %{_libdir}/libdns.a
664 %{_libdir}/libirs.a
665 %{_libdir}/libisc.a
666 %{_libdir}/libisccc.a
667 %{_libdir}/libisccfg.a
668 %{_libdir}/liblwres.a
669 %endif
670
671 %if %{with ldap}
672 %files -n openldap-schema-bind
673 %defattr(644,root,root,755)
674 %{_datadir}/openldap/schema/dnszone.schema
675 %endif
This page took 0.08984 seconds and 4 git commands to generate.