]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- added systemd service file
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with     edns_cli        # build with the ability to use edns-client-subnet in dig
13 %bcond_with     hip             # build with HIP RR support
14 %if "%{pld_release}" == "ac"
15 %bcond_with     epoll           # enable epoll support
16 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
17 %ifarch %{x8664}
18 %define         with_epoll      1
19 %endif
20 %else
21 %bcond_without  epoll           # disable epoll support
22 %endif
23
24 %define         ver     9.9.2
25 %if 1
26 %define         pverdot .P2
27 %define         pverdir -P2
28 %else
29 %define         pverdot %{nil}
30 %define         pverdir %{nil}
31 %endif
32 Summary:        BIND - DNS name server
33 Summary(de.UTF-8):      BIND - DNS-Namenserver
34 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
35 Summary(fr.UTF-8):      BIND - serveur de noms DNS
36 Summary(pl.UTF-8):      BIND - serwer nazw DNS
37 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
38 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
39 Summary(tr.UTF-8):      DNS alan adı sunucusu
40 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
41 Summary(zh_CN.UTF-8):   Internet 域名服务器
42 Name:           bind
43 Version:        %{ver}%{pverdot}
44 Release:        1
45 Epoch:          7
46 License:        BSD-like
47 Group:          Networking/Daemons
48 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
49 # Source0-md5:  2be7763c99b7e7b42ac3a18a267ce1aa
50 Source1:        named.init
51 Source2:        named.sysconfig
52 Source3:        named.logrotate
53 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
54 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
55 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
56 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
57 Source6:        %{name}-hip.tar.gz
58 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
59 Source7:        ftp://rs.internic.net/domain/root.zone
60 # Source7-md5:  6241cd7c70f855345a68ed0697097ba5
61 Source8:        %{name}-127.0.0.zone
62 Source9:        %{name}-localhost.zone
63 Source10:       %{name}-named.conf
64 Source11:       %{name}.tmpfiles
65 Source12:       named.service
66 Patch0:         %{name}-time.patch
67 Patch1:         %{name}-link.patch
68 Patch2:         %{name}-pmake.patch
69 Patch3:         %{name}-sdb-ldap.patch
70 Patch4:         %{name}-ac-libs.patch
71 Patch5:         %{name}-edns-client-subnet.patch
72 Patch6:         nsupdate_segfault.patch
73 URL:            https://www.isc.org/software/bind
74 BuildRequires:  autoconf >= 2.59
75 BuildRequires:  automake
76 BuildRequires:  bison
77 BuildRequires:  flex
78 %{?with_kerberos5:BuildRequires:        heimdal-devel}
79 BuildRequires:  idnkit-devel
80 BuildRequires:  libtool
81 %{?with_hip:BuildRequires:      libxml2-devel}
82 %{?with_sql:BuildRequires:      mysql-devel}
83 %{?with_ldap:BuildRequires:     openldap-devel}
84 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
85 %{?with_sql:BuildRequires:      postgresql-devel}
86 BuildRequires:  readline-devel
87 BuildRequires:  rpm >= 4.4.9-56
88 BuildRequires:  rpmbuild(macros) >= 1.268
89 %{?with_sql:BuildRequires:      unixODBC-devel}
90 Requires(post,preun):   /sbin/chkconfig
91 Requires(postun):       /usr/sbin/groupdel
92 Requires(postun):       /usr/sbin/userdel
93 Requires(pre):  /bin/id
94 Requires(pre):  /usr/bin/getgid
95 Requires(pre):  /usr/sbin/groupadd
96 Requires(pre):  /usr/sbin/useradd
97 Requires(pre):  fileutils
98 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
99 Requires:       psmisc >= 20.1
100 Requires:       rc-scripts >= 0.2.0
101 Requires:       uname(release) >= 2.2.18
102 Provides:       group(named)
103 Provides:       nameserver
104 Provides:       user(named)
105 Obsoletes:      caching-nameserver
106 Conflicts:      %{name}-chroot
107 Conflicts:      logrotate < 3.8.0
108 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
109
110 %define         schemadir       /usr/share/openldap/schema
111
112 %description
113 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
114 (Domain Name System) protocols. BIND includes a DNS server (named),
115 which resolves host names to IP addresses, and a resolver library
116 (routines for applications to use when interfacing with DNS). A DNS
117 server allows clients to name resources or objects and share the
118 information with other network machines. The named DNS server can be
119 used on workstations as a caching name server, but is generally only
120 needed on one machine for an entire network. Note that the
121 configuration files for making BIND act as a simple caching nameserver
122 are included in the caching-nameserver package.
123
124 Install the bind package if you need a DNS server for your network. If
125 you want bind to act a caching name server, you will also need to
126 install the caching-nameserver package.
127
128 %description -l de.UTF-8
129 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
130 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
131 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
132 Recher des Netzwerks erforderlich.
133
134 %description -l es.UTF-8
135 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
136 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
137 un servidor de nombres caché, pero generalmente sólo hace falta en una
138 máquina para toda la red.
139
140 %description -l fr.UTF-8
141 Contient le serveur de noms named, utilisé pour définir les
142 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
143 utilisé sur les stations de travail comme serveur de nom en cache mais
144 n'est souvent nécessaire que sur une machine pour un réseau entier.
145
146 %description -l pl.UTF-8
147 Pakiet ten zawiera demona named, który służy do zmieniania nazw
148 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
149 roboczych jako bufor odwołań do serwisu nazw (caching name server),
150 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
151 program na fragment sieci.
152
153 %description -l pt_BR.UTF-8
154 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
155 IP (e vice-versa). Pode ser usado em estações de trabalho como um
156 servidor de nomes cache, mas geralmente só é necessário em uma máquina
157 para toda a rede.
158
159 %description -l ru.UTF-8
160 BIND (Berkeley Internet Name Domain) является реализацией протоколов
161 DNS (Domain Name System). BIND включает DNS сервер (named) и
162 библиотеку "резолвера" (подпрограммы для приложений, через которые
163 происходят обращения к DNS). DNS сервер named может быть использован
164 на рабочих станциях как кеширующий сервер, но обычно запускается на
165 одной машине в локальной сети и используется остальными машинами (этим
166 достигается намного более эффективное кеширование).
167
168 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
169 кеширующего сервера, включены в пакет caching-nameserver.
170
171 %description -l tr.UTF-8
172 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
173 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
174 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
175 için sadece bir makina üzerinde kurulur.
176
177 %description -l uk.UTF-8
178 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
179 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
180 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
181 сервер named може бути використаний на робочих станціях як кешируючий
182 сервер, але звичайно запускається на одній машині в локальній мережі і
183 використовується іншими (цим досягається більша ефективність
184 використання кешу).
185
186 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
187 кешируючого серверу, включені в пакет caching-nameserver.
188
189 %package utils
190 Summary:        DNS utils - host, dig, dnsquery, nslookup
191 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
192 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
193 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
194 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
195 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
196 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
197 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
198 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
199 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
200 Group:          Networking/Utilities
201 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
202 Requires:       iconv
203
204 %description utils
205 Bind-utils contains a collection of utilities for querying DNS (Domain
206 Name Service) name servers to find out information about Internet
207 hosts. These tools will provide you with the IP addresses for given
208 host names, as well as other information about registered domains and
209 network addresses.
210
211 You should install bind-utils if you need to get information from DNS
212 name servers.
213
214 %description utils -l de.UTF-8
215 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
216 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
217 Informationen über registrierte Domains und Netzwerk-Adressen.
218
219 %description utils -l es.UTF-8
220 Conjunto de utilitarios para consulta a servidores de nombres. Estas
221 herramientas permiten la determinación de direcciones IP para nombres
222 de máquinas informados y busca información sobre dominios registrados
223 y direcciones de red.
224
225 %description utils -l fr.UTF-8
226 Ensemble d'utilitaires pour interroger les serveurs de noms et
227 rechercher des hôtes. Ces outils vous permettent de déterminer les
228 adresses IP pour des noms d'hôtes donnés, et trouver des informations
229 sur les noms de domaine déclarés et les adresses réseau.
230
231 %description utils -l pl.UTF-8
232 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
233 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
234 i ich adresach IP.
235
236 %description utils -l pt_BR.UTF-8
237 Conjunto de utilitários para consulta a servidores DNS. Estas
238 ferramentas permitem a determinação de endereços IP para nomes de
239 máquinas informados e busca informações sobre domínios registrados e
240 endereços de rede. Você deveria instalar este pacote se necessitar
241 obter informações de servidores DNS.
242
243 %description utils -l ru.UTF-8
244 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
245 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
246 доменному имени (и наоборот) и другую информацию о зарегистрированных
247 доменах и сетевых адресах.
248
249 %description utils -l tr.UTF-8
250 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
251 için kullanılan araçlar bulunmaktadır.
252
253 %description utils -l uk.UTF-8
254 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
255 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
256 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
257 домени та адреси.
258
259 %package libs
260 Summary:        DNS libraries
261 Summary(pl.UTF-8):      Biblioteki DNS
262 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
263 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
264 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
265 Group:          Libraries
266
267 %description libs
268 The bind-libs package contains all libraries required for running BIND
269 and bind utils.
270
271 %description libs -l pl.UTF-8
272 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
273 lub programów z pakietu bind-utils.
274
275 %description libs -l ru.UTF-8
276 Библиотеки, необходимые для работы bind.
277
278 %description libs -l uk.UTF-8
279 Бібліотеки, необхідні для роботи bind.
280
281 %package devel
282 Summary:        DNS development includes
283 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
284 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
285 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
286 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
287 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
288 Group:          Development/Libraries
289 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
290
291 %description devel
292 The bind-devel package contains all the include files and symlinks
293 required for DNS (Domain Name Service) development for BIND.
294
295 You should install bind-devel if you want to develop bind DNS
296 applications. If you install bind-devel, you'll also need to install
297 bind-libs.
298
299 %description devel -l es.UTF-8
300 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
301 para el bind.
302
303 %description devel -l pl.UTF-8
304 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
305 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
306 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
307 pakiet.
308
309 %description devel -l pt_BR.UTF-8
310 Todos os arquivos de cabeçalho e bibliotecas necessários para o
311 desenvolvimento com o bind.
312
313 %description devel -l ru.UTF-8
314 Все хедеры и библиотеки, необходимые для написания программ с
315 использованием BIND 9.x.x.
316
317 %description devel -l uk.UTF-8
318 Всі хедери та бібліотеки, необхідні для розробки програм з
319 використанням BIND 9.x.x.
320
321 %package static
322 Summary:        DNS static libs
323 Summary(pl.UTF-8):      Biblioteki statyczne DNS
324 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
325 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
326 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
327 Group:          Development/Libraries
328 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
329
330 %description static
331 Static bind libraries.
332
333 %description static -l pl.UTF-8
334 Statyczne biblioteki binda.
335
336 %description static -l pt_BR.UTF-8
337 Bibliotecas estáticas para desenvolvimento DNS.
338
339 %description static -l ru.UTF-8
340 Статические библиотеки, необходимые для написания программ с
341 использованием BIND.
342
343 %description static -l uk.UTF-8
344 Статичні бібліотеки, необхідні для розробки програм з використанням
345 BIND.
346
347 %package -n openldap-schema-bind
348 Summary:        BIND schema for openldap
349 Summary(pl.UTF-8):      Schemat BIND dla openldap
350 Group:          Development/Libraries
351 Requires(post,postun):  sed >= 4.0
352 Requires:       openldap-servers
353 Requires:       sed >= 4.0
354
355 %description -n openldap-schema-bind
356 BIND schema for openldap.
357
358 %description -n openldap-schema-bind -l pl.UTF-8
359 Schemat BIND dla openldap.
360
361 %prep
362 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
363 %patch0 -p1
364 %patch1 -p1
365 %patch2 -p1
366 %{?with_ldap:%patch3 -p1}
367 %patch4 -p1
368 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
369 %patch6 -p0
370
371 %{?with_edns_cli:%patch5 -p0}
372
373 %build
374 %{__libtoolize}
375 %{__aclocal}
376 %{__autoconf}
377 cp -f /usr/share/automake/config.* .
378 %configure \
379         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
380         --with-idn \
381         --with-libtool \
382         %{?with_ssl:--with-openssl} \
383         %{?with_ipv6:--enable-ipv6} \
384         %{?with_kerberos5:--with-gssapi} \
385         %{?with_sql:--with-dlz-postgres=yes} \
386         %{?with_sql:--with-dlz-mysql=yes} \
387         --with-dlz-bdb=no \
388         --with-dlz-filesystem=yes \
389         %{?with_ldap:--with-dlz-ldap=yes} \
390         --with-dlz-odbc=no \
391         --with-dlz-stub=yes \
392         --enable-largefile \
393         %{!?with_epoll:--disable-epoll --disable-devpoll} \
394         %{!?with_static_libs:--enable-static=no} \
395         --enable-threads \
396         --enable-getifaddrs
397
398 %{__make}
399 %{?with_hip:cd bind-hip/; %{__make}}
400
401 %{?with_tests:%{__make} test}
402
403 %install
404 rm -rf $RPM_BUILD_ROOT
405 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
406         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
407         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}} \
408         $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
409
410 %{__make} install \
411         DESTDIR=$RPM_BUILD_ROOT
412
413 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
414 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
415 %{__perl} -pi -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
416
417 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
418 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
419 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
420 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
421 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
422 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
423 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
424 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
425 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
426 mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
427
428 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
429 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
430 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
431 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
432
433 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
434
435 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
436 install %{SOURCE11} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
437
438 %if %{with ldap}
439 install -d $RPM_BUILD_ROOT%{schemadir}
440 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
441 %endif
442
443 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
444
445 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
446 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
447
448 # let rpm generate deps (workaround -m644 used for libs installation)
449 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
450
451 # we don't want Makefiles in documentation...
452 rm -rf _doc
453 cp -a doc _doc
454 rm -f _doc/misc/Makefile*
455
456 %clean
457 rm -rf $RPM_BUILD_ROOT
458
459 %pre
460 if [ -f %{_sysconfdir}/named.boot ]; then
461         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
462         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
463         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
464 fi
465 %groupadd -g 58 named
466 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
467
468 %post
469 /sbin/chkconfig --add named
470 %service named restart
471
472 %preun
473 if [ "$1" = "0" ]; then
474         %service named stop
475         /sbin/chkconfig --del named
476 fi
477
478 %postun
479 if [ "$1" = "0" ]; then
480         %userremove named
481         %groupremove named
482 fi
483
484 %post   libs -p /sbin/ldconfig
485 %postun libs -p /sbin/ldconfig
486
487 %post -n openldap-schema-bind
488 %openldap_schema_register %{schemadir}/dnszone.schema
489 %service -q ldap restart
490
491 %postun -n openldap-schema-bind
492 if [ "$1" = "0" ]; then
493         %openldap_schema_unregister %{schemadir}/dnszone.schema
494         %service -q ldap restart
495 fi
496
497 %triggerpostun -- %{name} < 7:9.4.2-2
498 /sbin/chkconfig named reset
499 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
500 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
501 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
502
503 %files
504 %defattr(644,root,root,755)
505 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
506 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
507
508 %attr(754,root,root) /etc/rc.d/init.d/named
509 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
510 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
511 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
512 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
513
514 %attr(755,root,root) %{_sbindir}/arpaname
515 %attr(755,root,root) %{_sbindir}/ddns-confgen
516 %attr(755,root,root) %{_sbindir}/dnssec-*
517 %attr(755,root,root) %{_sbindir}/genrandom
518 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
519 %attr(755,root,root) %{_sbindir}/lwresd
520 %attr(755,root,root) %{_sbindir}/named
521 %attr(755,root,root) %{_sbindir}/named-*
522 %attr(755,root,root) %{_sbindir}/nsec3hash
523 %attr(755,root,root) %{_sbindir}/rndc
524 %attr(755,root,root) %{_sbindir}/rndc-confgen
525
526 %{_mandir}/man1/arpaname.1*
527 %{_mandir}/man5/named.conf.5*
528 %{_mandir}/man5/rndc.conf.5*
529 %{_mandir}/man8/ddns-confgen.8*
530 %{_mandir}/man8/dnssec-*.8*
531 %{_mandir}/man8/genrandom.8*
532 %{_mandir}/man8/isc-hmac-fixup.8*
533 %{_mandir}/man8/lwresd.8*
534 %{_mandir}/man8/named.8*
535 %{_mandir}/man8/named-*.8*
536 %{_mandir}/man8/nsec3hash.8*
537 %{_mandir}/man8/rndc.8*
538 %{_mandir}/man8/rndc-confgen.8*
539 %lang(ja) %{_mandir}/ja/man8/named*
540
541 /usr/lib/tmpfiles.d/%{name}.conf
542
543 %attr(770,root,named) %dir %{_var}/lib/named
544 %attr(770,root,named) %dir %{_var}/lib/named/D
545 %attr(750,root,named) %dir %{_var}/lib/named/M
546 %attr(770,root,named) %dir %{_var}/lib/named/S
547 %attr(750,root,named) %dir %{_var}/lib/named/etc
548 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
549 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
550 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
551 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
552 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
553 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
554
555 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
556 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
557
558 %attr(770,root,named) %dir %{_var}/run/named
559 %attr(770,root,named) %dir %{_var}/run/lwresd
560
561 %files utils
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_bindir}/dig
564 %attr(755,root,root) %{_bindir}/host
565 %attr(755,root,root) %{_bindir}/nslookup
566 %attr(755,root,root) %{_bindir}/nsupdate
567 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
568 %{_mandir}/man1/dig.1*
569 %{_mandir}/man1/host.1*
570 %{_mandir}/man1/nslookup.1*
571 %{_mandir}/man1/nsupdate.1*
572
573 %lang(fi) %{_mandir}/fi/man1/host.1*
574
575 %lang(fr) %{_mandir}/fr/man1/host.1*
576
577 %lang(hu) %{_mandir}/hu/man1/host.1*
578
579 %lang(ja) %{_mandir}/ja/man1/dig.1*
580 %lang(ja) %{_mandir}/ja/man1/host.1*
581 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
582 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
583
584 %lang(pl) %{_mandir}/pl/man1/host.1*
585
586 %files libs
587 %defattr(644,root,root,755)
588 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
589 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.[0-9][0-9]
590 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
591 %attr(755,root,root) %ghost %{_libdir}/libdns.so.[0-9][0-9]
592 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
593 %attr(755,root,root) %ghost %{_libdir}/libisc.so.[0-9][0-9]
594 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
595 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.[0-9][0-9]
596 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
597 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.[0-9][0-9]
598 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
599 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.[0-9][0-9]
600
601 %files devel
602 %defattr(644,root,root,755)
603 %attr(755,root,root) %{_bindir}/isc-config.sh
604 %attr(755,root,root) %{_libdir}/libbind9.so
605 %attr(755,root,root) %{_libdir}/libdns.so
606 %attr(755,root,root) %{_libdir}/libisc.so
607 %attr(755,root,root) %{_libdir}/libisccc.so
608 %attr(755,root,root) %{_libdir}/libisccfg.so
609 %attr(755,root,root) %{_libdir}/liblwres.so
610 %{_libdir}/libbind9.la
611 %{_libdir}/libdns.la
612 %{_libdir}/libisc.la
613 %{_libdir}/libisccc.la
614 %{_libdir}/libisccfg.la
615 %{_libdir}/liblwres.la
616 %{_includedir}/bind9
617 %{_includedir}/dns
618 %{_includedir}/dst
619 %{_includedir}/isc
620 %{_includedir}/isccc
621 %{_includedir}/isccfg
622 %{_includedir}/lwres
623 %{_mandir}/man1/isc-config.sh.1*
624 %{_mandir}/man3/lwres*.3*
625
626 %if %{with static_libs}
627 %files static
628 %defattr(644,root,root,755)
629 %{_libdir}/libbind9.a
630 %{_libdir}/libdns.a
631 %{_libdir}/libisc.a
632 %{_libdir}/libisccc.a
633 %{_libdir}/libisccfg.a
634 %{_libdir}/liblwres.a
635 %endif
636
637 %if %{with ldap}
638 %files -n openldap-schema-bind
639 %defattr(644,root,root,755)
640 %{_datadir}/openldap/schema/dnszone.schema
641 %endif
This page took 0.087411 seconds and 4 git commands to generate.