]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- up to 9.9.2 P2, fixes CVE-2012-5688, CVE-2012-5166, CVE-2012-4244, CVE-2012-3817...
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with     edns_cli        # build with the ability to use edns-client-subnet in dig
13 %bcond_with     hip             # build with HIP RR support
14 %if "%{pld_release}" == "ac"
15 %bcond_with     epoll           # enable epoll support
16 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
17 %ifarch %{x8664}
18 %define         with_epoll      1
19 %endif
20 %else
21 %bcond_without  epoll           # disable epoll support
22 %endif
23
24 %define         ver     9.9.2
25 %if 1
26 %define         pverdot .P2
27 %define         pverdir -P2
28 %else
29 %define         pverdot %{nil}
30 %define         pverdir %{nil}
31 %endif
32 Summary:        BIND - DNS name server
33 Summary(de.UTF-8):      BIND - DNS-Namenserver
34 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
35 Summary(fr.UTF-8):      BIND - serveur de noms DNS
36 Summary(pl.UTF-8):      BIND - serwer nazw DNS
37 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
38 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
39 Summary(tr.UTF-8):      DNS alan adı sunucusu
40 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
41 Summary(zh_CN.UTF-8):   Internet 域名服务器
42 Name:           bind
43 Version:        %{ver}%{pverdot}
44 Release:        1
45 Epoch:          7
46 License:        BSD-like
47 Group:          Networking/Daemons
48 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
49 # Source0-md5:  2be7763c99b7e7b42ac3a18a267ce1aa
50 Source1:        named.init
51 Source2:        named.sysconfig
52 Source3:        named.logrotate
53 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
54 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
55 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
56 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
57 Source6:        %{name}-hip.tar.gz
58 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
59 Source7:        ftp://rs.internic.net/domain/root.zone
60 # Source7-md5:  6241cd7c70f855345a68ed0697097ba5
61 Source8:        %{name}-127.0.0.zone
62 Source9:        %{name}-localhost.zone
63 Source10:       %{name}-named.conf
64 Source11:       %{name}.tmpfiles
65 Patch0:         %{name}-time.patch
66 Patch1:         %{name}-link.patch
67 Patch2:         %{name}-pmake.patch
68 Patch3:         %{name}-sdb-ldap.patch
69 Patch4:         %{name}-ac-libs.patch
70 Patch5:         %{name}-edns-client-subnet.patch
71 Patch6:         nsupdate_segfault.patch
72 URL:            https://www.isc.org/software/bind
73 BuildRequires:  autoconf >= 2.59
74 BuildRequires:  automake
75 BuildRequires:  bison
76 BuildRequires:  flex
77 %{?with_kerberos5:BuildRequires:        heimdal-devel}
78 BuildRequires:  idnkit-devel
79 BuildRequires:  libtool
80 %{?with_hip:BuildRequires:      libxml2-devel}
81 %{?with_sql:BuildRequires:      mysql-devel}
82 %{?with_ldap:BuildRequires:     openldap-devel}
83 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
84 %{?with_sql:BuildRequires:      postgresql-devel}
85 BuildRequires:  readline-devel
86 BuildRequires:  rpm >= 4.4.9-56
87 BuildRequires:  rpmbuild(macros) >= 1.268
88 %{?with_sql:BuildRequires:      unixODBC-devel}
89 Requires(post,preun):   /sbin/chkconfig
90 Requires(postun):       /usr/sbin/groupdel
91 Requires(postun):       /usr/sbin/userdel
92 Requires(pre):  /bin/id
93 Requires(pre):  /usr/bin/getgid
94 Requires(pre):  /usr/sbin/groupadd
95 Requires(pre):  /usr/sbin/useradd
96 Requires(pre):  fileutils
97 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
98 Requires:       psmisc >= 20.1
99 Requires:       rc-scripts >= 0.2.0
100 Requires:       uname(release) >= 2.2.18
101 Provides:       group(named)
102 Provides:       nameserver
103 Provides:       user(named)
104 Obsoletes:      caching-nameserver
105 Conflicts:      %{name}-chroot
106 Conflicts:      logrotate < 3.8.0
107 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
108
109 %define         schemadir       /usr/share/openldap/schema
110
111 %description
112 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
113 (Domain Name System) protocols. BIND includes a DNS server (named),
114 which resolves host names to IP addresses, and a resolver library
115 (routines for applications to use when interfacing with DNS). A DNS
116 server allows clients to name resources or objects and share the
117 information with other network machines. The named DNS server can be
118 used on workstations as a caching name server, but is generally only
119 needed on one machine for an entire network. Note that the
120 configuration files for making BIND act as a simple caching nameserver
121 are included in the caching-nameserver package.
122
123 Install the bind package if you need a DNS server for your network. If
124 you want bind to act a caching name server, you will also need to
125 install the caching-nameserver package.
126
127 %description -l de.UTF-8
128 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
129 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
130 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
131 Recher des Netzwerks erforderlich.
132
133 %description -l es.UTF-8
134 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
135 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
136 un servidor de nombres caché, pero generalmente sólo hace falta en una
137 máquina para toda la red.
138
139 %description -l fr.UTF-8
140 Contient le serveur de noms named, utilisé pour définir les
141 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
142 utilisé sur les stations de travail comme serveur de nom en cache mais
143 n'est souvent nécessaire que sur une machine pour un réseau entier.
144
145 %description -l pl.UTF-8
146 Pakiet ten zawiera demona named, który służy do zmieniania nazw
147 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
148 roboczych jako bufor odwołań do serwisu nazw (caching name server),
149 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
150 program na fragment sieci.
151
152 %description -l pt_BR.UTF-8
153 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
154 IP (e vice-versa). Pode ser usado em estações de trabalho como um
155 servidor de nomes cache, mas geralmente só é necessário em uma máquina
156 para toda a rede.
157
158 %description -l ru.UTF-8
159 BIND (Berkeley Internet Name Domain) является реализацией протоколов
160 DNS (Domain Name System). BIND включает DNS сервер (named) и
161 библиотеку "резолвера" (подпрограммы для приложений, через которые
162 происходят обращения к DNS). DNS сервер named может быть использован
163 на рабочих станциях как кеширующий сервер, но обычно запускается на
164 одной машине в локальной сети и используется остальными машинами (этим
165 достигается намного более эффективное кеширование).
166
167 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
168 кеширующего сервера, включены в пакет caching-nameserver.
169
170 %description -l tr.UTF-8
171 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
172 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
173 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
174 için sadece bir makina üzerinde kurulur.
175
176 %description -l uk.UTF-8
177 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
178 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
179 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
180 сервер named може бути використаний на робочих станціях як кешируючий
181 сервер, але звичайно запускається на одній машині в локальній мережі і
182 використовується іншими (цим досягається більша ефективність
183 використання кешу).
184
185 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
186 кешируючого серверу, включені в пакет caching-nameserver.
187
188 %package utils
189 Summary:        DNS utils - host, dig, dnsquery, nslookup
190 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
191 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
192 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
193 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
194 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
195 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
196 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
197 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
198 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
199 Group:          Networking/Utilities
200 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
201 Requires:       iconv
202
203 %description utils
204 Bind-utils contains a collection of utilities for querying DNS (Domain
205 Name Service) name servers to find out information about Internet
206 hosts. These tools will provide you with the IP addresses for given
207 host names, as well as other information about registered domains and
208 network addresses.
209
210 You should install bind-utils if you need to get information from DNS
211 name servers.
212
213 %description utils -l de.UTF-8
214 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
215 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
216 Informationen über registrierte Domains und Netzwerk-Adressen.
217
218 %description utils -l es.UTF-8
219 Conjunto de utilitarios para consulta a servidores de nombres. Estas
220 herramientas permiten la determinación de direcciones IP para nombres
221 de máquinas informados y busca información sobre dominios registrados
222 y direcciones de red.
223
224 %description utils -l fr.UTF-8
225 Ensemble d'utilitaires pour interroger les serveurs de noms et
226 rechercher des hôtes. Ces outils vous permettent de déterminer les
227 adresses IP pour des noms d'hôtes donnés, et trouver des informations
228 sur les noms de domaine déclarés et les adresses réseau.
229
230 %description utils -l pl.UTF-8
231 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
232 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
233 i ich adresach IP.
234
235 %description utils -l pt_BR.UTF-8
236 Conjunto de utilitários para consulta a servidores DNS. Estas
237 ferramentas permitem a determinação de endereços IP para nomes de
238 máquinas informados e busca informações sobre domínios registrados e
239 endereços de rede. Você deveria instalar este pacote se necessitar
240 obter informações de servidores DNS.
241
242 %description utils -l ru.UTF-8
243 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
244 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
245 доменному имени (и наоборот) и другую информацию о зарегистрированных
246 доменах и сетевых адресах.
247
248 %description utils -l tr.UTF-8
249 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
250 için kullanılan araçlar bulunmaktadır.
251
252 %description utils -l uk.UTF-8
253 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
254 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
255 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
256 домени та адреси.
257
258 %package libs
259 Summary:        DNS libraries
260 Summary(pl.UTF-8):      Biblioteki DNS
261 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
262 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
263 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
264 Group:          Libraries
265
266 %description libs
267 The bind-libs package contains all libraries required for running BIND
268 and bind utils.
269
270 %description libs -l pl.UTF-8
271 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
272 lub programów z pakietu bind-utils.
273
274 %description libs -l ru.UTF-8
275 Библиотеки, необходимые для работы bind.
276
277 %description libs -l uk.UTF-8
278 Бібліотеки, необхідні для роботи bind.
279
280 %package devel
281 Summary:        DNS development includes
282 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
283 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
284 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
285 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
286 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
287 Group:          Development/Libraries
288 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
289
290 %description devel
291 The bind-devel package contains all the include files and symlinks
292 required for DNS (Domain Name Service) development for BIND.
293
294 You should install bind-devel if you want to develop bind DNS
295 applications. If you install bind-devel, you'll also need to install
296 bind-libs.
297
298 %description devel -l es.UTF-8
299 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
300 para el bind.
301
302 %description devel -l pl.UTF-8
303 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
304 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
305 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
306 pakiet.
307
308 %description devel -l pt_BR.UTF-8
309 Todos os arquivos de cabeçalho e bibliotecas necessários para o
310 desenvolvimento com o bind.
311
312 %description devel -l ru.UTF-8
313 Все хедеры и библиотеки, необходимые для написания программ с
314 использованием BIND 9.x.x.
315
316 %description devel -l uk.UTF-8
317 Всі хедери та бібліотеки, необхідні для розробки програм з
318 використанням BIND 9.x.x.
319
320 %package static
321 Summary:        DNS static libs
322 Summary(pl.UTF-8):      Biblioteki statyczne DNS
323 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
324 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
325 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
326 Group:          Development/Libraries
327 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
328
329 %description static
330 Static bind libraries.
331
332 %description static -l pl.UTF-8
333 Statyczne biblioteki binda.
334
335 %description static -l pt_BR.UTF-8
336 Bibliotecas estáticas para desenvolvimento DNS.
337
338 %description static -l ru.UTF-8
339 Статические библиотеки, необходимые для написания программ с
340 использованием BIND.
341
342 %description static -l uk.UTF-8
343 Статичні бібліотеки, необхідні для розробки програм з використанням
344 BIND.
345
346 %package -n openldap-schema-bind
347 Summary:        BIND schema for openldap
348 Summary(pl.UTF-8):      Schemat BIND dla openldap
349 Group:          Development/Libraries
350 Requires(post,postun):  sed >= 4.0
351 Requires:       openldap-servers
352 Requires:       sed >= 4.0
353
354 %description -n openldap-schema-bind
355 BIND schema for openldap.
356
357 %description -n openldap-schema-bind -l pl.UTF-8
358 Schemat BIND dla openldap.
359
360 %prep
361 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
362 %patch0 -p1
363 %patch1 -p1
364 %patch2 -p1
365 %{?with_ldap:%patch3 -p1}
366 %patch4 -p1
367 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
368 %patch6 -p0
369
370 %{?with_edns_cli:%patch5 -p0}
371
372 %build
373 %{__libtoolize}
374 %{__aclocal}
375 %{__autoconf}
376 cp -f /usr/share/automake/config.* .
377 %configure \
378         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
379         --with-idn \
380         --with-libtool \
381         %{?with_ssl:--with-openssl} \
382         %{?with_ipv6:--enable-ipv6} \
383         %{?with_kerberos5:--with-gssapi} \
384         %{?with_sql:--with-dlz-postgres=yes} \
385         %{?with_sql:--with-dlz-mysql=yes} \
386         --with-dlz-bdb=no \
387         --with-dlz-filesystem=yes \
388         %{?with_ldap:--with-dlz-ldap=yes} \
389         --with-dlz-odbc=no \
390         --with-dlz-stub=yes \
391         --enable-largefile \
392         %{!?with_epoll:--disable-epoll --disable-devpoll} \
393         %{!?with_static_libs:--enable-static=no} \
394         --enable-threads \
395         --enable-getifaddrs
396
397 %{__make}
398 %{?with_hip:cd bind-hip/; %{__make}}
399
400 %{?with_tests:%{__make} test}
401
402 %install
403 rm -rf $RPM_BUILD_ROOT
404 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
405         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
406         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}} \
407         $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
408
409 %{__make} install \
410         DESTDIR=$RPM_BUILD_ROOT
411
412 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
413 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
414 %{__perl} -pi -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
415
416 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
417 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
418 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
419 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
420 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
421 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
422 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
423 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
424 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
425 mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
426
427 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
428 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
429 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
430 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
431
432 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
433
434 install %{SOURCE11} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
435
436 %if %{with ldap}
437 install -d $RPM_BUILD_ROOT%{schemadir}
438 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
439 %endif
440
441 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
442
443 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
444 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
445
446 # let rpm generate deps (workaround -m644 used for libs installation)
447 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
448
449 # we don't want Makefiles in documentation...
450 rm -rf _doc
451 cp -a doc _doc
452 rm -f _doc/misc/Makefile*
453
454 %clean
455 rm -rf $RPM_BUILD_ROOT
456
457 %pre
458 if [ -f %{_sysconfdir}/named.boot ]; then
459         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
460         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
461         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
462 fi
463 %groupadd -g 58 named
464 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
465
466 %post
467 /sbin/chkconfig --add named
468 %service named restart
469
470 %preun
471 if [ "$1" = "0" ]; then
472         %service named stop
473         /sbin/chkconfig --del named
474 fi
475
476 %postun
477 if [ "$1" = "0" ]; then
478         %userremove named
479         %groupremove named
480 fi
481
482 %post   libs -p /sbin/ldconfig
483 %postun libs -p /sbin/ldconfig
484
485 %post -n openldap-schema-bind
486 %openldap_schema_register %{schemadir}/dnszone.schema
487 %service -q ldap restart
488
489 %postun -n openldap-schema-bind
490 if [ "$1" = "0" ]; then
491         %openldap_schema_unregister %{schemadir}/dnszone.schema
492         %service -q ldap restart
493 fi
494
495 %triggerpostun -- %{name} < 7:9.4.2-2
496 /sbin/chkconfig named reset
497 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
498 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
499 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
500
501 %files
502 %defattr(644,root,root,755)
503 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
504 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
505
506 %attr(754,root,root) /etc/rc.d/init.d/named
507 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
508 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
509 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
510 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
511
512 %attr(755,root,root) %{_sbindir}/arpaname
513 %attr(755,root,root) %{_sbindir}/ddns-confgen
514 %attr(755,root,root) %{_sbindir}/dnssec-*
515 %attr(755,root,root) %{_sbindir}/genrandom
516 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
517 %attr(755,root,root) %{_sbindir}/lwresd
518 %attr(755,root,root) %{_sbindir}/named
519 %attr(755,root,root) %{_sbindir}/named-*
520 %attr(755,root,root) %{_sbindir}/nsec3hash
521 %attr(755,root,root) %{_sbindir}/rndc
522 %attr(755,root,root) %{_sbindir}/rndc-confgen
523
524 %{_mandir}/man1/arpaname.1*
525 %{_mandir}/man5/named.conf.5*
526 %{_mandir}/man5/rndc.conf.5*
527 %{_mandir}/man8/ddns-confgen.8*
528 %{_mandir}/man8/dnssec-*.8*
529 %{_mandir}/man8/genrandom.8*
530 %{_mandir}/man8/isc-hmac-fixup.8*
531 %{_mandir}/man8/lwresd.8*
532 %{_mandir}/man8/named.8*
533 %{_mandir}/man8/named-*.8*
534 %{_mandir}/man8/nsec3hash.8*
535 %{_mandir}/man8/rndc.8*
536 %{_mandir}/man8/rndc-confgen.8*
537 %lang(ja) %{_mandir}/ja/man8/named*
538
539 /usr/lib/tmpfiles.d/%{name}.conf
540
541 %attr(770,root,named) %dir %{_var}/lib/named
542 %attr(770,root,named) %dir %{_var}/lib/named/D
543 %attr(750,root,named) %dir %{_var}/lib/named/M
544 %attr(770,root,named) %dir %{_var}/lib/named/S
545 %attr(750,root,named) %dir %{_var}/lib/named/etc
546 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
547 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
548 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
549 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
550 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
551 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
552
553 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
554 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
555
556 %attr(770,root,named) %dir %{_var}/run/named
557 %attr(770,root,named) %dir %{_var}/run/lwresd
558
559 %files utils
560 %defattr(644,root,root,755)
561 %attr(755,root,root) %{_bindir}/dig
562 %attr(755,root,root) %{_bindir}/host
563 %attr(755,root,root) %{_bindir}/nslookup
564 %attr(755,root,root) %{_bindir}/nsupdate
565 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
566 %{_mandir}/man1/dig.1*
567 %{_mandir}/man1/host.1*
568 %{_mandir}/man1/nslookup.1*
569 %{_mandir}/man1/nsupdate.1*
570
571 %lang(fi) %{_mandir}/fi/man1/host.1*
572
573 %lang(fr) %{_mandir}/fr/man1/host.1*
574
575 %lang(hu) %{_mandir}/hu/man1/host.1*
576
577 %lang(ja) %{_mandir}/ja/man1/dig.1*
578 %lang(ja) %{_mandir}/ja/man1/host.1*
579 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
580 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
581
582 %lang(pl) %{_mandir}/pl/man1/host.1*
583
584 %files libs
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
587 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.[0-9][0-9]
588 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
589 %attr(755,root,root) %ghost %{_libdir}/libdns.so.[0-9][0-9]
590 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
591 %attr(755,root,root) %ghost %{_libdir}/libisc.so.[0-9][0-9]
592 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
593 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.[0-9][0-9]
594 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
595 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.[0-9][0-9]
596 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
597 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.[0-9][0-9]
598
599 %files devel
600 %defattr(644,root,root,755)
601 %attr(755,root,root) %{_bindir}/isc-config.sh
602 %attr(755,root,root) %{_libdir}/libbind9.so
603 %attr(755,root,root) %{_libdir}/libdns.so
604 %attr(755,root,root) %{_libdir}/libisc.so
605 %attr(755,root,root) %{_libdir}/libisccc.so
606 %attr(755,root,root) %{_libdir}/libisccfg.so
607 %attr(755,root,root) %{_libdir}/liblwres.so
608 %{_libdir}/libbind9.la
609 %{_libdir}/libdns.la
610 %{_libdir}/libisc.la
611 %{_libdir}/libisccc.la
612 %{_libdir}/libisccfg.la
613 %{_libdir}/liblwres.la
614 %{_includedir}/bind9
615 %{_includedir}/dns
616 %{_includedir}/dst
617 %{_includedir}/isc
618 %{_includedir}/isccc
619 %{_includedir}/isccfg
620 %{_includedir}/lwres
621 %{_mandir}/man1/isc-config.sh.1*
622 %{_mandir}/man3/lwres*.3*
623
624 %if %{with static_libs}
625 %files static
626 %defattr(644,root,root,755)
627 %{_libdir}/libbind9.a
628 %{_libdir}/libdns.a
629 %{_libdir}/libisc.a
630 %{_libdir}/libisccc.a
631 %{_libdir}/libisccfg.a
632 %{_libdir}/liblwres.a
633 %endif
634
635 %if %{with ldap}
636 %files -n openldap-schema-bind
637 %defattr(644,root,root,755)
638 %{_datadir}/openldap/schema/dnszone.schema
639 %endif
This page took 0.081373 seconds and 4 git commands to generate.