]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- up to 9.9.3; fixes CVE-2013-2266, CVE-2012-5688, CVE-2012-5689
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with     edns_cli        # build with the ability to use edns-client-subnet in dig
13 %bcond_with     hip             # build with HIP RR support
14 %if "%{pld_release}" == "ac"
15 %bcond_with     epoll           # enable epoll support
16 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
17 %ifarch %{x8664}
18 %define         with_epoll      1
19 %endif
20 %else
21 %bcond_without  epoll           # disable epoll support
22 %endif
23
24 %define         ver     9.9.3
25 %if 0
26 %define         pverdot .P2
27 %define         pverdir -P2
28 %else
29 %define         pverdot %{nil}
30 %define         pverdir %{nil}
31 %endif
32 Summary:        BIND - DNS name server
33 Summary(de.UTF-8):      BIND - DNS-Namenserver
34 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
35 Summary(fr.UTF-8):      BIND - serveur de noms DNS
36 Summary(pl.UTF-8):      BIND - serwer nazw DNS
37 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
38 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
39 Summary(tr.UTF-8):      DNS alan adı sunucusu
40 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
41 Summary(zh_CN.UTF-8):   Internet 域名服务器
42 Name:           bind
43 Version:        %{ver}%{pverdot}
44 Release:        1
45 Epoch:          7
46 License:        BSD-like
47 Group:          Networking/Daemons
48 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
49 # Source0-md5:  7baa8359f0773e04f63d7e694db1909c
50 Source1:        named.init
51 Source2:        named.sysconfig
52 Source3:        named.logrotate
53 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
54 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
55 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
56 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
57 Source6:        %{name}-hip.tar.gz
58 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
59 Source7:        ftp://rs.internic.net/domain/root.zone
60 # Source7-md5:  2b06fa74e9415aaf02269160d95fa01a
61 Source8:        %{name}-127.0.0.zone
62 Source9:        %{name}-localhost.zone
63 Source10:       %{name}-named.conf
64 Source11:       %{name}.tmpfiles
65 Source12:       named.service
66 Patch0:         %{name}-time.patch
67 Patch1:         %{name}-link.patch
68 Patch2:         %{name}-pmake.patch
69 Patch3:         %{name}-sdb-ldap.patch
70 Patch4:         %{name}-ac-libs.patch
71 Patch5:         %{name}-edns-client-subnet.patch
72 Patch6:         nsupdate_segfault.patch
73 URL:            https://www.isc.org/software/bind
74 BuildRequires:  autoconf >= 2.59
75 BuildRequires:  automake
76 BuildRequires:  bison
77 BuildRequires:  flex
78 %{?with_kerberos5:BuildRequires:        heimdal-devel}
79 BuildRequires:  idnkit-devel
80 BuildRequires:  libtool
81 %{?with_hip:BuildRequires:      libxml2-devel}
82 %{?with_sql:BuildRequires:      mysql-devel}
83 %{?with_ldap:BuildRequires:     openldap-devel}
84 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
85 %{?with_sql:BuildRequires:      postgresql-devel}
86 BuildRequires:  readline-devel
87 BuildRequires:  rpm >= 4.4.9-56
88 BuildRequires:  rpmbuild(macros) >= 1.647
89 %{?with_sql:BuildRequires:      unixODBC-devel}
90 Requires(post,preun):   /sbin/chkconfig
91 Requires(postun):       /usr/sbin/groupdel
92 Requires(postun):       /usr/sbin/userdel
93 Requires(pre):  /bin/id
94 Requires(pre):  /usr/bin/getgid
95 Requires(pre):  /usr/sbin/groupadd
96 Requires(pre):  /usr/sbin/useradd
97 Requires(pre):  fileutils
98 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
99 Requires:       psmisc >= 20.1
100 Requires:       rc-scripts >= 0.2.0
101 Requires:       systemd-units >= 38
102 Requires:       uname(release) >= 2.2.18
103 Provides:       group(named)
104 Provides:       nameserver
105 Provides:       user(named)
106 Obsoletes:      caching-nameserver
107 Conflicts:      %{name}-chroot
108 Conflicts:      logrotate < 3.8.0
109 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
110
111 %define         schemadir       /usr/share/openldap/schema
112
113 %description
114 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
115 (Domain Name System) protocols. BIND includes a DNS server (named),
116 which resolves host names to IP addresses, and a resolver library
117 (routines for applications to use when interfacing with DNS). A DNS
118 server allows clients to name resources or objects and share the
119 information with other network machines. The named DNS server can be
120 used on workstations as a caching name server, but is generally only
121 needed on one machine for an entire network. Note that the
122 configuration files for making BIND act as a simple caching nameserver
123 are included in the caching-nameserver package.
124
125 Install the bind package if you need a DNS server for your network. If
126 you want bind to act a caching name server, you will also need to
127 install the caching-nameserver package.
128
129 %description -l de.UTF-8
130 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
131 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
132 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
133 Recher des Netzwerks erforderlich.
134
135 %description -l es.UTF-8
136 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
137 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
138 un servidor de nombres caché, pero generalmente sólo hace falta en una
139 máquina para toda la red.
140
141 %description -l fr.UTF-8
142 Contient le serveur de noms named, utilisé pour définir les
143 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
144 utilisé sur les stations de travail comme serveur de nom en cache mais
145 n'est souvent nécessaire que sur une machine pour un réseau entier.
146
147 %description -l pl.UTF-8
148 Pakiet ten zawiera demona named, który służy do zmieniania nazw
149 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
150 roboczych jako bufor odwołań do serwisu nazw (caching name server),
151 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
152 program na fragment sieci.
153
154 %description -l pt_BR.UTF-8
155 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
156 IP (e vice-versa). Pode ser usado em estações de trabalho como um
157 servidor de nomes cache, mas geralmente só é necessário em uma máquina
158 para toda a rede.
159
160 %description -l ru.UTF-8
161 BIND (Berkeley Internet Name Domain) является реализацией протоколов
162 DNS (Domain Name System). BIND включает DNS сервер (named) и
163 библиотеку "резолвера" (подпрограммы для приложений, через которые
164 происходят обращения к DNS). DNS сервер named может быть использован
165 на рабочих станциях как кеширующий сервер, но обычно запускается на
166 одной машине в локальной сети и используется остальными машинами (этим
167 достигается намного более эффективное кеширование).
168
169 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
170 кеширующего сервера, включены в пакет caching-nameserver.
171
172 %description -l tr.UTF-8
173 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
174 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
175 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
176 için sadece bir makina üzerinde kurulur.
177
178 %description -l uk.UTF-8
179 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
180 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
181 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
182 сервер named може бути використаний на робочих станціях як кешируючий
183 сервер, але звичайно запускається на одній машині в локальній мережі і
184 використовується іншими (цим досягається більша ефективність
185 використання кешу).
186
187 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
188 кешируючого серверу, включені в пакет caching-nameserver.
189
190 %package utils
191 Summary:        DNS utils - host, dig, dnsquery, nslookup
192 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
193 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
194 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
195 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
196 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
197 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
198 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
199 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
200 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
201 Group:          Networking/Utilities
202 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
203 Requires:       iconv
204
205 %description utils
206 Bind-utils contains a collection of utilities for querying DNS (Domain
207 Name Service) name servers to find out information about Internet
208 hosts. These tools will provide you with the IP addresses for given
209 host names, as well as other information about registered domains and
210 network addresses.
211
212 You should install bind-utils if you need to get information from DNS
213 name servers.
214
215 %description utils -l de.UTF-8
216 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
217 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
218 Informationen über registrierte Domains und Netzwerk-Adressen.
219
220 %description utils -l es.UTF-8
221 Conjunto de utilitarios para consulta a servidores de nombres. Estas
222 herramientas permiten la determinación de direcciones IP para nombres
223 de máquinas informados y busca información sobre dominios registrados
224 y direcciones de red.
225
226 %description utils -l fr.UTF-8
227 Ensemble d'utilitaires pour interroger les serveurs de noms et
228 rechercher des hôtes. Ces outils vous permettent de déterminer les
229 adresses IP pour des noms d'hôtes donnés, et trouver des informations
230 sur les noms de domaine déclarés et les adresses réseau.
231
232 %description utils -l pl.UTF-8
233 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
234 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
235 i ich adresach IP.
236
237 %description utils -l pt_BR.UTF-8
238 Conjunto de utilitários para consulta a servidores DNS. Estas
239 ferramentas permitem a determinação de endereços IP para nomes de
240 máquinas informados e busca informações sobre domínios registrados e
241 endereços de rede. Você deveria instalar este pacote se necessitar
242 obter informações de servidores DNS.
243
244 %description utils -l ru.UTF-8
245 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
246 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
247 доменному имени (и наоборот) и другую информацию о зарегистрированных
248 доменах и сетевых адресах.
249
250 %description utils -l tr.UTF-8
251 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
252 için kullanılan araçlar bulunmaktadır.
253
254 %description utils -l uk.UTF-8
255 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
256 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
257 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
258 домени та адреси.
259
260 %package libs
261 Summary:        DNS libraries
262 Summary(pl.UTF-8):      Biblioteki DNS
263 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
264 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
265 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
266 Group:          Libraries
267
268 %description libs
269 The bind-libs package contains all libraries required for running BIND
270 and bind utils.
271
272 %description libs -l pl.UTF-8
273 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
274 lub programów z pakietu bind-utils.
275
276 %description libs -l ru.UTF-8
277 Библиотеки, необходимые для работы bind.
278
279 %description libs -l uk.UTF-8
280 Бібліотеки, необхідні для роботи bind.
281
282 %package devel
283 Summary:        DNS development includes
284 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
285 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
286 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
287 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
288 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
289 Group:          Development/Libraries
290 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
291
292 %description devel
293 The bind-devel package contains all the include files and symlinks
294 required for DNS (Domain Name Service) development for BIND.
295
296 You should install bind-devel if you want to develop bind DNS
297 applications. If you install bind-devel, you'll also need to install
298 bind-libs.
299
300 %description devel -l es.UTF-8
301 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
302 para el bind.
303
304 %description devel -l pl.UTF-8
305 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
306 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
307 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
308 pakiet.
309
310 %description devel -l pt_BR.UTF-8
311 Todos os arquivos de cabeçalho e bibliotecas necessários para o
312 desenvolvimento com o bind.
313
314 %description devel -l ru.UTF-8
315 Все хедеры и библиотеки, необходимые для написания программ с
316 использованием BIND 9.x.x.
317
318 %description devel -l uk.UTF-8
319 Всі хедери та бібліотеки, необхідні для розробки програм з
320 використанням BIND 9.x.x.
321
322 %package static
323 Summary:        DNS static libs
324 Summary(pl.UTF-8):      Biblioteki statyczne DNS
325 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
326 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
327 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
328 Group:          Development/Libraries
329 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
330
331 %description static
332 Static bind libraries.
333
334 %description static -l pl.UTF-8
335 Statyczne biblioteki binda.
336
337 %description static -l pt_BR.UTF-8
338 Bibliotecas estáticas para desenvolvimento DNS.
339
340 %description static -l ru.UTF-8
341 Статические библиотеки, необходимые для написания программ с
342 использованием BIND.
343
344 %description static -l uk.UTF-8
345 Статичні бібліотеки, необхідні для розробки програм з використанням
346 BIND.
347
348 %package -n openldap-schema-bind
349 Summary:        BIND schema for openldap
350 Summary(pl.UTF-8):      Schemat BIND dla openldap
351 Group:          Development/Libraries
352 Requires(post,postun):  sed >= 4.0
353 Requires:       openldap-servers
354 Requires:       sed >= 4.0
355
356 %description -n openldap-schema-bind
357 BIND schema for openldap.
358
359 %description -n openldap-schema-bind -l pl.UTF-8
360 Schemat BIND dla openldap.
361
362 %prep
363 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
364 %patch0 -p1
365 %patch1 -p1
366 %patch2 -p1
367 %{?with_ldap:%patch3 -p1}
368 %patch4 -p1
369 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
370 %patch6 -p0
371
372 %{?with_edns_cli:%patch5 -p0}
373
374 %build
375 %{__libtoolize}
376 %{__aclocal}
377 %{__autoconf}
378 cp -f /usr/share/automake/config.* .
379 %configure \
380         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
381         --with-idn \
382         --with-libtool \
383         %{?with_ssl:--with-openssl} \
384         %{?with_ipv6:--enable-ipv6} \
385         %{?with_kerberos5:--with-gssapi} \
386         %{?with_sql:--with-dlz-postgres=yes} \
387         %{?with_sql:--with-dlz-mysql=yes} \
388         --with-dlz-bdb=no \
389         --with-dlz-filesystem=yes \
390         %{?with_ldap:--with-dlz-ldap=yes} \
391         --with-dlz-odbc=no \
392         --with-dlz-stub=yes \
393         --enable-largefile \
394         %{!?with_epoll:--disable-epoll --disable-devpoll} \
395         %{!?with_static_libs:--enable-static=no} \
396         --enable-threads \
397         --enable-getifaddrs \
398         --enable-newstats
399
400 %{__make}
401 %{?with_hip:cd bind-hip/; %{__make}}
402
403 %{?with_tests:%{__make} test}
404
405 %install
406 rm -rf $RPM_BUILD_ROOT
407 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
408         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
409         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}} \
410         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
411
412 %{__make} install \
413         DESTDIR=$RPM_BUILD_ROOT
414
415 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
416 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
417 %{__perl} -pi -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
418
419 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
420 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
421 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
422 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
423 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
424 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
425 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
426 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
427 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
428 mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
429
430 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
431 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
432 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
433 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
434
435 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
436
437 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
438 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
439
440 %if %{with ldap}
441 install -d $RPM_BUILD_ROOT%{schemadir}
442 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
443 %endif
444
445 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
446
447 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
448 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
449
450 # let rpm generate deps (workaround -m644 used for libs installation)
451 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
452
453 # we don't want Makefiles in documentation...
454 rm -rf _doc
455 cp -a doc _doc
456 rm -f _doc/misc/Makefile*
457
458 %clean
459 rm -rf $RPM_BUILD_ROOT
460
461 %pre
462 if [ -f %{_sysconfdir}/named.boot ]; then
463         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
464         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
465         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
466 fi
467 %groupadd -g 58 named
468 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
469
470 %post
471 /sbin/chkconfig --add named
472 %service named restart
473 %systemd_post named.service
474
475 %preun
476 if [ "$1" = "0" ]; then
477         %service named stop
478         /sbin/chkconfig --del named
479 fi
480 %systemd_preun named.service
481
482 %postun
483 if [ "$1" = "0" ]; then
484         %userremove named
485         %groupremove named
486 fi
487 %systemd_reload
488
489 %post   libs -p /sbin/ldconfig
490 %postun libs -p /sbin/ldconfig
491
492 %post -n openldap-schema-bind
493 %openldap_schema_register %{schemadir}/dnszone.schema
494 %service -q ldap restart
495
496 %postun -n openldap-schema-bind
497 if [ "$1" = "0" ]; then
498         %openldap_schema_unregister %{schemadir}/dnszone.schema
499         %service -q ldap restart
500 fi
501
502 %triggerpostun -- %{name} < 7:9.4.2-2
503 /sbin/chkconfig named reset
504 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
505 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
506 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
507
508 %triggerpostun -- %{name} < 7:9.9.2.P2-2
509 %systemd_trigger named.service
510
511 %files
512 %defattr(644,root,root,755)
513 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
514 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
515
516 %{systemdunitdir}/named.service
517 %attr(754,root,root) /etc/rc.d/init.d/named
518 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
519 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
520 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
521 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
522
523 %attr(755,root,root) %{_sbindir}/arpaname
524 %attr(755,root,root) %{_sbindir}/ddns-confgen
525 %attr(755,root,root) %{_sbindir}/dnssec-*
526 %attr(755,root,root) %{_sbindir}/genrandom
527 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
528 %attr(755,root,root) %{_sbindir}/lwresd
529 %attr(755,root,root) %{_sbindir}/named
530 %attr(755,root,root) %{_sbindir}/named-*
531 %attr(755,root,root) %{_sbindir}/nsec3hash
532 %attr(755,root,root) %{_sbindir}/rndc
533 %attr(755,root,root) %{_sbindir}/rndc-confgen
534
535 %{_mandir}/man1/arpaname.1*
536 %{_mandir}/man5/named.conf.5*
537 %{_mandir}/man5/rndc.conf.5*
538 %{_mandir}/man8/ddns-confgen.8*
539 %{_mandir}/man8/dnssec-*.8*
540 %{_mandir}/man8/genrandom.8*
541 %{_mandir}/man8/isc-hmac-fixup.8*
542 %{_mandir}/man8/lwresd.8*
543 %{_mandir}/man8/named.8*
544 %{_mandir}/man8/named-*.8*
545 %{_mandir}/man8/nsec3hash.8*
546 %{_mandir}/man8/rndc.8*
547 %{_mandir}/man8/rndc-confgen.8*
548 %lang(ja) %{_mandir}/ja/man8/named*
549
550 %{systemdtmpfilesdir}/%{name}.conf
551
552 %attr(770,root,named) %dir %{_var}/lib/named
553 %attr(770,root,named) %dir %{_var}/lib/named/D
554 %attr(750,root,named) %dir %{_var}/lib/named/M
555 %attr(770,root,named) %dir %{_var}/lib/named/S
556 %attr(750,root,named) %dir %{_var}/lib/named/etc
557 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
558 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
559 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
560 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
561 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
562 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
563
564 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
565 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
566
567 %attr(770,root,named) %dir %{_var}/run/named
568 %attr(770,root,named) %dir %{_var}/run/lwresd
569
570 %files utils
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{_bindir}/dig
573 %attr(755,root,root) %{_bindir}/host
574 %attr(755,root,root) %{_bindir}/nslookup
575 %attr(755,root,root) %{_bindir}/nsupdate
576 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
577 %{_mandir}/man1/dig.1*
578 %{_mandir}/man1/host.1*
579 %{_mandir}/man1/nslookup.1*
580 %{_mandir}/man1/nsupdate.1*
581
582 %lang(fi) %{_mandir}/fi/man1/host.1*
583
584 %lang(fr) %{_mandir}/fr/man1/host.1*
585
586 %lang(hu) %{_mandir}/hu/man1/host.1*
587
588 %lang(ja) %{_mandir}/ja/man1/dig.1*
589 %lang(ja) %{_mandir}/ja/man1/host.1*
590 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
591 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
592
593 %lang(pl) %{_mandir}/pl/man1/host.1*
594
595 %files libs
596 %defattr(644,root,root,755)
597 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
598 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.[0-9][0-9]
599 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
600 %attr(755,root,root) %ghost %{_libdir}/libdns.so.[0-9][0-9]
601 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
602 %attr(755,root,root) %ghost %{_libdir}/libisc.so.[0-9][0-9]
603 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
604 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.[0-9][0-9]
605 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
606 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.[0-9][0-9]
607 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
608 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.[0-9][0-9]
609
610 %files devel
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_bindir}/isc-config.sh
613 %attr(755,root,root) %{_libdir}/libbind9.so
614 %attr(755,root,root) %{_libdir}/libdns.so
615 %attr(755,root,root) %{_libdir}/libisc.so
616 %attr(755,root,root) %{_libdir}/libisccc.so
617 %attr(755,root,root) %{_libdir}/libisccfg.so
618 %attr(755,root,root) %{_libdir}/liblwres.so
619 %{_libdir}/libbind9.la
620 %{_libdir}/libdns.la
621 %{_libdir}/libisc.la
622 %{_libdir}/libisccc.la
623 %{_libdir}/libisccfg.la
624 %{_libdir}/liblwres.la
625 %{_includedir}/bind9
626 %{_includedir}/dns
627 %{_includedir}/dst
628 %{_includedir}/isc
629 %{_includedir}/isccc
630 %{_includedir}/isccfg
631 %{_includedir}/lwres
632 %{_mandir}/man1/isc-config.sh.1*
633 %{_mandir}/man3/lwres*.3*
634
635 %if %{with static_libs}
636 %files static
637 %defattr(644,root,root,755)
638 %{_libdir}/libbind9.a
639 %{_libdir}/libdns.a
640 %{_libdir}/libisc.a
641 %{_libdir}/libisccc.a
642 %{_libdir}/libisccfg.a
643 %{_libdir}/liblwres.a
644 %endif
645
646 %if %{with ldap}
647 %files -n openldap-schema-bind
648 %defattr(644,root,root,755)
649 %{_datadir}/openldap/schema/dnszone.schema
650 %endif
This page took 0.077433 seconds and 4 git commands to generate.