]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- missing BR: for geoip
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with     edns_cli        # build with the ability to use edns-client-subnet in dig
13 %bcond_with     hip             # build with HIP RR support
14 %bcond_without  geoip           # build with GeoIP support
15 %bcond_with     seccomp         # seccomp
16
17 %if "%{pld_release}" == "ac"
18 %bcond_with     epoll           # enable epoll support
19 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
20 %ifarch %{x8664}
21 %define         with_epoll      1
22 %endif
23 %else
24 %bcond_without  epoll           # disable epoll support
25 %endif
26
27 %define         ver     9.11.0
28 %if 0
29 %define         pverdot .P1
30 %define         pverdir -P1
31 %else
32 %define         pverdot %{nil}
33 %define         pverdir %{nil}
34 %endif
35 Summary:        BIND - DNS name server
36 Summary(de.UTF-8):      BIND - DNS-Namenserver
37 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
38 Summary(fr.UTF-8):      BIND - serveur de noms DNS
39 Summary(pl.UTF-8):      BIND - serwer nazw DNS
40 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
41 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
42 Summary(tr.UTF-8):      DNS alan adı sunucusu
43 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
44 Summary(zh_CN.UTF-8):   Internet 域名服务器
45 Name:           bind
46 Version:        %{ver}%{pverdot}
47 Release:        1
48 Epoch:          7
49 License:        MPL 2.0
50 Group:          Networking/Daemons
51 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
52 # Source0-md5:  b12f386e35f3193e6255ed8c03230539
53 Source1:        named.init
54 Source2:        named.sysconfig
55 Source3:        named.logrotate
56 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
57 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
58 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
59 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
60 Source6:        %{name}-hip.tar.gz
61 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
62 Source7:        ftp://rs.internic.net/domain/root.zone
63 # Source7-md5:  d72d81babfab4d8eda47c206447b1fc3
64 Source8:        %{name}-127.0.0.zone
65 Source9:        %{name}-localhost.zone
66 Source10:       %{name}-named.conf
67 Source11:       %{name}.tmpfiles
68 Source12:       named.service
69 Patch0:         %{name}-time.patch
70 Patch1:         %{name}-link.patch
71 Patch2:         %{name}-pmake.patch
72 Patch3:         %{name}-sdb-ldap.patch
73 Patch4:         %{name}-ac-libs.patch
74 Patch5:         %{name}-edns-client-subnet.patch
75 Patch6:         nsupdate_segfault.patch
76 URL:            https://www.isc.org/software/bind
77 BuildRequires:  autoconf >= 2.59
78 BuildRequires:  automake
79 BuildRequires:  bison
80 BuildRequires:  flex
81 %{?with_geoip:BuildRequires:    GeoIP-devel}
82 %{?with_kerberos5:BuildRequires:        heimdal-devel}
83 BuildRequires:  idnkit-devel
84 %{?with_seccomp:BuildRequires:  libseccomp-devel}
85 BuildRequires:  libtool
86 %{?with_hip:BuildRequires:      libxml2-devel}
87 %{?with_sql:BuildRequires:      mysql-devel}
88 %{?with_ldap:BuildRequires:     openldap-devel}
89 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
90 %{?with_sql:BuildRequires:      postgresql-devel}
91 BuildRequires:  python3-devel
92 BuildRequires:  python3-ply
93 BuildRequires:  readline-devel
94 BuildRequires:  rpm >= 4.4.9-56
95 BuildRequires:  rpmbuild(macros) >= 1.647
96 %{?with_sql:BuildRequires:      unixODBC-devel}
97 Requires(post,preun):   /sbin/chkconfig
98 Requires(postun):       /usr/sbin/groupdel
99 Requires(postun):       /usr/sbin/userdel
100 Requires(pre):  /bin/id
101 Requires(pre):  /usr/bin/getgid
102 Requires(pre):  /usr/sbin/groupadd
103 Requires(pre):  /usr/sbin/useradd
104 Requires(pre):  fileutils
105 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
106 Requires:       psmisc >= 20.1
107 Requires:       rc-scripts >= 0.2.0
108 Requires:       systemd-units >= 38
109 Requires:       uname(release) >= 2.2.18
110 Provides:       group(named)
111 Provides:       nameserver
112 Provides:       user(named)
113 Obsoletes:      caching-nameserver
114 Conflicts:      %{name}-chroot
115 Conflicts:      logrotate < 3.8.0
116 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
117
118 %define         schemadir       /usr/share/openldap/schema
119
120 %description
121 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
122 (Domain Name System) protocols. BIND includes a DNS server (named),
123 which resolves host names to IP addresses, and a resolver library
124 (routines for applications to use when interfacing with DNS). A DNS
125 server allows clients to name resources or objects and share the
126 information with other network machines. The named DNS server can be
127 used on workstations as a caching name server, but is generally only
128 needed on one machine for an entire network. Note that the
129 configuration files for making BIND act as a simple caching nameserver
130 are included in the caching-nameserver package.
131
132 Install the bind package if you need a DNS server for your network. If
133 you want bind to act a caching name server, you will also need to
134 install the caching-nameserver package.
135
136 %description -l de.UTF-8
137 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
138 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
139 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
140 Recher des Netzwerks erforderlich.
141
142 %description -l es.UTF-8
143 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
144 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
145 un servidor de nombres caché, pero generalmente sólo hace falta en una
146 máquina para toda la red.
147
148 %description -l fr.UTF-8
149 Contient le serveur de noms named, utilisé pour définir les
150 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
151 utilisé sur les stations de travail comme serveur de nom en cache mais
152 n'est souvent nécessaire que sur une machine pour un réseau entier.
153
154 %description -l pl.UTF-8
155 Pakiet ten zawiera demona named, który służy do zmieniania nazw
156 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
157 roboczych jako bufor odwołań do serwisu nazw (caching name server),
158 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
159 program na fragment sieci.
160
161 %description -l pt_BR.UTF-8
162 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
163 IP (e vice-versa). Pode ser usado em estações de trabalho como um
164 servidor de nomes cache, mas geralmente só é necessário em uma máquina
165 para toda a rede.
166
167 %description -l ru.UTF-8
168 BIND (Berkeley Internet Name Domain) является реализацией протоколов
169 DNS (Domain Name System). BIND включает DNS сервер (named) и
170 библиотеку "резолвера" (подпрограммы для приложений, через которые
171 происходят обращения к DNS). DNS сервер named может быть использован
172 на рабочих станциях как кеширующий сервер, но обычно запускается на
173 одной машине в локальной сети и используется остальными машинами (этим
174 достигается намного более эффективное кеширование).
175
176 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
177 кеширующего сервера, включены в пакет caching-nameserver.
178
179 %description -l tr.UTF-8
180 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
181 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
182 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
183 için sadece bir makina üzerinde kurulur.
184
185 %description -l uk.UTF-8
186 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
187 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
188 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
189 сервер named може бути використаний на робочих станціях як кешируючий
190 сервер, але звичайно запускається на одній машині в локальній мережі і
191 використовується іншими (цим досягається більша ефективність
192 використання кешу).
193
194 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
195 кешируючого серверу, включені в пакет caching-nameserver.
196
197 %package utils
198 Summary:        DNS utils - host, dig, dnsquery, nslookup
199 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
200 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
201 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
202 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
203 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
204 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
205 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
206 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
207 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
208 Group:          Networking/Utilities
209 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
210 Requires:       iconv
211
212 %description utils
213 Bind-utils contains a collection of utilities for querying DNS (Domain
214 Name Service) name servers to find out information about Internet
215 hosts. These tools will provide you with the IP addresses for given
216 host names, as well as other information about registered domains and
217 network addresses.
218
219 You should install bind-utils if you need to get information from DNS
220 name servers.
221
222 %description utils -l de.UTF-8
223 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
224 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
225 Informationen über registrierte Domains und Netzwerk-Adressen.
226
227 %description utils -l es.UTF-8
228 Conjunto de utilitarios para consulta a servidores de nombres. Estas
229 herramientas permiten la determinación de direcciones IP para nombres
230 de máquinas informados y busca información sobre dominios registrados
231 y direcciones de red.
232
233 %description utils -l fr.UTF-8
234 Ensemble d'utilitaires pour interroger les serveurs de noms et
235 rechercher des hôtes. Ces outils vous permettent de déterminer les
236 adresses IP pour des noms d'hôtes donnés, et trouver des informations
237 sur les noms de domaine déclarés et les adresses réseau.
238
239 %description utils -l pl.UTF-8
240 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
241 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
242 i ich adresach IP.
243
244 %description utils -l pt_BR.UTF-8
245 Conjunto de utilitários para consulta a servidores DNS. Estas
246 ferramentas permitem a determinação de endereços IP para nomes de
247 máquinas informados e busca informações sobre domínios registrados e
248 endereços de rede. Você deveria instalar este pacote se necessitar
249 obter informações de servidores DNS.
250
251 %description utils -l ru.UTF-8
252 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
253 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
254 доменному имени (и наоборот) и другую информацию о зарегистрированных
255 доменах и сетевых адресах.
256
257 %description utils -l tr.UTF-8
258 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
259 için kullanılan araçlar bulunmaktadır.
260
261 %description utils -l uk.UTF-8
262 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
263 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
264 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
265 домени та адреси.
266
267 %package libs
268 Summary:        DNS libraries
269 Summary(pl.UTF-8):      Biblioteki DNS
270 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
271 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
272 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
273 Group:          Libraries
274
275 %description libs
276 The bind-libs package contains all libraries required for running BIND
277 and bind utils.
278
279 %description libs -l pl.UTF-8
280 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
281 lub programów z pakietu bind-utils.
282
283 %description libs -l ru.UTF-8
284 Библиотеки, необходимые для работы bind.
285
286 %description libs -l uk.UTF-8
287 Бібліотеки, необхідні для роботи bind.
288
289 %package devel
290 Summary:        DNS development includes
291 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
292 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
293 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
294 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
295 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
296 Group:          Development/Libraries
297 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
298
299 %description devel
300 The bind-devel package contains all the include files and symlinks
301 required for DNS (Domain Name Service) development for BIND.
302
303 You should install bind-devel if you want to develop bind DNS
304 applications. If you install bind-devel, you'll also need to install
305 bind-libs.
306
307 %description devel -l es.UTF-8
308 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
309 para el bind.
310
311 %description devel -l pl.UTF-8
312 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
313 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
314 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
315 pakiet.
316
317 %description devel -l pt_BR.UTF-8
318 Todos os arquivos de cabeçalho e bibliotecas necessários para o
319 desenvolvimento com o bind.
320
321 %description devel -l ru.UTF-8
322 Все хедеры и библиотеки, необходимые для написания программ с
323 использованием BIND 9.x.x.
324
325 %description devel -l uk.UTF-8
326 Всі хедери та бібліотеки, необхідні для розробки програм з
327 використанням BIND 9.x.x.
328
329 %package static
330 Summary:        DNS static libs
331 Summary(pl.UTF-8):      Biblioteki statyczne DNS
332 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
333 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
334 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
335 Group:          Development/Libraries
336 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
337
338 %description static
339 Static bind libraries.
340
341 %description static -l pl.UTF-8
342 Statyczne biblioteki binda.
343
344 %description static -l pt_BR.UTF-8
345 Bibliotecas estáticas para desenvolvimento DNS.
346
347 %description static -l ru.UTF-8
348 Статические библиотеки, необходимые для написания программ с
349 использованием BIND.
350
351 %description static -l uk.UTF-8
352 Статичні бібліотеки, необхідні для розробки програм з використанням
353 BIND.
354
355 %package -n openldap-schema-bind
356 Summary:        BIND schema for openldap
357 Summary(pl.UTF-8):      Schemat BIND dla openldap
358 Group:          Development/Libraries
359 Requires(post,postun):  sed >= 4.0
360 Requires:       openldap-servers
361 Requires:       sed >= 4.0
362 %if "%{_rpmversion}" >= "5"
363 BuildArch:      noarch
364 %endif
365
366 %description -n openldap-schema-bind
367 BIND schema for openldap.
368
369 %description -n openldap-schema-bind -l pl.UTF-8
370 Schemat BIND dla openldap.
371
372 %package -n python3-isc
373 Summary:        Python BIND module
374 Group:          Libraries/Python
375 Requires:       python3-modules
376
377 %description -n python3-isc
378 Python BIND module.
379
380 %prep
381 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
382 %patch0 -p1
383 %patch1 -p1
384 %patch2 -p1
385 %{?with_ldap:%patch3 -p1}
386 %patch4 -p1
387 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
388 %{?with_edns_cli:%patch5 -p0}
389 %patch6 -p0
390
391 %build
392 %{__libtoolize}
393 %{__aclocal}
394 %{__autoconf}
395 cp -f /usr/share/automake/config.* .
396 %configure \
397         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
398         --with-idn \
399         --with-libtool \
400         %{?with_ssl:--with-openssl} \
401         %{?with_ipv6:--enable-ipv6} \
402         %{?with_kerberos5:--with-gssapi} \
403         %{?with_sql:--with-dlz-postgres=yes} \
404         %{?with_sql:--with-dlz-mysql=yes} \
405         --with-dlz-bdb=no \
406         --with-dlz-filesystem=yes \
407         %{?with_ldap:--with-dlz-ldap=yes} \
408         %{?with_geoip:--with-geoip=yes} \
409         --with-dlz-odbc=no \
410         --with-dlz-stub=yes \
411         --enable-largefile \
412         %{!?with_epoll:--disable-epoll --disable-devpoll} \
413         %{!?with_static_libs:--enable-static=no} \
414         --enable-threads \
415         --enable-getifaddrs \
416         --enable-full-report \
417         %{__enable_disable seccomp} \
418         --with-python=%{__python3}
419
420 %{__make}
421 %{?with_hip:cd bind-hip/; %{__make}}
422
423 %{?with_tests:%{__make} test-force}
424
425 %install
426 rm -rf $RPM_BUILD_ROOT
427 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
428         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
429         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}} \
430         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
431
432 %{__make} install \
433         DESTDIR=$RPM_BUILD_ROOT
434
435 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
436 rm $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
437 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
438 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
439
440 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
441 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
442 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
443 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
444 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
445 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
446 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
447 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
448 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
449 mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
450
451 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
452 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
453 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
454 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
455
456 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
457
458 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
459 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
460
461 %if %{with ldap}
462 install -d $RPM_BUILD_ROOT%{schemadir}
463 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
464 %endif
465
466 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
467
468 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
469 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
470
471 # let rpm generate deps (workaround -m644 used for libs installation)
472 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
473
474 # we don't want Makefiles in documentation...
475 rm -rf _doc
476 cp -a doc _doc
477 %{__rm} _doc/misc/Makefile*
478
479 %clean
480 rm -rf $RPM_BUILD_ROOT
481
482 %pre
483 if [ -f %{_sysconfdir}/named.boot ]; then
484         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
485         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
486         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
487 fi
488 %groupadd -g 58 named
489 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
490
491 %post
492 /sbin/chkconfig --add named
493 %service named restart
494 %systemd_post named.service
495
496 %preun
497 if [ "$1" = "0" ]; then
498         %service named stop
499         /sbin/chkconfig --del named
500 fi
501 %systemd_preun named.service
502
503 %postun
504 if [ "$1" = "0" ]; then
505         %userremove named
506         %groupremove named
507 fi
508 %systemd_reload
509
510 %post   libs -p /sbin/ldconfig
511 %postun libs -p /sbin/ldconfig
512
513 %post -n openldap-schema-bind
514 %openldap_schema_register %{schemadir}/dnszone.schema
515 %service -q ldap restart
516
517 %postun -n openldap-schema-bind
518 if [ "$1" = "0" ]; then
519         %openldap_schema_unregister %{schemadir}/dnszone.schema
520         %service -q ldap restart
521 fi
522
523 %triggerpostun -- %{name} < 7:9.4.2-2
524 /sbin/chkconfig named reset
525 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
526 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
527 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
528
529 %triggerpostun -- %{name} < 7:9.9.2.P2-2
530 %systemd_trigger named.service
531
532 %files
533 %defattr(644,root,root,755)
534 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
535 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
536
537 %{systemdunitdir}/named.service
538 %attr(754,root,root) /etc/rc.d/init.d/named
539 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
540 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
541 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
542 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
543
544 %attr(755,root,root) %{_sbindir}/ddns-confgen
545 %attr(755,root,root) %{_sbindir}/dnssec-*
546 %attr(755,root,root) %{_sbindir}/genrandom
547 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
548 %attr(755,root,root) %{_sbindir}/lwresd
549 %attr(755,root,root) %{_sbindir}/named
550 %attr(755,root,root) %{_sbindir}/named-*
551 %attr(755,root,root) %{_sbindir}/nsec3hash
552 %attr(755,root,root) %{_sbindir}/rndc
553 %attr(755,root,root) %{_sbindir}/rndc-confgen
554 %attr(755,root,root) %{_sbindir}/tsig-keygen
555
556 %{_mandir}/man5/named.conf.5*
557 %{_mandir}/man5/rndc.conf.5*
558 %{_mandir}/man8/ddns-confgen.8*
559 %{_mandir}/man8/dnssec-*.8*
560 %{_mandir}/man8/genrandom.8*
561 %{_mandir}/man8/isc-hmac-fixup.8*
562 %{_mandir}/man8/lwresd.8*
563 %{_mandir}/man8/named.8*
564 %{_mandir}/man8/named-*.8*
565 %{_mandir}/man8/nsec3hash.8*
566 %{_mandir}/man8/rndc.8*
567 %{_mandir}/man8/rndc-confgen.8*
568 %{_mandir}/man8/tsig-keygen.8*
569 %lang(ja) %{_mandir}/ja/man8/named*
570
571 %{systemdtmpfilesdir}/%{name}.conf
572
573 %attr(770,root,named) %dir %{_var}/lib/named
574 %attr(770,root,named) %dir %{_var}/lib/named/D
575 %attr(770,root,named) %dir %{_var}/lib/named/M
576 %attr(770,root,named) %dir %{_var}/lib/named/S
577 %attr(750,root,named) %dir %{_var}/lib/named/etc
578 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
579 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
580 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
581 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
582 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
583 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
584
585 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
586 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
587
588 %attr(770,root,named) %dir %{_var}/run/named
589 %attr(770,root,named) %dir %{_var}/run/lwresd
590
591 %files utils
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_bindir}/arpaname
594 %attr(755,root,root) %{_bindir}/delv
595 %attr(755,root,root) %{_bindir}/dig
596 %attr(755,root,root) %{_bindir}/host
597 %attr(755,root,root) %{_bindir}/named-rrchecker
598 %attr(755,root,root) %{_bindir}/mdig
599 %attr(755,root,root) %{_bindir}/nslookup
600 %attr(755,root,root) %{_bindir}/nsupdate
601 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
602 %{_mandir}/man1/arpaname.1*
603 %{_mandir}/man1/delv.1*
604 %{_mandir}/man1/dig.1*
605 %{_mandir}/man1/host.1*
606 %{_mandir}/man1/mdig.1*
607 %{_mandir}/man1/named-rrchecker.1*
608 %{_mandir}/man1/nslookup.1*
609 %{_mandir}/man1/nsupdate.1*
610
611 %lang(fi) %{_mandir}/fi/man1/host.1*
612
613 %lang(fr) %{_mandir}/fr/man1/host.1*
614
615 %lang(hu) %{_mandir}/hu/man1/host.1*
616
617 %lang(ja) %{_mandir}/ja/man1/dig.1*
618 %lang(ja) %{_mandir}/ja/man1/host.1*
619 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
620 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
621
622 %lang(pl) %{_mandir}/pl/man1/host.1*
623
624 %files libs
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
627 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.160
628 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
629 %attr(755,root,root) %ghost %{_libdir}/libdns.so.166
630 %attr(755,root,root) %{_libdir}/libirs.so.*.*.*
631 %attr(755,root,root) %ghost %{_libdir}/libirs.so.160
632 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
633 %attr(755,root,root) %ghost %{_libdir}/libisc.so.160
634 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
635 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.160
636 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
637 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.160
638 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
639 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.160
640
641 %files devel
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_bindir}/bind9-config
644 %attr(755,root,root) %{_bindir}/isc-config.sh
645 %attr(755,root,root) %{_libdir}/libbind9.so
646 %attr(755,root,root) %{_libdir}/libdns.so
647 %attr(755,root,root) %{_libdir}/libirs.so
648 %attr(755,root,root) %{_libdir}/libisc.so
649 %attr(755,root,root) %{_libdir}/libisccc.so
650 %attr(755,root,root) %{_libdir}/libisccfg.so
651 %attr(755,root,root) %{_libdir}/liblwres.so
652 %{_libdir}/libbind9.la
653 %{_libdir}/libdns.la
654 %{_libdir}/libirs.la
655 %{_libdir}/libisc.la
656 %{_libdir}/libisccc.la
657 %{_libdir}/libisccfg.la
658 %{_libdir}/liblwres.la
659 %{_includedir}/bind9
660 %{_includedir}/dns
661 %{_includedir}/dst
662 %{_includedir}/irs
663 %{_includedir}/isc
664 %{_includedir}/isccc
665 %{_includedir}/isccfg
666 %{_includedir}/lwres
667 %{_includedir}/pk11
668 %{_includedir}/pkcs11
669 %{_mandir}/man1/bind9-config.1*
670 %{_mandir}/man1/isc-config.sh.1*
671 %{_mandir}/man3/lwres*.3*
672
673 %if %{with static_libs}
674 %files static
675 %defattr(644,root,root,755)
676 %{_libdir}/libbind9.a
677 %{_libdir}/libdns.a
678 %{_libdir}/libirs.a
679 %{_libdir}/libisc.a
680 %{_libdir}/libisccc.a
681 %{_libdir}/libisccfg.a
682 %{_libdir}/liblwres.a
683 %endif
684
685 %if %{with ldap}
686 %files -n openldap-schema-bind
687 %defattr(644,root,root,755)
688 %{_datadir}/openldap/schema/dnszone.schema
689 %endif
690
691 %files -n python3-isc
692 %defattr(644,root,root,755)
693 %{py3_sitedir}/isc
694 %{py3_sitedir}/isc-*-py*.egg-info
This page took 0.127145 seconds and 4 git commands to generate.