]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- release 3
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with     hip             # build with HIP RR support
13 %if "%{pld_release}" == "ac"
14 %bcond_with             epoll           # enable epoll support
15 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
16 %ifarch %{x8664}
17 %define         with_epoll      1
18 %endif
19 %else
20 %bcond_without  epoll           # disable epoll support
21 %endif
22
23 %define         ver     9.8.0
24 %if 1
25 %define         pverdot .P4
26 %define         pverdir -P4
27 %else
28 %define         pverdot %{nil}
29 %define         pverdir %{nil}
30 %endif
31 Summary:        BIND - DNS name server
32 Summary(de.UTF-8):      BIND - DNS-Namenserver
33 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
34 Summary(fr.UTF-8):      BIND - serveur de noms DNS
35 Summary(pl.UTF-8):      BIND - serwer nazw DNS
36 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
37 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
38 Summary(tr.UTF-8):      DNS alan adı sunucusu
39 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
40 Summary(zh_CN.UTF-8):   Internet 域名服务器
41 Name:           bind
42 Version:        %{ver}%{pverdot}
43 Release:        3
44 Epoch:          7
45 License:        BSD-like
46 Group:          Networking/Daemons
47 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
48 # Source0-md5:  13e36e3f28dc1ce7675b45a4192e8389
49 Source1:        named.init
50 Source2:        named.sysconfig
51 Source3:        named.logrotate
52 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
53 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
54 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
55 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
56 Source6:        %{name}-hip.tar.gz
57 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
58 Source7:        ftp://rs.internic.net/domain/named.root
59 # Source7-md5:  013336e29e65923682f7bce094bb3e5c
60 Source8:        %{name}-127.0.0.zone
61 Source9:        %{name}-localhost.zone
62 Source10:       %{name}-named.conf
63 Patch0:         %{name}-time.patch
64 Patch1:         %{name}-link.patch
65 Patch2:         %{name}-pmake.patch
66 Patch3:         %{name}-sdb-ldap.patch
67 URL:            https://www.isc.org/software/bind
68 BuildRequires:  autoconf
69 BuildRequires:  automake
70 BuildRequires:  bison
71 BuildRequires:  flex
72 %{?with_kerberos5:BuildRequires:        heimdal-devel}
73 BuildRequires:  idnkit-devel
74 BuildRequires:  libtool
75 %{?with_hip:BuildRequires:      libxml2-devel}
76 %{?with_sql:BuildRequires:      mysql-devel}
77 %{?with_ldap:BuildRequires:     openldap-devel}
78 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
79 %{?with_sql:BuildRequires:      postgresql-devel}
80 BuildRequires:  rpm >= 4.4.9-56
81 BuildRequires:  rpmbuild(macros) >= 1.268
82 %{?with_sql:BuildRequires:      unixODBC-devel}
83 Requires(post,preun):   /sbin/chkconfig
84 Requires(postun):       /usr/sbin/groupdel
85 Requires(postun):       /usr/sbin/userdel
86 Requires(pre):  /bin/id
87 Requires(pre):  /usr/bin/getgid
88 Requires(pre):  /usr/sbin/groupadd
89 Requires(pre):  /usr/sbin/useradd
90 Requires(pre):  fileutils
91 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
92 Requires:       psmisc >= 20.1
93 Requires:       rc-scripts >= 0.2.0
94 Provides:       group(named)
95 Provides:       nameserver
96 Provides:       user(named)
97 Obsoletes:      caching-nameserver
98 Conflicts:      %{name}-chroot
99 Conflicts:      kernel < 2.2.18
100 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
101
102 %define         schemadir       /usr/share/openldap/schema
103
104 %description
105 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
106 (Domain Name System) protocols. BIND includes a DNS server (named),
107 which resolves host names to IP addresses, and a resolver library
108 (routines for applications to use when interfacing with DNS). A DNS
109 server allows clients to name resources or objects and share the
110 information with other network machines. The named DNS server can be
111 used on workstations as a caching name server, but is generally only
112 needed on one machine for an entire network. Note that the
113 configuration files for making BIND act as a simple caching nameserver
114 are included in the caching-nameserver package.
115
116 Install the bind package if you need a DNS server for your network. If
117 you want bind to act a caching name server, you will also need to
118 install the caching-nameserver package.
119
120 %description -l de.UTF-8
121 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
122 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
123 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
124 Recher des Netzwerks erforderlich.
125
126 %description -l es.UTF-8
127 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
128 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
129 un servidor de nombres caché, pero generalmente sólo hace falta en una
130 máquina para toda la red.
131
132 %description -l fr.UTF-8
133 Contient le serveur de noms named, utilisé pour définir les
134 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
135 utilisé sur les stations de travail comme serveur de nom en cache mais
136 n'est souvent nécessaire que sur une machine pour un réseau entier.
137
138 %description -l pl.UTF-8
139 Pakiet ten zawiera demona named, który służy do zmieniania nazw
140 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
141 roboczych jako bufor odwołań do serwisu nazw (caching name server),
142 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
143 program na fragment sieci.
144
145 %description -l pt_BR.UTF-8
146 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
147 IP (e vice-versa). Pode ser usado em estações de trabalho como um
148 servidor de nomes cache, mas geralmente só é necessário em uma máquina
149 para toda a rede.
150
151 %description -l ru.UTF-8
152 BIND (Berkeley Internet Name Domain) является реализацией протоколов
153 DNS (Domain Name System). BIND включает DNS сервер (named) и
154 библиотеку "резолвера" (подпрограммы для приложений, через которые
155 происходят обращения к DNS). DNS сервер named может быть использован
156 на рабочих станциях как кеширующий сервер, но обычно запускается на
157 одной машине в локальной сети и используется остальными машинами (этим
158 достигается намного более эффективное кеширование).
159
160 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
161 кеширующего сервера, включены в пакет caching-nameserver.
162
163 %description -l tr.UTF-8
164 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
165 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
166 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
167 için sadece bir makina üzerinde kurulur.
168
169 %description -l uk.UTF-8
170 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
171 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
172 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
173 сервер named може бути використаний на робочих станціях як кешируючий
174 сервер, але звичайно запускається на одній машині в локальній мережі і
175 використовується іншими (цим досягається більша ефективність
176 використання кешу).
177
178 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
179 кешируючого серверу, включені в пакет caching-nameserver.
180
181 %package utils
182 Summary:        DNS utils - host, dig, dnsquery, nslookup
183 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
184 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
185 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
186 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
187 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
188 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
189 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
190 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
191 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
192 Group:          Networking/Utilities
193 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
194 Requires:       iconv
195
196 %description utils
197 Bind-utils contains a collection of utilities for querying DNS (Domain
198 Name Service) name servers to find out information about Internet
199 hosts. These tools will provide you with the IP addresses for given
200 host names, as well as other information about registered domains and
201 network addresses.
202
203 You should install bind-utils if you need to get information from DNS
204 name servers.
205
206 %description utils -l de.UTF-8
207 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
208 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
209 Informationen über registrierte Domains und Netzwerk-Adressen.
210
211 %description utils -l es.UTF-8
212 Conjunto de utilitarios para consulta a servidores de nombres. Estas
213 herramientas permiten la determinación de direcciones IP para nombres
214 de máquinas informados y busca información sobre dominios registrados
215 y direcciones de red.
216
217 %description utils -l fr.UTF-8
218 Ensemble d'utilitaires pour interroger les serveurs de noms et
219 rechercher des hôtes. Ces outils vous permettent de déterminer les
220 adresses IP pour des noms d'hôtes donnés, et trouver des informations
221 sur les noms de domaine déclarés et les adresses réseau.
222
223 %description utils -l pl.UTF-8
224 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
225 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
226 i ich adresach IP.
227
228 %description utils -l pt_BR.UTF-8
229 Conjunto de utilitários para consulta a servidores DNS. Estas
230 ferramentas permitem a determinação de endereços IP para nomes de
231 máquinas informados e busca informações sobre domínios registrados e
232 endereços de rede. Você deveria instalar este pacote se necessitar
233 obter informações de servidores DNS.
234
235 %description utils -l ru.UTF-8
236 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
237 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
238 доменному имени (и наоборот) и другую информацию о зарегистрированных
239 доменах и сетевых адресах.
240
241 %description utils -l tr.UTF-8
242 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
243 için kullanılan araçlar bulunmaktadır.
244
245 %description utils -l uk.UTF-8
246 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
247 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
248 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
249 домени та адреси.
250
251 %package libs
252 Summary:        DNS libraries
253 Summary(pl.UTF-8):      Biblioteki DNS
254 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
255 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
256 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
257 Group:          Libraries
258
259 %description libs
260 The bind-libs package contains all libraries required for running BIND
261 and bind utils.
262
263 %description libs -l pl.UTF-8
264 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
265 lub programów z pakietu bind-utils.
266
267 %description libs -l ru.UTF-8
268 Библиотеки, необходимые для работы bind.
269
270 %description libs -l uk.UTF-8
271 Бібліотеки, необхідні для роботи bind.
272
273 %package devel
274 Summary:        DNS development includes
275 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
276 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
277 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
278 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
279 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
280 Group:          Development/Libraries
281 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
282
283 %description devel
284 The bind-devel package contains all the include files and symlinks
285 required for DNS (Domain Name Service) development for BIND.
286
287 You should install bind-devel if you want to develop bind DNS
288 applications. If you install bind-devel, you'll also need to install
289 bind-libs.
290
291 %description devel -l es.UTF-8
292 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
293 para el bind.
294
295 %description devel -l pl.UTF-8
296 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
297 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
298 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
299 pakiet.
300
301 %description devel -l pt_BR.UTF-8
302 Todos os arquivos de cabeçalho e bibliotecas necessários para o
303 desenvolvimento com o bind.
304
305 %description devel -l ru.UTF-8
306 Все хедеры и библиотеки, необходимые для написания программ с
307 использованием BIND 9.x.x.
308
309 %description devel -l uk.UTF-8
310 Всі хедери та бібліотеки, необхідні для розробки програм з
311 використанням BIND 9.x.x.
312
313 %package static
314 Summary:        DNS static libs
315 Summary(pl.UTF-8):      Biblioteki statyczne DNS
316 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
317 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
318 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
319 Group:          Development/Libraries
320 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
321
322 %description static
323 Static bind libraries.
324
325 %description static -l pl.UTF-8
326 Statyczne biblioteki binda.
327
328 %description static -l pt_BR.UTF-8
329 Bibliotecas estáticas para desenvolvimento DNS.
330
331 %description static -l ru.UTF-8
332 Статические библиотеки, необходимые для написания программ с
333 использованием BIND.
334
335 %description static -l uk.UTF-8
336 Статичні бібліотеки, необхідні для розробки програм з використанням
337 BIND.
338
339 %package -n openldap-schema-bind
340 Summary:        BIND schema for openldap
341 Summary(pl.UTF-8):      Schemat BIND dla openldap
342 Group:          Development/Libraries
343 Requires(post,postun):  sed >= 4.0
344 Requires:       openldap-servers
345 Requires:       sed >= 4.0
346
347 %description -n openldap-schema-bind
348 BIND schema for openldap.
349
350 %description -n openldap-schema-bind -l pl.UTF-8
351 Schemat BIND dla openldap.
352
353 %prep
354 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
355 %patch0 -p1
356 %patch1 -p1
357 %patch2 -p1
358 %{?with_ldap:%patch3 -p1}
359 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
360
361
362 %build
363 %{__libtoolize}
364 %{__aclocal}
365 %{__autoconf}
366 cp -f /usr/share/automake/config.* .
367 %configure \
368         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
369         --with-idn \
370         --with-libtool \
371         %{?with_ssl:--with-openssl=%{_prefix}} \
372         %{?with_ipv6:--enable-ipv6} \
373         %{?with_kerberos5:--with-gssapi} \
374         %{?with_sql:--with-dlz-postgres=yes} \
375         %{?with_sql:--with-dlz-mysql=yes} \
376         --with-dlz-bdb=no \
377         --with-dlz-filesystem=yes \
378         %{?with_ldap:--with-dlz-ldap=yes} \
379         --with-dlz-odbc=no \
380         --with-dlz-stub=yes \
381         --enable-largefile \
382         %{!?with_epoll:--disable-epoll --disable-devpoll} \
383         %{!?with_static_libs:--enable-static=no} \
384         --enable-threads \
385         --enable-getifaddrs
386
387 %{__make}
388 %{?with_hip:cd bind-hip/; %{__make}}
389
390 %{?with_tests:%{__make} test}
391
392 %install
393 rm -rf $RPM_BUILD_ROOT
394 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
395         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
396         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}}
397
398 %{__make} install \
399         DESTDIR=$RPM_BUILD_ROOT
400
401 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
402 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
403 %{__perl} -pi -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
404
405 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
406 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
407 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
408 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
409 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
410 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
411 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
412 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
413 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
414 mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
415
416 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
417 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
418 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
419 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
420
421 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
422
423 %if %{with ldap}
424 install -d $RPM_BUILD_ROOT%{schemadir}
425 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
426 %endif
427
428 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
429
430 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
431 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
432
433 # let rpm generate deps (workaround -m644 used for libs installation)
434 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
435
436 # we don't want Makefiles in documentation...
437 rm -rf _doc
438 cp -a doc _doc
439 rm -f _doc/rfc/rfc*
440 rm -f _doc/misc/Makefile*
441
442 %clean
443 rm -rf $RPM_BUILD_ROOT
444
445 %pre
446 if [ -f %{_sysconfdir}/named.boot ]; then
447         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
448         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
449         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
450 fi
451 %groupadd -g 58 named
452 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
453
454 %post
455 /sbin/chkconfig --add named
456 %service named restart
457
458 %preun
459 if [ "$1" = "0" ]; then
460         %service named stop
461         /sbin/chkconfig --del named
462 fi
463
464 %postun
465 if [ "$1" = "0" ]; then
466         %userremove named
467         %groupremove named
468 fi
469
470 %post   libs -p /sbin/ldconfig
471 %postun libs -p /sbin/ldconfig
472
473 %post -n openldap-schema-bind
474 %openldap_schema_register %{schemadir}/dnszone.schema
475 %service -q ldap restart
476
477 %postun -n openldap-schema-bind
478 if [ "$1" = "0" ]; then
479         %openldap_schema_unregister %{schemadir}/dnszone.schema
480         %service -q ldap restart
481 fi
482
483 %triggerpostun -- %{name} < 7:9.4.2-2
484 /sbin/chkconfig named reset
485 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
486 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
487 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
488
489 %files
490 %defattr(644,root,root,755)
491 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
492 %doc _doc/misc/* _doc/arm/*.html _doc/rfc/index %{?with_ldap:_doc/*.sdb-ldap}
493
494 %attr(754,root,root) /etc/rc.d/init.d/named
495 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
496 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
497 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
498 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
499
500 %attr(755,root,root) %{_sbindir}/arpaname
501 %attr(755,root,root) %{_sbindir}/ddns-confgen
502 %attr(755,root,root) %{_sbindir}/dnssec-*
503 %attr(755,root,root) %{_sbindir}/genrandom
504 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
505 %attr(755,root,root) %{_sbindir}/lwresd
506 %attr(755,root,root) %{_sbindir}/named
507 %attr(755,root,root) %{_sbindir}/named-*
508 %attr(755,root,root) %{_sbindir}/nsec3hash
509 %attr(755,root,root) %{_sbindir}/rndc
510 %attr(755,root,root) %{_sbindir}/rndc-confgen
511
512 %{_mandir}/man1/arpaname.1*
513 %{_mandir}/man5/named.conf.5*
514 %{_mandir}/man5/rndc.conf.5*
515 %{_mandir}/man8/ddns-confgen.8*
516 %{_mandir}/man8/dnssec-*.8*
517 %{_mandir}/man8/genrandom.8*
518 %{_mandir}/man8/isc-hmac-fixup.8*
519 %{_mandir}/man8/lwresd.8*
520 %{_mandir}/man8/named.8*
521 %{_mandir}/man8/named-*.8*
522 %{_mandir}/man8/nsec3hash.8*
523 %{_mandir}/man8/rndc.8*
524 %{_mandir}/man8/rndc-confgen.8*
525 %lang(ja) %{_mandir}/ja/man8/named*
526
527 %attr(770,root,named) %dir %{_var}/lib/named
528 %attr(770,root,named) %dir %{_var}/lib/named/D
529 %attr(750,root,named) %dir %{_var}/lib/named/M
530 %attr(770,root,named) %dir %{_var}/lib/named/S
531 %attr(750,root,named) %dir %{_var}/lib/named/etc
532 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
533 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
534 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
535 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
536 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
537 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
538
539 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
540 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
541
542 %attr(770,root,named) %dir %{_var}/run/named
543 %attr(770,root,named) %dir %{_var}/run/lwresd
544
545 %files utils
546 %defattr(644,root,root,755)
547 %attr(755,root,root) %{_bindir}/dig
548 %attr(755,root,root) %{_bindir}/host
549 %attr(755,root,root) %{_bindir}/nslookup
550 %attr(755,root,root) %{_bindir}/nsupdate
551 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
552 %{_mandir}/man1/dig.1*
553 %{_mandir}/man1/host.1*
554 %{_mandir}/man1/nslookup.1*
555 %{_mandir}/man1/nsupdate.1*
556
557 %lang(fi) %{_mandir}/fi/man1/host.1*
558
559 %lang(fr) %{_mandir}/fr/man1/host.1*
560
561 %lang(hu) %{_mandir}/hu/man1/host.1*
562
563 %lang(ja) %{_mandir}/ja/man1/dig.1*
564 %lang(ja) %{_mandir}/ja/man1/host.1*
565 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
566 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
567
568 %lang(pl) %{_mandir}/pl/man1/host.1*
569
570 %files libs
571 %defattr(644,root,root,755)
572 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
573 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.[0-9][0-9]
574 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
575 %attr(755,root,root) %ghost %{_libdir}/libdns.so.[0-9][0-9]
576 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
577 %attr(755,root,root) %ghost %{_libdir}/libisc.so.[0-9][0-9]
578 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
579 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.[0-9][0-9]
580 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
581 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.[0-9][0-9]
582 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
583 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.[0-9][0-9]
584
585 %files devel
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_bindir}/isc-config.sh
588 %attr(755,root,root) %{_libdir}/libbind9.so
589 %attr(755,root,root) %{_libdir}/libdns.so
590 %attr(755,root,root) %{_libdir}/libisc.so
591 %attr(755,root,root) %{_libdir}/libisccc.so
592 %attr(755,root,root) %{_libdir}/libisccfg.so
593 %attr(755,root,root) %{_libdir}/liblwres.so
594 %{_libdir}/libbind9.la
595 %{_libdir}/libdns.la
596 %{_libdir}/libisc.la
597 %{_libdir}/libisccc.la
598 %{_libdir}/libisccfg.la
599 %{_libdir}/liblwres.la
600 %{_includedir}/bind9
601 %{_includedir}/dns
602 %{_includedir}/dst
603 %{_includedir}/isc
604 %{_includedir}/isccc
605 %{_includedir}/isccfg
606 %{_includedir}/lwres
607 %{_mandir}/man1/isc-config.sh.1*
608 %{_mandir}/man3/lwres*.3*
609
610 %if %{with static_libs}
611 %files static
612 %defattr(644,root,root,755)
613 %{_libdir}/libbind9.a
614 %{_libdir}/libdns.a
615 %{_libdir}/libisc.a
616 %{_libdir}/libisccc.a
617 %{_libdir}/libisccfg.a
618 %{_libdir}/liblwres.a
619 %endif
620
621 %if %{with ldap}
622 %files -n openldap-schema-bind
623 %defattr(644,root,root,755)
624 %{_datadir}/openldap/schema/dnszone.schema
625 %endif
This page took 0.141208 seconds and 4 git commands to generate.