]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- rel 3; use signed root zone
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with edns_cli            # build with the ability to use edns-client-subnet in dig
13 %bcond_with     hip             # build with HIP RR support
14 %if "%{pld_release}" == "ac"
15 %bcond_with             epoll           # enable epoll support
16 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
17 %ifarch %{x8664}
18 %define         with_epoll      1
19 %endif
20 %else
21 %bcond_without  epoll           # disable epoll support
22 %endif
23
24 %define         ver     9.8.1
25 %if 1
26 %define         pverdot .P1
27 %define         pverdir -P1
28 %else
29 %define         pverdot %{nil}
30 %define         pverdir %{nil}
31 %endif
32 Summary:        BIND - DNS name server
33 Summary(de.UTF-8):      BIND - DNS-Namenserver
34 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
35 Summary(fr.UTF-8):      BIND - serveur de noms DNS
36 Summary(pl.UTF-8):      BIND - serwer nazw DNS
37 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
38 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
39 Summary(tr.UTF-8):      DNS alan adı sunucusu
40 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
41 Summary(zh_CN.UTF-8):   Internet 域名服务器
42 Name:           bind
43 Version:        %{ver}%{pverdot}
44 Release:        3
45 Epoch:          7
46 License:        BSD-like
47 Group:          Networking/Daemons
48 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
49 # Source0-md5:  afa41f8203d50bedad65071f9b6f96d7
50 Source1:        named.init
51 Source2:        named.sysconfig
52 Source3:        named.logrotate
53 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
54 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
55 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
56 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
57 Source6:        %{name}-hip.tar.gz
58 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
59 Source7:        ftp://rs.internic.net/domain/root.zone
60 # Source7-md5:  268175178a06a1588134bd8afe4b3685
61 Source8:        %{name}-127.0.0.zone
62 Source9:        %{name}-localhost.zone
63 Source10:       %{name}-named.conf
64 Patch0:         %{name}-time.patch
65 Patch1:         %{name}-link.patch
66 Patch2:         %{name}-pmake.patch
67 Patch3:         %{name}-sdb-ldap.patch
68 Patch4:         %{name}-ac-libs.patch
69 Patch5:         %{name}-edns-client-subnet.patch
70 URL:            https://www.isc.org/software/bind
71 BuildRequires:  autoconf >= 2.59
72 BuildRequires:  automake
73 BuildRequires:  bison
74 BuildRequires:  flex
75 %{?with_kerberos5:BuildRequires:        heimdal-devel}
76 BuildRequires:  idnkit-devel
77 BuildRequires:  libtool
78 %{?with_hip:BuildRequires:      libxml2-devel}
79 %{?with_sql:BuildRequires:      mysql-devel}
80 %{?with_ldap:BuildRequires:     openldap-devel}
81 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
82 %{?with_sql:BuildRequires:      postgresql-devel}
83 BuildRequires:  rpm >= 4.4.9-56
84 BuildRequires:  rpmbuild(macros) >= 1.268
85 %{?with_sql:BuildRequires:      unixODBC-devel}
86 Requires(post,preun):   /sbin/chkconfig
87 Requires(postun):       /usr/sbin/groupdel
88 Requires(postun):       /usr/sbin/userdel
89 Requires(pre):  /bin/id
90 Requires(pre):  /usr/bin/getgid
91 Requires(pre):  /usr/sbin/groupadd
92 Requires(pre):  /usr/sbin/useradd
93 Requires(pre):  fileutils
94 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
95 Requires:       psmisc >= 20.1
96 Requires:       rc-scripts >= 0.2.0
97 Provides:       group(named)
98 Provides:       nameserver
99 Provides:       user(named)
100 Obsoletes:      caching-nameserver
101 Conflicts:      %{name}-chroot
102 Conflicts:      kernel < 2.2.18
103 Conflicts:  logrotate < 3.8.0
104 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
105
106 %define         schemadir       /usr/share/openldap/schema
107
108 %description
109 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
110 (Domain Name System) protocols. BIND includes a DNS server (named),
111 which resolves host names to IP addresses, and a resolver library
112 (routines for applications to use when interfacing with DNS). A DNS
113 server allows clients to name resources or objects and share the
114 information with other network machines. The named DNS server can be
115 used on workstations as a caching name server, but is generally only
116 needed on one machine for an entire network. Note that the
117 configuration files for making BIND act as a simple caching nameserver
118 are included in the caching-nameserver package.
119
120 Install the bind package if you need a DNS server for your network. If
121 you want bind to act a caching name server, you will also need to
122 install the caching-nameserver package.
123
124 %description -l de.UTF-8
125 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
126 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
127 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
128 Recher des Netzwerks erforderlich.
129
130 %description -l es.UTF-8
131 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
132 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
133 un servidor de nombres caché, pero generalmente sólo hace falta en una
134 máquina para toda la red.
135
136 %description -l fr.UTF-8
137 Contient le serveur de noms named, utilisé pour définir les
138 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
139 utilisé sur les stations de travail comme serveur de nom en cache mais
140 n'est souvent nécessaire que sur une machine pour un réseau entier.
141
142 %description -l pl.UTF-8
143 Pakiet ten zawiera demona named, który służy do zmieniania nazw
144 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
145 roboczych jako bufor odwołań do serwisu nazw (caching name server),
146 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
147 program na fragment sieci.
148
149 %description -l pt_BR.UTF-8
150 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
151 IP (e vice-versa). Pode ser usado em estações de trabalho como um
152 servidor de nomes cache, mas geralmente só é necessário em uma máquina
153 para toda a rede.
154
155 %description -l ru.UTF-8
156 BIND (Berkeley Internet Name Domain) является реализацией протоколов
157 DNS (Domain Name System). BIND включает DNS сервер (named) и
158 библиотеку "резолвера" (подпрограммы для приложений, через которые
159 происходят обращения к DNS). DNS сервер named может быть использован
160 на рабочих станциях как кеширующий сервер, но обычно запускается на
161 одной машине в локальной сети и используется остальными машинами (этим
162 достигается намного более эффективное кеширование).
163
164 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
165 кеширующего сервера, включены в пакет caching-nameserver.
166
167 %description -l tr.UTF-8
168 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
169 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
170 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
171 için sadece bir makina üzerinde kurulur.
172
173 %description -l uk.UTF-8
174 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
175 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
176 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
177 сервер named може бути використаний на робочих станціях як кешируючий
178 сервер, але звичайно запускається на одній машині в локальній мережі і
179 використовується іншими (цим досягається більша ефективність
180 використання кешу).
181
182 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
183 кешируючого серверу, включені в пакет caching-nameserver.
184
185 %package utils
186 Summary:        DNS utils - host, dig, dnsquery, nslookup
187 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
188 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
189 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
190 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
191 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
192 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
193 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
194 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
195 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
196 Group:          Networking/Utilities
197 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
198 Requires:       iconv
199
200 %description utils
201 Bind-utils contains a collection of utilities for querying DNS (Domain
202 Name Service) name servers to find out information about Internet
203 hosts. These tools will provide you with the IP addresses for given
204 host names, as well as other information about registered domains and
205 network addresses.
206
207 You should install bind-utils if you need to get information from DNS
208 name servers.
209
210 %description utils -l de.UTF-8
211 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
212 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
213 Informationen über registrierte Domains und Netzwerk-Adressen.
214
215 %description utils -l es.UTF-8
216 Conjunto de utilitarios para consulta a servidores de nombres. Estas
217 herramientas permiten la determinación de direcciones IP para nombres
218 de máquinas informados y busca información sobre dominios registrados
219 y direcciones de red.
220
221 %description utils -l fr.UTF-8
222 Ensemble d'utilitaires pour interroger les serveurs de noms et
223 rechercher des hôtes. Ces outils vous permettent de déterminer les
224 adresses IP pour des noms d'hôtes donnés, et trouver des informations
225 sur les noms de domaine déclarés et les adresses réseau.
226
227 %description utils -l pl.UTF-8
228 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
229 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
230 i ich adresach IP.
231
232 %description utils -l pt_BR.UTF-8
233 Conjunto de utilitários para consulta a servidores DNS. Estas
234 ferramentas permitem a determinação de endereços IP para nomes de
235 máquinas informados e busca informações sobre domínios registrados e
236 endereços de rede. Você deveria instalar este pacote se necessitar
237 obter informações de servidores DNS.
238
239 %description utils -l ru.UTF-8
240 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
241 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
242 доменному имени (и наоборот) и другую информацию о зарегистрированных
243 доменах и сетевых адресах.
244
245 %description utils -l tr.UTF-8
246 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
247 için kullanılan araçlar bulunmaktadır.
248
249 %description utils -l uk.UTF-8
250 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
251 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
252 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
253 домени та адреси.
254
255 %package libs
256 Summary:        DNS libraries
257 Summary(pl.UTF-8):      Biblioteki DNS
258 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
259 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
260 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
261 Group:          Libraries
262
263 %description libs
264 The bind-libs package contains all libraries required for running BIND
265 and bind utils.
266
267 %description libs -l pl.UTF-8
268 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
269 lub programów z pakietu bind-utils.
270
271 %description libs -l ru.UTF-8
272 Библиотеки, необходимые для работы bind.
273
274 %description libs -l uk.UTF-8
275 Бібліотеки, необхідні для роботи bind.
276
277 %package devel
278 Summary:        DNS development includes
279 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
280 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
281 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
282 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
283 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
284 Group:          Development/Libraries
285 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
286
287 %description devel
288 The bind-devel package contains all the include files and symlinks
289 required for DNS (Domain Name Service) development for BIND.
290
291 You should install bind-devel if you want to develop bind DNS
292 applications. If you install bind-devel, you'll also need to install
293 bind-libs.
294
295 %description devel -l es.UTF-8
296 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
297 para el bind.
298
299 %description devel -l pl.UTF-8
300 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
301 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
302 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
303 pakiet.
304
305 %description devel -l pt_BR.UTF-8
306 Todos os arquivos de cabeçalho e bibliotecas necessários para o
307 desenvolvimento com o bind.
308
309 %description devel -l ru.UTF-8
310 Все хедеры и библиотеки, необходимые для написания программ с
311 использованием BIND 9.x.x.
312
313 %description devel -l uk.UTF-8
314 Всі хедери та бібліотеки, необхідні для розробки програм з
315 використанням BIND 9.x.x.
316
317 %package static
318 Summary:        DNS static libs
319 Summary(pl.UTF-8):      Biblioteki statyczne DNS
320 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
321 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
322 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
323 Group:          Development/Libraries
324 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
325
326 %description static
327 Static bind libraries.
328
329 %description static -l pl.UTF-8
330 Statyczne biblioteki binda.
331
332 %description static -l pt_BR.UTF-8
333 Bibliotecas estáticas para desenvolvimento DNS.
334
335 %description static -l ru.UTF-8
336 Статические библиотеки, необходимые для написания программ с
337 использованием BIND.
338
339 %description static -l uk.UTF-8
340 Статичні бібліотеки, необхідні для розробки програм з використанням
341 BIND.
342
343 %package -n openldap-schema-bind
344 Summary:        BIND schema for openldap
345 Summary(pl.UTF-8):      Schemat BIND dla openldap
346 Group:          Development/Libraries
347 Requires(post,postun):  sed >= 4.0
348 Requires:       openldap-servers
349 Requires:       sed >= 4.0
350
351 %description -n openldap-schema-bind
352 BIND schema for openldap.
353
354 %description -n openldap-schema-bind -l pl.UTF-8
355 Schemat BIND dla openldap.
356
357 %prep
358 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
359 %patch0 -p1
360 %patch1 -p1
361 %patch2 -p1
362 %{?with_ldap:%patch3 -p1}
363 %patch4 -p1
364 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
365
366 %{?with_edns_cli:%patch5 -p0}
367
368 %build
369 %{__libtoolize}
370 %{__aclocal}
371 %{__autoconf}
372 cp -f /usr/share/automake/config.* .
373 %configure \
374         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
375         --with-idn \
376         --with-libtool \
377         %{?with_ssl:--with-openssl} \
378         %{?with_ipv6:--enable-ipv6} \
379         %{?with_kerberos5:--with-gssapi} \
380         %{?with_sql:--with-dlz-postgres=yes} \
381         %{?with_sql:--with-dlz-mysql=yes} \
382         --with-dlz-bdb=no \
383         --with-dlz-filesystem=yes \
384         %{?with_ldap:--with-dlz-ldap=yes} \
385         --with-dlz-odbc=no \
386         --with-dlz-stub=yes \
387         --enable-largefile \
388         %{!?with_epoll:--disable-epoll --disable-devpoll} \
389         %{!?with_static_libs:--enable-static=no} \
390         --enable-threads \
391         --enable-getifaddrs
392
393 %{__make}
394 %{?with_hip:cd bind-hip/; %{__make}}
395
396 %{?with_tests:%{__make} test}
397
398 %install
399 rm -rf $RPM_BUILD_ROOT
400 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
401         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
402         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}}
403
404 %{__make} install \
405         DESTDIR=$RPM_BUILD_ROOT
406
407 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
408 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
409 %{__perl} -pi -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
410
411 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
412 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
413 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
414 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
415 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
416 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
417 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
418 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
419 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
420 mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
421
422 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
423 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
424 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
425 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
426
427 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
428
429 %if %{with ldap}
430 install -d $RPM_BUILD_ROOT%{schemadir}
431 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
432 %endif
433
434 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
435
436 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
437 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
438
439 # let rpm generate deps (workaround -m644 used for libs installation)
440 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
441
442 # we don't want Makefiles in documentation...
443 rm -rf _doc
444 cp -a doc _doc
445 rm -f _doc/rfc/rfc*
446 rm -f _doc/misc/Makefile*
447
448 %clean
449 rm -rf $RPM_BUILD_ROOT
450
451 %pre
452 if [ -f %{_sysconfdir}/named.boot ]; then
453         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
454         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
455         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
456 fi
457 %groupadd -g 58 named
458 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
459
460 %post
461 /sbin/chkconfig --add named
462 %service named restart
463
464 %preun
465 if [ "$1" = "0" ]; then
466         %service named stop
467         /sbin/chkconfig --del named
468 fi
469
470 %postun
471 if [ "$1" = "0" ]; then
472         %userremove named
473         %groupremove named
474 fi
475
476 %post   libs -p /sbin/ldconfig
477 %postun libs -p /sbin/ldconfig
478
479 %post -n openldap-schema-bind
480 %openldap_schema_register %{schemadir}/dnszone.schema
481 %service -q ldap restart
482
483 %postun -n openldap-schema-bind
484 if [ "$1" = "0" ]; then
485         %openldap_schema_unregister %{schemadir}/dnszone.schema
486         %service -q ldap restart
487 fi
488
489 %triggerpostun -- %{name} < 7:9.4.2-2
490 /sbin/chkconfig named reset
491 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
492 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
493 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
494
495 %files
496 %defattr(644,root,root,755)
497 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
498 %doc _doc/misc/* _doc/arm/*.html _doc/rfc/index %{?with_ldap:_doc/*.sdb-ldap}
499
500 %attr(754,root,root) /etc/rc.d/init.d/named
501 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
502 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
503 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
504 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
505
506 %attr(755,root,root) %{_sbindir}/arpaname
507 %attr(755,root,root) %{_sbindir}/ddns-confgen
508 %attr(755,root,root) %{_sbindir}/dnssec-*
509 %attr(755,root,root) %{_sbindir}/genrandom
510 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
511 %attr(755,root,root) %{_sbindir}/lwresd
512 %attr(755,root,root) %{_sbindir}/named
513 %attr(755,root,root) %{_sbindir}/named-*
514 %attr(755,root,root) %{_sbindir}/nsec3hash
515 %attr(755,root,root) %{_sbindir}/rndc
516 %attr(755,root,root) %{_sbindir}/rndc-confgen
517
518 %{_mandir}/man1/arpaname.1*
519 %{_mandir}/man5/named.conf.5*
520 %{_mandir}/man5/rndc.conf.5*
521 %{_mandir}/man8/ddns-confgen.8*
522 %{_mandir}/man8/dnssec-*.8*
523 %{_mandir}/man8/genrandom.8*
524 %{_mandir}/man8/isc-hmac-fixup.8*
525 %{_mandir}/man8/lwresd.8*
526 %{_mandir}/man8/named.8*
527 %{_mandir}/man8/named-*.8*
528 %{_mandir}/man8/nsec3hash.8*
529 %{_mandir}/man8/rndc.8*
530 %{_mandir}/man8/rndc-confgen.8*
531 %lang(ja) %{_mandir}/ja/man8/named*
532
533 %attr(770,root,named) %dir %{_var}/lib/named
534 %attr(770,root,named) %dir %{_var}/lib/named/D
535 %attr(750,root,named) %dir %{_var}/lib/named/M
536 %attr(770,root,named) %dir %{_var}/lib/named/S
537 %attr(750,root,named) %dir %{_var}/lib/named/etc
538 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
539 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
540 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
541 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
542 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
543 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
544
545 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
546 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
547
548 %attr(770,root,named) %dir %{_var}/run/named
549 %attr(770,root,named) %dir %{_var}/run/lwresd
550
551 %files utils
552 %defattr(644,root,root,755)
553 %attr(755,root,root) %{_bindir}/dig
554 %attr(755,root,root) %{_bindir}/host
555 %attr(755,root,root) %{_bindir}/nslookup
556 %attr(755,root,root) %{_bindir}/nsupdate
557 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
558 %{_mandir}/man1/dig.1*
559 %{_mandir}/man1/host.1*
560 %{_mandir}/man1/nslookup.1*
561 %{_mandir}/man1/nsupdate.1*
562
563 %lang(fi) %{_mandir}/fi/man1/host.1*
564
565 %lang(fr) %{_mandir}/fr/man1/host.1*
566
567 %lang(hu) %{_mandir}/hu/man1/host.1*
568
569 %lang(ja) %{_mandir}/ja/man1/dig.1*
570 %lang(ja) %{_mandir}/ja/man1/host.1*
571 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
572 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
573
574 %lang(pl) %{_mandir}/pl/man1/host.1*
575
576 %files libs
577 %defattr(644,root,root,755)
578 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
579 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.[0-9][0-9]
580 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
581 %attr(755,root,root) %ghost %{_libdir}/libdns.so.[0-9][0-9]
582 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
583 %attr(755,root,root) %ghost %{_libdir}/libisc.so.[0-9][0-9]
584 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
585 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.[0-9][0-9]
586 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
587 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.[0-9][0-9]
588 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
589 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.[0-9][0-9]
590
591 %files devel
592 %defattr(644,root,root,755)
593 %attr(755,root,root) %{_bindir}/isc-config.sh
594 %attr(755,root,root) %{_libdir}/libbind9.so
595 %attr(755,root,root) %{_libdir}/libdns.so
596 %attr(755,root,root) %{_libdir}/libisc.so
597 %attr(755,root,root) %{_libdir}/libisccc.so
598 %attr(755,root,root) %{_libdir}/libisccfg.so
599 %attr(755,root,root) %{_libdir}/liblwres.so
600 %{_libdir}/libbind9.la
601 %{_libdir}/libdns.la
602 %{_libdir}/libisc.la
603 %{_libdir}/libisccc.la
604 %{_libdir}/libisccfg.la
605 %{_libdir}/liblwres.la
606 %{_includedir}/bind9
607 %{_includedir}/dns
608 %{_includedir}/dst
609 %{_includedir}/isc
610 %{_includedir}/isccc
611 %{_includedir}/isccfg
612 %{_includedir}/lwres
613 %{_mandir}/man1/isc-config.sh.1*
614 %{_mandir}/man3/lwres*.3*
615
616 %if %{with static_libs}
617 %files static
618 %defattr(644,root,root,755)
619 %{_libdir}/libbind9.a
620 %{_libdir}/libdns.a
621 %{_libdir}/libisc.a
622 %{_libdir}/libisccc.a
623 %{_libdir}/libisccfg.a
624 %{_libdir}/liblwres.a
625 %endif
626
627 %if %{with ldap}
628 %files -n openldap-schema-bind
629 %defattr(644,root,root,755)
630 %{_datadir}/openldap/schema/dnszone.schema
631 %endif
This page took 0.164264 seconds and 4 git commands to generate.