]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- up to 9.10.0-P1; fixes CVE-2014-3214
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with     edns_cli        # build with the ability to use edns-client-subnet in dig
13 %bcond_with     hip             # build with HIP RR support
14 %bcond_without  geoip           # build with GeoIP support
15
16 %if "%{pld_release}" == "ac"
17 %bcond_with     epoll           # enable epoll support
18 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
19 %ifarch %{x8664}
20 %define         with_epoll      1
21 %endif
22 %else
23 %bcond_without  epoll           # disable epoll support
24 %endif
25
26 %define         ver     9.10.0
27 %if 1
28 %define         pverdot .P1
29 %define         pverdir -P1
30 %else
31 %define         pverdot %{nil}
32 %define         pverdir %{nil}
33 %endif
34 Summary:        BIND - DNS name server
35 Summary(de.UTF-8):      BIND - DNS-Namenserver
36 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
37 Summary(fr.UTF-8):      BIND - serveur de noms DNS
38 Summary(pl.UTF-8):      BIND - serwer nazw DNS
39 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
40 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
41 Summary(tr.UTF-8):      DNS alan adı sunucusu
42 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
43 Summary(zh_CN.UTF-8):   Internet 域名服务器
44 Name:           bind
45 Version:        %{ver}%{pverdot}
46 Release:        1
47 Epoch:          7
48 License:        BSD-like
49 Group:          Networking/Daemons
50 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
51 # Source0-md5:  3c058f6bd73cfd91d324d20388a76e1a
52 Source1:        named.init
53 Source2:        named.sysconfig
54 Source3:        named.logrotate
55 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
56 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
57 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
58 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
59 Source6:        %{name}-hip.tar.gz
60 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
61 Source7:        ftp://rs.internic.net/domain/root.zone
62 # Source7-md5:  0d083eaa4bcee10f2d746ebd8b18694b
63 Source8:        %{name}-127.0.0.zone
64 Source9:        %{name}-localhost.zone
65 Source10:       %{name}-named.conf
66 Source11:       %{name}.tmpfiles
67 Source12:       named.service
68 Patch0:         %{name}-time.patch
69 Patch1:         %{name}-link.patch
70 Patch2:         %{name}-pmake.patch
71 Patch3:         %{name}-sdb-ldap.patch
72 Patch4:         %{name}-ac-libs.patch
73 Patch5:         %{name}-edns-client-subnet.patch
74 Patch6:         nsupdate_segfault.patch
75 URL:            https://www.isc.org/software/bind
76 BuildRequires:  autoconf >= 2.59
77 BuildRequires:  automake
78 BuildRequires:  bison
79 BuildRequires:  flex
80 %{?with_kerberos5:BuildRequires:        heimdal-devel}
81 BuildRequires:  idnkit-devel
82 BuildRequires:  libtool
83 %{?with_hip:BuildRequires:      libxml2-devel}
84 %{?with_sql:BuildRequires:      mysql-devel}
85 %{?with_ldap:BuildRequires:     openldap-devel}
86 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
87 %{?with_sql:BuildRequires:      postgresql-devel}
88 BuildRequires:  readline-devel
89 BuildRequires:  rpm >= 4.4.9-56
90 BuildRequires:  rpmbuild(macros) >= 1.647
91 %{?with_sql:BuildRequires:      unixODBC-devel}
92 Requires(post,preun):   /sbin/chkconfig
93 Requires(postun):       /usr/sbin/groupdel
94 Requires(postun):       /usr/sbin/userdel
95 Requires(pre):  /bin/id
96 Requires(pre):  /usr/bin/getgid
97 Requires(pre):  /usr/sbin/groupadd
98 Requires(pre):  /usr/sbin/useradd
99 Requires(pre):  fileutils
100 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
101 Requires:       psmisc >= 20.1
102 Requires:       rc-scripts >= 0.2.0
103 Requires:       systemd-units >= 38
104 Requires:       uname(release) >= 2.2.18
105 Provides:       group(named)
106 Provides:       nameserver
107 Provides:       user(named)
108 Obsoletes:      caching-nameserver
109 Conflicts:      %{name}-chroot
110 Conflicts:      logrotate < 3.8.0
111 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
112
113 %define         schemadir       /usr/share/openldap/schema
114
115 %description
116 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
117 (Domain Name System) protocols. BIND includes a DNS server (named),
118 which resolves host names to IP addresses, and a resolver library
119 (routines for applications to use when interfacing with DNS). A DNS
120 server allows clients to name resources or objects and share the
121 information with other network machines. The named DNS server can be
122 used on workstations as a caching name server, but is generally only
123 needed on one machine for an entire network. Note that the
124 configuration files for making BIND act as a simple caching nameserver
125 are included in the caching-nameserver package.
126
127 Install the bind package if you need a DNS server for your network. If
128 you want bind to act a caching name server, you will also need to
129 install the caching-nameserver package.
130
131 %description -l de.UTF-8
132 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
133 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
134 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
135 Recher des Netzwerks erforderlich.
136
137 %description -l es.UTF-8
138 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
139 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
140 un servidor de nombres caché, pero generalmente sólo hace falta en una
141 máquina para toda la red.
142
143 %description -l fr.UTF-8
144 Contient le serveur de noms named, utilisé pour définir les
145 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
146 utilisé sur les stations de travail comme serveur de nom en cache mais
147 n'est souvent nécessaire que sur une machine pour un réseau entier.
148
149 %description -l pl.UTF-8
150 Pakiet ten zawiera demona named, który służy do zmieniania nazw
151 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
152 roboczych jako bufor odwołań do serwisu nazw (caching name server),
153 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
154 program na fragment sieci.
155
156 %description -l pt_BR.UTF-8
157 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
158 IP (e vice-versa). Pode ser usado em estações de trabalho como um
159 servidor de nomes cache, mas geralmente só é necessário em uma máquina
160 para toda a rede.
161
162 %description -l ru.UTF-8
163 BIND (Berkeley Internet Name Domain) является реализацией протоколов
164 DNS (Domain Name System). BIND включает DNS сервер (named) и
165 библиотеку "резолвера" (подпрограммы для приложений, через которые
166 происходят обращения к DNS). DNS сервер named может быть использован
167 на рабочих станциях как кеширующий сервер, но обычно запускается на
168 одной машине в локальной сети и используется остальными машинами (этим
169 достигается намного более эффективное кеширование).
170
171 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
172 кеширующего сервера, включены в пакет caching-nameserver.
173
174 %description -l tr.UTF-8
175 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
176 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
177 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
178 için sadece bir makina üzerinde kurulur.
179
180 %description -l uk.UTF-8
181 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
182 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
183 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
184 сервер named може бути використаний на робочих станціях як кешируючий
185 сервер, але звичайно запускається на одній машині в локальній мережі і
186 використовується іншими (цим досягається більша ефективність
187 використання кешу).
188
189 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
190 кешируючого серверу, включені в пакет caching-nameserver.
191
192 %package utils
193 Summary:        DNS utils - host, dig, dnsquery, nslookup
194 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
195 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
196 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
197 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
198 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
199 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
200 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
201 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
202 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
203 Group:          Networking/Utilities
204 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
205 Requires:       iconv
206
207 %description utils
208 Bind-utils contains a collection of utilities for querying DNS (Domain
209 Name Service) name servers to find out information about Internet
210 hosts. These tools will provide you with the IP addresses for given
211 host names, as well as other information about registered domains and
212 network addresses.
213
214 You should install bind-utils if you need to get information from DNS
215 name servers.
216
217 %description utils -l de.UTF-8
218 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
219 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
220 Informationen über registrierte Domains und Netzwerk-Adressen.
221
222 %description utils -l es.UTF-8
223 Conjunto de utilitarios para consulta a servidores de nombres. Estas
224 herramientas permiten la determinación de direcciones IP para nombres
225 de máquinas informados y busca información sobre dominios registrados
226 y direcciones de red.
227
228 %description utils -l fr.UTF-8
229 Ensemble d'utilitaires pour interroger les serveurs de noms et
230 rechercher des hôtes. Ces outils vous permettent de déterminer les
231 adresses IP pour des noms d'hôtes donnés, et trouver des informations
232 sur les noms de domaine déclarés et les adresses réseau.
233
234 %description utils -l pl.UTF-8
235 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
236 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
237 i ich adresach IP.
238
239 %description utils -l pt_BR.UTF-8
240 Conjunto de utilitários para consulta a servidores DNS. Estas
241 ferramentas permitem a determinação de endereços IP para nomes de
242 máquinas informados e busca informações sobre domínios registrados e
243 endereços de rede. Você deveria instalar este pacote se necessitar
244 obter informações de servidores DNS.
245
246 %description utils -l ru.UTF-8
247 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
248 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
249 доменному имени (и наоборот) и другую информацию о зарегистрированных
250 доменах и сетевых адресах.
251
252 %description utils -l tr.UTF-8
253 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
254 için kullanılan araçlar bulunmaktadır.
255
256 %description utils -l uk.UTF-8
257 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
258 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
259 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
260 домени та адреси.
261
262 %package libs
263 Summary:        DNS libraries
264 Summary(pl.UTF-8):      Biblioteki DNS
265 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
266 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
267 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
268 Group:          Libraries
269
270 %description libs
271 The bind-libs package contains all libraries required for running BIND
272 and bind utils.
273
274 %description libs -l pl.UTF-8
275 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
276 lub programów z pakietu bind-utils.
277
278 %description libs -l ru.UTF-8
279 Библиотеки, необходимые для работы bind.
280
281 %description libs -l uk.UTF-8
282 Бібліотеки, необхідні для роботи bind.
283
284 %package devel
285 Summary:        DNS development includes
286 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
287 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
288 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
289 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
290 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
291 Group:          Development/Libraries
292 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
293
294 %description devel
295 The bind-devel package contains all the include files and symlinks
296 required for DNS (Domain Name Service) development for BIND.
297
298 You should install bind-devel if you want to develop bind DNS
299 applications. If you install bind-devel, you'll also need to install
300 bind-libs.
301
302 %description devel -l es.UTF-8
303 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
304 para el bind.
305
306 %description devel -l pl.UTF-8
307 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
308 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
309 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
310 pakiet.
311
312 %description devel -l pt_BR.UTF-8
313 Todos os arquivos de cabeçalho e bibliotecas necessários para o
314 desenvolvimento com o bind.
315
316 %description devel -l ru.UTF-8
317 Все хедеры и библиотеки, необходимые для написания программ с
318 использованием BIND 9.x.x.
319
320 %description devel -l uk.UTF-8
321 Всі хедери та бібліотеки, необхідні для розробки програм з
322 використанням BIND 9.x.x.
323
324 %package static
325 Summary:        DNS static libs
326 Summary(pl.UTF-8):      Biblioteki statyczne DNS
327 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
328 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
329 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
330 Group:          Development/Libraries
331 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
332
333 %description static
334 Static bind libraries.
335
336 %description static -l pl.UTF-8
337 Statyczne biblioteki binda.
338
339 %description static -l pt_BR.UTF-8
340 Bibliotecas estáticas para desenvolvimento DNS.
341
342 %description static -l ru.UTF-8
343 Статические библиотеки, необходимые для написания программ с
344 использованием BIND.
345
346 %description static -l uk.UTF-8
347 Статичні бібліотеки, необхідні для розробки програм з використанням
348 BIND.
349
350 %package -n openldap-schema-bind
351 Summary:        BIND schema for openldap
352 Summary(pl.UTF-8):      Schemat BIND dla openldap
353 Group:          Development/Libraries
354 Requires(post,postun):  sed >= 4.0
355 Requires:       openldap-servers
356 Requires:       sed >= 4.0
357 %if "%{_rpmversion}" >= "5"
358 BuildArch:      noarch
359 %endif
360
361 %description -n openldap-schema-bind
362 BIND schema for openldap.
363
364 %description -n openldap-schema-bind -l pl.UTF-8
365 Schemat BIND dla openldap.
366
367 %prep
368 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
369 %patch0 -p1
370 %patch1 -p1
371 %patch2 -p1
372 %{?with_ldap:%patch3 -p1}
373 %patch4 -p1
374 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
375 %{?with_edns_cli:%patch5 -p0}
376 %patch6 -p0
377
378 %build
379 %{__libtoolize}
380 %{__aclocal}
381 %{__autoconf}
382 cp -f /usr/share/automake/config.* .
383 %configure \
384         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
385         --with-idn \
386         --with-libtool \
387         %{?with_ssl:--with-openssl} \
388         %{?with_ipv6:--enable-ipv6} \
389         %{?with_kerberos5:--with-gssapi} \
390         %{?with_sql:--with-dlz-postgres=yes} \
391         %{?with_sql:--with-dlz-mysql=yes} \
392         --with-dlz-bdb=no \
393         --with-dlz-filesystem=yes \
394         %{?with_ldap:--with-dlz-ldap=yes} \
395         %{?with_geoip:--with-geoip=yes} \
396         --with-dlz-odbc=no \
397         --with-dlz-stub=yes \
398         --enable-largefile \
399         %{!?with_epoll:--disable-epoll --disable-devpoll} \
400         %{!?with_static_libs:--enable-static=no} \
401         --enable-sit \
402         --enable-threads \
403         --enable-getifaddrs \
404         --enable-newstats \
405         --enable-full-report
406
407 %{__make}
408 %{?with_hip:cd bind-hip/; %{__make}}
409
410 %{?with_tests:%{__make} test-force}
411
412 %install
413 rm -rf $RPM_BUILD_ROOT
414 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
415         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
416         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}} \
417         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
418
419 %{__make} install \
420         DESTDIR=$RPM_BUILD_ROOT
421
422 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
423 rm $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
424 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
425 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
426
427 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
428 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
429 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
430 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
431 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
432 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
433 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
434 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
435 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
436 mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
437
438 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
439 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
440 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
441 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
442
443 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
444
445 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
446 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
447
448 %if %{with ldap}
449 install -d $RPM_BUILD_ROOT%{schemadir}
450 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
451 %endif
452
453 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
454
455 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
456 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
457
458 # let rpm generate deps (workaround -m644 used for libs installation)
459 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
460
461 # we don't want Makefiles in documentation...
462 rm -rf _doc
463 cp -a doc _doc
464 rm -f _doc/misc/Makefile*
465
466 %clean
467 rm -rf $RPM_BUILD_ROOT
468
469 %pre
470 if [ -f %{_sysconfdir}/named.boot ]; then
471         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
472         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
473         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
474 fi
475 %groupadd -g 58 named
476 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
477
478 %post
479 /sbin/chkconfig --add named
480 %service named restart
481 %systemd_post named.service
482
483 %preun
484 if [ "$1" = "0" ]; then
485         %service named stop
486         /sbin/chkconfig --del named
487 fi
488 %systemd_preun named.service
489
490 %postun
491 if [ "$1" = "0" ]; then
492         %userremove named
493         %groupremove named
494 fi
495 %systemd_reload
496
497 %post   libs -p /sbin/ldconfig
498 %postun libs -p /sbin/ldconfig
499
500 %post -n openldap-schema-bind
501 %openldap_schema_register %{schemadir}/dnszone.schema
502 %service -q ldap restart
503
504 %postun -n openldap-schema-bind
505 if [ "$1" = "0" ]; then
506         %openldap_schema_unregister %{schemadir}/dnszone.schema
507         %service -q ldap restart
508 fi
509
510 %triggerpostun -- %{name} < 7:9.4.2-2
511 /sbin/chkconfig named reset
512 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
513 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
514 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
515
516 %triggerpostun -- %{name} < 7:9.9.2.P2-2
517 %systemd_trigger named.service
518
519 %files
520 %defattr(644,root,root,755)
521 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
522 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
523
524 %{systemdunitdir}/named.service
525 %attr(754,root,root) /etc/rc.d/init.d/named
526 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
527 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
528 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
529 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
530
531 %attr(755,root,root) %{_sbindir}/arpaname
532 %attr(755,root,root) %{_sbindir}/ddns-confgen
533 %attr(755,root,root) %{_sbindir}/dnssec-*
534 %attr(755,root,root) %{_sbindir}/genrandom
535 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
536 %attr(755,root,root) %{_sbindir}/lwresd
537 %attr(755,root,root) %{_sbindir}/named
538 %attr(755,root,root) %{_sbindir}/named-*
539 %attr(755,root,root) %{_sbindir}/nsec3hash
540 %attr(755,root,root) %{_sbindir}/rndc
541 %attr(755,root,root) %{_sbindir}/rndc-confgen
542 %attr(755,root,root) %{_sbindir}/tsig-keygen
543
544 %{_mandir}/man1/arpaname.1*
545 %{_mandir}/man5/named.conf.5*
546 %{_mandir}/man5/rndc.conf.5*
547 %{_mandir}/man8/ddns-confgen.8*
548 %{_mandir}/man8/dnssec-*.8*
549 %{_mandir}/man8/genrandom.8*
550 %{_mandir}/man8/isc-hmac-fixup.8*
551 %{_mandir}/man8/lwresd.8*
552 %{_mandir}/man8/named.8*
553 %{_mandir}/man8/named-*.8*
554 %{_mandir}/man8/nsec3hash.8*
555 %{_mandir}/man8/rndc.8*
556 %{_mandir}/man8/rndc-confgen.8*
557 %{_mandir}/man8/tsig-keygen.8*
558 %lang(ja) %{_mandir}/ja/man8/named*
559
560 %{systemdtmpfilesdir}/%{name}.conf
561
562 %attr(770,root,named) %dir %{_var}/lib/named
563 %attr(770,root,named) %dir %{_var}/lib/named/D
564 %attr(750,root,named) %dir %{_var}/lib/named/M
565 %attr(770,root,named) %dir %{_var}/lib/named/S
566 %attr(750,root,named) %dir %{_var}/lib/named/etc
567 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
568 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
569 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
570 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
571 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
572 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
573
574 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
575 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
576
577 %attr(770,root,named) %dir %{_var}/run/named
578 %attr(770,root,named) %dir %{_var}/run/lwresd
579
580 %files utils
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_bindir}/delv
583 %attr(755,root,root) %{_bindir}/dig
584 %attr(755,root,root) %{_bindir}/host
585 %attr(755,root,root) %{_bindir}/nslookup
586 %attr(755,root,root) %{_bindir}/nsupdate
587 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
588 %{_mandir}/man1/delv.1*
589 %{_mandir}/man1/dig.1*
590 %{_mandir}/man1/host.1*
591 %{_mandir}/man1/nslookup.1*
592 %{_mandir}/man1/nsupdate.1*
593
594 %lang(fi) %{_mandir}/fi/man1/host.1*
595
596 %lang(fr) %{_mandir}/fr/man1/host.1*
597
598 %lang(hu) %{_mandir}/hu/man1/host.1*
599
600 %lang(ja) %{_mandir}/ja/man1/dig.1*
601 %lang(ja) %{_mandir}/ja/man1/host.1*
602 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
603 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
604
605 %lang(pl) %{_mandir}/pl/man1/host.1*
606
607 %files libs
608 %defattr(644,root,root,755)
609 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
610 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.[0-9][0-9][0-9]
611 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
612 %attr(755,root,root) %ghost %{_libdir}/libdns.so.[0-9][0-9][0-9]
613 %attr(755,root,root) %{_libdir}/libirs.so.*.*.*
614 %attr(755,root,root) %ghost %{_libdir}/libirs.so.[0-9][0-9][0-9]
615 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
616 %attr(755,root,root) %ghost %{_libdir}/libisc.so.[0-9][0-9][0-9]
617 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
618 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.[0-9][0-9][0-9]
619 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
620 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.[0-9][0-9][0-9]
621 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
622 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.[0-9][0-9][0-9]
623
624 %files devel
625 %defattr(644,root,root,755)
626 %attr(755,root,root) %{_bindir}/bind9-config
627 %attr(755,root,root) %{_bindir}/isc-config.sh
628 %attr(755,root,root) %{_libdir}/libbind9.so
629 %attr(755,root,root) %{_libdir}/libdns.so
630 %attr(755,root,root) %{_libdir}/libirs.so
631 %attr(755,root,root) %{_libdir}/libisc.so
632 %attr(755,root,root) %{_libdir}/libisccc.so
633 %attr(755,root,root) %{_libdir}/libisccfg.so
634 %attr(755,root,root) %{_libdir}/liblwres.so
635 %{_libdir}/libbind9.la
636 %{_libdir}/libdns.la
637 %{_libdir}/libirs.la
638 %{_libdir}/libisc.la
639 %{_libdir}/libisccc.la
640 %{_libdir}/libisccfg.la
641 %{_libdir}/liblwres.la
642 %{_includedir}/bind9
643 %{_includedir}/dns
644 %{_includedir}/dst
645 %{_includedir}/irs
646 %{_includedir}/isc
647 %{_includedir}/isccc
648 %{_includedir}/isccfg
649 %{_includedir}/lwres
650 %{_includedir}/pk11
651 %{_includedir}/pkcs11
652 %{_mandir}/man1/bind9-config.1*
653 %{_mandir}/man1/isc-config.sh.1*
654 %{_mandir}/man3/lwres*.3*
655
656 %if %{with static_libs}
657 %files static
658 %defattr(644,root,root,755)
659 %{_libdir}/libbind9.a
660 %{_libdir}/libdns.a
661 %{_libdir}/libirs.a
662 %{_libdir}/libisc.a
663 %{_libdir}/libisccc.a
664 %{_libdir}/libisccfg.a
665 %{_libdir}/liblwres.a
666 %endif
667
668 %if %{with ldap}
669 %files -n openldap-schema-bind
670 %defattr(644,root,root,755)
671 %{_datadir}/openldap/schema/dnszone.schema
672 %endif
This page took 0.079576 seconds and 4 git commands to generate.