]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- up to 9.11.0 beta 3 (TODO: python package as noarch)
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with     edns_cli        # build with the ability to use edns-client-subnet in dig
13 %bcond_with     hip             # build with HIP RR support
14 %bcond_without  geoip           # build with GeoIP support
15 %bcond_with     seccomp         # seccomp
16
17 %if "%{pld_release}" == "ac"
18 %bcond_with     epoll           # enable epoll support
19 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
20 %ifarch %{x8664}
21 %define         with_epoll      1
22 %endif
23 %else
24 %bcond_without  epoll           # disable epoll support
25 %endif
26
27 %define         ver     9.11.0b3
28 %if 0
29 %define         pverdot .P2
30 %define         pverdir -P2
31 %else
32 %define         pverdot %{nil}
33 %define         pverdir %{nil}
34 %endif
35 Summary:        BIND - DNS name server
36 Summary(de.UTF-8):      BIND - DNS-Namenserver
37 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
38 Summary(fr.UTF-8):      BIND - serveur de noms DNS
39 Summary(pl.UTF-8):      BIND - serwer nazw DNS
40 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
41 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
42 Summary(tr.UTF-8):      DNS alan adı sunucusu
43 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
44 Summary(zh_CN.UTF-8):   Internet 域名服务器
45 Name:           bind
46 Version:        %{ver}%{pverdot}
47 Release:        0.1
48 Epoch:          7
49 License:        BSD-like
50 Group:          Networking/Daemons
51 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
52 # Source0-md5:  7a9bdcb0bd832a0e9a633b951f5af664
53 Source1:        named.init
54 Source2:        named.sysconfig
55 Source3:        named.logrotate
56 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
57 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
58 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
59 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
60 Source6:        %{name}-hip.tar.gz
61 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
62 Source7:        ftp://rs.internic.net/domain/root.zone
63 # Source7-md5:  83be6717681dcf7c74cfb7831553592f
64 Source8:        %{name}-127.0.0.zone
65 Source9:        %{name}-localhost.zone
66 Source10:       %{name}-named.conf
67 Source11:       %{name}.tmpfiles
68 Source12:       named.service
69 Patch0:         %{name}-time.patch
70 Patch1:         %{name}-link.patch
71 Patch2:         %{name}-pmake.patch
72 Patch3:         %{name}-sdb-ldap.patch
73 Patch4:         %{name}-ac-libs.patch
74 Patch5:         %{name}-edns-client-subnet.patch
75 Patch6:         nsupdate_segfault.patch
76 URL:            https://www.isc.org/software/bind
77 BuildRequires:  autoconf >= 2.59
78 BuildRequires:  automake
79 BuildRequires:  bison
80 BuildRequires:  flex
81 %{?with_kerberos5:BuildRequires:        heimdal-devel}
82 BuildRequires:  idnkit-devel
83 %{?with_seccomp:BuildRequires:  libseccomp-devel}
84 BuildRequires:  libtool
85 %{?with_hip:BuildRequires:      libxml2-devel}
86 %{?with_sql:BuildRequires:      mysql-devel}
87 %{?with_ldap:BuildRequires:     openldap-devel}
88 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
89 %{?with_sql:BuildRequires:      postgresql-devel}
90 BuildRequires:  python3-devel
91 BuildRequires:  python3-ply
92 BuildRequires:  readline-devel
93 BuildRequires:  rpm >= 4.4.9-56
94 BuildRequires:  rpmbuild(macros) >= 1.647
95 %{?with_sql:BuildRequires:      unixODBC-devel}
96 Requires(post,preun):   /sbin/chkconfig
97 Requires(postun):       /usr/sbin/groupdel
98 Requires(postun):       /usr/sbin/userdel
99 Requires(pre):  /bin/id
100 Requires(pre):  /usr/bin/getgid
101 Requires(pre):  /usr/sbin/groupadd
102 Requires(pre):  /usr/sbin/useradd
103 Requires(pre):  fileutils
104 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
105 Requires:       psmisc >= 20.1
106 Requires:       rc-scripts >= 0.2.0
107 Requires:       systemd-units >= 38
108 Requires:       uname(release) >= 2.2.18
109 Provides:       group(named)
110 Provides:       nameserver
111 Provides:       user(named)
112 Obsoletes:      caching-nameserver
113 Conflicts:      %{name}-chroot
114 Conflicts:      logrotate < 3.8.0
115 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
116
117 %define         schemadir       /usr/share/openldap/schema
118
119 %description
120 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
121 (Domain Name System) protocols. BIND includes a DNS server (named),
122 which resolves host names to IP addresses, and a resolver library
123 (routines for applications to use when interfacing with DNS). A DNS
124 server allows clients to name resources or objects and share the
125 information with other network machines. The named DNS server can be
126 used on workstations as a caching name server, but is generally only
127 needed on one machine for an entire network. Note that the
128 configuration files for making BIND act as a simple caching nameserver
129 are included in the caching-nameserver package.
130
131 Install the bind package if you need a DNS server for your network. If
132 you want bind to act a caching name server, you will also need to
133 install the caching-nameserver package.
134
135 %description -l de.UTF-8
136 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
137 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
138 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
139 Recher des Netzwerks erforderlich.
140
141 %description -l es.UTF-8
142 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
143 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
144 un servidor de nombres caché, pero generalmente sólo hace falta en una
145 máquina para toda la red.
146
147 %description -l fr.UTF-8
148 Contient le serveur de noms named, utilisé pour définir les
149 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
150 utilisé sur les stations de travail comme serveur de nom en cache mais
151 n'est souvent nécessaire que sur une machine pour un réseau entier.
152
153 %description -l pl.UTF-8
154 Pakiet ten zawiera demona named, który służy do zmieniania nazw
155 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
156 roboczych jako bufor odwołań do serwisu nazw (caching name server),
157 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
158 program na fragment sieci.
159
160 %description -l pt_BR.UTF-8
161 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
162 IP (e vice-versa). Pode ser usado em estações de trabalho como um
163 servidor de nomes cache, mas geralmente só é necessário em uma máquina
164 para toda a rede.
165
166 %description -l ru.UTF-8
167 BIND (Berkeley Internet Name Domain) является реализацией протоколов
168 DNS (Domain Name System). BIND включает DNS сервер (named) и
169 библиотеку "резолвера" (подпрограммы для приложений, через которые
170 происходят обращения к DNS). DNS сервер named может быть использован
171 на рабочих станциях как кеширующий сервер, но обычно запускается на
172 одной машине в локальной сети и используется остальными машинами (этим
173 достигается намного более эффективное кеширование).
174
175 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
176 кеширующего сервера, включены в пакет caching-nameserver.
177
178 %description -l tr.UTF-8
179 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
180 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
181 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
182 için sadece bir makina üzerinde kurulur.
183
184 %description -l uk.UTF-8
185 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
186 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
187 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
188 сервер named може бути використаний на робочих станціях як кешируючий
189 сервер, але звичайно запускається на одній машині в локальній мережі і
190 використовується іншими (цим досягається більша ефективність
191 використання кешу).
192
193 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
194 кешируючого серверу, включені в пакет caching-nameserver.
195
196 %package utils
197 Summary:        DNS utils - host, dig, dnsquery, nslookup
198 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
199 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
200 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
201 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
202 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
203 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
204 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
205 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
206 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
207 Group:          Networking/Utilities
208 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
209 Requires:       iconv
210
211 %description utils
212 Bind-utils contains a collection of utilities for querying DNS (Domain
213 Name Service) name servers to find out information about Internet
214 hosts. These tools will provide you with the IP addresses for given
215 host names, as well as other information about registered domains and
216 network addresses.
217
218 You should install bind-utils if you need to get information from DNS
219 name servers.
220
221 %description utils -l de.UTF-8
222 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
223 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
224 Informationen über registrierte Domains und Netzwerk-Adressen.
225
226 %description utils -l es.UTF-8
227 Conjunto de utilitarios para consulta a servidores de nombres. Estas
228 herramientas permiten la determinación de direcciones IP para nombres
229 de máquinas informados y busca información sobre dominios registrados
230 y direcciones de red.
231
232 %description utils -l fr.UTF-8
233 Ensemble d'utilitaires pour interroger les serveurs de noms et
234 rechercher des hôtes. Ces outils vous permettent de déterminer les
235 adresses IP pour des noms d'hôtes donnés, et trouver des informations
236 sur les noms de domaine déclarés et les adresses réseau.
237
238 %description utils -l pl.UTF-8
239 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
240 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
241 i ich adresach IP.
242
243 %description utils -l pt_BR.UTF-8
244 Conjunto de utilitários para consulta a servidores DNS. Estas
245 ferramentas permitem a determinação de endereços IP para nomes de
246 máquinas informados e busca informações sobre domínios registrados e
247 endereços de rede. Você deveria instalar este pacote se necessitar
248 obter informações de servidores DNS.
249
250 %description utils -l ru.UTF-8
251 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
252 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
253 доменному имени (и наоборот) и другую информацию о зарегистрированных
254 доменах и сетевых адресах.
255
256 %description utils -l tr.UTF-8
257 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
258 için kullanılan araçlar bulunmaktadır.
259
260 %description utils -l uk.UTF-8
261 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
262 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
263 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
264 домени та адреси.
265
266 %package libs
267 Summary:        DNS libraries
268 Summary(pl.UTF-8):      Biblioteki DNS
269 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
270 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
271 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
272 Group:          Libraries
273
274 %description libs
275 The bind-libs package contains all libraries required for running BIND
276 and bind utils.
277
278 %description libs -l pl.UTF-8
279 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
280 lub programów z pakietu bind-utils.
281
282 %description libs -l ru.UTF-8
283 Библиотеки, необходимые для работы bind.
284
285 %description libs -l uk.UTF-8
286 Бібліотеки, необхідні для роботи bind.
287
288 %package devel
289 Summary:        DNS development includes
290 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
291 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
292 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
293 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
294 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
295 Group:          Development/Libraries
296 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
297
298 %description devel
299 The bind-devel package contains all the include files and symlinks
300 required for DNS (Domain Name Service) development for BIND.
301
302 You should install bind-devel if you want to develop bind DNS
303 applications. If you install bind-devel, you'll also need to install
304 bind-libs.
305
306 %description devel -l es.UTF-8
307 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
308 para el bind.
309
310 %description devel -l pl.UTF-8
311 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
312 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
313 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
314 pakiet.
315
316 %description devel -l pt_BR.UTF-8
317 Todos os arquivos de cabeçalho e bibliotecas necessários para o
318 desenvolvimento com o bind.
319
320 %description devel -l ru.UTF-8
321 Все хедеры и библиотеки, необходимые для написания программ с
322 использованием BIND 9.x.x.
323
324 %description devel -l uk.UTF-8
325 Всі хедери та бібліотеки, необхідні для розробки програм з
326 використанням BIND 9.x.x.
327
328 %package static
329 Summary:        DNS static libs
330 Summary(pl.UTF-8):      Biblioteki statyczne DNS
331 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
332 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
333 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
334 Group:          Development/Libraries
335 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
336
337 %description static
338 Static bind libraries.
339
340 %description static -l pl.UTF-8
341 Statyczne biblioteki binda.
342
343 %description static -l pt_BR.UTF-8
344 Bibliotecas estáticas para desenvolvimento DNS.
345
346 %description static -l ru.UTF-8
347 Статические библиотеки, необходимые для написания программ с
348 использованием BIND.
349
350 %description static -l uk.UTF-8
351 Статичні бібліотеки, необхідні для розробки програм з використанням
352 BIND.
353
354 %package -n openldap-schema-bind
355 Summary:        BIND schema for openldap
356 Summary(pl.UTF-8):      Schemat BIND dla openldap
357 Group:          Development/Libraries
358 Requires(post,postun):  sed >= 4.0
359 Requires:       openldap-servers
360 Requires:       sed >= 4.0
361 %if "%{_rpmversion}" >= "5"
362 BuildArch:      noarch
363 %endif
364
365 %description -n openldap-schema-bind
366 BIND schema for openldap.
367
368 %description -n openldap-schema-bind -l pl.UTF-8
369 Schemat BIND dla openldap.
370
371 %package -n python3-isc
372 Summary:        Python BIND module
373 Group:          Libraries/Python
374 Requires:       python3-modules
375
376 %description -n python3-isc
377 Python BIND module.
378
379 %prep
380 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
381 %patch0 -p1
382 %patch1 -p1
383 %patch2 -p1
384 %{?with_ldap:%patch3 -p1}
385 %patch4 -p1
386 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
387 %{?with_edns_cli:%patch5 -p0}
388 %patch6 -p0
389
390 %build
391 %{__libtoolize}
392 %{__aclocal}
393 %{__autoconf}
394 cp -f /usr/share/automake/config.* .
395 %configure \
396         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
397         --with-idn \
398         --with-libtool \
399         %{?with_ssl:--with-openssl} \
400         %{?with_ipv6:--enable-ipv6} \
401         %{?with_kerberos5:--with-gssapi} \
402         %{?with_sql:--with-dlz-postgres=yes} \
403         %{?with_sql:--with-dlz-mysql=yes} \
404         --with-dlz-bdb=no \
405         --with-dlz-filesystem=yes \
406         %{?with_ldap:--with-dlz-ldap=yes} \
407         %{?with_geoip:--with-geoip=yes} \
408         --with-dlz-odbc=no \
409         --with-dlz-stub=yes \
410         --enable-largefile \
411         %{!?with_epoll:--disable-epoll --disable-devpoll} \
412         %{!?with_static_libs:--enable-static=no} \
413         --enable-threads \
414         --enable-getifaddrs \
415         --enable-full-report \
416         %{__enable_disable seccomp} \
417         --with-python=%{__python3}
418
419 %{__make}
420 %{?with_hip:cd bind-hip/; %{__make}}
421
422 %{?with_tests:%{__make} test-force}
423
424 %install
425 rm -rf $RPM_BUILD_ROOT
426 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
427         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
428         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}} \
429         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
430
431 %{__make} install \
432         DESTDIR=$RPM_BUILD_ROOT
433
434 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
435 rm $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
436 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
437 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
438
439 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
440 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
441 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
442 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
443 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
444 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
445 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
446 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
447 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
448 mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
449
450 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
451 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
452 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
453 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
454
455 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
456
457 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
458 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
459
460 %if %{with ldap}
461 install -d $RPM_BUILD_ROOT%{schemadir}
462 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
463 %endif
464
465 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
466
467 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
468 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
469
470 # let rpm generate deps (workaround -m644 used for libs installation)
471 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
472
473 # we don't want Makefiles in documentation...
474 rm -rf _doc
475 cp -a doc _doc
476 %{__rm} _doc/misc/Makefile*
477
478 %clean
479 rm -rf $RPM_BUILD_ROOT
480
481 %pre
482 if [ -f %{_sysconfdir}/named.boot ]; then
483         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
484         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
485         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
486 fi
487 %groupadd -g 58 named
488 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
489
490 %post
491 /sbin/chkconfig --add named
492 %service named restart
493 %systemd_post named.service
494
495 %preun
496 if [ "$1" = "0" ]; then
497         %service named stop
498         /sbin/chkconfig --del named
499 fi
500 %systemd_preun named.service
501
502 %postun
503 if [ "$1" = "0" ]; then
504         %userremove named
505         %groupremove named
506 fi
507 %systemd_reload
508
509 %post   libs -p /sbin/ldconfig
510 %postun libs -p /sbin/ldconfig
511
512 %post -n openldap-schema-bind
513 %openldap_schema_register %{schemadir}/dnszone.schema
514 %service -q ldap restart
515
516 %postun -n openldap-schema-bind
517 if [ "$1" = "0" ]; then
518         %openldap_schema_unregister %{schemadir}/dnszone.schema
519         %service -q ldap restart
520 fi
521
522 %triggerpostun -- %{name} < 7:9.4.2-2
523 /sbin/chkconfig named reset
524 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
525 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
526 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
527
528 %triggerpostun -- %{name} < 7:9.9.2.P2-2
529 %systemd_trigger named.service
530
531 %files
532 %defattr(644,root,root,755)
533 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
534 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
535
536 %{systemdunitdir}/named.service
537 %attr(754,root,root) /etc/rc.d/init.d/named
538 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
539 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
540 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
541 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
542
543 %attr(755,root,root) %{_sbindir}/ddns-confgen
544 %attr(755,root,root) %{_sbindir}/dnssec-*
545 %attr(755,root,root) %{_sbindir}/genrandom
546 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
547 %attr(755,root,root) %{_sbindir}/lwresd
548 %attr(755,root,root) %{_sbindir}/named
549 %attr(755,root,root) %{_sbindir}/named-*
550 %attr(755,root,root) %{_sbindir}/nsec3hash
551 %attr(755,root,root) %{_sbindir}/rndc
552 %attr(755,root,root) %{_sbindir}/rndc-confgen
553 %attr(755,root,root) %{_sbindir}/tsig-keygen
554
555 %{_mandir}/man5/named.conf.5*
556 %{_mandir}/man5/rndc.conf.5*
557 %{_mandir}/man8/ddns-confgen.8*
558 %{_mandir}/man8/dnssec-*.8*
559 %{_mandir}/man8/genrandom.8*
560 %{_mandir}/man8/isc-hmac-fixup.8*
561 %{_mandir}/man8/lwresd.8*
562 %{_mandir}/man8/named.8*
563 %{_mandir}/man8/named-*.8*
564 %{_mandir}/man8/nsec3hash.8*
565 %{_mandir}/man8/rndc.8*
566 %{_mandir}/man8/rndc-confgen.8*
567 %{_mandir}/man8/tsig-keygen.8*
568 %lang(ja) %{_mandir}/ja/man8/named*
569
570 %{systemdtmpfilesdir}/%{name}.conf
571
572 %attr(770,root,named) %dir %{_var}/lib/named
573 %attr(770,root,named) %dir %{_var}/lib/named/D
574 %attr(770,root,named) %dir %{_var}/lib/named/M
575 %attr(770,root,named) %dir %{_var}/lib/named/S
576 %attr(750,root,named) %dir %{_var}/lib/named/etc
577 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
578 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
579 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
580 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
581 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
582 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
583
584 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
585 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
586
587 %attr(770,root,named) %dir %{_var}/run/named
588 %attr(770,root,named) %dir %{_var}/run/lwresd
589
590 %files utils
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_bindir}/arpaname
593 %attr(755,root,root) %{_bindir}/delv
594 %attr(755,root,root) %{_bindir}/dig
595 %attr(755,root,root) %{_bindir}/host
596 %attr(755,root,root) %{_bindir}/named-rrchecker
597 %attr(755,root,root) %{_bindir}/mdig
598 %attr(755,root,root) %{_bindir}/nslookup
599 %attr(755,root,root) %{_bindir}/nsupdate
600 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
601 %{_mandir}/man1/arpaname.1*
602 %{_mandir}/man1/delv.1*
603 %{_mandir}/man1/dig.1*
604 %{_mandir}/man1/host.1*
605 %{_mandir}/man1/mdig.1*
606 %{_mandir}/man1/named-rrchecker.1*
607 %{_mandir}/man1/nslookup.1*
608 %{_mandir}/man1/nsupdate.1*
609
610 %lang(fi) %{_mandir}/fi/man1/host.1*
611
612 %lang(fr) %{_mandir}/fr/man1/host.1*
613
614 %lang(hu) %{_mandir}/hu/man1/host.1*
615
616 %lang(ja) %{_mandir}/ja/man1/dig.1*
617 %lang(ja) %{_mandir}/ja/man1/host.1*
618 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
619 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
620
621 %lang(pl) %{_mandir}/pl/man1/host.1*
622
623 %files libs
624 %defattr(644,root,root,755)
625 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
626 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.160
627 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
628 %attr(755,root,root) %ghost %{_libdir}/libdns.so.165
629 %attr(755,root,root) %{_libdir}/libirs.so.*.*.*
630 %attr(755,root,root) %ghost %{_libdir}/libirs.so.160
631 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
632 %attr(755,root,root) %ghost %{_libdir}/libisc.so.160
633 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
634 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.160
635 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
636 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.160
637 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
638 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.160
639
640 %files devel
641 %defattr(644,root,root,755)
642 %attr(755,root,root) %{_bindir}/bind9-config
643 %attr(755,root,root) %{_bindir}/isc-config.sh
644 %attr(755,root,root) %{_libdir}/libbind9.so
645 %attr(755,root,root) %{_libdir}/libdns.so
646 %attr(755,root,root) %{_libdir}/libirs.so
647 %attr(755,root,root) %{_libdir}/libisc.so
648 %attr(755,root,root) %{_libdir}/libisccc.so
649 %attr(755,root,root) %{_libdir}/libisccfg.so
650 %attr(755,root,root) %{_libdir}/liblwres.so
651 %{_libdir}/libbind9.la
652 %{_libdir}/libdns.la
653 %{_libdir}/libirs.la
654 %{_libdir}/libisc.la
655 %{_libdir}/libisccc.la
656 %{_libdir}/libisccfg.la
657 %{_libdir}/liblwres.la
658 %{_includedir}/bind9
659 %{_includedir}/dns
660 %{_includedir}/dst
661 %{_includedir}/irs
662 %{_includedir}/isc
663 %{_includedir}/isccc
664 %{_includedir}/isccfg
665 %{_includedir}/lwres
666 %{_includedir}/pk11
667 %{_includedir}/pkcs11
668 %{_mandir}/man1/bind9-config.1*
669 %{_mandir}/man1/isc-config.sh.1*
670 %{_mandir}/man3/lwres*.3*
671
672 %if %{with static_libs}
673 %files static
674 %defattr(644,root,root,755)
675 %{_libdir}/libbind9.a
676 %{_libdir}/libdns.a
677 %{_libdir}/libirs.a
678 %{_libdir}/libisc.a
679 %{_libdir}/libisccc.a
680 %{_libdir}/libisccfg.a
681 %{_libdir}/liblwres.a
682 %endif
683
684 %if %{with ldap}
685 %files -n openldap-schema-bind
686 %defattr(644,root,root,755)
687 %{_datadir}/openldap/schema/dnszone.schema
688 %endif
689
690 %files -n python3-isc
691 %defattr(644,root,root,755)
692 %{py3_sitedir}/isc
693 %{py3_sitedir}/isc-*-py*.egg-info
This page took 0.138523 seconds and 4 git commands to generate.