]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- fix /usr/lib pollution
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with     hip             # build with HIP RR support
13 %if "%{pld_release}" == "ac"
14 %bcond_with             epoll           # enable epoll support
15 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
16 %ifarch %{x8664}
17 %define         with_epoll      1
18 %endif
19 %else
20 %bcond_without  epoll           # disable epoll support
21 %endif
22
23 %define         ver     9.8.0
24 %if 1
25 %define         pverdot .P4
26 %define         pverdir -P4
27 %else
28 %define         pverdot %{nil}
29 %define         pverdir %{nil}
30 %endif
31 Summary:        BIND - DNS name server
32 Summary(de.UTF-8):      BIND - DNS-Namenserver
33 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
34 Summary(fr.UTF-8):      BIND - serveur de noms DNS
35 Summary(pl.UTF-8):      BIND - serwer nazw DNS
36 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
37 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
38 Summary(tr.UTF-8):      DNS alan adı sunucusu
39 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
40 Summary(zh_CN.UTF-8):   Internet 域名服务器
41 Name:           bind
42 Version:        %{ver}%{pverdot}
43 Release:        3.1
44 Epoch:          7
45 License:        BSD-like
46 Group:          Networking/Daemons
47 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
48 # Source0-md5:  13e36e3f28dc1ce7675b45a4192e8389
49 Source1:        named.init
50 Source2:        named.sysconfig
51 Source3:        named.logrotate
52 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
53 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
54 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
55 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
56 Source6:        %{name}-hip.tar.gz
57 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
58 Source7:        ftp://rs.internic.net/domain/named.root
59 # Source7-md5:  013336e29e65923682f7bce094bb3e5c
60 Source8:        %{name}-127.0.0.zone
61 Source9:        %{name}-localhost.zone
62 Source10:       %{name}-named.conf
63 Patch0:         %{name}-time.patch
64 Patch1:         %{name}-link.patch
65 Patch2:         %{name}-pmake.patch
66 Patch3:         %{name}-sdb-ldap.patch
67 Patch4:         %{name}-ac-libs.patch
68 URL:            https://www.isc.org/software/bind
69 BuildRequires:  autoconf
70 BuildRequires:  automake
71 BuildRequires:  bison
72 BuildRequires:  flex
73 %{?with_kerberos5:BuildRequires:        heimdal-devel}
74 BuildRequires:  idnkit-devel
75 BuildRequires:  libtool
76 %{?with_hip:BuildRequires:      libxml2-devel}
77 %{?with_sql:BuildRequires:      mysql-devel}
78 %{?with_ldap:BuildRequires:     openldap-devel}
79 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7d}
80 %{?with_sql:BuildRequires:      postgresql-devel}
81 BuildRequires:  rpm >= 4.4.9-56
82 BuildRequires:  rpmbuild(macros) >= 1.268
83 %{?with_sql:BuildRequires:      unixODBC-devel}
84 Requires(post,preun):   /sbin/chkconfig
85 Requires(postun):       /usr/sbin/groupdel
86 Requires(postun):       /usr/sbin/userdel
87 Requires(pre):  /bin/id
88 Requires(pre):  /usr/bin/getgid
89 Requires(pre):  /usr/sbin/groupadd
90 Requires(pre):  /usr/sbin/useradd
91 Requires(pre):  fileutils
92 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
93 Requires:       psmisc >= 20.1
94 Requires:       rc-scripts >= 0.2.0
95 Provides:       group(named)
96 Provides:       nameserver
97 Provides:       user(named)
98 Obsoletes:      caching-nameserver
99 Conflicts:      %{name}-chroot
100 Conflicts:      kernel < 2.2.18
101 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103 %define         schemadir       /usr/share/openldap/schema
104
105 %description
106 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
107 (Domain Name System) protocols. BIND includes a DNS server (named),
108 which resolves host names to IP addresses, and a resolver library
109 (routines for applications to use when interfacing with DNS). A DNS
110 server allows clients to name resources or objects and share the
111 information with other network machines. The named DNS server can be
112 used on workstations as a caching name server, but is generally only
113 needed on one machine for an entire network. Note that the
114 configuration files for making BIND act as a simple caching nameserver
115 are included in the caching-nameserver package.
116
117 Install the bind package if you need a DNS server for your network. If
118 you want bind to act a caching name server, you will also need to
119 install the caching-nameserver package.
120
121 %description -l de.UTF-8
122 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
123 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
124 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
125 Recher des Netzwerks erforderlich.
126
127 %description -l es.UTF-8
128 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
129 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
130 un servidor de nombres caché, pero generalmente sólo hace falta en una
131 máquina para toda la red.
132
133 %description -l fr.UTF-8
134 Contient le serveur de noms named, utilisé pour définir les
135 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
136 utilisé sur les stations de travail comme serveur de nom en cache mais
137 n'est souvent nécessaire que sur une machine pour un réseau entier.
138
139 %description -l pl.UTF-8
140 Pakiet ten zawiera demona named, który służy do zmieniania nazw
141 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
142 roboczych jako bufor odwołań do serwisu nazw (caching name server),
143 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
144 program na fragment sieci.
145
146 %description -l pt_BR.UTF-8
147 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
148 IP (e vice-versa). Pode ser usado em estações de trabalho como um
149 servidor de nomes cache, mas geralmente só é necessário em uma máquina
150 para toda a rede.
151
152 %description -l ru.UTF-8
153 BIND (Berkeley Internet Name Domain) является реализацией протоколов
154 DNS (Domain Name System). BIND включает DNS сервер (named) и
155 библиотеку "резолвера" (подпрограммы для приложений, через которые
156 происходят обращения к DNS). DNS сервер named может быть использован
157 на рабочих станциях как кеширующий сервер, но обычно запускается на
158 одной машине в локальной сети и используется остальными машинами (этим
159 достигается намного более эффективное кеширование).
160
161 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
162 кеширующего сервера, включены в пакет caching-nameserver.
163
164 %description -l tr.UTF-8
165 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
166 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
167 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
168 için sadece bir makina üzerinde kurulur.
169
170 %description -l uk.UTF-8
171 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
172 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
173 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
174 сервер named може бути використаний на робочих станціях як кешируючий
175 сервер, але звичайно запускається на одній машині в локальній мережі і
176 використовується іншими (цим досягається більша ефективність
177 використання кешу).
178
179 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
180 кешируючого серверу, включені в пакет caching-nameserver.
181
182 %package utils
183 Summary:        DNS utils - host, dig, dnsquery, nslookup
184 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
185 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
186 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
187 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
188 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
189 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
190 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
191 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
192 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
193 Group:          Networking/Utilities
194 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
195 Requires:       iconv
196
197 %description utils
198 Bind-utils contains a collection of utilities for querying DNS (Domain
199 Name Service) name servers to find out information about Internet
200 hosts. These tools will provide you with the IP addresses for given
201 host names, as well as other information about registered domains and
202 network addresses.
203
204 You should install bind-utils if you need to get information from DNS
205 name servers.
206
207 %description utils -l de.UTF-8
208 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
209 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
210 Informationen über registrierte Domains und Netzwerk-Adressen.
211
212 %description utils -l es.UTF-8
213 Conjunto de utilitarios para consulta a servidores de nombres. Estas
214 herramientas permiten la determinación de direcciones IP para nombres
215 de máquinas informados y busca información sobre dominios registrados
216 y direcciones de red.
217
218 %description utils -l fr.UTF-8
219 Ensemble d'utilitaires pour interroger les serveurs de noms et
220 rechercher des hôtes. Ces outils vous permettent de déterminer les
221 adresses IP pour des noms d'hôtes donnés, et trouver des informations
222 sur les noms de domaine déclarés et les adresses réseau.
223
224 %description utils -l pl.UTF-8
225 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
226 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
227 i ich adresach IP.
228
229 %description utils -l pt_BR.UTF-8
230 Conjunto de utilitários para consulta a servidores DNS. Estas
231 ferramentas permitem a determinação de endereços IP para nomes de
232 máquinas informados e busca informações sobre domínios registrados e
233 endereços de rede. Você deveria instalar este pacote se necessitar
234 obter informações de servidores DNS.
235
236 %description utils -l ru.UTF-8
237 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
238 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
239 доменному имени (и наоборот) и другую информацию о зарегистрированных
240 доменах и сетевых адресах.
241
242 %description utils -l tr.UTF-8
243 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
244 için kullanılan araçlar bulunmaktadır.
245
246 %description utils -l uk.UTF-8
247 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
248 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
249 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
250 домени та адреси.
251
252 %package libs
253 Summary:        DNS libraries
254 Summary(pl.UTF-8):      Biblioteki DNS
255 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
256 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
257 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
258 Group:          Libraries
259
260 %description libs
261 The bind-libs package contains all libraries required for running BIND
262 and bind utils.
263
264 %description libs -l pl.UTF-8
265 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
266 lub programów z pakietu bind-utils.
267
268 %description libs -l ru.UTF-8
269 Библиотеки, необходимые для работы bind.
270
271 %description libs -l uk.UTF-8
272 Бібліотеки, необхідні для роботи bind.
273
274 %package devel
275 Summary:        DNS development includes
276 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
277 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
278 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
279 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
280 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
281 Group:          Development/Libraries
282 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
283
284 %description devel
285 The bind-devel package contains all the include files and symlinks
286 required for DNS (Domain Name Service) development for BIND.
287
288 You should install bind-devel if you want to develop bind DNS
289 applications. If you install bind-devel, you'll also need to install
290 bind-libs.
291
292 %description devel -l es.UTF-8
293 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
294 para el bind.
295
296 %description devel -l pl.UTF-8
297 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
298 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
299 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
300 pakiet.
301
302 %description devel -l pt_BR.UTF-8
303 Todos os arquivos de cabeçalho e bibliotecas necessários para o
304 desenvolvimento com o bind.
305
306 %description devel -l ru.UTF-8
307 Все хедеры и библиотеки, необходимые для написания программ с
308 использованием BIND 9.x.x.
309
310 %description devel -l uk.UTF-8
311 Всі хедери та бібліотеки, необхідні для розробки програм з
312 використанням BIND 9.x.x.
313
314 %package static
315 Summary:        DNS static libs
316 Summary(pl.UTF-8):      Biblioteki statyczne DNS
317 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
318 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
319 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
320 Group:          Development/Libraries
321 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
322
323 %description static
324 Static bind libraries.
325
326 %description static -l pl.UTF-8
327 Statyczne biblioteki binda.
328
329 %description static -l pt_BR.UTF-8
330 Bibliotecas estáticas para desenvolvimento DNS.
331
332 %description static -l ru.UTF-8
333 Статические библиотеки, необходимые для написания программ с
334 использованием BIND.
335
336 %description static -l uk.UTF-8
337 Статичні бібліотеки, необхідні для розробки програм з використанням
338 BIND.
339
340 %package -n openldap-schema-bind
341 Summary:        BIND schema for openldap
342 Summary(pl.UTF-8):      Schemat BIND dla openldap
343 Group:          Development/Libraries
344 Requires(post,postun):  sed >= 4.0
345 Requires:       openldap-servers
346 Requires:       sed >= 4.0
347
348 %description -n openldap-schema-bind
349 BIND schema for openldap.
350
351 %description -n openldap-schema-bind -l pl.UTF-8
352 Schemat BIND dla openldap.
353
354 %prep
355 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
356 %patch0 -p1
357 %patch1 -p1
358 %patch2 -p1
359 %{?with_ldap:%patch3 -p1}
360 %patch4 -p1
361 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
362
363
364 %build
365 %{__libtoolize}
366 %{__aclocal}
367 %{__autoconf}
368 cp -f /usr/share/automake/config.* .
369 %configure \
370         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
371         --with-idn \
372         --with-libtool \
373         %{?with_ssl:--with-openssl} \
374         %{?with_ipv6:--enable-ipv6} \
375         %{?with_kerberos5:--with-gssapi} \
376         %{?with_sql:--with-dlz-postgres=yes} \
377         %{?with_sql:--with-dlz-mysql=yes} \
378         --with-dlz-bdb=no \
379         --with-dlz-filesystem=yes \
380         %{?with_ldap:--with-dlz-ldap=yes} \
381         --with-dlz-odbc=no \
382         --with-dlz-stub=yes \
383         --enable-largefile \
384         %{!?with_epoll:--disable-epoll --disable-devpoll} \
385         %{!?with_static_libs:--enable-static=no} \
386         --enable-threads \
387         --enable-getifaddrs
388
389 %{__make}
390 %{?with_hip:cd bind-hip/; %{__make}}
391
392 %{?with_tests:%{__make} test}
393
394 %install
395 rm -rf $RPM_BUILD_ROOT
396 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
397         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
398         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}}
399
400 %{__make} install \
401         DESTDIR=$RPM_BUILD_ROOT
402
403 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
404 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
405 %{__perl} -pi -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
406
407 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
408 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
409 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
410 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
411 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
412 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
413 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
414 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
415 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
416 mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
417
418 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
419 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
420 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
421 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
422
423 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
424
425 %if %{with ldap}
426 install -d $RPM_BUILD_ROOT%{schemadir}
427 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
428 %endif
429
430 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
431
432 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
433 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
434
435 # let rpm generate deps (workaround -m644 used for libs installation)
436 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
437
438 # we don't want Makefiles in documentation...
439 rm -rf _doc
440 cp -a doc _doc
441 rm -f _doc/rfc/rfc*
442 rm -f _doc/misc/Makefile*
443
444 %clean
445 rm -rf $RPM_BUILD_ROOT
446
447 %pre
448 if [ -f %{_sysconfdir}/named.boot ]; then
449         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
450         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
451         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
452 fi
453 %groupadd -g 58 named
454 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
455
456 %post
457 /sbin/chkconfig --add named
458 %service named restart
459
460 %preun
461 if [ "$1" = "0" ]; then
462         %service named stop
463         /sbin/chkconfig --del named
464 fi
465
466 %postun
467 if [ "$1" = "0" ]; then
468         %userremove named
469         %groupremove named
470 fi
471
472 %post   libs -p /sbin/ldconfig
473 %postun libs -p /sbin/ldconfig
474
475 %post -n openldap-schema-bind
476 %openldap_schema_register %{schemadir}/dnszone.schema
477 %service -q ldap restart
478
479 %postun -n openldap-schema-bind
480 if [ "$1" = "0" ]; then
481         %openldap_schema_unregister %{schemadir}/dnszone.schema
482         %service -q ldap restart
483 fi
484
485 %triggerpostun -- %{name} < 7:9.4.2-2
486 /sbin/chkconfig named reset
487 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
488 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
489 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
490
491 %files
492 %defattr(644,root,root,755)
493 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
494 %doc _doc/misc/* _doc/arm/*.html _doc/rfc/index %{?with_ldap:_doc/*.sdb-ldap}
495
496 %attr(754,root,root) /etc/rc.d/init.d/named
497 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
498 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
499 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
500 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
501
502 %attr(755,root,root) %{_sbindir}/arpaname
503 %attr(755,root,root) %{_sbindir}/ddns-confgen
504 %attr(755,root,root) %{_sbindir}/dnssec-*
505 %attr(755,root,root) %{_sbindir}/genrandom
506 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
507 %attr(755,root,root) %{_sbindir}/lwresd
508 %attr(755,root,root) %{_sbindir}/named
509 %attr(755,root,root) %{_sbindir}/named-*
510 %attr(755,root,root) %{_sbindir}/nsec3hash
511 %attr(755,root,root) %{_sbindir}/rndc
512 %attr(755,root,root) %{_sbindir}/rndc-confgen
513
514 %{_mandir}/man1/arpaname.1*
515 %{_mandir}/man5/named.conf.5*
516 %{_mandir}/man5/rndc.conf.5*
517 %{_mandir}/man8/ddns-confgen.8*
518 %{_mandir}/man8/dnssec-*.8*
519 %{_mandir}/man8/genrandom.8*
520 %{_mandir}/man8/isc-hmac-fixup.8*
521 %{_mandir}/man8/lwresd.8*
522 %{_mandir}/man8/named.8*
523 %{_mandir}/man8/named-*.8*
524 %{_mandir}/man8/nsec3hash.8*
525 %{_mandir}/man8/rndc.8*
526 %{_mandir}/man8/rndc-confgen.8*
527 %lang(ja) %{_mandir}/ja/man8/named*
528
529 %attr(770,root,named) %dir %{_var}/lib/named
530 %attr(770,root,named) %dir %{_var}/lib/named/D
531 %attr(750,root,named) %dir %{_var}/lib/named/M
532 %attr(770,root,named) %dir %{_var}/lib/named/S
533 %attr(750,root,named) %dir %{_var}/lib/named/etc
534 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
535 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
536 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
537 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
538 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
539 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
540
541 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
542 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
543
544 %attr(770,root,named) %dir %{_var}/run/named
545 %attr(770,root,named) %dir %{_var}/run/lwresd
546
547 %files utils
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_bindir}/dig
550 %attr(755,root,root) %{_bindir}/host
551 %attr(755,root,root) %{_bindir}/nslookup
552 %attr(755,root,root) %{_bindir}/nsupdate
553 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
554 %{_mandir}/man1/dig.1*
555 %{_mandir}/man1/host.1*
556 %{_mandir}/man1/nslookup.1*
557 %{_mandir}/man1/nsupdate.1*
558
559 %lang(fi) %{_mandir}/fi/man1/host.1*
560
561 %lang(fr) %{_mandir}/fr/man1/host.1*
562
563 %lang(hu) %{_mandir}/hu/man1/host.1*
564
565 %lang(ja) %{_mandir}/ja/man1/dig.1*
566 %lang(ja) %{_mandir}/ja/man1/host.1*
567 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
568 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
569
570 %lang(pl) %{_mandir}/pl/man1/host.1*
571
572 %files libs
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
575 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.[0-9][0-9]
576 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
577 %attr(755,root,root) %ghost %{_libdir}/libdns.so.[0-9][0-9]
578 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
579 %attr(755,root,root) %ghost %{_libdir}/libisc.so.[0-9][0-9]
580 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
581 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.[0-9][0-9]
582 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
583 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.[0-9][0-9]
584 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
585 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.[0-9][0-9]
586
587 %files devel
588 %defattr(644,root,root,755)
589 %attr(755,root,root) %{_bindir}/isc-config.sh
590 %attr(755,root,root) %{_libdir}/libbind9.so
591 %attr(755,root,root) %{_libdir}/libdns.so
592 %attr(755,root,root) %{_libdir}/libisc.so
593 %attr(755,root,root) %{_libdir}/libisccc.so
594 %attr(755,root,root) %{_libdir}/libisccfg.so
595 %attr(755,root,root) %{_libdir}/liblwres.so
596 %{_libdir}/libbind9.la
597 %{_libdir}/libdns.la
598 %{_libdir}/libisc.la
599 %{_libdir}/libisccc.la
600 %{_libdir}/libisccfg.la
601 %{_libdir}/liblwres.la
602 %{_includedir}/bind9
603 %{_includedir}/dns
604 %{_includedir}/dst
605 %{_includedir}/isc
606 %{_includedir}/isccc
607 %{_includedir}/isccfg
608 %{_includedir}/lwres
609 %{_mandir}/man1/isc-config.sh.1*
610 %{_mandir}/man3/lwres*.3*
611
612 %if %{with static_libs}
613 %files static
614 %defattr(644,root,root,755)
615 %{_libdir}/libbind9.a
616 %{_libdir}/libdns.a
617 %{_libdir}/libisc.a
618 %{_libdir}/libisccc.a
619 %{_libdir}/libisccfg.a
620 %{_libdir}/liblwres.a
621 %endif
622
623 %if %{with ldap}
624 %files -n openldap-schema-bind
625 %defattr(644,root,root,755)
626 %{_datadir}/openldap/schema/dnszone.schema
627 %endif
This page took 0.075825 seconds and 4 git commands to generate.