]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- updated ac,openssl versions (openssl 0.9.8d+ or 0.9.7l+ required)
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with edns_cli            # build with the ability to use edns-client-subnet in dig
13 %bcond_with     hip             # build with HIP RR support
14 %if "%{pld_release}" == "ac"
15 %bcond_with             epoll           # enable epoll support
16 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
17 %ifarch %{x8664}
18 %define         with_epoll      1
19 %endif
20 %else
21 %bcond_without  epoll           # disable epoll support
22 %endif
23
24 %define         ver     9.8.1
25 %if 1
26 %define         pverdot .P1
27 %define         pverdir -P1
28 %else
29 %define         pverdot %{nil}
30 %define         pverdir %{nil}
31 %endif
32 Summary:        BIND - DNS name server
33 Summary(de.UTF-8):      BIND - DNS-Namenserver
34 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
35 Summary(fr.UTF-8):      BIND - serveur de noms DNS
36 Summary(pl.UTF-8):      BIND - serwer nazw DNS
37 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
38 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
39 Summary(tr.UTF-8):      DNS alan adı sunucusu
40 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
41 Summary(zh_CN.UTF-8):   Internet 域名服务器
42 Name:           bind
43 Version:        %{ver}%{pverdot}
44 Release:        1
45 Epoch:          7
46 License:        BSD-like
47 Group:          Networking/Daemons
48 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
49 # Source0-md5:  afa41f8203d50bedad65071f9b6f96d7
50 Source1:        named.init
51 Source2:        named.sysconfig
52 Source3:        named.logrotate
53 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
54 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
55 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
56 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
57 Source6:        %{name}-hip.tar.gz
58 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
59 Source7:        ftp://rs.internic.net/domain/named.root
60 # Source7-md5:  013336e29e65923682f7bce094bb3e5c
61 Source8:        %{name}-127.0.0.zone
62 Source9:        %{name}-localhost.zone
63 Source10:       %{name}-named.conf
64 Patch0:         %{name}-time.patch
65 Patch1:         %{name}-link.patch
66 Patch2:         %{name}-pmake.patch
67 Patch3:         %{name}-sdb-ldap.patch
68 Patch4:         %{name}-ac-libs.patch
69 Patch5:         %{name}-edns-client-subnet.patch
70 URL:            https://www.isc.org/software/bind
71 BuildRequires:  autoconf >= 2.59
72 BuildRequires:  automake
73 BuildRequires:  bison
74 BuildRequires:  flex
75 %{?with_kerberos5:BuildRequires:        heimdal-devel}
76 BuildRequires:  idnkit-devel
77 BuildRequires:  libtool
78 %{?with_hip:BuildRequires:      libxml2-devel}
79 %{?with_sql:BuildRequires:      mysql-devel}
80 %{?with_ldap:BuildRequires:     openldap-devel}
81 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
82 %{?with_sql:BuildRequires:      postgresql-devel}
83 BuildRequires:  rpm >= 4.4.9-56
84 BuildRequires:  rpmbuild(macros) >= 1.268
85 %{?with_sql:BuildRequires:      unixODBC-devel}
86 Requires(post,preun):   /sbin/chkconfig
87 Requires(postun):       /usr/sbin/groupdel
88 Requires(postun):       /usr/sbin/userdel
89 Requires(pre):  /bin/id
90 Requires(pre):  /usr/bin/getgid
91 Requires(pre):  /usr/sbin/groupadd
92 Requires(pre):  /usr/sbin/useradd
93 Requires(pre):  fileutils
94 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
95 Requires:       psmisc >= 20.1
96 Requires:       rc-scripts >= 0.2.0
97 Provides:       group(named)
98 Provides:       nameserver
99 Provides:       user(named)
100 Obsoletes:      caching-nameserver
101 Conflicts:      %{name}-chroot
102 Conflicts:      kernel < 2.2.18
103 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
104
105 %define         schemadir       /usr/share/openldap/schema
106
107 %description
108 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
109 (Domain Name System) protocols. BIND includes a DNS server (named),
110 which resolves host names to IP addresses, and a resolver library
111 (routines for applications to use when interfacing with DNS). A DNS
112 server allows clients to name resources or objects and share the
113 information with other network machines. The named DNS server can be
114 used on workstations as a caching name server, but is generally only
115 needed on one machine for an entire network. Note that the
116 configuration files for making BIND act as a simple caching nameserver
117 are included in the caching-nameserver package.
118
119 Install the bind package if you need a DNS server for your network. If
120 you want bind to act a caching name server, you will also need to
121 install the caching-nameserver package.
122
123 %description -l de.UTF-8
124 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
125 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
126 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
127 Recher des Netzwerks erforderlich.
128
129 %description -l es.UTF-8
130 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
131 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
132 un servidor de nombres caché, pero generalmente sólo hace falta en una
133 máquina para toda la red.
134
135 %description -l fr.UTF-8
136 Contient le serveur de noms named, utilisé pour définir les
137 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
138 utilisé sur les stations de travail comme serveur de nom en cache mais
139 n'est souvent nécessaire que sur une machine pour un réseau entier.
140
141 %description -l pl.UTF-8
142 Pakiet ten zawiera demona named, który służy do zmieniania nazw
143 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
144 roboczych jako bufor odwołań do serwisu nazw (caching name server),
145 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
146 program na fragment sieci.
147
148 %description -l pt_BR.UTF-8
149 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
150 IP (e vice-versa). Pode ser usado em estações de trabalho como um
151 servidor de nomes cache, mas geralmente só é necessário em uma máquina
152 para toda a rede.
153
154 %description -l ru.UTF-8
155 BIND (Berkeley Internet Name Domain) является реализацией протоколов
156 DNS (Domain Name System). BIND включает DNS сервер (named) и
157 библиотеку "резолвера" (подпрограммы для приложений, через которые
158 происходят обращения к DNS). DNS сервер named может быть использован
159 на рабочих станциях как кеширующий сервер, но обычно запускается на
160 одной машине в локальной сети и используется остальными машинами (этим
161 достигается намного более эффективное кеширование).
162
163 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
164 кеширующего сервера, включены в пакет caching-nameserver.
165
166 %description -l tr.UTF-8
167 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
168 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
169 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
170 için sadece bir makina üzerinde kurulur.
171
172 %description -l uk.UTF-8
173 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
174 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
175 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
176 сервер named може бути використаний на робочих станціях як кешируючий
177 сервер, але звичайно запускається на одній машині в локальній мережі і
178 використовується іншими (цим досягається більша ефективність
179 використання кешу).
180
181 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
182 кешируючого серверу, включені в пакет caching-nameserver.
183
184 %package utils
185 Summary:        DNS utils - host, dig, dnsquery, nslookup
186 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
187 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
188 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
189 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
190 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
191 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
192 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
193 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
194 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
195 Group:          Networking/Utilities
196 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
197 Requires:       iconv
198
199 %description utils
200 Bind-utils contains a collection of utilities for querying DNS (Domain
201 Name Service) name servers to find out information about Internet
202 hosts. These tools will provide you with the IP addresses for given
203 host names, as well as other information about registered domains and
204 network addresses.
205
206 You should install bind-utils if you need to get information from DNS
207 name servers.
208
209 %description utils -l de.UTF-8
210 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
211 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
212 Informationen über registrierte Domains und Netzwerk-Adressen.
213
214 %description utils -l es.UTF-8
215 Conjunto de utilitarios para consulta a servidores de nombres. Estas
216 herramientas permiten la determinación de direcciones IP para nombres
217 de máquinas informados y busca información sobre dominios registrados
218 y direcciones de red.
219
220 %description utils -l fr.UTF-8
221 Ensemble d'utilitaires pour interroger les serveurs de noms et
222 rechercher des hôtes. Ces outils vous permettent de déterminer les
223 adresses IP pour des noms d'hôtes donnés, et trouver des informations
224 sur les noms de domaine déclarés et les adresses réseau.
225
226 %description utils -l pl.UTF-8
227 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
228 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
229 i ich adresach IP.
230
231 %description utils -l pt_BR.UTF-8
232 Conjunto de utilitários para consulta a servidores DNS. Estas
233 ferramentas permitem a determinação de endereços IP para nomes de
234 máquinas informados e busca informações sobre domínios registrados e
235 endereços de rede. Você deveria instalar este pacote se necessitar
236 obter informações de servidores DNS.
237
238 %description utils -l ru.UTF-8
239 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
240 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
241 доменному имени (и наоборот) и другую информацию о зарегистрированных
242 доменах и сетевых адресах.
243
244 %description utils -l tr.UTF-8
245 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
246 için kullanılan araçlar bulunmaktadır.
247
248 %description utils -l uk.UTF-8
249 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
250 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
251 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
252 домени та адреси.
253
254 %package libs
255 Summary:        DNS libraries
256 Summary(pl.UTF-8):      Biblioteki DNS
257 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
258 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
259 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
260 Group:          Libraries
261
262 %description libs
263 The bind-libs package contains all libraries required for running BIND
264 and bind utils.
265
266 %description libs -l pl.UTF-8
267 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
268 lub programów z pakietu bind-utils.
269
270 %description libs -l ru.UTF-8
271 Библиотеки, необходимые для работы bind.
272
273 %description libs -l uk.UTF-8
274 Бібліотеки, необхідні для роботи bind.
275
276 %package devel
277 Summary:        DNS development includes
278 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
279 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
280 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
281 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
282 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
283 Group:          Development/Libraries
284 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
285
286 %description devel
287 The bind-devel package contains all the include files and symlinks
288 required for DNS (Domain Name Service) development for BIND.
289
290 You should install bind-devel if you want to develop bind DNS
291 applications. If you install bind-devel, you'll also need to install
292 bind-libs.
293
294 %description devel -l es.UTF-8
295 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
296 para el bind.
297
298 %description devel -l pl.UTF-8
299 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
300 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
301 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
302 pakiet.
303
304 %description devel -l pt_BR.UTF-8
305 Todos os arquivos de cabeçalho e bibliotecas necessários para o
306 desenvolvimento com o bind.
307
308 %description devel -l ru.UTF-8
309 Все хедеры и библиотеки, необходимые для написания программ с
310 использованием BIND 9.x.x.
311
312 %description devel -l uk.UTF-8
313 Всі хедери та бібліотеки, необхідні для розробки програм з
314 використанням BIND 9.x.x.
315
316 %package static
317 Summary:        DNS static libs
318 Summary(pl.UTF-8):      Biblioteki statyczne DNS
319 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
320 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
321 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
322 Group:          Development/Libraries
323 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
324
325 %description static
326 Static bind libraries.
327
328 %description static -l pl.UTF-8
329 Statyczne biblioteki binda.
330
331 %description static -l pt_BR.UTF-8
332 Bibliotecas estáticas para desenvolvimento DNS.
333
334 %description static -l ru.UTF-8
335 Статические библиотеки, необходимые для написания программ с
336 использованием BIND.
337
338 %description static -l uk.UTF-8
339 Статичні бібліотеки, необхідні для розробки програм з використанням
340 BIND.
341
342 %package -n openldap-schema-bind
343 Summary:        BIND schema for openldap
344 Summary(pl.UTF-8):      Schemat BIND dla openldap
345 Group:          Development/Libraries
346 Requires(post,postun):  sed >= 4.0
347 Requires:       openldap-servers
348 Requires:       sed >= 4.0
349
350 %description -n openldap-schema-bind
351 BIND schema for openldap.
352
353 %description -n openldap-schema-bind -l pl.UTF-8
354 Schemat BIND dla openldap.
355
356 %prep
357 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
358 %patch0 -p1
359 %patch1 -p1
360 %patch2 -p1
361 %{?with_ldap:%patch3 -p1}
362 %patch4 -p1
363 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
364
365 %{?with_edns_cli:%patch5 -p0}
366
367 %build
368 %{__libtoolize}
369 %{__aclocal}
370 %{__autoconf}
371 cp -f /usr/share/automake/config.* .
372 %configure \
373         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
374         --with-idn \
375         --with-libtool \
376         %{?with_ssl:--with-openssl} \
377         %{?with_ipv6:--enable-ipv6} \
378         %{?with_kerberos5:--with-gssapi} \
379         %{?with_sql:--with-dlz-postgres=yes} \
380         %{?with_sql:--with-dlz-mysql=yes} \
381         --with-dlz-bdb=no \
382         --with-dlz-filesystem=yes \
383         %{?with_ldap:--with-dlz-ldap=yes} \
384         --with-dlz-odbc=no \
385         --with-dlz-stub=yes \
386         --enable-largefile \
387         %{!?with_epoll:--disable-epoll --disable-devpoll} \
388         %{!?with_static_libs:--enable-static=no} \
389         --enable-threads \
390         --enable-getifaddrs
391
392 %{__make}
393 %{?with_hip:cd bind-hip/; %{__make}}
394
395 %{?with_tests:%{__make} test}
396
397 %install
398 rm -rf $RPM_BUILD_ROOT
399 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
400         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
401         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}}
402
403 %{__make} install \
404         DESTDIR=$RPM_BUILD_ROOT
405
406 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
407 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
408 %{__perl} -pi -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
409
410 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
411 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
412 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
413 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
414 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
415 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
416 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
417 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
418 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
419 mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
420
421 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
422 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
423 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
424 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
425
426 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
427
428 %if %{with ldap}
429 install -d $RPM_BUILD_ROOT%{schemadir}
430 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
431 %endif
432
433 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
434
435 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
436 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
437
438 # let rpm generate deps (workaround -m644 used for libs installation)
439 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
440
441 # we don't want Makefiles in documentation...
442 rm -rf _doc
443 cp -a doc _doc
444 rm -f _doc/rfc/rfc*
445 rm -f _doc/misc/Makefile*
446
447 %clean
448 rm -rf $RPM_BUILD_ROOT
449
450 %pre
451 if [ -f %{_sysconfdir}/named.boot ]; then
452         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
453         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
454         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
455 fi
456 %groupadd -g 58 named
457 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
458
459 %post
460 /sbin/chkconfig --add named
461 %service named restart
462
463 %preun
464 if [ "$1" = "0" ]; then
465         %service named stop
466         /sbin/chkconfig --del named
467 fi
468
469 %postun
470 if [ "$1" = "0" ]; then
471         %userremove named
472         %groupremove named
473 fi
474
475 %post   libs -p /sbin/ldconfig
476 %postun libs -p /sbin/ldconfig
477
478 %post -n openldap-schema-bind
479 %openldap_schema_register %{schemadir}/dnszone.schema
480 %service -q ldap restart
481
482 %postun -n openldap-schema-bind
483 if [ "$1" = "0" ]; then
484         %openldap_schema_unregister %{schemadir}/dnszone.schema
485         %service -q ldap restart
486 fi
487
488 %triggerpostun -- %{name} < 7:9.4.2-2
489 /sbin/chkconfig named reset
490 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
491 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
492 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
493
494 %files
495 %defattr(644,root,root,755)
496 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
497 %doc _doc/misc/* _doc/arm/*.html _doc/rfc/index %{?with_ldap:_doc/*.sdb-ldap}
498
499 %attr(754,root,root) /etc/rc.d/init.d/named
500 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
501 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
502 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
503 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
504
505 %attr(755,root,root) %{_sbindir}/arpaname
506 %attr(755,root,root) %{_sbindir}/ddns-confgen
507 %attr(755,root,root) %{_sbindir}/dnssec-*
508 %attr(755,root,root) %{_sbindir}/genrandom
509 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
510 %attr(755,root,root) %{_sbindir}/lwresd
511 %attr(755,root,root) %{_sbindir}/named
512 %attr(755,root,root) %{_sbindir}/named-*
513 %attr(755,root,root) %{_sbindir}/nsec3hash
514 %attr(755,root,root) %{_sbindir}/rndc
515 %attr(755,root,root) %{_sbindir}/rndc-confgen
516
517 %{_mandir}/man1/arpaname.1*
518 %{_mandir}/man5/named.conf.5*
519 %{_mandir}/man5/rndc.conf.5*
520 %{_mandir}/man8/ddns-confgen.8*
521 %{_mandir}/man8/dnssec-*.8*
522 %{_mandir}/man8/genrandom.8*
523 %{_mandir}/man8/isc-hmac-fixup.8*
524 %{_mandir}/man8/lwresd.8*
525 %{_mandir}/man8/named.8*
526 %{_mandir}/man8/named-*.8*
527 %{_mandir}/man8/nsec3hash.8*
528 %{_mandir}/man8/rndc.8*
529 %{_mandir}/man8/rndc-confgen.8*
530 %lang(ja) %{_mandir}/ja/man8/named*
531
532 %attr(770,root,named) %dir %{_var}/lib/named
533 %attr(770,root,named) %dir %{_var}/lib/named/D
534 %attr(750,root,named) %dir %{_var}/lib/named/M
535 %attr(770,root,named) %dir %{_var}/lib/named/S
536 %attr(750,root,named) %dir %{_var}/lib/named/etc
537 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
538 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
539 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
540 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
541 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
542 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
543
544 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
545 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
546
547 %attr(770,root,named) %dir %{_var}/run/named
548 %attr(770,root,named) %dir %{_var}/run/lwresd
549
550 %files utils
551 %defattr(644,root,root,755)
552 %attr(755,root,root) %{_bindir}/dig
553 %attr(755,root,root) %{_bindir}/host
554 %attr(755,root,root) %{_bindir}/nslookup
555 %attr(755,root,root) %{_bindir}/nsupdate
556 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
557 %{_mandir}/man1/dig.1*
558 %{_mandir}/man1/host.1*
559 %{_mandir}/man1/nslookup.1*
560 %{_mandir}/man1/nsupdate.1*
561
562 %lang(fi) %{_mandir}/fi/man1/host.1*
563
564 %lang(fr) %{_mandir}/fr/man1/host.1*
565
566 %lang(hu) %{_mandir}/hu/man1/host.1*
567
568 %lang(ja) %{_mandir}/ja/man1/dig.1*
569 %lang(ja) %{_mandir}/ja/man1/host.1*
570 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
571 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
572
573 %lang(pl) %{_mandir}/pl/man1/host.1*
574
575 %files libs
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
578 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.[0-9][0-9]
579 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
580 %attr(755,root,root) %ghost %{_libdir}/libdns.so.[0-9][0-9]
581 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
582 %attr(755,root,root) %ghost %{_libdir}/libisc.so.[0-9][0-9]
583 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
584 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.[0-9][0-9]
585 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
586 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.[0-9][0-9]
587 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
588 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.[0-9][0-9]
589
590 %files devel
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_bindir}/isc-config.sh
593 %attr(755,root,root) %{_libdir}/libbind9.so
594 %attr(755,root,root) %{_libdir}/libdns.so
595 %attr(755,root,root) %{_libdir}/libisc.so
596 %attr(755,root,root) %{_libdir}/libisccc.so
597 %attr(755,root,root) %{_libdir}/libisccfg.so
598 %attr(755,root,root) %{_libdir}/liblwres.so
599 %{_libdir}/libbind9.la
600 %{_libdir}/libdns.la
601 %{_libdir}/libisc.la
602 %{_libdir}/libisccc.la
603 %{_libdir}/libisccfg.la
604 %{_libdir}/liblwres.la
605 %{_includedir}/bind9
606 %{_includedir}/dns
607 %{_includedir}/dst
608 %{_includedir}/isc
609 %{_includedir}/isccc
610 %{_includedir}/isccfg
611 %{_includedir}/lwres
612 %{_mandir}/man1/isc-config.sh.1*
613 %{_mandir}/man3/lwres*.3*
614
615 %if %{with static_libs}
616 %files static
617 %defattr(644,root,root,755)
618 %{_libdir}/libbind9.a
619 %{_libdir}/libdns.a
620 %{_libdir}/libisc.a
621 %{_libdir}/libisccc.a
622 %{_libdir}/libisccfg.a
623 %{_libdir}/liblwres.a
624 %endif
625
626 %if %{with ldap}
627 %files -n openldap-schema-bind
628 %defattr(644,root,root,755)
629 %{_datadir}/openldap/schema/dnszone.schema
630 %endif
This page took 0.078099 seconds and 4 git commands to generate.