]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- rel 2; enable seccomp support
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with     edns_cli        # build with the ability to use edns-client-subnet in dig
13 %bcond_with     hip             # build with HIP RR support
14 %bcond_without  geoip           # build with GeoIP support
15
16 %if "%{pld_release}" == "ac"
17 %bcond_with     epoll           # enable epoll support
18 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
19 %ifarch %{x8664}
20 %define         with_epoll      1
21 %endif
22 %else
23 %bcond_without  epoll           # disable epoll support
24 %endif
25
26 %define         ver     9.10.1
27 %if 0
28 %define         pverdot .P2
29 %define         pverdir -P2
30 %else
31 %define         pverdot %{nil}
32 %define         pverdir %{nil}
33 %endif
34 Summary:        BIND - DNS name server
35 Summary(de.UTF-8):      BIND - DNS-Namenserver
36 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
37 Summary(fr.UTF-8):      BIND - serveur de noms DNS
38 Summary(pl.UTF-8):      BIND - serwer nazw DNS
39 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
40 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
41 Summary(tr.UTF-8):      DNS alan adı sunucusu
42 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
43 Summary(zh_CN.UTF-8):   Internet 域名服务器
44 Name:           bind
45 Version:        %{ver}%{pverdot}
46 Release:        2
47 Epoch:          7
48 License:        BSD-like
49 Group:          Networking/Daemons
50 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
51 # Source0-md5:  82a69faf01b569568d9233f2666e744d
52 Source1:        named.init
53 Source2:        named.sysconfig
54 Source3:        named.logrotate
55 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
56 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
57 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
58 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
59 Source6:        %{name}-hip.tar.gz
60 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
61 Source7:        ftp://rs.internic.net/domain/root.zone
62 # Source7-md5:  f6e19255972d0d584c629df560cd5f75
63 Source8:        %{name}-127.0.0.zone
64 Source9:        %{name}-localhost.zone
65 Source10:       %{name}-named.conf
66 Source11:       %{name}.tmpfiles
67 Source12:       named.service
68 Patch0:         %{name}-time.patch
69 Patch1:         %{name}-link.patch
70 Patch2:         %{name}-pmake.patch
71 Patch3:         %{name}-sdb-ldap.patch
72 Patch4:         %{name}-ac-libs.patch
73 Patch5:         %{name}-edns-client-subnet.patch
74 Patch6:         nsupdate_segfault.patch
75 URL:            https://www.isc.org/software/bind
76 BuildRequires:  autoconf >= 2.59
77 BuildRequires:  automake
78 BuildRequires:  bison
79 BuildRequires:  flex
80 %{?with_kerberos5:BuildRequires:        heimdal-devel}
81 BuildRequires:  idnkit-devel
82 BuildRequires:  libseccomp-devel
83 BuildRequires:  libtool
84 %{?with_hip:BuildRequires:      libxml2-devel}
85 %{?with_sql:BuildRequires:      mysql-devel}
86 %{?with_ldap:BuildRequires:     openldap-devel}
87 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
88 %{?with_sql:BuildRequires:      postgresql-devel}
89 BuildRequires:  readline-devel
90 BuildRequires:  rpm >= 4.4.9-56
91 BuildRequires:  rpmbuild(macros) >= 1.647
92 %{?with_sql:BuildRequires:      unixODBC-devel}
93 Requires(post,preun):   /sbin/chkconfig
94 Requires(postun):       /usr/sbin/groupdel
95 Requires(postun):       /usr/sbin/userdel
96 Requires(pre):  /bin/id
97 Requires(pre):  /usr/bin/getgid
98 Requires(pre):  /usr/sbin/groupadd
99 Requires(pre):  /usr/sbin/useradd
100 Requires(pre):  fileutils
101 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
102 Requires:       psmisc >= 20.1
103 Requires:       rc-scripts >= 0.2.0
104 Requires:       systemd-units >= 38
105 Requires:       uname(release) >= 2.2.18
106 Provides:       group(named)
107 Provides:       nameserver
108 Provides:       user(named)
109 Obsoletes:      caching-nameserver
110 Conflicts:      %{name}-chroot
111 Conflicts:      logrotate < 3.8.0
112 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
113
114 %define         schemadir       /usr/share/openldap/schema
115
116 %description
117 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
118 (Domain Name System) protocols. BIND includes a DNS server (named),
119 which resolves host names to IP addresses, and a resolver library
120 (routines for applications to use when interfacing with DNS). A DNS
121 server allows clients to name resources or objects and share the
122 information with other network machines. The named DNS server can be
123 used on workstations as a caching name server, but is generally only
124 needed on one machine for an entire network. Note that the
125 configuration files for making BIND act as a simple caching nameserver
126 are included in the caching-nameserver package.
127
128 Install the bind package if you need a DNS server for your network. If
129 you want bind to act a caching name server, you will also need to
130 install the caching-nameserver package.
131
132 %description -l de.UTF-8
133 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
134 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
135 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
136 Recher des Netzwerks erforderlich.
137
138 %description -l es.UTF-8
139 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
140 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
141 un servidor de nombres caché, pero generalmente sólo hace falta en una
142 máquina para toda la red.
143
144 %description -l fr.UTF-8
145 Contient le serveur de noms named, utilisé pour définir les
146 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
147 utilisé sur les stations de travail comme serveur de nom en cache mais
148 n'est souvent nécessaire que sur une machine pour un réseau entier.
149
150 %description -l pl.UTF-8
151 Pakiet ten zawiera demona named, który służy do zmieniania nazw
152 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
153 roboczych jako bufor odwołań do serwisu nazw (caching name server),
154 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
155 program na fragment sieci.
156
157 %description -l pt_BR.UTF-8
158 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
159 IP (e vice-versa). Pode ser usado em estações de trabalho como um
160 servidor de nomes cache, mas geralmente só é necessário em uma máquina
161 para toda a rede.
162
163 %description -l ru.UTF-8
164 BIND (Berkeley Internet Name Domain) является реализацией протоколов
165 DNS (Domain Name System). BIND включает DNS сервер (named) и
166 библиотеку "резолвера" (подпрограммы для приложений, через которые
167 происходят обращения к DNS). DNS сервер named может быть использован
168 на рабочих станциях как кеширующий сервер, но обычно запускается на
169 одной машине в локальной сети и используется остальными машинами (этим
170 достигается намного более эффективное кеширование).
171
172 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
173 кеширующего сервера, включены в пакет caching-nameserver.
174
175 %description -l tr.UTF-8
176 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
177 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
178 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
179 için sadece bir makina üzerinde kurulur.
180
181 %description -l uk.UTF-8
182 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
183 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
184 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
185 сервер named може бути використаний на робочих станціях як кешируючий
186 сервер, але звичайно запускається на одній машині в локальній мережі і
187 використовується іншими (цим досягається більша ефективність
188 використання кешу).
189
190 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
191 кешируючого серверу, включені в пакет caching-nameserver.
192
193 %package utils
194 Summary:        DNS utils - host, dig, dnsquery, nslookup
195 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
196 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
197 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
198 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
199 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
200 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
201 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
202 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
203 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
204 Group:          Networking/Utilities
205 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
206 Requires:       iconv
207
208 %description utils
209 Bind-utils contains a collection of utilities for querying DNS (Domain
210 Name Service) name servers to find out information about Internet
211 hosts. These tools will provide you with the IP addresses for given
212 host names, as well as other information about registered domains and
213 network addresses.
214
215 You should install bind-utils if you need to get information from DNS
216 name servers.
217
218 %description utils -l de.UTF-8
219 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
220 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
221 Informationen über registrierte Domains und Netzwerk-Adressen.
222
223 %description utils -l es.UTF-8
224 Conjunto de utilitarios para consulta a servidores de nombres. Estas
225 herramientas permiten la determinación de direcciones IP para nombres
226 de máquinas informados y busca información sobre dominios registrados
227 y direcciones de red.
228
229 %description utils -l fr.UTF-8
230 Ensemble d'utilitaires pour interroger les serveurs de noms et
231 rechercher des hôtes. Ces outils vous permettent de déterminer les
232 adresses IP pour des noms d'hôtes donnés, et trouver des informations
233 sur les noms de domaine déclarés et les adresses réseau.
234
235 %description utils -l pl.UTF-8
236 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
237 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
238 i ich adresach IP.
239
240 %description utils -l pt_BR.UTF-8
241 Conjunto de utilitários para consulta a servidores DNS. Estas
242 ferramentas permitem a determinação de endereços IP para nomes de
243 máquinas informados e busca informações sobre domínios registrados e
244 endereços de rede. Você deveria instalar este pacote se necessitar
245 obter informações de servidores DNS.
246
247 %description utils -l ru.UTF-8
248 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
249 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
250 доменному имени (и наоборот) и другую информацию о зарегистрированных
251 доменах и сетевых адресах.
252
253 %description utils -l tr.UTF-8
254 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
255 için kullanılan araçlar bulunmaktadır.
256
257 %description utils -l uk.UTF-8
258 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
259 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
260 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
261 домени та адреси.
262
263 %package libs
264 Summary:        DNS libraries
265 Summary(pl.UTF-8):      Biblioteki DNS
266 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
267 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
268 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
269 Group:          Libraries
270
271 %description libs
272 The bind-libs package contains all libraries required for running BIND
273 and bind utils.
274
275 %description libs -l pl.UTF-8
276 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
277 lub programów z pakietu bind-utils.
278
279 %description libs -l ru.UTF-8
280 Библиотеки, необходимые для работы bind.
281
282 %description libs -l uk.UTF-8
283 Бібліотеки, необхідні для роботи bind.
284
285 %package devel
286 Summary:        DNS development includes
287 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
288 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
289 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
290 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
291 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
292 Group:          Development/Libraries
293 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
294
295 %description devel
296 The bind-devel package contains all the include files and symlinks
297 required for DNS (Domain Name Service) development for BIND.
298
299 You should install bind-devel if you want to develop bind DNS
300 applications. If you install bind-devel, you'll also need to install
301 bind-libs.
302
303 %description devel -l es.UTF-8
304 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
305 para el bind.
306
307 %description devel -l pl.UTF-8
308 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
309 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
310 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
311 pakiet.
312
313 %description devel -l pt_BR.UTF-8
314 Todos os arquivos de cabeçalho e bibliotecas necessários para o
315 desenvolvimento com o bind.
316
317 %description devel -l ru.UTF-8
318 Все хедеры и библиотеки, необходимые для написания программ с
319 использованием BIND 9.x.x.
320
321 %description devel -l uk.UTF-8
322 Всі хедери та бібліотеки, необхідні для розробки програм з
323 використанням BIND 9.x.x.
324
325 %package static
326 Summary:        DNS static libs
327 Summary(pl.UTF-8):      Biblioteki statyczne DNS
328 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
329 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
330 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
331 Group:          Development/Libraries
332 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
333
334 %description static
335 Static bind libraries.
336
337 %description static -l pl.UTF-8
338 Statyczne biblioteki binda.
339
340 %description static -l pt_BR.UTF-8
341 Bibliotecas estáticas para desenvolvimento DNS.
342
343 %description static -l ru.UTF-8
344 Статические библиотеки, необходимые для написания программ с
345 использованием BIND.
346
347 %description static -l uk.UTF-8
348 Статичні бібліотеки, необхідні для розробки програм з використанням
349 BIND.
350
351 %package -n openldap-schema-bind
352 Summary:        BIND schema for openldap
353 Summary(pl.UTF-8):      Schemat BIND dla openldap
354 Group:          Development/Libraries
355 Requires(post,postun):  sed >= 4.0
356 Requires:       openldap-servers
357 Requires:       sed >= 4.0
358 %if "%{_rpmversion}" >= "5"
359 BuildArch:      noarch
360 %endif
361
362 %description -n openldap-schema-bind
363 BIND schema for openldap.
364
365 %description -n openldap-schema-bind -l pl.UTF-8
366 Schemat BIND dla openldap.
367
368 %prep
369 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
370 %patch0 -p1
371 %patch1 -p1
372 %patch2 -p1
373 %{?with_ldap:%patch3 -p1}
374 %patch4 -p1
375 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
376 %{?with_edns_cli:%patch5 -p0}
377 %patch6 -p0
378
379 %build
380 %{__libtoolize}
381 %{__aclocal}
382 %{__autoconf}
383 cp -f /usr/share/automake/config.* .
384 %configure \
385         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
386         --with-idn \
387         --with-libtool \
388         %{?with_ssl:--with-openssl} \
389         %{?with_ipv6:--enable-ipv6} \
390         %{?with_kerberos5:--with-gssapi} \
391         %{?with_sql:--with-dlz-postgres=yes} \
392         %{?with_sql:--with-dlz-mysql=yes} \
393         --with-dlz-bdb=no \
394         --with-dlz-filesystem=yes \
395         %{?with_ldap:--with-dlz-ldap=yes} \
396         %{?with_geoip:--with-geoip=yes} \
397         --with-dlz-odbc=no \
398         --with-dlz-stub=yes \
399         --enable-largefile \
400         %{!?with_epoll:--disable-epoll --disable-devpoll} \
401         %{!?with_static_libs:--enable-static=no} \
402         --enable-sit \
403         --enable-threads \
404         --enable-getifaddrs \
405         --enable-newstats \
406         --enable-full-report \
407         --enable-seccomp
408
409 %{__make}
410 %{?with_hip:cd bind-hip/; %{__make}}
411
412 %{?with_tests:%{__make} test-force}
413
414 %install
415 rm -rf $RPM_BUILD_ROOT
416 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
417         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
418         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}} \
419         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
420
421 %{__make} install \
422         DESTDIR=$RPM_BUILD_ROOT
423
424 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
425 rm $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
426 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
427 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
428
429 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
430 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
431 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
432 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
433 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
434 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
435 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
436 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
437 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
438 mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
439
440 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
441 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
442 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
443 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
444
445 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
446
447 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
448 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
449
450 %if %{with ldap}
451 install -d $RPM_BUILD_ROOT%{schemadir}
452 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
453 %endif
454
455 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
456
457 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
458 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
459
460 # let rpm generate deps (workaround -m644 used for libs installation)
461 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
462
463 # we don't want Makefiles in documentation...
464 rm -rf _doc
465 cp -a doc _doc
466 %{__rm} _doc/misc/Makefile*
467
468 %clean
469 rm -rf $RPM_BUILD_ROOT
470
471 %pre
472 if [ -f %{_sysconfdir}/named.boot ]; then
473         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
474         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
475         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
476 fi
477 %groupadd -g 58 named
478 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
479
480 %post
481 /sbin/chkconfig --add named
482 %service named restart
483 %systemd_post named.service
484
485 %preun
486 if [ "$1" = "0" ]; then
487         %service named stop
488         /sbin/chkconfig --del named
489 fi
490 %systemd_preun named.service
491
492 %postun
493 if [ "$1" = "0" ]; then
494         %userremove named
495         %groupremove named
496 fi
497 %systemd_reload
498
499 %post   libs -p /sbin/ldconfig
500 %postun libs -p /sbin/ldconfig
501
502 %post -n openldap-schema-bind
503 %openldap_schema_register %{schemadir}/dnszone.schema
504 %service -q ldap restart
505
506 %postun -n openldap-schema-bind
507 if [ "$1" = "0" ]; then
508         %openldap_schema_unregister %{schemadir}/dnszone.schema
509         %service -q ldap restart
510 fi
511
512 %triggerpostun -- %{name} < 7:9.4.2-2
513 /sbin/chkconfig named reset
514 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
515 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
516 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
517
518 %triggerpostun -- %{name} < 7:9.9.2.P2-2
519 %systemd_trigger named.service
520
521 %files
522 %defattr(644,root,root,755)
523 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
524 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
525
526 %{systemdunitdir}/named.service
527 %attr(754,root,root) /etc/rc.d/init.d/named
528 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
529 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
530 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
531 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
532
533 %attr(755,root,root) %{_sbindir}/arpaname
534 %attr(755,root,root) %{_sbindir}/ddns-confgen
535 %attr(755,root,root) %{_sbindir}/dnssec-*
536 %attr(755,root,root) %{_sbindir}/genrandom
537 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
538 %attr(755,root,root) %{_sbindir}/lwresd
539 %attr(755,root,root) %{_sbindir}/named
540 %attr(755,root,root) %{_sbindir}/named-*
541 %attr(755,root,root) %{_sbindir}/nsec3hash
542 %attr(755,root,root) %{_sbindir}/rndc
543 %attr(755,root,root) %{_sbindir}/rndc-confgen
544 %attr(755,root,root) %{_sbindir}/tsig-keygen
545
546 %{_mandir}/man1/arpaname.1*
547 %{_mandir}/man1/named-rrchecker.1*
548 %{_mandir}/man5/named.conf.5*
549 %{_mandir}/man5/rndc.conf.5*
550 %{_mandir}/man8/ddns-confgen.8*
551 %{_mandir}/man8/dnssec-*.8*
552 %{_mandir}/man8/genrandom.8*
553 %{_mandir}/man8/isc-hmac-fixup.8*
554 %{_mandir}/man8/lwresd.8*
555 %{_mandir}/man8/named.8*
556 %{_mandir}/man8/named-*.8*
557 %{_mandir}/man8/nsec3hash.8*
558 %{_mandir}/man8/rndc.8*
559 %{_mandir}/man8/rndc-confgen.8*
560 %{_mandir}/man8/tsig-keygen.8*
561 %lang(ja) %{_mandir}/ja/man8/named*
562
563 %{systemdtmpfilesdir}/%{name}.conf
564
565 %attr(770,root,named) %dir %{_var}/lib/named
566 %attr(770,root,named) %dir %{_var}/lib/named/D
567 %attr(770,root,named) %dir %{_var}/lib/named/M
568 %attr(770,root,named) %dir %{_var}/lib/named/S
569 %attr(750,root,named) %dir %{_var}/lib/named/etc
570 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
571 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
572 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
573 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
574 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
575 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
576
577 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
578 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
579
580 %attr(770,root,named) %dir %{_var}/run/named
581 %attr(770,root,named) %dir %{_var}/run/lwresd
582
583 %files utils
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{_bindir}/delv
586 %attr(755,root,root) %{_bindir}/dig
587 %attr(755,root,root) %{_bindir}/host
588 %attr(755,root,root) %{_bindir}/nslookup
589 %attr(755,root,root) %{_bindir}/nsupdate
590 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
591 %{_mandir}/man1/delv.1*
592 %{_mandir}/man1/dig.1*
593 %{_mandir}/man1/host.1*
594 %{_mandir}/man1/nslookup.1*
595 %{_mandir}/man1/nsupdate.1*
596
597 %lang(fi) %{_mandir}/fi/man1/host.1*
598
599 %lang(fr) %{_mandir}/fr/man1/host.1*
600
601 %lang(hu) %{_mandir}/hu/man1/host.1*
602
603 %lang(ja) %{_mandir}/ja/man1/dig.1*
604 %lang(ja) %{_mandir}/ja/man1/host.1*
605 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
606 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
607
608 %lang(pl) %{_mandir}/pl/man1/host.1*
609
610 %files libs
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
613 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.140
614 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
615 %attr(755,root,root) %ghost %{_libdir}/libdns.so.146
616 %attr(755,root,root) %{_libdir}/libirs.so.*.*.*
617 %attr(755,root,root) %ghost %{_libdir}/libirs.so.141
618 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
619 %attr(755,root,root) %ghost %{_libdir}/libisc.so.142
620 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
621 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.140
622 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
623 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.140
624 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
625 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.141
626
627 %files devel
628 %defattr(644,root,root,755)
629 %attr(755,root,root) %{_bindir}/bind9-config
630 %attr(755,root,root) %{_bindir}/isc-config.sh
631 %attr(755,root,root) %{_libdir}/libbind9.so
632 %attr(755,root,root) %{_libdir}/libdns.so
633 %attr(755,root,root) %{_libdir}/libirs.so
634 %attr(755,root,root) %{_libdir}/libisc.so
635 %attr(755,root,root) %{_libdir}/libisccc.so
636 %attr(755,root,root) %{_libdir}/libisccfg.so
637 %attr(755,root,root) %{_libdir}/liblwres.so
638 %{_libdir}/libbind9.la
639 %{_libdir}/libdns.la
640 %{_libdir}/libirs.la
641 %{_libdir}/libisc.la
642 %{_libdir}/libisccc.la
643 %{_libdir}/libisccfg.la
644 %{_libdir}/liblwres.la
645 %{_includedir}/bind9
646 %{_includedir}/dns
647 %{_includedir}/dst
648 %{_includedir}/irs
649 %{_includedir}/isc
650 %{_includedir}/isccc
651 %{_includedir}/isccfg
652 %{_includedir}/lwres
653 %{_includedir}/pk11
654 %{_includedir}/pkcs11
655 %{_mandir}/man1/bind9-config.1*
656 %{_mandir}/man1/isc-config.sh.1*
657 %{_mandir}/man3/lwres*.3*
658
659 %if %{with static_libs}
660 %files static
661 %defattr(644,root,root,755)
662 %{_libdir}/libbind9.a
663 %{_libdir}/libdns.a
664 %{_libdir}/libirs.a
665 %{_libdir}/libisc.a
666 %{_libdir}/libisccc.a
667 %{_libdir}/libisccfg.a
668 %{_libdir}/liblwres.a
669 %endif
670
671 %if %{with ldap}
672 %files -n openldap-schema-bind
673 %defattr(644,root,root,755)
674 %{_datadir}/openldap/schema/dnszone.schema
675 %endif
This page took 0.17446 seconds and 4 git commands to generate.