]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- update root.zone
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with     edns_cli        # build with the ability to use edns-client-subnet in dig
13 %bcond_with     hip             # build with HIP RR support
14 %bcond_without  geoip           # build with GeoIP support
15 %bcond_with     seccomp         # seccomp
16 %bcond_with     sit             # SIT (Source Identity Token)
17
18 %if "%{pld_release}" == "ac"
19 %bcond_with     epoll           # enable epoll support
20 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
21 %ifarch %{x8664}
22 %define         with_epoll      1
23 %endif
24 %else
25 %bcond_without  epoll           # disable epoll support
26 %endif
27
28 %define         ver     9.10.4
29 %if 1
30 %define         pverdot .P2
31 %define         pverdir -P2
32 %else
33 %define         pverdot %{nil}
34 %define         pverdir %{nil}
35 %endif
36 Summary:        BIND - DNS name server
37 Summary(de.UTF-8):      BIND - DNS-Namenserver
38 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
39 Summary(fr.UTF-8):      BIND - serveur de noms DNS
40 Summary(pl.UTF-8):      BIND - serwer nazw DNS
41 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
42 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
43 Summary(tr.UTF-8):      DNS alan adı sunucusu
44 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
45 Summary(zh_CN.UTF-8):   Internet 域名服务器
46 Name:           bind
47 Version:        %{ver}%{pverdot}
48 Release:        2
49 Epoch:          7
50 License:        BSD-like
51 Group:          Networking/Daemons
52 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
53 # Source0-md5:  50163d229020c48929c84bec5b0068d7
54 Source1:        named.init
55 Source2:        named.sysconfig
56 Source3:        named.logrotate
57 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
58 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
59 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
60 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
61 Source6:        %{name}-hip.tar.gz
62 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
63 Source7:        ftp://rs.internic.net/domain/root.zone
64 # Source7-md5:  83be6717681dcf7c74cfb7831553592f
65 Source8:        %{name}-127.0.0.zone
66 Source9:        %{name}-localhost.zone
67 Source10:       %{name}-named.conf
68 Source11:       %{name}.tmpfiles
69 Source12:       named.service
70 Patch0:         %{name}-time.patch
71 Patch1:         %{name}-link.patch
72 Patch2:         %{name}-pmake.patch
73 Patch3:         %{name}-sdb-ldap.patch
74 Patch4:         %{name}-ac-libs.patch
75 Patch5:         %{name}-edns-client-subnet.patch
76 Patch6:         nsupdate_segfault.patch
77 URL:            https://www.isc.org/software/bind
78 BuildRequires:  autoconf >= 2.59
79 BuildRequires:  automake
80 BuildRequires:  bison
81 BuildRequires:  flex
82 %{?with_kerberos5:BuildRequires:        heimdal-devel}
83 BuildRequires:  idnkit-devel
84 %{?with_seccomp:BuildRequires:  libseccomp-devel}
85 BuildRequires:  libtool
86 %{?with_hip:BuildRequires:      libxml2-devel}
87 %{?with_sql:BuildRequires:      mysql-devel}
88 %{?with_ldap:BuildRequires:     openldap-devel}
89 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
90 %{?with_sql:BuildRequires:      postgresql-devel}
91 BuildRequires:  readline-devel
92 BuildRequires:  rpm >= 4.4.9-56
93 BuildRequires:  rpmbuild(macros) >= 1.647
94 %{?with_sql:BuildRequires:      unixODBC-devel}
95 Requires(post,preun):   /sbin/chkconfig
96 Requires(postun):       /usr/sbin/groupdel
97 Requires(postun):       /usr/sbin/userdel
98 Requires(pre):  /bin/id
99 Requires(pre):  /usr/bin/getgid
100 Requires(pre):  /usr/sbin/groupadd
101 Requires(pre):  /usr/sbin/useradd
102 Requires(pre):  fileutils
103 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
104 Requires:       psmisc >= 20.1
105 Requires:       rc-scripts >= 0.2.0
106 Requires:       systemd-units >= 38
107 Requires:       uname(release) >= 2.2.18
108 Provides:       group(named)
109 Provides:       nameserver
110 Provides:       user(named)
111 Obsoletes:      caching-nameserver
112 Conflicts:      %{name}-chroot
113 Conflicts:      logrotate < 3.8.0
114 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
116 %define         schemadir       /usr/share/openldap/schema
117
118 %description
119 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
120 (Domain Name System) protocols. BIND includes a DNS server (named),
121 which resolves host names to IP addresses, and a resolver library
122 (routines for applications to use when interfacing with DNS). A DNS
123 server allows clients to name resources or objects and share the
124 information with other network machines. The named DNS server can be
125 used on workstations as a caching name server, but is generally only
126 needed on one machine for an entire network. Note that the
127 configuration files for making BIND act as a simple caching nameserver
128 are included in the caching-nameserver package.
129
130 Install the bind package if you need a DNS server for your network. If
131 you want bind to act a caching name server, you will also need to
132 install the caching-nameserver package.
133
134 %description -l de.UTF-8
135 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
136 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
137 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
138 Recher des Netzwerks erforderlich.
139
140 %description -l es.UTF-8
141 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
142 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
143 un servidor de nombres caché, pero generalmente sólo hace falta en una
144 máquina para toda la red.
145
146 %description -l fr.UTF-8
147 Contient le serveur de noms named, utilisé pour définir les
148 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
149 utilisé sur les stations de travail comme serveur de nom en cache mais
150 n'est souvent nécessaire que sur une machine pour un réseau entier.
151
152 %description -l pl.UTF-8
153 Pakiet ten zawiera demona named, który służy do zmieniania nazw
154 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
155 roboczych jako bufor odwołań do serwisu nazw (caching name server),
156 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
157 program na fragment sieci.
158
159 %description -l pt_BR.UTF-8
160 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
161 IP (e vice-versa). Pode ser usado em estações de trabalho como um
162 servidor de nomes cache, mas geralmente só é necessário em uma máquina
163 para toda a rede.
164
165 %description -l ru.UTF-8
166 BIND (Berkeley Internet Name Domain) является реализацией протоколов
167 DNS (Domain Name System). BIND включает DNS сервер (named) и
168 библиотеку "резолвера" (подпрограммы для приложений, через которые
169 происходят обращения к DNS). DNS сервер named может быть использован
170 на рабочих станциях как кеширующий сервер, но обычно запускается на
171 одной машине в локальной сети и используется остальными машинами (этим
172 достигается намного более эффективное кеширование).
173
174 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
175 кеширующего сервера, включены в пакет caching-nameserver.
176
177 %description -l tr.UTF-8
178 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
179 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
180 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
181 için sadece bir makina üzerinde kurulur.
182
183 %description -l uk.UTF-8
184 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
185 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
186 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
187 сервер named може бути використаний на робочих станціях як кешируючий
188 сервер, але звичайно запускається на одній машині в локальній мережі і
189 використовується іншими (цим досягається більша ефективність
190 використання кешу).
191
192 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
193 кешируючого серверу, включені в пакет caching-nameserver.
194
195 %package utils
196 Summary:        DNS utils - host, dig, dnsquery, nslookup
197 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
198 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
199 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
200 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
201 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
202 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
203 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
204 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
205 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
206 Group:          Networking/Utilities
207 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
208 Requires:       iconv
209
210 %description utils
211 Bind-utils contains a collection of utilities for querying DNS (Domain
212 Name Service) name servers to find out information about Internet
213 hosts. These tools will provide you with the IP addresses for given
214 host names, as well as other information about registered domains and
215 network addresses.
216
217 You should install bind-utils if you need to get information from DNS
218 name servers.
219
220 %description utils -l de.UTF-8
221 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
222 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
223 Informationen über registrierte Domains und Netzwerk-Adressen.
224
225 %description utils -l es.UTF-8
226 Conjunto de utilitarios para consulta a servidores de nombres. Estas
227 herramientas permiten la determinación de direcciones IP para nombres
228 de máquinas informados y busca información sobre dominios registrados
229 y direcciones de red.
230
231 %description utils -l fr.UTF-8
232 Ensemble d'utilitaires pour interroger les serveurs de noms et
233 rechercher des hôtes. Ces outils vous permettent de déterminer les
234 adresses IP pour des noms d'hôtes donnés, et trouver des informations
235 sur les noms de domaine déclarés et les adresses réseau.
236
237 %description utils -l pl.UTF-8
238 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
239 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
240 i ich adresach IP.
241
242 %description utils -l pt_BR.UTF-8
243 Conjunto de utilitários para consulta a servidores DNS. Estas
244 ferramentas permitem a determinação de endereços IP para nomes de
245 máquinas informados e busca informações sobre domínios registrados e
246 endereços de rede. Você deveria instalar este pacote se necessitar
247 obter informações de servidores DNS.
248
249 %description utils -l ru.UTF-8
250 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
251 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
252 доменному имени (и наоборот) и другую информацию о зарегистрированных
253 доменах и сетевых адресах.
254
255 %description utils -l tr.UTF-8
256 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
257 için kullanılan araçlar bulunmaktadır.
258
259 %description utils -l uk.UTF-8
260 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
261 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
262 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
263 домени та адреси.
264
265 %package libs
266 Summary:        DNS libraries
267 Summary(pl.UTF-8):      Biblioteki DNS
268 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
269 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
270 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
271 Group:          Libraries
272
273 %description libs
274 The bind-libs package contains all libraries required for running BIND
275 and bind utils.
276
277 %description libs -l pl.UTF-8
278 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
279 lub programów z pakietu bind-utils.
280
281 %description libs -l ru.UTF-8
282 Библиотеки, необходимые для работы bind.
283
284 %description libs -l uk.UTF-8
285 Бібліотеки, необхідні для роботи bind.
286
287 %package devel
288 Summary:        DNS development includes
289 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
290 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
291 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
292 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
293 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
294 Group:          Development/Libraries
295 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
296
297 %description devel
298 The bind-devel package contains all the include files and symlinks
299 required for DNS (Domain Name Service) development for BIND.
300
301 You should install bind-devel if you want to develop bind DNS
302 applications. If you install bind-devel, you'll also need to install
303 bind-libs.
304
305 %description devel -l es.UTF-8
306 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
307 para el bind.
308
309 %description devel -l pl.UTF-8
310 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
311 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
312 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
313 pakiet.
314
315 %description devel -l pt_BR.UTF-8
316 Todos os arquivos de cabeçalho e bibliotecas necessários para o
317 desenvolvimento com o bind.
318
319 %description devel -l ru.UTF-8
320 Все хедеры и библиотеки, необходимые для написания программ с
321 использованием BIND 9.x.x.
322
323 %description devel -l uk.UTF-8
324 Всі хедери та бібліотеки, необхідні для розробки програм з
325 використанням BIND 9.x.x.
326
327 %package static
328 Summary:        DNS static libs
329 Summary(pl.UTF-8):      Biblioteki statyczne DNS
330 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
331 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
332 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
333 Group:          Development/Libraries
334 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
335
336 %description static
337 Static bind libraries.
338
339 %description static -l pl.UTF-8
340 Statyczne biblioteki binda.
341
342 %description static -l pt_BR.UTF-8
343 Bibliotecas estáticas para desenvolvimento DNS.
344
345 %description static -l ru.UTF-8
346 Статические библиотеки, необходимые для написания программ с
347 использованием BIND.
348
349 %description static -l uk.UTF-8
350 Статичні бібліотеки, необхідні для розробки програм з використанням
351 BIND.
352
353 %package -n openldap-schema-bind
354 Summary:        BIND schema for openldap
355 Summary(pl.UTF-8):      Schemat BIND dla openldap
356 Group:          Development/Libraries
357 Requires(post,postun):  sed >= 4.0
358 Requires:       openldap-servers
359 Requires:       sed >= 4.0
360 %if "%{_rpmversion}" >= "5"
361 BuildArch:      noarch
362 %endif
363
364 %description -n openldap-schema-bind
365 BIND schema for openldap.
366
367 %description -n openldap-schema-bind -l pl.UTF-8
368 Schemat BIND dla openldap.
369
370 %prep
371 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
372 %patch0 -p1
373 %patch1 -p1
374 %patch2 -p1
375 %{?with_ldap:%patch3 -p1}
376 %patch4 -p1
377 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
378 %{?with_edns_cli:%patch5 -p0}
379 %patch6 -p0
380
381 %build
382 %{__libtoolize}
383 %{__aclocal}
384 %{__autoconf}
385 cp -f /usr/share/automake/config.* .
386 %configure \
387         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
388         --with-idn \
389         --with-libtool \
390         %{?with_ssl:--with-openssl} \
391         %{?with_ipv6:--enable-ipv6} \
392         %{?with_kerberos5:--with-gssapi} \
393         %{?with_sql:--with-dlz-postgres=yes} \
394         %{?with_sql:--with-dlz-mysql=yes} \
395         --with-dlz-bdb=no \
396         --with-dlz-filesystem=yes \
397         %{?with_ldap:--with-dlz-ldap=yes} \
398         %{?with_geoip:--with-geoip=yes} \
399         --with-dlz-odbc=no \
400         --with-dlz-stub=yes \
401         --enable-largefile \
402         %{!?with_epoll:--disable-epoll --disable-devpoll} \
403         %{!?with_static_libs:--enable-static=no} \
404         %{__enable_disable sit} \
405         --enable-threads \
406         --enable-getifaddrs \
407         --enable-full-report \
408         %{__enable_disable seccomp}
409
410 %{__make}
411 %{?with_hip:cd bind-hip/; %{__make}}
412
413 %{?with_tests:%{__make} test-force}
414
415 %install
416 rm -rf $RPM_BUILD_ROOT
417 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
418         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
419         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}} \
420         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
421
422 %{__make} install \
423         DESTDIR=$RPM_BUILD_ROOT
424
425 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
426 rm $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
427 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
428 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
429
430 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
431 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
432 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
433 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
434 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
435 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
436 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
437 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
438 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
439 mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
440
441 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
442 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
443 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
444 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
445
446 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
447
448 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
449 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
450
451 %if %{with ldap}
452 install -d $RPM_BUILD_ROOT%{schemadir}
453 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
454 %endif
455
456 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
457
458 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
459 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
460
461 # let rpm generate deps (workaround -m644 used for libs installation)
462 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
463
464 # we don't want Makefiles in documentation...
465 rm -rf _doc
466 cp -a doc _doc
467 %{__rm} _doc/misc/Makefile*
468
469 %clean
470 rm -rf $RPM_BUILD_ROOT
471
472 %pre
473 if [ -f %{_sysconfdir}/named.boot ]; then
474         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
475         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
476         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
477 fi
478 %groupadd -g 58 named
479 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
480
481 %post
482 /sbin/chkconfig --add named
483 %service named restart
484 %systemd_post named.service
485
486 %preun
487 if [ "$1" = "0" ]; then
488         %service named stop
489         /sbin/chkconfig --del named
490 fi
491 %systemd_preun named.service
492
493 %postun
494 if [ "$1" = "0" ]; then
495         %userremove named
496         %groupremove named
497 fi
498 %systemd_reload
499
500 %post   libs -p /sbin/ldconfig
501 %postun libs -p /sbin/ldconfig
502
503 %post -n openldap-schema-bind
504 %openldap_schema_register %{schemadir}/dnszone.schema
505 %service -q ldap restart
506
507 %postun -n openldap-schema-bind
508 if [ "$1" = "0" ]; then
509         %openldap_schema_unregister %{schemadir}/dnszone.schema
510         %service -q ldap restart
511 fi
512
513 %triggerpostun -- %{name} < 7:9.4.2-2
514 /sbin/chkconfig named reset
515 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
516 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
517 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
518
519 %triggerpostun -- %{name} < 7:9.9.2.P2-2
520 %systemd_trigger named.service
521
522 %files
523 %defattr(644,root,root,755)
524 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
525 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
526
527 %{systemdunitdir}/named.service
528 %attr(754,root,root) /etc/rc.d/init.d/named
529 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
530 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
531 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
532 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
533
534 %attr(755,root,root) %{_sbindir}/arpaname
535 %attr(755,root,root) %{_sbindir}/ddns-confgen
536 %attr(755,root,root) %{_sbindir}/dnssec-*
537 %attr(755,root,root) %{_sbindir}/genrandom
538 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
539 %attr(755,root,root) %{_sbindir}/lwresd
540 %attr(755,root,root) %{_sbindir}/named
541 %attr(755,root,root) %{_sbindir}/named-*
542 %attr(755,root,root) %{_sbindir}/nsec3hash
543 %attr(755,root,root) %{_sbindir}/rndc
544 %attr(755,root,root) %{_sbindir}/rndc-confgen
545 %attr(755,root,root) %{_sbindir}/tsig-keygen
546
547 %{_mandir}/man1/arpaname.1*
548 %{_mandir}/man1/named-rrchecker.1*
549 %{_mandir}/man5/named.conf.5*
550 %{_mandir}/man5/rndc.conf.5*
551 %{_mandir}/man8/ddns-confgen.8*
552 %{_mandir}/man8/dnssec-*.8*
553 %{_mandir}/man8/genrandom.8*
554 %{_mandir}/man8/isc-hmac-fixup.8*
555 %{_mandir}/man8/lwresd.8*
556 %{_mandir}/man8/named.8*
557 %{_mandir}/man8/named-*.8*
558 %{_mandir}/man8/nsec3hash.8*
559 %{_mandir}/man8/rndc.8*
560 %{_mandir}/man8/rndc-confgen.8*
561 %{_mandir}/man8/tsig-keygen.8*
562 %lang(ja) %{_mandir}/ja/man8/named*
563
564 %{systemdtmpfilesdir}/%{name}.conf
565
566 %attr(770,root,named) %dir %{_var}/lib/named
567 %attr(770,root,named) %dir %{_var}/lib/named/D
568 %attr(770,root,named) %dir %{_var}/lib/named/M
569 %attr(770,root,named) %dir %{_var}/lib/named/S
570 %attr(750,root,named) %dir %{_var}/lib/named/etc
571 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
572 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
573 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
574 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
575 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
576 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
577
578 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
579 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
580
581 %attr(770,root,named) %dir %{_var}/run/named
582 %attr(770,root,named) %dir %{_var}/run/lwresd
583
584 %files utils
585 %defattr(644,root,root,755)
586 %attr(755,root,root) %{_bindir}/delv
587 %attr(755,root,root) %{_bindir}/dig
588 %attr(755,root,root) %{_bindir}/host
589 %attr(755,root,root) %{_bindir}/nslookup
590 %attr(755,root,root) %{_bindir}/nsupdate
591 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
592 %{_mandir}/man1/delv.1*
593 %{_mandir}/man1/dig.1*
594 %{_mandir}/man1/host.1*
595 %{_mandir}/man1/nslookup.1*
596 %{_mandir}/man1/nsupdate.1*
597
598 %lang(fi) %{_mandir}/fi/man1/host.1*
599
600 %lang(fr) %{_mandir}/fr/man1/host.1*
601
602 %lang(hu) %{_mandir}/hu/man1/host.1*
603
604 %lang(ja) %{_mandir}/ja/man1/dig.1*
605 %lang(ja) %{_mandir}/ja/man1/host.1*
606 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
607 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
608
609 %lang(pl) %{_mandir}/pl/man1/host.1*
610
611 %files libs
612 %defattr(644,root,root,755)
613 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
614 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.140
615 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
616 %attr(755,root,root) %ghost %{_libdir}/libdns.so.165
617 %attr(755,root,root) %{_libdir}/libirs.so.*.*.*
618 %attr(755,root,root) %ghost %{_libdir}/libirs.so.141
619 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
620 %attr(755,root,root) %ghost %{_libdir}/libisc.so.160
621 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
622 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.140
623 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
624 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.140
625 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
626 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.141
627
628 %files devel
629 %defattr(644,root,root,755)
630 %attr(755,root,root) %{_bindir}/bind9-config
631 %attr(755,root,root) %{_bindir}/isc-config.sh
632 %attr(755,root,root) %{_libdir}/libbind9.so
633 %attr(755,root,root) %{_libdir}/libdns.so
634 %attr(755,root,root) %{_libdir}/libirs.so
635 %attr(755,root,root) %{_libdir}/libisc.so
636 %attr(755,root,root) %{_libdir}/libisccc.so
637 %attr(755,root,root) %{_libdir}/libisccfg.so
638 %attr(755,root,root) %{_libdir}/liblwres.so
639 %{_libdir}/libbind9.la
640 %{_libdir}/libdns.la
641 %{_libdir}/libirs.la
642 %{_libdir}/libisc.la
643 %{_libdir}/libisccc.la
644 %{_libdir}/libisccfg.la
645 %{_libdir}/liblwres.la
646 %{_includedir}/bind9
647 %{_includedir}/dns
648 %{_includedir}/dst
649 %{_includedir}/irs
650 %{_includedir}/isc
651 %{_includedir}/isccc
652 %{_includedir}/isccfg
653 %{_includedir}/lwres
654 %{_includedir}/pk11
655 %{_includedir}/pkcs11
656 %{_mandir}/man1/bind9-config.1*
657 %{_mandir}/man1/isc-config.sh.1*
658 %{_mandir}/man3/lwres*.3*
659
660 %if %{with static_libs}
661 %files static
662 %defattr(644,root,root,755)
663 %{_libdir}/libbind9.a
664 %{_libdir}/libdns.a
665 %{_libdir}/libirs.a
666 %{_libdir}/libisc.a
667 %{_libdir}/libisccc.a
668 %{_libdir}/libisccfg.a
669 %{_libdir}/liblwres.a
670 %endif
671
672 %if %{with ldap}
673 %files -n openldap-schema-bind
674 %defattr(644,root,root,755)
675 %{_datadir}/openldap/schema/dnszone.schema
676 %endif
This page took 0.108922 seconds and 4 git commands to generate.