]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
- root.zone updated
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  ssl             # build without OpenSSL support
6 %bcond_without  ipv6            # build without IPv6 support
7 %bcond_without  ldap            # build without LDAP support
8 %bcond_without  kerberos5       # build without kerneros5 support
9 %bcond_without  sql             # build without SQL support
10 %bcond_without  static_libs     # build without static libraries
11 %bcond_without  tests           # perform tests
12 %bcond_with edns_cli            # build with the ability to use edns-client-subnet in dig
13 %bcond_with     hip             # build with HIP RR support
14 %if "%{pld_release}" == "ac"
15 %bcond_with             epoll           # enable epoll support
16 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
17 %ifarch %{x8664}
18 %define         with_epoll      1
19 %endif
20 %else
21 %bcond_without  epoll           # disable epoll support
22 %endif
23
24 %define         ver     9.9.2
25 %if 0
26 %define         pverdot .P1
27 %define         pverdir -P1
28 %else
29 %define         pverdot %{nil}
30 %define         pverdir %{nil}
31 %endif
32 Summary:        BIND - DNS name server
33 Summary(de.UTF-8):      BIND - DNS-Namenserver
34 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
35 Summary(fr.UTF-8):      BIND - serveur de noms DNS
36 Summary(pl.UTF-8):      BIND - serwer nazw DNS
37 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
38 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
39 Summary(tr.UTF-8):      DNS alan adı sunucusu
40 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
41 Summary(zh_CN.UTF-8):   Internet 域名服务器
42 Name:           bind
43 Version:        %{ver}%{pverdot}
44 Release:        1
45 Epoch:          7
46 License:        BSD-like
47 Group:          Networking/Daemons
48 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
49 # Source0-md5:  3b37d8de1bb15d3e887ce9ee8e07cd71
50 Source1:        named.init
51 Source2:        named.sysconfig
52 Source3:        named.logrotate
53 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
54 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
55 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
56 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
57 Source6:        %{name}-hip.tar.gz
58 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
59 Source7:        ftp://rs.internic.net/domain/root.zone
60 # Source7-md5:  57ad1cee4e934de51884602ad9c61be2
61 Source8:        %{name}-127.0.0.zone
62 Source9:        %{name}-localhost.zone
63 Source10:       %{name}-named.conf
64 Source11:       %{name}.tmpfiles
65 Patch0:         %{name}-time.patch
66 Patch1:         %{name}-link.patch
67 Patch2:         %{name}-pmake.patch
68 Patch3:         %{name}-sdb-ldap.patch
69 Patch4:         %{name}-ac-libs.patch
70 Patch5:         %{name}-edns-client-subnet.patch
71 Patch6:         nsupdate_segfault.patch
72 URL:            https://www.isc.org/software/bind
73 BuildRequires:  autoconf >= 2.59
74 BuildRequires:  automake
75 BuildRequires:  bison
76 BuildRequires:  flex
77 %{?with_kerberos5:BuildRequires:        heimdal-devel}
78 BuildRequires:  idnkit-devel
79 BuildRequires:  libtool
80 %{?with_hip:BuildRequires:      libxml2-devel}
81 %{?with_sql:BuildRequires:      mysql-devel}
82 %{?with_ldap:BuildRequires:     openldap-devel}
83 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
84 %{?with_sql:BuildRequires:      postgresql-devel}
85 BuildRequires:  rpm >= 4.4.9-56
86 BuildRequires:  rpmbuild(macros) >= 1.268
87 %{?with_sql:BuildRequires:      unixODBC-devel}
88 Requires(post,preun):   /sbin/chkconfig
89 Requires(postun):       /usr/sbin/groupdel
90 Requires(postun):       /usr/sbin/userdel
91 Requires(pre):  /bin/id
92 Requires(pre):  /usr/bin/getgid
93 Requires(pre):  /usr/sbin/groupadd
94 Requires(pre):  /usr/sbin/useradd
95 Requires(pre):  fileutils
96 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
97 Requires:       psmisc >= 20.1
98 Requires:       rc-scripts >= 0.2.0
99 Requires:       uname(release) >= 2.2.18
100 Provides:       group(named)
101 Provides:       nameserver
102 Provides:       user(named)
103 Obsoletes:      caching-nameserver
104 Conflicts:      %{name}-chroot
105 Conflicts:      logrotate < 3.8.0
106 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
107
108 %define         schemadir       /usr/share/openldap/schema
109
110 %description
111 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
112 (Domain Name System) protocols. BIND includes a DNS server (named),
113 which resolves host names to IP addresses, and a resolver library
114 (routines for applications to use when interfacing with DNS). A DNS
115 server allows clients to name resources or objects and share the
116 information with other network machines. The named DNS server can be
117 used on workstations as a caching name server, but is generally only
118 needed on one machine for an entire network. Note that the
119 configuration files for making BIND act as a simple caching nameserver
120 are included in the caching-nameserver package.
121
122 Install the bind package if you need a DNS server for your network. If
123 you want bind to act a caching name server, you will also need to
124 install the caching-nameserver package.
125
126 %description -l de.UTF-8
127 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
128 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
129 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
130 Recher des Netzwerks erforderlich.
131
132 %description -l es.UTF-8
133 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
134 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
135 un servidor de nombres caché, pero generalmente sólo hace falta en una
136 máquina para toda la red.
137
138 %description -l fr.UTF-8
139 Contient le serveur de noms named, utilisé pour définir les
140 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
141 utilisé sur les stations de travail comme serveur de nom en cache mais
142 n'est souvent nécessaire que sur une machine pour un réseau entier.
143
144 %description -l pl.UTF-8
145 Pakiet ten zawiera demona named, który służy do zmieniania nazw
146 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
147 roboczych jako bufor odwołań do serwisu nazw (caching name server),
148 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
149 program na fragment sieci.
150
151 %description -l pt_BR.UTF-8
152 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
153 IP (e vice-versa). Pode ser usado em estações de trabalho como um
154 servidor de nomes cache, mas geralmente só é necessário em uma máquina
155 para toda a rede.
156
157 %description -l ru.UTF-8
158 BIND (Berkeley Internet Name Domain) является реализацией протоколов
159 DNS (Domain Name System). BIND включает DNS сервер (named) и
160 библиотеку "резолвера" (подпрограммы для приложений, через которые
161 происходят обращения к DNS). DNS сервер named может быть использован
162 на рабочих станциях как кеширующий сервер, но обычно запускается на
163 одной машине в локальной сети и используется остальными машинами (этим
164 достигается намного более эффективное кеширование).
165
166 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
167 кеширующего сервера, включены в пакет caching-nameserver.
168
169 %description -l tr.UTF-8
170 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
171 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
172 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
173 için sadece bir makina üzerinde kurulur.
174
175 %description -l uk.UTF-8
176 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
177 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
178 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
179 сервер named може бути використаний на робочих станціях як кешируючий
180 сервер, але звичайно запускається на одній машині в локальній мережі і
181 використовується іншими (цим досягається більша ефективність
182 використання кешу).
183
184 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
185 кешируючого серверу, включені в пакет caching-nameserver.
186
187 %package utils
188 Summary:        DNS utils - host, dig, dnsquery, nslookup
189 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
190 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
191 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
192 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
193 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
194 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
195 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
196 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
197 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
198 Group:          Networking/Utilities
199 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
200 Requires:       iconv
201
202 %description utils
203 Bind-utils contains a collection of utilities for querying DNS (Domain
204 Name Service) name servers to find out information about Internet
205 hosts. These tools will provide you with the IP addresses for given
206 host names, as well as other information about registered domains and
207 network addresses.
208
209 You should install bind-utils if you need to get information from DNS
210 name servers.
211
212 %description utils -l de.UTF-8
213 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
214 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
215 Informationen über registrierte Domains und Netzwerk-Adressen.
216
217 %description utils -l es.UTF-8
218 Conjunto de utilitarios para consulta a servidores de nombres. Estas
219 herramientas permiten la determinación de direcciones IP para nombres
220 de máquinas informados y busca información sobre dominios registrados
221 y direcciones de red.
222
223 %description utils -l fr.UTF-8
224 Ensemble d'utilitaires pour interroger les serveurs de noms et
225 rechercher des hôtes. Ces outils vous permettent de déterminer les
226 adresses IP pour des noms d'hôtes donnés, et trouver des informations
227 sur les noms de domaine déclarés et les adresses réseau.
228
229 %description utils -l pl.UTF-8
230 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
231 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
232 i ich adresach IP.
233
234 %description utils -l pt_BR.UTF-8
235 Conjunto de utilitários para consulta a servidores DNS. Estas
236 ferramentas permitem a determinação de endereços IP para nomes de
237 máquinas informados e busca informações sobre domínios registrados e
238 endereços de rede. Você deveria instalar este pacote se necessitar
239 obter informações de servidores DNS.
240
241 %description utils -l ru.UTF-8
242 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
243 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
244 доменному имени (и наоборот) и другую информацию о зарегистрированных
245 доменах и сетевых адресах.
246
247 %description utils -l tr.UTF-8
248 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
249 için kullanılan araçlar bulunmaktadır.
250
251 %description utils -l uk.UTF-8
252 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
253 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
254 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
255 домени та адреси.
256
257 %package libs
258 Summary:        DNS libraries
259 Summary(pl.UTF-8):      Biblioteki DNS
260 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
261 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
262 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
263 Group:          Libraries
264
265 %description libs
266 The bind-libs package contains all libraries required for running BIND
267 and bind utils.
268
269 %description libs -l pl.UTF-8
270 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
271 lub programów z pakietu bind-utils.
272
273 %description libs -l ru.UTF-8
274 Библиотеки, необходимые для работы bind.
275
276 %description libs -l uk.UTF-8
277 Бібліотеки, необхідні для роботи bind.
278
279 %package devel
280 Summary:        DNS development includes
281 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
282 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
283 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
284 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
285 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
286 Group:          Development/Libraries
287 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
288
289 %description devel
290 The bind-devel package contains all the include files and symlinks
291 required for DNS (Domain Name Service) development for BIND.
292
293 You should install bind-devel if you want to develop bind DNS
294 applications. If you install bind-devel, you'll also need to install
295 bind-libs.
296
297 %description devel -l es.UTF-8
298 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
299 para el bind.
300
301 %description devel -l pl.UTF-8
302 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
303 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
304 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
305 pakiet.
306
307 %description devel -l pt_BR.UTF-8
308 Todos os arquivos de cabeçalho e bibliotecas necessários para o
309 desenvolvimento com o bind.
310
311 %description devel -l ru.UTF-8
312 Все хедеры и библиотеки, необходимые для написания программ с
313 использованием BIND 9.x.x.
314
315 %description devel -l uk.UTF-8
316 Всі хедери та бібліотеки, необхідні для розробки програм з
317 використанням BIND 9.x.x.
318
319 %package static
320 Summary:        DNS static libs
321 Summary(pl.UTF-8):      Biblioteki statyczne DNS
322 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
323 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
324 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
325 Group:          Development/Libraries
326 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
327
328 %description static
329 Static bind libraries.
330
331 %description static -l pl.UTF-8
332 Statyczne biblioteki binda.
333
334 %description static -l pt_BR.UTF-8
335 Bibliotecas estáticas para desenvolvimento DNS.
336
337 %description static -l ru.UTF-8
338 Статические библиотеки, необходимые для написания программ с
339 использованием BIND.
340
341 %description static -l uk.UTF-8
342 Статичні бібліотеки, необхідні для розробки програм з використанням
343 BIND.
344
345 %package -n openldap-schema-bind
346 Summary:        BIND schema for openldap
347 Summary(pl.UTF-8):      Schemat BIND dla openldap
348 Group:          Development/Libraries
349 Requires(post,postun):  sed >= 4.0
350 Requires:       openldap-servers
351 Requires:       sed >= 4.0
352
353 %description -n openldap-schema-bind
354 BIND schema for openldap.
355
356 %description -n openldap-schema-bind -l pl.UTF-8
357 Schemat BIND dla openldap.
358
359 %prep
360 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
361 %patch0 -p1
362 %patch1 -p1
363 %patch2 -p1
364 %{?with_ldap:%patch3 -p1}
365 %patch4 -p1
366 %{?with_hip:mv bind-hip/hip_55.[ch] lib/dns/rdata/generic}
367 %patch6 -p0
368
369 %{?with_edns_cli:%patch5 -p0}
370
371 %build
372 %{__libtoolize}
373 %{__aclocal}
374 %{__autoconf}
375 cp -f /usr/share/automake/config.* .
376 %configure \
377         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
378         --with-idn \
379         --with-libtool \
380         %{?with_ssl:--with-openssl} \
381         %{?with_ipv6:--enable-ipv6} \
382         %{?with_kerberos5:--with-gssapi} \
383         %{?with_sql:--with-dlz-postgres=yes} \
384         %{?with_sql:--with-dlz-mysql=yes} \
385         --with-dlz-bdb=no \
386         --with-dlz-filesystem=yes \
387         %{?with_ldap:--with-dlz-ldap=yes} \
388         --with-dlz-odbc=no \
389         --with-dlz-stub=yes \
390         --enable-largefile \
391         %{!?with_epoll:--disable-epoll --disable-devpoll} \
392         %{!?with_static_libs:--enable-static=no} \
393         --enable-threads \
394         --enable-getifaddrs
395
396 %{__make}
397 %{?with_hip:cd bind-hip/; %{__make}}
398
399 %{?with_tests:%{__make} test}
400
401 %install
402 rm -rf $RPM_BUILD_ROOT
403 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
404         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
405         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/{named,lwresd},log}} \
406         $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
407
408 %{__make} install \
409         DESTDIR=$RPM_BUILD_ROOT
410
411 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
412 mv $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
413 %{__perl} -pi -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
414
415 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
416 cp -p bin/tests/ndc.conf                EXAMPLE-CONFIG-ndc
417 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
418 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
419 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
420 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
421 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
422 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
423 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
424 mv $RPM_BUILD_ROOT/etc/bind.keys        $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
425
426 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
427 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
428 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
429 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
430
431 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
432
433 install %{SOURCE11} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/%{name}.conf
434
435 %if %{with ldap}
436 install -d $RPM_BUILD_ROOT%{schemadir}
437 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
438 %endif
439
440 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
441
442 rm -f $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
443 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
444
445 # let rpm generate deps (workaround -m644 used for libs installation)
446 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
447
448 # we don't want Makefiles in documentation...
449 rm -rf _doc
450 cp -a doc _doc
451 rm -f _doc/misc/Makefile*
452
453 %clean
454 rm -rf $RPM_BUILD_ROOT
455
456 %pre
457 if [ -f %{_sysconfdir}/named.boot ]; then
458         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
459         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
460         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
461 fi
462 %groupadd -g 58 named
463 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
464
465 %post
466 /sbin/chkconfig --add named
467 %service named restart
468
469 %preun
470 if [ "$1" = "0" ]; then
471         %service named stop
472         /sbin/chkconfig --del named
473 fi
474
475 %postun
476 if [ "$1" = "0" ]; then
477         %userremove named
478         %groupremove named
479 fi
480
481 %post   libs -p /sbin/ldconfig
482 %postun libs -p /sbin/ldconfig
483
484 %post -n openldap-schema-bind
485 %openldap_schema_register %{schemadir}/dnszone.schema
486 %service -q ldap restart
487
488 %postun -n openldap-schema-bind
489 if [ "$1" = "0" ]; then
490         %openldap_schema_unregister %{schemadir}/dnszone.schema
491         %service -q ldap restart
492 fi
493
494 %triggerpostun -- %{name} < 7:9.4.2-2
495 /sbin/chkconfig named reset
496 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
497 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
498 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
499
500 %files
501 %defattr(644,root,root,755)
502 %doc README EXAMPLE-CONFIG-* FAQ %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
503 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
504
505 %attr(754,root,root) /etc/rc.d/init.d/named
506 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
507 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
508 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
509 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
510
511 %attr(755,root,root) %{_sbindir}/arpaname
512 %attr(755,root,root) %{_sbindir}/ddns-confgen
513 %attr(755,root,root) %{_sbindir}/dnssec-*
514 %attr(755,root,root) %{_sbindir}/genrandom
515 %attr(755,root,root) %{_sbindir}/isc-hmac-fixup
516 %attr(755,root,root) %{_sbindir}/lwresd
517 %attr(755,root,root) %{_sbindir}/named
518 %attr(755,root,root) %{_sbindir}/named-*
519 %attr(755,root,root) %{_sbindir}/nsec3hash
520 %attr(755,root,root) %{_sbindir}/rndc
521 %attr(755,root,root) %{_sbindir}/rndc-confgen
522
523 %{_mandir}/man1/arpaname.1*
524 %{_mandir}/man5/named.conf.5*
525 %{_mandir}/man5/rndc.conf.5*
526 %{_mandir}/man8/ddns-confgen.8*
527 %{_mandir}/man8/dnssec-*.8*
528 %{_mandir}/man8/genrandom.8*
529 %{_mandir}/man8/isc-hmac-fixup.8*
530 %{_mandir}/man8/lwresd.8*
531 %{_mandir}/man8/named.8*
532 %{_mandir}/man8/named-*.8*
533 %{_mandir}/man8/nsec3hash.8*
534 %{_mandir}/man8/rndc.8*
535 %{_mandir}/man8/rndc-confgen.8*
536 %lang(ja) %{_mandir}/ja/man8/named*
537
538 /usr/lib/tmpfiles.d/%{name}.conf
539
540 %attr(770,root,named) %dir %{_var}/lib/named
541 %attr(770,root,named) %dir %{_var}/lib/named/D
542 %attr(750,root,named) %dir %{_var}/lib/named/M
543 %attr(770,root,named) %dir %{_var}/lib/named/S
544 %attr(750,root,named) %dir %{_var}/lib/named/etc
545 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
546 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
547 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
548 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
549 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
550 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
551
552 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
553 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
554
555 %attr(770,root,named) %dir %{_var}/run/named
556 %attr(770,root,named) %dir %{_var}/run/lwresd
557
558 %files utils
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_bindir}/dig
561 %attr(755,root,root) %{_bindir}/host
562 %attr(755,root,root) %{_bindir}/nslookup
563 %attr(755,root,root) %{_bindir}/nsupdate
564 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
565 %{_mandir}/man1/dig.1*
566 %{_mandir}/man1/host.1*
567 %{_mandir}/man1/nslookup.1*
568 %{_mandir}/man1/nsupdate.1*
569
570 %lang(fi) %{_mandir}/fi/man1/host.1*
571
572 %lang(fr) %{_mandir}/fr/man1/host.1*
573
574 %lang(hu) %{_mandir}/hu/man1/host.1*
575
576 %lang(ja) %{_mandir}/ja/man1/dig.1*
577 %lang(ja) %{_mandir}/ja/man1/host.1*
578 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
579 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
580
581 %lang(pl) %{_mandir}/pl/man1/host.1*
582
583 %files libs
584 %defattr(644,root,root,755)
585 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
586 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.[0-9][0-9]
587 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
588 %attr(755,root,root) %ghost %{_libdir}/libdns.so.[0-9][0-9]
589 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
590 %attr(755,root,root) %ghost %{_libdir}/libisc.so.[0-9][0-9]
591 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
592 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.[0-9][0-9]
593 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
594 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.[0-9][0-9]
595 %attr(755,root,root) %{_libdir}/liblwres.so.*.*.*
596 %attr(755,root,root) %ghost %{_libdir}/liblwres.so.[0-9][0-9]
597
598 %files devel
599 %defattr(644,root,root,755)
600 %attr(755,root,root) %{_bindir}/isc-config.sh
601 %attr(755,root,root) %{_libdir}/libbind9.so
602 %attr(755,root,root) %{_libdir}/libdns.so
603 %attr(755,root,root) %{_libdir}/libisc.so
604 %attr(755,root,root) %{_libdir}/libisccc.so
605 %attr(755,root,root) %{_libdir}/libisccfg.so
606 %attr(755,root,root) %{_libdir}/liblwres.so
607 %{_libdir}/libbind9.la
608 %{_libdir}/libdns.la
609 %{_libdir}/libisc.la
610 %{_libdir}/libisccc.la
611 %{_libdir}/libisccfg.la
612 %{_libdir}/liblwres.la
613 %{_includedir}/bind9
614 %{_includedir}/dns
615 %{_includedir}/dst
616 %{_includedir}/isc
617 %{_includedir}/isccc
618 %{_includedir}/isccfg
619 %{_includedir}/lwres
620 %{_mandir}/man1/isc-config.sh.1*
621 %{_mandir}/man3/lwres*.3*
622
623 %if %{with static_libs}
624 %files static
625 %defattr(644,root,root,755)
626 %{_libdir}/libbind9.a
627 %{_libdir}/libdns.a
628 %{_libdir}/libisc.a
629 %{_libdir}/libisccc.a
630 %{_libdir}/libisccfg.a
631 %{_libdir}/liblwres.a
632 %endif
633
634 %if %{with ldap}
635 %files -n openldap-schema-bind
636 %defattr(644,root,root,755)
637 %{_datadir}/openldap/schema/dnszone.schema
638 %endif
This page took 0.082789 seconds and 4 git commands to generate.