]> git.pld-linux.org Git - packages/bind.git/blob - bind.spec
e9504de934dc8e2b181d007925d52ed7d98b777d
[packages/bind.git] / bind.spec
1 # TODO
2 # - apply http://www.caraytech.com/geodns/
3 #
4 # Conditional build:
5 %bcond_without  geoip           # GeoIP support
6 %bcond_without  ipv6            # IPv6 support
7 %bcond_without  kerberos5       # GSS-API support
8 %bcond_without  ssl             # OpenSSL support
9 %bcond_with     ldap            # LDAP DLZ support
10 %bcond_with     odbc            # ODBC DLZ support
11 %bcond_without  sql             # SQL (MySQL+PostgreSQL) DLZ support
12 %bcond_without  lmdb            # LMDB storage support for addzone zones
13 %bcond_without  static_libs     # static libraries
14 %bcond_without  tests           # perform tests
15 %bcond_with     edns_cli        # ability to use edns-client-subnet in dig
16 %bcond_with     hip             # HIP RR support
17 %bcond_with     seccomp         # libseccomp system call filtering
18
19 %if "%{pld_release}" == "ac"
20 %bcond_with     epoll           # enable epoll support
21 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
22 %ifarch %{x8664}
23 %define         with_epoll      1
24 %endif
25 %else
26 %bcond_without  epoll           # disable epoll support
27 %endif
28
29 %define         ver     9.12.2
30 %if 0
31 %define         pverdot .P1
32 %define         pverdir -P1
33 %else
34 %define         pverdot %{nil}
35 %define         pverdir %{nil}
36 %endif
37 Summary:        BIND - DNS name server
38 Summary(de.UTF-8):      BIND - DNS-Namenserver
39 Summary(es.UTF-8):      BIND - Servidor de nombres DNS
40 Summary(fr.UTF-8):      BIND - serveur de noms DNS
41 Summary(pl.UTF-8):      BIND - serwer nazw DNS
42 Summary(pt_BR.UTF-8):   BIND - Servidor de nomes DNS
43 Summary(ru.UTF-8):      BIND - cервер системы доменных имен (DNS)
44 Summary(tr.UTF-8):      DNS alan adı sunucusu
45 Summary(uk.UTF-8):      BIND - cервер системи доменних імен (DNS)
46 Summary(zh_CN.UTF-8):   Internet 域名服务器
47 Name:           bind
48 Version:        %{ver}%{pverdot}
49 Release:        2
50 Epoch:          7
51 License:        MPL 2.0
52 Group:          Networking/Daemons
53 Source0:        ftp://ftp.isc.org/isc/bind9/%{ver}%{pverdir}/%{name}-%{ver}%{pverdir}.tar.gz
54 # Source0-md5:  37c0e31138976cfddd48fe6e2fa3e329
55 Source1:        named.init
56 Source2:        named.sysconfig
57 Source3:        named.logrotate
58 Source4:        http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-non-english-man-pages.tar.bz2
59 # Source4-md5:  35b1dfaa12615c9802126ee833e0e7f7
60 Source5:        http://www.venaas.no/ldap/bind-sdb/dnszone-schema.txt
61 # Source5-md5:  49fe799c6eca54ae227b22d57ebc1145
62 Source6:        %{name}-hip.tar.gz
63 # Source6-md5:  62a8a67f51ff8db9fe815205416a1f62
64 Source7:        https://www.internic.net/domain/named.root
65 # Source7-md5:  d090610a892c2e476d93042dc70dc393
66 Source8:        %{name}-127.0.0.zone
67 Source9:        %{name}-localhost.zone
68 Source10:       %{name}-named.conf
69 Source11:       %{name}.tmpfiles
70 Source12:       named.service
71 Patch0:         %{name}-time.patch
72 Patch1:         %{name}-link.patch
73 Patch2:         %{name}-pmake.patch
74 Patch3:         %{name}-sdb-ldap.patch
75 Patch4:         %{name}-ac-libs.patch
76 Patch5:         %{name}-edns-client-subnet.patch
77 Patch6:         nsupdate_segfault.patch
78 URL:            https://www.isc.org/software/bind
79 BuildRequires:  autoconf >= 2.59
80 BuildRequires:  automake
81 BuildRequires:  bison
82 BuildRequires:  flex
83 %{?with_geoip:BuildRequires:    GeoIP-devel}
84 %{?with_kerberos5:BuildRequires:        heimdal-devel}
85 BuildRequires:  json-c-devel
86 BuildRequires:  libidn2-devel
87 %{?with_seccomp:BuildRequires:  libseccomp-devel}
88 BuildRequires:  libtool
89 %{?with_hip:BuildRequires:      libxml2-devel}
90 %{?with_lmdb:BuildRequires:     lmdb-devel}
91 %{?with_sql:BuildRequires:      mysql-devel}
92 %{?with_ldap:BuildRequires:     openldap-devel}
93 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.8d}
94 %{?with_sql:BuildRequires:      postgresql-devel}
95 BuildRequires:  python3-devel
96 BuildRequires:  python3-ply
97 BuildRequires:  readline-devel
98 BuildRequires:  rpm >= 4.4.9-56
99 BuildRequires:  rpmbuild(macros) >= 1.647
100 %{?with_odbc:BuildRequires:     unixODBC-devel}
101 BuildRequires:  zlib-devel
102 Requires(post,preun):   /sbin/chkconfig
103 Requires(postun):       /usr/sbin/groupdel
104 Requires(postun):       /usr/sbin/userdel
105 Requires(pre):  /bin/id
106 Requires(pre):  /usr/bin/getgid
107 Requires(pre):  /usr/sbin/groupadd
108 Requires(pre):  /usr/sbin/useradd
109 Requires(pre):  fileutils
110 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
111 # for dnssec-{checkds,coverage,keymgr}
112 Requires:       python3-isc = %{epoch}:%{version}-%{release}
113 Requires:       psmisc >= 20.1
114 Requires:       rc-scripts >= 0.2.0
115 Requires:       systemd-units >= 38
116 Requires:       uname(release) >= 2.2.18
117 Provides:       group(named)
118 Provides:       nameserver
119 Provides:       user(named)
120 Obsoletes:      caching-nameserver
121 Conflicts:      %{name}-chroot
122 Conflicts:      logrotate < 3.8.0
123 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
124
125 %define         schemadir       /usr/share/openldap/schema
126
127 %description
128 BIND (Berkeley Internet Name Domain) is an implementation of the DNS
129 (Domain Name System) protocols. BIND includes a DNS server (named),
130 which resolves host names to IP addresses, and a resolver library
131 (routines for applications to use when interfacing with DNS). A DNS
132 server allows clients to name resources or objects and share the
133 information with other network machines. The named DNS server can be
134 used on workstations as a caching name server, but is generally only
135 needed on one machine for an entire network. Note that the
136 configuration files for making BIND act as a simple caching nameserver
137 are included in the caching-nameserver package.
138
139 Install the bind package if you need a DNS server for your network. If
140 you want bind to act a caching name server, you will also need to
141 install the caching-nameserver package.
142
143 %description -l de.UTF-8
144 Enthält den Namen-Server, der zum Umwandeln von Host-Namen in
145 IP-Adressen und umgekehrt verwendet wird. Er kann auf Workstations als
146 caching Namen-Server verwendet werden, ist aber i.d.R. nur auf einem
147 Recher des Netzwerks erforderlich.
148
149 %description -l es.UTF-8
150 Incluye el servidor de nombres (DNS), que se usa para traducir nombres
151 para IP (y viceversa). Puede ser usado en estaciones de trabajo como
152 un servidor de nombres caché, pero generalmente sólo hace falta en una
153 máquina para toda la red.
154
155 %description -l fr.UTF-8
156 Contient le serveur de noms named, utilisé pour définir les
157 traductions nom d'hôte vers adresse IP (et vice versa). Il peut être
158 utilisé sur les stations de travail comme serveur de nom en cache mais
159 n'est souvent nécessaire que sur une machine pour un réseau entier.
160
161 %description -l pl.UTF-8
162 Pakiet ten zawiera demona named, który służy do zmieniania nazw
163 komputerów na numery IP i odwrotnie. Może być on używany na stacjach
164 roboczych jako bufor odwołań do serwisu nazw (caching name server),
165 ale generalnie wystarczy tylko jedna jednostka wyposażona w ten
166 program na fragment sieci.
167
168 %description -l pt_BR.UTF-8
169 Inclui o servidor de nomes (DNS), que é usado para traduzir nomes para
170 IP (e vice-versa). Pode ser usado em estações de trabalho como um
171 servidor de nomes cache, mas geralmente só é necessário em uma máquina
172 para toda a rede.
173
174 %description -l ru.UTF-8
175 BIND (Berkeley Internet Name Domain) является реализацией протоколов
176 DNS (Domain Name System). BIND включает DNS сервер (named) и
177 библиотеку "резолвера" (подпрограммы для приложений, через которые
178 происходят обращения к DNS). DNS сервер named может быть использован
179 на рабочих станциях как кеширующий сервер, но обычно запускается на
180 одной машине в локальной сети и используется остальными машинами (этим
181 достигается намного более эффективное кеширование).
182
183 Конфигурационные файлы, настраивающие BIND на работу в режиме простого
184 кеширующего сервера, включены в пакет caching-nameserver.
185
186 %description -l tr.UTF-8
187 Bu paket, makina adını IP numarasına (ya da tersi) çevirmek için
188 kullanılan alan adı sunucusunu içerir. İş istasyonlarında bir önbellek
189 isim sunucusu olarak da kullanılabilir ama genellikle bütün bir ağ
190 için sadece bir makina üzerinde kurulur.
191
192 %description -l uk.UTF-8
193 BIND (Berkeley Internet Name Domain) є реалізацією протоколів DNS
194 (Domain Name System). BIND включає DNS сервер (named) та бібліотеку
195 "резолвера" (підпрограми, що забезпечують інтерфейс до DNS). DNS
196 сервер named може бути використаний на робочих станціях як кешируючий
197 сервер, але звичайно запускається на одній машині в локальній мережі і
198 використовується іншими (цим досягається більша ефективність
199 використання кешу).
200
201 Конфігураційні файли, ща настроюють BIND на роботу в режимі простого
202 кешируючого серверу, включені в пакет caching-nameserver.
203
204 %package utils
205 Summary:        DNS utils - host, dig, dnsquery, nslookup
206 Summary(de.UTF-8):      DNS-Utils - Host, Dig, Dnsquery, Nslookup
207 Summary(es.UTF-8):      Utilitarios DNS - host, dig, dnsquery y nslookup
208 Summary(fr.UTF-8):      Utilitaires DNS - host, dig, dnsquery, nslookup
209 Summary(pl.UTF-8):      Narzędzia DNS - host, dig, dnsquery, nslookup
210 Summary(pt_BR.UTF-8):   Utilitários DNS - host, dig, dnsquery e nslookup
211 Summary(ru.UTF-8):      Утилиты для посылки запросов к серверам DNS
212 Summary(tr.UTF-8):      DNS araçları - host, dig, dnsquery, nslookup
213 Summary(uk.UTF-8):      Утиліти для надсилання запитів до серверів DNS
214 Summary(zh_CN.UTF-8):   Internet 域名服务器实用工具
215 Group:          Networking/Utilities
216 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
217 Requires:       iconv
218
219 %description utils
220 Bind-utils contains a collection of utilities for querying DNS (Domain
221 Name Service) name servers to find out information about Internet
222 hosts. These tools will provide you with the IP addresses for given
223 host names, as well as other information about registered domains and
224 network addresses.
225
226 You should install bind-utils if you need to get information from DNS
227 name servers.
228
229 %description utils -l de.UTF-8
230 Dienstprogrammsammlung zum Abfragen von Namen-Servern und Hosts. Diese
231 Tools bestimmen die IP-Adresse eines angegebenen Host-Namen und finden
232 Informationen über registrierte Domains und Netzwerk-Adressen.
233
234 %description utils -l es.UTF-8
235 Conjunto de utilitarios para consulta a servidores de nombres. Estas
236 herramientas permiten la determinación de direcciones IP para nombres
237 de máquinas informados y busca información sobre dominios registrados
238 y direcciones de red.
239
240 %description utils -l fr.UTF-8
241 Ensemble d'utilitaires pour interroger les serveurs de noms et
242 rechercher des hôtes. Ces outils vous permettent de déterminer les
243 adresses IP pour des noms d'hôtes donnés, et trouver des informations
244 sur les noms de domaine déclarés et les adresses réseau.
245
246 %description utils -l pl.UTF-8
247 Pakiet ten zawiera zbiór aplikacji umożliwiających odpytywanie
248 serwerów nazw z innych domen w celu uzyskania informacji o komputerach
249 i ich adresach IP.
250
251 %description utils -l pt_BR.UTF-8
252 Conjunto de utilitários para consulta a servidores DNS. Estas
253 ferramentas permitem a determinação de endereços IP para nomes de
254 máquinas informados e busca informações sobre domínios registrados e
255 endereços de rede. Você deveria instalar este pacote se necessitar
256 obter informações de servidores DNS.
257
258 %description utils -l ru.UTF-8
259 Набор утилит для генерации запросов к серверам имен (DNS) и поиска
260 адресов машин. Эти утилиты позволяют определить IP-адрес по известному
261 доменному имени (и наоборот) и другую информацию о зарегистрированных
262 доменах и сетевых адресах.
263
264 %description utils -l tr.UTF-8
265 Bu pakette isim sunucularını sorgulamak ve makina adreslerini çözmek
266 için kullanılan araçlar bulunmaktadır.
267
268 %description utils -l uk.UTF-8
269 Набір утиліт для генерації запитів до серверів імен (DNS) та пошуку
270 адрес машин. Ці утиліти дозволяють отримати IP-адресу за відомим
271 доменним іменем та навпаки, а також іншу інформацію про зареєстровані
272 домени та адреси.
273
274 %package libs
275 Summary:        DNS libraries
276 Summary(pl.UTF-8):      Biblioteki DNS
277 Summary(ru.UTF-8):      Библиотеки, необходимые для bind
278 Summary(uk.UTF-8):      Бібліотеки, необхідні для bind
279 Summary(zh_CN.UTF-8):   Internet 域名服务器开发库
280 Group:          Libraries
281
282 %description libs
283 The bind-libs package contains all libraries required for running BIND
284 and bind utils.
285
286 %description libs -l pl.UTF-8
287 Pakiet zawiera wszystkie biblioteki potrzebne do uruchomienia binda
288 lub programów z pakietu bind-utils.
289
290 %description libs -l ru.UTF-8
291 Библиотеки, необходимые для работы bind.
292
293 %description libs -l uk.UTF-8
294 Бібліотеки, необхідні для роботи bind.
295
296 %package devel
297 Summary:        DNS development includes
298 Summary(es.UTF-8):      Archivos de inclusión y bibliotecas para desarrollo DNS
299 Summary(pl.UTF-8):      Pliki nagłówkowe bibliotek DNS
300 Summary(pt_BR.UTF-8):   Todos os arquivos de cabeçalho e bibliotecas para desenvolvimento DNS
301 Summary(ru.UTF-8):      Хедеры и библиотеки разработчика для bind
302 Summary(uk.UTF-8):      Хедери та бібліотеки програміста для bind
303 Group:          Development/Libraries
304 Requires:       %{name}-libs = %{epoch}:%{version}-%{release}
305
306 %description devel
307 The bind-devel package contains all the include files and symlinks
308 required for DNS (Domain Name Service) development for BIND.
309
310 You should install bind-devel if you want to develop bind DNS
311 applications. If you install bind-devel, you'll also need to install
312 bind-libs.
313
314 %description devel -l es.UTF-8
315 Los archivos de inclusión y bibliotecas necesarios al desarrollo DNS
316 para el bind.
317
318 %description devel -l pl.UTF-8
319 Pakiet zawiera pliki nagłówkowe. Jeżeli będziesz pisał programy pod
320 binda, lub kompilował kod źródłowy oprogramowania korzystającego z
321 tych plików nagłówkowych czy biblioteki powinieneś zainstalować ten
322 pakiet.
323
324 %description devel -l pt_BR.UTF-8
325 Todos os arquivos de cabeçalho e bibliotecas necessários para o
326 desenvolvimento com o bind.
327
328 %description devel -l ru.UTF-8
329 Все хедеры и библиотеки, необходимые для написания программ с
330 использованием BIND 9.x.x.
331
332 %description devel -l uk.UTF-8
333 Всі хедери та бібліотеки, необхідні для розробки програм з
334 використанням BIND 9.x.x.
335
336 %package static
337 Summary:        DNS static libs
338 Summary(pl.UTF-8):      Biblioteki statyczne DNS
339 Summary(pt_BR.UTF-8):   Bibliotecas estáticas para desenvolvimento DNS
340 Summary(ru.UTF-8):      Статические библиотеки разработчика для bind
341 Summary(uk.UTF-8):      Статичні бібліотеки програміста для bind
342 Group:          Development/Libraries
343 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
344
345 %description static
346 Static bind libraries.
347
348 %description static -l pl.UTF-8
349 Statyczne biblioteki binda.
350
351 %description static -l pt_BR.UTF-8
352 Bibliotecas estáticas para desenvolvimento DNS.
353
354 %description static -l ru.UTF-8
355 Статические библиотеки, необходимые для написания программ с
356 использованием BIND.
357
358 %description static -l uk.UTF-8
359 Статичні бібліотеки, необхідні для розробки програм з використанням
360 BIND.
361
362 %package -n openldap-schema-bind
363 Summary:        BIND schema for openldap
364 Summary(pl.UTF-8):      Schemat BIND dla openldap
365 Group:          Development/Libraries
366 Requires(post,postun):  sed >= 4.0
367 Requires:       openldap-servers
368 Requires:       sed >= 4.0
369 %if "%{_rpmversion}" >= "5"
370 BuildArch:      noarch
371 %endif
372
373 %description -n openldap-schema-bind
374 BIND schema for openldap.
375
376 %description -n openldap-schema-bind -l pl.UTF-8
377 Schemat BIND dla openldap.
378
379 %package -n python3-isc
380 Summary:        Python 3 ISC module - functions to support BIND utilities
381 Summary(pl.UTF-8):      Moduł Pythona 3 ISC - funkcje wspomagające narzędzia BIND-a
382 Group:          Libraries/Python
383 Requires:       python3-modules
384
385 %description -n python3-isc
386 Python 3 ISC module containing functions to support BIND utilities.
387
388 %description -n python3-isc -l pl.UTF-8
389 Moduł Pythona 3 ISC, zawierający funkcje wspomagające narzędzia
390 BIND-a.
391
392 %prep
393 %setup -q %{?with_hip:-a6} -n %{name}-%{ver}%{pverdir}
394 %patch0 -p1
395 %patch1 -p1
396 %patch2 -p1
397 %{?with_ldap:%patch3 -p1}
398 %patch4 -p1
399 %{?with_hip:%{__mv} bind-hip/hip_55.[ch] lib/dns/rdata/generic}
400 %{?with_edns_cli:%patch5 -p0}
401 %patch6 -p0
402
403 %build
404 %{__libtoolize}
405 %{__aclocal}
406 %{__autoconf}
407 cp -f /usr/share/automake/config.* .
408 %configure \
409         CFLAGS="-D_GNU_SOURCE=1 %{rpmcppflags}" \
410         %{!?with_epoll:--disable-epoll --disable-devpoll} \
411         --enable-full-report \
412         --enable-getifaddrs \
413         %{?with_ipv6:--enable-ipv6} \
414         --enable-largefile \
415         %{__enable_disable seccomp} \
416         %{!?with_static_libs:--disable-static} \
417         --enable-threads \
418         %{?with_kerberos5:--with-gssapi} \
419         --with-libidn2 \
420         --with-libtool \
421         %{?with_ssl:--with-openssl} \
422         %{?with_sql:--with-dlz-postgres} \
423         %{?with_sql:--with-dlz-mysql} \
424         --without-dlz-bdb \
425         --with-dlz-filesystem \
426         %{?with_ldap:--with-dlz-ldap} \
427         --with-dlz-odbc%{!?with_odbc:=no} \
428         --with-dlz-stub \
429         %{?with_geoip:--with-geoip} \
430         --with-lmdb%{!?with_lmdb:=no} \
431         --with-python=%{__python3}
432
433 %{__make}
434
435 %{?with_hip:%{__make} -C bind-hip}
436
437 %{?with_tests:%{__make} test-force}
438
439 %install
440 rm -rf $RPM_BUILD_ROOT
441 install -d $RPM_BUILD_ROOT{%{_includedir},%{_bindir},%{_sbindir},%{_includedir}} \
442         $RPM_BUILD_ROOT/etc/{rc.d/init.d,logrotate.d,sysconfig} \
443         $RPM_BUILD_ROOT{%{_mandir}/man{1,3,5,8},%{_var}/{lib/named/{M,D,S,dev,etc},run/named,log}} \
444         $RPM_BUILD_ROOT{%{systemdunitdir},%{systemdtmpfilesdir}}
445
446 %{__make} install \
447         DESTDIR=$RPM_BUILD_ROOT
448
449 bzip2 -dc %{SOURCE4} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
450 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.named-non-english-man-pages
451 %{__mv} $RPM_BUILD_ROOT%{_mandir}/ja/man8/nslookup.8 $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
452 %{__sed} -i -e 's/NSLOOKUP 8/NSLOOKUP 1/' $RPM_BUILD_ROOT%{_mandir}/ja/man1/nslookup.1
453
454 cp -p bin/tests/named.conf              EXAMPLE-CONFIG-named
455 install -p %{SOURCE1}                   $RPM_BUILD_ROOT/etc/rc.d/init.d/named
456 cp -p %{SOURCE2}                        $RPM_BUILD_ROOT/etc/sysconfig/named
457 cp -p %{SOURCE3}                        $RPM_BUILD_ROOT/etc/logrotate.d/named
458 cp -p %{SOURCE7}                        $RPM_BUILD_ROOT%{_var}/lib/named/root.hint
459 cp -p %{SOURCE8}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/127.0.0.zone
460 cp -p %{SOURCE9}                        $RPM_BUILD_ROOT%{_var}/lib/named/M/localhost.zone
461 cp -p %{SOURCE10}                       $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/named.conf
462 %{__mv} $RPM_BUILD_ROOT/etc/bind.keys   $RPM_BUILD_ROOT%{_var}/lib/named%{_sysconfdir}/
463
464 ln -sf %{_var}/lib/named%{_sysconfdir}/named.conf $RPM_BUILD_ROOT/etc/named.conf
465 ln -sf %{_var}/lib/named%{_sysconfdir}/bind.keys $RPM_BUILD_ROOT/etc/bind.keys
466 ln -sf %{_var}/lib/named/named.log      $RPM_BUILD_ROOT%{_var}/log/named
467 ln -sf %{_var}/lib/named/named.stats    $RPM_BUILD_ROOT%{_var}/log/named.stats
468
469 touch $RPM_BUILD_ROOT%{_var}/lib/named/named.{log,stats}
470
471 install %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/named.service
472 install %{SOURCE11} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
473
474 %if %{with ldap}
475 install -d $RPM_BUILD_ROOT%{schemadir}
476 cp -p %{SOURCE5} $RPM_BUILD_ROOT%{schemadir}/dnszone.schema
477 %endif
478
479 %{?with_hip:install -p bind-hip/hi2dns $RPM_BUILD_ROOT%{_bindir}}
480
481 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
482 echo ".so man8/named-checkzone.8" > $RPM_BUILD_ROOT%{_mandir}/man8/named-compilezone.8
483
484 # let rpm generate deps (workaround -m644 used for libs installation)
485 chmod 755 $RPM_BUILD_ROOT%{_libdir}/lib*.so.*.*.*
486
487 # we don't want Makefiles in documentation...
488 rm -rf _doc
489 cp -a doc _doc
490 %{__rm} _doc/misc/Makefile*
491
492 %clean
493 rm -rf $RPM_BUILD_ROOT
494
495 %pre
496 if [ -f %{_sysconfdir}/named.boot ]; then
497         cp -f %{_sysconfdir}/named.boot /etc/named.boot.2conf
498         mv -f %{_sysconfdir}/named.boot /etc/named.rpmsave
499         echo >&2 "Warning: %{_sysconfdir}/named.boot saved as /etc/named.rpmsave."
500 fi
501 %groupadd -g 58 named
502 %useradd -u 58 -g 58 -d /tmp -s /bin/false -c "BIND user" named
503
504 %post
505 /sbin/chkconfig --add named
506 %service named restart
507 %systemd_post named.service
508
509 %preun
510 if [ "$1" = "0" ]; then
511         %service named stop
512         /sbin/chkconfig --del named
513 fi
514 %systemd_preun named.service
515
516 %postun
517 if [ "$1" = "0" ]; then
518         %userremove named
519         %groupremove named
520 fi
521 %systemd_reload
522
523 %post   libs -p /sbin/ldconfig
524 %postun libs -p /sbin/ldconfig
525
526 %post -n openldap-schema-bind
527 %openldap_schema_register %{schemadir}/dnszone.schema
528 %service -q ldap restart
529
530 %postun -n openldap-schema-bind
531 if [ "$1" = "0" ]; then
532         %openldap_schema_unregister %{schemadir}/dnszone.schema
533         %service -q ldap restart
534 fi
535
536 %triggerpostun -- %{name} < 7:9.4.2-2
537 /sbin/chkconfig named reset
538 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+cname[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
539 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+response-checks[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
540 %{__sed} -i -e 's#^\([ \t]*category[ \t]\+load[ \t]\+.*\)$#// \1#g' /var/lib/named/etc/named.conf
541
542 %triggerpostun -- %{name} < 7:9.9.2.P2-2
543 %systemd_trigger named.service
544
545 %files
546 %defattr(644,root,root,755)
547 %doc README EXAMPLE-CONFIG-* %{?with_hip:bind-hip/COPYRIGHT-HIP-RR}
548 %doc _doc/misc/* _doc/arm/*.html %{?with_ldap:_doc/*.sdb-ldap}
549
550 %{systemdunitdir}/named.service
551 %attr(754,root,root) /etc/rc.d/init.d/named
552 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/named
553 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/named.conf
554 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/bind.keys
555 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/named
556
557 %attr(755,root,root) %{_sbindir}/ddns-confgen
558 %attr(755,root,root) %{_sbindir}/dnssec-*
559 %attr(755,root,root) %{_sbindir}/genrandom
560 %attr(755,root,root) %{_sbindir}/named
561 %attr(755,root,root) %{_sbindir}/named-*
562 %attr(755,root,root) %{_sbindir}/nsec3hash
563 %attr(755,root,root) %{_sbindir}/rndc
564 %attr(755,root,root) %{_sbindir}/rndc-confgen
565 %attr(755,root,root) %{_sbindir}/tsig-keygen
566
567 %{_mandir}/man5/named.conf.5*
568 %{_mandir}/man5/rndc.conf.5*
569 %{_mandir}/man8/ddns-confgen.8*
570 %{_mandir}/man8/dnssec-*.8*
571 %{_mandir}/man8/genrandom.8*
572 %{_mandir}/man8/named.8*
573 %{_mandir}/man8/named-*.8*
574 %{_mandir}/man8/nsec3hash.8*
575 %{_mandir}/man8/rndc.8*
576 %{_mandir}/man8/rndc-confgen.8*
577 %{_mandir}/man8/tsig-keygen.8*
578 %lang(ja) %{_mandir}/ja/man8/named*
579
580 %{systemdtmpfilesdir}/%{name}.conf
581
582 %attr(770,root,named) %dir %{_var}/lib/named
583 %attr(770,root,named) %dir %{_var}/lib/named/D
584 %attr(770,root,named) %dir %{_var}/lib/named/M
585 %attr(770,root,named) %dir %{_var}/lib/named/S
586 %attr(770,root,named) %dir %{_var}/lib/named/dev
587 %dev(c,1,9) %attr(644,root,root) %{_var}/lib/named/dev/urandom
588 %attr(750,root,named) %dir %{_var}/lib/named/etc
589 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/bind.keys
590 %attr(640,root,named) %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/etc/named.conf
591 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/M/*.zone
592 %config(noreplace) %verify(not md5 mtime size) %{_var}/lib/named/root.hint
593 %attr(660,named,named) %ghost %{_var}/lib/named/named.log
594 %attr(660,named,named) %ghost %{_var}/lib/named/named.stats
595
596 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named
597 %attr(660,named,named) %config(noreplace,missingok) %verify(not md5 mtime size) %{_var}/log/named.stats
598
599 %attr(770,root,named) %dir %{_var}/run/named
600
601 %files utils
602 %defattr(644,root,root,755)
603 %attr(755,root,root) %{_bindir}/arpaname
604 %attr(755,root,root) %{_bindir}/delv
605 %attr(755,root,root) %{_bindir}/dig
606 %attr(755,root,root) %{_bindir}/host
607 %attr(755,root,root) %{_bindir}/named-rrchecker
608 %attr(755,root,root) %{_bindir}/mdig
609 %attr(755,root,root) %{_bindir}/nslookup
610 %attr(755,root,root) %{_bindir}/nsupdate
611 %{?with_hip:%attr(755,root,root) %{_bindir}/hi2dns}
612 %{_mandir}/man1/arpaname.1*
613 %{_mandir}/man1/delv.1*
614 %{_mandir}/man1/dig.1*
615 %{_mandir}/man1/host.1*
616 %{_mandir}/man1/mdig.1*
617 %{_mandir}/man1/named-rrchecker.1*
618 %{_mandir}/man1/nslookup.1*
619 %{_mandir}/man1/nsupdate.1*
620
621 %lang(fi) %{_mandir}/fi/man1/host.1*
622
623 %lang(fr) %{_mandir}/fr/man1/host.1*
624
625 %lang(hu) %{_mandir}/hu/man1/host.1*
626
627 %lang(ja) %{_mandir}/ja/man1/dig.1*
628 %lang(ja) %{_mandir}/ja/man1/host.1*
629 %lang(ja) %{_mandir}/ja/man1/nslookup.1*
630 %lang(ja) %{_mandir}/ja/man8/nsupdate.8*
631
632 %lang(pl) %{_mandir}/pl/man1/host.1*
633
634 %files libs
635 %defattr(644,root,root,755)
636 %attr(755,root,root) %{_libdir}/libbind9.so.*.*.*
637 %attr(755,root,root) %ghost %{_libdir}/libbind9.so.1200
638 %attr(755,root,root) %{_libdir}/libdns.so.*.*.*
639 %attr(755,root,root) %ghost %{_libdir}/libdns.so.1205
640 %attr(755,root,root) %{_libdir}/libirs.so.*.*.*
641 %attr(755,root,root) %ghost %{_libdir}/libirs.so.1200
642 %attr(755,root,root) %{_libdir}/libisc.so.*.*.*
643 %attr(755,root,root) %ghost %{_libdir}/libisc.so.1200
644 %attr(755,root,root) %{_libdir}/libisccc.so.*.*.*
645 %attr(755,root,root) %ghost %{_libdir}/libisccc.so.1200
646 %attr(755,root,root) %{_libdir}/libisccfg.so.*.*.*
647 %attr(755,root,root) %ghost %{_libdir}/libisccfg.so.1200
648 %attr(755,root,root) %{_libdir}/libns.so.*.*.*
649 %attr(755,root,root) %ghost %{_libdir}/libns.so.1203
650
651 %files devel
652 %defattr(644,root,root,755)
653 %attr(755,root,root) %{_bindir}/bind9-config
654 %attr(755,root,root) %{_bindir}/isc-config.sh
655 %attr(755,root,root) %{_libdir}/libbind9.so
656 %attr(755,root,root) %{_libdir}/libdns.so
657 %attr(755,root,root) %{_libdir}/libirs.so
658 %attr(755,root,root) %{_libdir}/libisc.so
659 %attr(755,root,root) %{_libdir}/libisccc.so
660 %attr(755,root,root) %{_libdir}/libisccfg.so
661 %attr(755,root,root) %{_libdir}/libns.so
662 %{_libdir}/libbind9.la
663 %{_libdir}/libdns.la
664 %{_libdir}/libirs.la
665 %{_libdir}/libisc.la
666 %{_libdir}/libisccc.la
667 %{_libdir}/libisccfg.la
668 %{_libdir}/libns.la
669 %{_includedir}/bind9
670 %{_includedir}/dns
671 %{_includedir}/dst
672 %{_includedir}/irs
673 %{_includedir}/isc
674 %{_includedir}/isccc
675 %{_includedir}/isccfg
676 %{_includedir}/ns
677 %{_includedir}/pk11
678 %{_includedir}/pkcs11
679 %{_mandir}/man1/bind9-config.1*
680 %{_mandir}/man1/isc-config.sh.1*
681
682 %if %{with static_libs}
683 %files static
684 %defattr(644,root,root,755)
685 %{_libdir}/libbind9.a
686 %{_libdir}/libdns.a
687 %{_libdir}/libirs.a
688 %{_libdir}/libisc.a
689 %{_libdir}/libisccc.a
690 %{_libdir}/libisccfg.a
691 %{_libdir}/libns.a
692 %endif
693
694 %if %{with ldap}
695 %files -n openldap-schema-bind
696 %defattr(644,root,root,755)
697 %{_datadir}/openldap/schema/dnszone.schema
698 %endif
699
700 %files -n python3-isc
701 %defattr(644,root,root,755)
702 %{py3_sitedir}/isc
703 %{py3_sitedir}/isc-*-py*.egg-info
This page took 0.580945 seconds and 2 git commands to generate.